added libxslt-python dependency
[sfa.git] / sfa.spec
1 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
2
3 %define name sfa
4 %define version 0.9
5 %define taglevel 1
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
10
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 Source0: %{name}-%{version}.tar.bz2
15 License: GPL
16 Group: Applications/System
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %(echo %{url} | cut -d ' ' -f 2)
23
24 BuildRequires: make
25 Requires: python
26 Requires: pyOpenSSL >= 0.7
27 Requires: m2crypto
28 Requires: libxslt-python
29
30 Summary: the SFA python libraries
31 Group: Applications/System
32
33 %package plc
34 Summary: the SFA wrapper arounf MyPLC
35 Group: Applications/System
36 Requires: sfa
37
38 %package client
39 Summary: the SFA experimenter-side CLI
40 Group: Applications/System
41 Requires: sfa
42
43 %description
44 This package provides the python libraries that the SFA implementation requires
45
46 %description plc
47 Geniwrapper implements the SFA interface which serves as a layer
48 between the existing PlanetLab interfaces and the SFA API.
49
50 %description client
51 This package provides the client side of the SFA API, in particular
52 sfi.py, together with other utilities.
53
54 %prep
55 %setup -q
56
57 %build
58 make
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 make install DESTDIR="$RPM_BUILD_ROOT"
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %{python_sitelib}/*
69 /usr/bin/keyconvert
70 /var/www/html/wsdl/*.wsdl
71
72 %files plc
73 %defattr(-,root,root)
74 %config (noreplace) /etc/sfa/sfa_config
75 %config (noreplace) /etc/sfa/aggregates.xml
76 %config (noreplace) /etc/sfa/registries.xml
77 /etc/init.d/sfa
78 %{_bindir}/sfa-config-tty
79 %{_bindir}/sfa-import-plc.py*
80 %{_bindir}/sfa-nuke-plc.py*
81 %{_bindir}/sfa-server.py*
82
83 %files client
84 %config (noreplace) /etc/sfa/sfi_config
85 %{_bindir}/sfi.py*
86 %{_bindir}/getNodes.py*
87 %{_bindir}/getRecord.py*
88 %{_bindir}/setRecord.py*
89 %{_bindir}/genidump.py*
90
91 %pre plc
92 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
93
94 %post plc
95 chkconfig --add sfa
96
97 %changelog
98 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
99 - added libxslt-python dependency
100
101 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
102 - unified single SFA database in the PLC-DB
103 - upcalls from  PLCAPI to SFA methods
104 - SFA call traceability and logging features
105 - many bug fixes
106 - includes first/rough version of sfatables for policy implementation
107
108 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
109 - snapshot after the GEC5 demo
110 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
111
112 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
113 - snapshot july 15 - has gone through superficial manual testing
114 - hopefully a good basis for gec5 demo
115 - multi-dir sfi client tested as well
116
117 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
118 - rename geniwrapper.spec into sfa.spec
119
120 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
121 - clean up in xmlrpc/soap, --protocol option to chose between both
122 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
123 - hopefully more helpful context in case of crashes when importing
124 - bugfixes for using only /etc/sfa for site-dep files
125 - bugfixes in wsdl generation
126
127 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
128 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
129 - config variables in sfa_config now start with SFA_ and not GENI_
130 - config.py can be loaded even with no config present
131
132 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
133 - first step for cleanup and reorganization
134 - mass-renaming from geni to sfa (some are still needed)
135 - sfa/trust implements the security architecture
136
137 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
138 - snapshot for reproducible builds
139
140 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
141 - snapshot for the convenience of alpha users
142
143 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
144 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
145
146 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
147 - ongoing work - snapshot for 4.3-rc9
148
149 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
150 - various fixes
151
152 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
153 - bugfixes - still a work in progress
154
155 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
156 - initial package
157
158
159 %define module_current_branch 0.2