Setting tag sfa-2.0-2
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45  
46 # python 2.5 has uuid module added, for python 2.4 we still need it.
47 # we can't really check for if we can load uuid as a python module,
48 # it'll be installed by "devel.pkgs". we have the epel repository so
49 # python-uuid will be provided. but we can test for the python
50 # version.
51 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
52 # %if %has_py24
53 #
54 # this also didn't work very well. I'll just check for distroname - baris
55 #%if %{distroname} == "centos5"
56 #Requires: python-uuid
57 #%endif
58
59 %package plc
60 Summary: the SFA layer around MyPLC
61 Group: Applications/System
62 Requires: sfa
63 Requires: python-psycopg2
64
65 %package client
66 Summary: the SFA experimenter-side CLI
67 Group: Applications/System
68 Requires: sfa
69 Requires: pyOpenSSL >= 0.7
70
71 %package sfatables
72 Summary: sfatables policy tool for SFA
73 Group: Applications/System
74 Requires: sfa
75
76 %package cm
77 Summary: the SFA layer around MyPLC NodeManager
78 Group: Applications/System
79 Requires: sfa
80 Requires: pyOpenSSL >= 0.6
81
82 %package flashpolicy
83 Summary: SFA support for flash clients
84 Group: Applications/System
85 Requires: sfa
86
87 %package tests
88 Summary: unit tests suite for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %description
93 This package provides the python libraries for the PlanetLab implementation of SFA
94
95 %description plc
96 This package implements the SFA interface which serves as a layer
97 between the existing PlanetLab interfaces and the SFA API.
98
99 %description client
100 This package provides the client side of the SFA API, in particular
101 sfi.py, together with other utilities.
102
103 %description sfatables
104 sfatables is a tool for defining access and admission control policies
105 in an SFA network, in much the same way as iptables is for ip
106 networks. This is the command line interface to manage sfatables
107
108 %description cm
109 This package implements the SFA interface which serves as a layer
110 between the existing PlanetLab NodeManager interfaces and the SFA API.
111  
112 %description flashpolicy
113 This package provides support for adobe flash client applications.  
114  
115 %description tests
116 Provides some binary unit tests in /usr/share/sfa/tests
117
118 %prep
119 %setup -q
120
121 %build
122 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
127 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/*egg-info
128 # this gets duplicated
129 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/sfa/storage/sfa.sql
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 # sfa and sfatables depend on each other.
136 %{python_sitelib}/sfa
137 %{python_sitelib}/xmlbuilder
138 /etc/init.d/sfa
139 %{_bindir}/sfa-start.py*
140 %{_bindir}/keyconvert.py*
141 %{_bindir}/sfa-config-tty
142 %config /etc/sfa/default_config.xml
143 %config (noreplace) /etc/sfa/aggregates.xml
144 %config (noreplace) /etc/sfa/registries.xml
145 /usr/share/sfa/sfa.sql
146 /var/www/html/wsdl/*.wsdl
147
148 %files plc
149 %defattr(-,root,root)
150 /etc/sfa/pl.rng
151 /etc/sfa/credential.xsd
152 /etc/sfa/top.xsd
153 /etc/sfa/sig.xsd
154 /etc/sfa/xml.xsd
155 /etc/sfa/protogeni-rspec-common.xsd
156 /etc/sfa/topology
157 %{_bindir}/sfa-import-plc.py*
158 %{_bindir}/sfa-nuke-plc.py*
159 %{_bindir}/sfa-clean-peer-records.py*
160 %{_bindir}/gen-sfa-cm-config.py*
161 %{_bindir}/sfa-ca.py*
162
163 %files client
164 %config (noreplace) /etc/sfa/sfi_config
165 %{_bindir}/sfi*
166 %{_bindir}/getNodes.py*
167 %{_bindir}/getRecord.py*
168 %{_bindir}/setRecord.py*
169 %{_bindir}/sfadump.py*
170
171 %files sfatables
172 /etc/sfatables/*
173 %{_bindir}/sfatables
174 %{python_sitelib}/sfatables
175
176 %files cm
177 /etc/init.d/sfa-cm
178 %{_bindir}/sfa_component_setup.py*
179 # cron jobs here 
180
181 %files flashpolicy
182 %{_bindir}/sfa_flashpolicy.py*
183 /etc/sfa/sfa_flashpolicy_config.xml
184
185 %files tests
186 %{_datadir}/sfa/tests
187
188 ### sfa-plc installs the 'sfa' service
189 %post plc
190 chkconfig --add sfa
191
192 %preun plc
193 if [ "$1" = 0 ] ; then
194   /sbin/service sfa stop || :
195   /sbin/chkconfig --del sfa || :
196 fi
197
198 %postun plc
199 [ "$1" -ge "1" ] && service sfa restart
200
201 ### sfa-cm installs the 'sfa-cm' service
202 %post cm
203 chkconfig --add sfa-cm
204
205 %preun cm
206 if [ "$1" = 0 ] ; then
207    /sbin/service sfa-cm stop || :
208    /sbin/chkconfig --del sfa-cm || :
209 fi
210
211 %postun cm
212 [ "$1" -ge "1" ] && service sfa-cm restart || :
213
214 %changelog
215 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
216 - various fixes in rspecs for sfav1&slice tags
217 - uses 'geni_rspec_version' and not just 'rspec_version'
218 - example flavour for the max testbed
219 - embryo for an sfa client library
220 - topology.py moved into plc
221 - sql: table is named records; record_types are enforced
222 - sql: table creation cleaned up
223
224 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
225 - cleaned up all references to SFA_*_TYPE in config
226 - enable cache at the aggregate by default
227 - registry now uses the driver in a sensible way (see managers/driver.py)
228 - slice manager supports sfav1/pgv2 neighbours
229 - get_key renamed into get_key_from_incoming_ip
230 - new sfa.storage module for record/table and all db-related stuff
231 - db schema in sfa.storage.sfa.sql
232 - init.d and cron.d move one step up
233 - cleaned up rspec/ directory
234 - add deps to pyopenssl and myplc-config
235 - start support for new API (return value)
236 - plc.remoteshell removed, use plshell instead
237 - plshell uses a 'capability' auth method whenever possible
238 - various tweaks in rspec elements
239 - made dependency on sfatables softer
240
241 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
242 - sfa should now be started *before* the initial import
243 - sfa to use its own database (default sfa) - can run without myplc
244 - server calls support optional 'options'
245 - client sends options in argument when needed
246 - fix infinite getattr recursion in elements/element.py
247 - error codes in line with geni
248
249 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
250 - fixed links and attributes in rspecs
251 - minor cleanup in the API methods, and more consistent names in manager methods
252
253 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
254 - ongoing refoactoring towards more genericity
255 - passes tests again although known issues remain with attributes/tags
256
257 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
258 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
259 - improvements in the pgv2 rspecs
260 - driver separated from api
261 - code starts moving around where it belongs
262 - sfascan caches getversion across invokations
263 - vini topology extracted as a config file
264
265 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
266 - first support for protogeni rspecs is working
267 - vini no longer needs a specific manager
268 - refactoring underway towards more flexible/generic architecture
269
270 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
271 - Unicode-friendliness for user names with accents/special chars.
272 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
273 - CreaetSliver no longer fails for users that have a capital letter in their URN.
274 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
275 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
276 - Fix bugs and missing imports     
277  
278
279 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
280 - new method record.get_field for sface
281
282 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
283 - new option -c to sfa-nuke-plc.py
284 - CreateSliver fixed for admin-only slice tags
285
286 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
287 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
288 - Fixed holes in certificate verification logic.
289 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
290 - Added 'boot_state' as an attribute of the node element in SFA rspec.
291 - Non authority certificates are marked as CA:FALSE.
292
293 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
294 - fix typo in sfa-1.0-31 tag.
295 - added CreateGid() Registry interface method.
296
297 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
298 - fix typo in sfa-1.0-30 tag
299
300 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
301 - Declare namespace and schema location in the credential.
302 - Fix bug that prevetend connections from timing out.
303 - Fix slice delegation.
304 - Add statistics to slicemaanger listresources/createsliver rspec.
305 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
306   of days a user can extend their slice expiration.
307 - CA certs are only issued to objects of type authority
308    
309 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
310 - tag 1.0-28 was broken due to typo in the changelog
311 - new class sfa/util/httpsProtocol.py that supports timeouts
312
313 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
314 - Resolved issue that caused sfa hold onto idle db connections.
315 - Fix bug that caused the registry to use the wrong type of credential.
316 - Support authority+sm type.
317 - Fix rspec merging bugs.
318 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
319 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
320  planetlab hosted initscripts using the <planetlab:initscript> tag  
321 - Can now handle extraneous whitespace in the rspec without failing.   
322  
323 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
324 - ProtoGENI v2 RSpec updates.
325 - Convert expiration timestamps with timezone info in credentials to utc.
326 - Fixed redundant logging issue. 
327 - Improved SliceManager and SFI client logging.
328 - Support aggregates that don't support the optional 'call_id' argument. 
329 - Only call get_trusted_certs() at aggreage interfaces that support the call.
330 - CreateSliver() now handles MyPLC slice attributes/tags.
331 - Cache now supports persistence.
332 - Hide whitelisted nodes.
333
334 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
335 - fixed issues with sup authority signing
336 - fixed bugs in remove_slivers and SliverStatus
337
338 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
339 - fix typo that prevented aggregates from operating properly
340
341 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
342 - load trusted certs into ssl context prior to handshake
343 - client's logfile lives in ~/.sfi/sfi.log
344
345 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
346 - includes a change on passphrases that was intended in 1.0-22
347
348 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
349 - Added support for ProtoGENI RSpec v2
350  
351 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
352 - stable sfascan
353 - fix in initscript, *ENABLED tags in config now taken into account
354
355 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
356 - some commits had not been pushed in tag 19
357
358 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
359 - GetVersion should now report full URLs with path
360 - scansfa has nicer output and new syntax (entry URLs as args and not options)
361 - dos2unix'ed flash policy pill
362
363 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
364 - fix packaging again for f8
365
366 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
367 - fix packaging (apparently broken in 1.0-16)
368 - first working version of sfascan
369 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
370 - deprecated the sfa_geni_aggregate config category
371
372 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
373 - Fix build problem
374 - First version of SFA scanner
375
376 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
377 - Add support for Flash clients using flashpolicy
378 - Fix problems with tag handling in RSpec
379
380 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
381 - Modifications to the Eucalyptus Aggregate Manager
382 - Fixes for VINI RSpec
383 - Fix tag handling for PL RSpec
384 - Fix XML Schema ordering for <urn> element
385
386 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
387 - just set x509 version to 2
388
389 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
390 - added urn to the node area in rspecs
391 - conversion to urn now exports fqdn
392 - sfa-import-plc.py now creates a unique registry record for each SFA interface
393
394 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
395 - undo broken attempt for python-2.7
396
397 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
398 - SMs avoid duplicates for when call graph has dags;
399 - just based on network's name, when a duplicate occurs, one is just dropped
400 - does not try to merge/aggregate 2 networks
401 - also reviewed logging with the hope to fix the sfa startup msg:
402 - TypeError: not all arguments converted during string formatting
403
404 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
405 - verify credentials against xsd schema
406 - Fix SM to SM communication
407 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
408 - new setting session_key_path
409
410 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
411 - fix registry credential regeneration and handle expiration
412 - support for setting slice tags (min_role=user)
413 - client can display its own version: sfi.py version --local
414 - GetVersion to provide urn in addition to hrn
415 - more code uses plxrn vs previous helper functions
416 - import replaces '+' in email addresses with '_'
417
418 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
419 - fix GetVersion code_tag and add code_url
420
421 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
422 - extend GetVersion towards minimum federation introspection, and expose local tag
423
424 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
425 - fixed some legacy issues (list vs List)
426 - deprecated sfa.util.namespace for xrn and plxrn
427 - unit tests ship as the sfa-tests rpm
428
429 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
430 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
431 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
432 - hrn-urn translations tweaked
433 - fixed 'service sfa status'
434 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
435 - started to repair sfadump - although not usable yet
436 - trust objects now have dump_string method that dump() actually prints
437 - unit tests under review
438 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
439 - binaries now support -v or -vv to increase loglevel
440 - trashed obsolete sfa.util.client
441
442 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
443 - various bugfixes and cleanup, improved/harmonized logging
444
445 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
446 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
447   to avoid returning a PLCAPI exception that might confuse users.
448 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
449 - fix build errors.  
450
451 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
452 - (Architecture) Credential format changed to match ProtoGENI xml format
453 - (Architecture) All interfaces export a new set of methods that are compatible
454    with the ProtoGeni Aggregate spec. These new methods are considered a 
455    replacement  for the pervious methods exported by the interfaces. All 
456    previous methods are still exported and work as normal, but they are 
457    considered deprecated and will not be supported in future releases.  
458 - (Architecture) SFI has been updated to use the new interface methods.
459 - (Architecture) Changed keyconvet implementation from c to python.
460 - (Architecture) Slice Manager now attempts looks for a delegated credential
461   provided by the client before using its own server credential.
462 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
463   This cache now exists only in memory and is cleared when service is restarted
464   or cache lifetime is exceeded.  
465 - (Performance) SliceManager sends request to Aggregates in parallel instead 
466   of sequentially.
467 - (Bug fix) SFA tickets now support the new rspec format.
468 - (Bug fix) SFI only uses cahced credential if they aren't expired.
469 - (Bug fix) Cerdential delegation modified to work with new credential format.
470 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
471   Aggregate instead of relaying through the Slice Manager.
472 - (Enhancement) Simplified caching. Accociated a global cache instance with
473   the api handler on every new server request, making it easier to access the 
474   cache and use in more general ways.     
475
476 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
477 - SfaServer now uses a pool of threads to handle requests concurrently
478 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
479 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
480 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
481 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
482 - Component manager does not install gid files if slice already has them  
483 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
484 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
485 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
486      
487 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
488 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
489 - - sfa-config-tty now has the same features like plc-config-tty
490 - - Contains code to support both urn and hrn
491 - - Cleaned up request_hash related stuff
492 - - SM, AM and Registry code is organized under respective managers
493 - - Site and Slice synchronization across federated aggregates
494 - - Script to generate sfa_component_config
495
496 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
497 - sfa-config-tty now has the same features like plc-config-tty
498 - Contains code to support both urn and hrn
499 - Cleaned up request_hash related stuff
500 - SM, AM and Registry code is organized under respective managers
501 - Slice synchronization across federated aggregates
502 - some bugs are fixed
503
504 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
505 - checkpoint with fewer mentions of geni
506
507 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
508 - checkpointing
509 - this is believed to pass the tests; among other things:
510 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
511
512 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
513 - This tag includes:
514 - - Sfatables
515 - - Preliminary version of hash based authentication
516 - - Initial code for Component Manager
517 - - Authority structure is moved to /var/lib/sfa/
518 - - some bug-fixes
519
520 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
521 - Create_slice and get_resources methods are connected to sfatables.
522 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
523
524 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
525 - Bug fix on update and remove_peer_object methods
526 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
527
528 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
529 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
530
531 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
532 - compatibility with RefreshPeer
533 - incremental mechanism for importing PLC records into SFA tables
534 - unified single database (still inside the underlying PLC db postgresql server)
535 - includes/improves call traceability and logging features
536 - several bug fixes
537
538 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
539 - added libxslt-python dependency
540
541 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
542 - unified single SFA database in the PLC-DB
543 - upcalls from  PLCAPI to SFA methods
544 - SFA call traceability and logging features
545 - many bug fixes
546 - includes first/rough version of sfatables for policy implementation
547
548 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
549 - snapshot after the GEC5 demo
550 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
551
552 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
553 - snapshot july 15 - has gone through superficial manual testing
554 - hopefully a good basis for gec5 demo
555 - multi-dir sfi client tested as well
556
557 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
558 - rename geniwrapper.spec into sfa.spec
559
560 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
561 - clean up in xmlrpc/soap, --protocol option to chose between both
562 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
563 - hopefully more helpful context in case of crashes when importing
564 - bugfixes for using only /etc/sfa for site-dep files
565 - bugfixes in wsdl generation
566
567 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
568 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
569 - config variables in sfa_config now start with SFA_ and not GENI_
570 - config.py can be loaded even with no config present
571
572 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
573 - first step for cleanup and reorganization
574 - mass-renaming from geni to sfa (some are still needed)
575 - sfa/trust implements the security architecture
576
577 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
578 - snapshot for reproducible builds
579
580 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
581 - snapshot for the convenience of alpha users
582
583 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
584 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
585
586 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
587 - ongoing work - snapshot for 4.3-rc9
588
589 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
590 - various fixes
591
592 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
593 - bugfixes - still a work in progress
594
595 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
596 - initial package
597
598
599 %define module_current_branch 0.2