setting sfa-1.0-31 tag
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 31
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart || :
197
198 %changelog
199 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
200 - fix typo in sfa-1.0-30 tag
201
202 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
203 - Declare namespace and schema location in the credential.
204 - Fix bug that prevetend connections from timing out.
205 - Fix slice delegation.
206 - Add statistics to slicemaanger listresources/createsliver rspec.
207 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
208   of days a user can extend their slice expiration.
209 - CA certs are only issued to objects of type authority
210    
211 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
212 - tag 1.0-28 was broken due to typo in the changelog
213 - new class sfa/util/httpsProtocol.py that supports timeouts
214
215 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
216 - Resolved issue that caused sfa hold onto idle db connections.
217 - Fix bug that caused the registry to use the wrong type of credential.
218 - Support authority+sm type.
219 - Fix rspec merging bugs.
220 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
221 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
222  planetlab hosted initscripts using the <planetlab:initscript> tag  
223 - Can now handle extraneous whitespace in the rspec without failing.   
224  
225 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
226 - ProtoGENI v2 RSpec updates.
227 - Convert expiration timestamps with timezone info in credentials to utc.
228 - Fixed redundant logging issue. 
229 - Improved SliceManager and SFI client logging.
230 - Support aggregates that don't support the optional 'call_id' argument. 
231 - Only call get_trusted_certs() at aggreage interfaces that support the call.
232 - CreateSliver() now handles MyPLC slice attributes/tags.
233 - Cache now supports persistence.
234 - Hide whitelisted nodes.
235
236 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
237 - fixed issues with sup authority signing
238 - fixed bugs in remove_slivers and SliverStatus
239
240 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
241 - fix typo that prevented aggregates from operating properly
242
243 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
244 - load trusted certs into ssl context prior to handshake
245 - client's logfile lives in ~/.sfi/sfi.log
246
247 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
248 - includes a change on passphrases that was intended in 1.0-22
249
250 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
251 - Added support for ProtoGENI RSpec v2
252  
253 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
254 - stable sfascan
255 - fix in initscript, *ENABLED tags in config now taken into account
256
257 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
258 - some commits had not been pushed in tag 19
259
260 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
261 - GetVersion should now report full URLs with path
262 - scansfa has nicer output and new syntax (entry URLs as args and not options)
263 - dos2unix'ed flash policy pill
264
265 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
266 - fix packaging again for f8
267
268 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
269 - fix packaging (apparently broken in 1.0-16)
270 - first working version of sfascan
271 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
272 - deprecated the sfa_geni_aggregate config category
273
274 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
275 - Fix build problem
276 - First version of SFA scanner
277
278 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
279 - Add support for Flash clients using flashpolicy
280 - Fix problems with tag handling in RSpec
281
282 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
283 - Modifications to the Eucalyptus Aggregate Manager
284 - Fixes for VINI RSpec
285 - Fix tag handling for PL RSpec
286 - Fix XML Schema ordering for <urn> element
287
288 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
289 - just set x509 version to 2
290
291 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
292 - added urn to the node area in rspecs
293 - conversion to urn now exports fqdn
294 - sfa-import-plc.py now creates a unique registry record for each SFA interface
295
296 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
297 - undo broken attempt for python-2.7
298
299 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
300 - SMs avoid duplicates for when call graph has dags;
301 - just based on network's name, when a duplicate occurs, one is just dropped
302 - does not try to merge/aggregate 2 networks
303 - also reviewed logging with the hope to fix the sfa startup msg:
304 - TypeError: not all arguments converted during string formatting
305
306 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
307 - verify credentials against xsd schema
308 - Fix SM to SM communication
309 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
310 - new setting session_key_path
311
312 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
313 - fix registry credential regeneration and handle expiration
314 - support for setting slice tags (min_role=user)
315 - client can display its own version: sfi.py version --local
316 - GetVersion to provide urn in addition to hrn
317 - more code uses plxrn vs previous helper functions
318 - import replaces '+' in email addresses with '_'
319
320 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
321 - fix GetVersion code_tag and add code_url
322
323 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
324 - extend GetVersion towards minimum federation introspection, and expose local tag
325
326 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
327 - fixed some legacy issues (list vs List)
328 - deprecated sfa.util.namespace for xrn and plxrn
329 - unit tests ship as the sfa-tests rpm
330
331 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
332 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
333 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
334 - hrn-urn translations tweaked
335 - fixed 'service sfa status'
336 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
337 - started to repair sfadump - although not usable yet
338 - trust objects now have dump_string method that dump() actually prints
339 - unit tests under review
340 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
341 - binaries now support -v or -vv to increase loglevel
342 - trashed obsolete sfa.util.client
343
344 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
345 - various bugfixes and cleanup, improved/harmonized logging
346
347 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
348 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
349   to avoid returning a PLCAPI exception that might confuse users.
350 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
351 - fix build errors.  
352
353 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
354 - (Architecture) Credential format changed to match ProtoGENI xml format
355 - (Architecture) All interfaces export a new set of methods that are compatible
356    with the ProtoGeni Aggregate spec. These new methods are considered a 
357    replacement  for the pervious methods exported by the interfaces. All 
358    previous methods are still exported and work as normal, but they are 
359    considered deprecated and will not be supported in future releases.  
360 - (Architecture) SFI has been updated to use the new interface methods.
361 - (Architecture) Changed keyconvet implementation from c to python.
362 - (Architecture) Slice Manager now attempts looks for a delegated credential
363   provided by the client before using its own server credential.
364 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
365   This cache now exists only in memory and is cleared when service is restarted
366   or cache lifetime is exceeded.  
367 - (Performance) SliceManager sends request to Aggregates in parallel instead 
368   of sequentially.
369 - (Bug fix) SFA tickets now support the new rspec format.
370 - (Bug fix) SFI only uses cahced credential if they aren't expired.
371 - (Bug fix) Cerdential delegation modified to work with new credential format.
372 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
373   Aggregate instead of relaying through the Slice Manager.
374 - (Enhancement) Simplified caching. Accociated a global cache instance with
375   the api handler on every new server request, making it easier to access the 
376   cache and use in more general ways.     
377
378 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
379 - SfaServer now uses a pool of threads to handle requests concurrently
380 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
381 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
382 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
383 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
384 - Component manager does not install gid files if slice already has them  
385 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
386 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
387 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
388      
389 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
390 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
391 - - sfa-config-tty now has the same features like plc-config-tty
392 - - Contains code to support both urn and hrn
393 - - Cleaned up request_hash related stuff
394 - - SM, AM and Registry code is organized under respective managers
395 - - Site and Slice synchronization across federated aggregates
396 - - Script to generate sfa_component_config
397
398 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
399 - sfa-config-tty now has the same features like plc-config-tty
400 - Contains code to support both urn and hrn
401 - Cleaned up request_hash related stuff
402 - SM, AM and Registry code is organized under respective managers
403 - Slice synchronization across federated aggregates
404 - some bugs are fixed
405
406 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
407 - checkpoint with fewer mentions of geni
408
409 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
410 - checkpointing
411 - this is believed to pass the tests; among other things:
412 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
413
414 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
415 - This tag includes:
416 - - Sfatables
417 - - Preliminary version of hash based authentication
418 - - Initial code for Component Manager
419 - - Authority structure is moved to /var/lib/sfa/
420 - - some bug-fixes
421
422 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
423 - Create_slice and get_resources methods are connected to sfatables.
424 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
425
426 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
427 - Bug fix on update and remove_peer_object methods
428 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
429
430 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
431 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
432
433 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
434 - compatibility with RefreshPeer
435 - incremental mechanism for importing PLC records into SFA tables
436 - unified single database (still inside the underlying PLC db postgresql server)
437 - includes/improves call traceability and logging features
438 - several bug fixes
439
440 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
441 - added libxslt-python dependency
442
443 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
444 - unified single SFA database in the PLC-DB
445 - upcalls from  PLCAPI to SFA methods
446 - SFA call traceability and logging features
447 - many bug fixes
448 - includes first/rough version of sfatables for policy implementation
449
450 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
451 - snapshot after the GEC5 demo
452 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
453
454 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
455 - snapshot july 15 - has gone through superficial manual testing
456 - hopefully a good basis for gec5 demo
457 - multi-dir sfi client tested as well
458
459 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
460 - rename geniwrapper.spec into sfa.spec
461
462 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
463 - clean up in xmlrpc/soap, --protocol option to chose between both
464 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
465 - hopefully more helpful context in case of crashes when importing
466 - bugfixes for using only /etc/sfa for site-dep files
467 - bugfixes in wsdl generation
468
469 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
470 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
471 - config variables in sfa_config now start with SFA_ and not GENI_
472 - config.py can be loaded even with no config present
473
474 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
475 - first step for cleanup and reorganization
476 - mass-renaming from geni to sfa (some are still needed)
477 - sfa/trust implements the security architecture
478
479 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
480 - snapshot for reproducible builds
481
482 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
483 - snapshot for the convenience of alpha users
484
485 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
486 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
487
488 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
489 - ongoing work - snapshot for 4.3-rc9
490
491 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
492 - various fixes
493
494 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
495 - bugfixes - still a work in progress
496
497 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
498 - initial package
499
500
501 %define module_current_branch 0.2