Merge branch 'master' of ssh://git.onelab.eu/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45 Requires: python-xmlbuilder
46  
47 # python 2.5 has uuid module added, for python 2.4 we still need it.
48 # we can't really check for if we can load uuid as a python module,
49 # it'll be installed by "devel.pkgs". we have the epel repository so
50 # python-uuid will be provided. but we can test for the python
51 # version.
52 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
53 # %if %has_py24
54 #
55 # this also didn't work very well. I'll just check for distroname - baris
56 #%if %{distroname} == "centos5"
57 #Requires: python-uuid
58 #%endif
59
60 %package plc
61 Summary: the SFA layer around MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package cm
78 Summary: the SFA layer around MyPLC NodeManager
79 Group: Applications/System
80 Requires: sfa
81 Requires: pyOpenSSL >= 0.6
82
83 %package flashpolicy
84 Summary: SFA support for flash clients
85 Group: Applications/System
86 Requires: sfa
87
88 %package xmlbuilder
89 Summary: third-party xmlbuilder tool
90 Group: Applications/System
91 Provides: python-xmlbuilder
92
93 %package tests
94 Summary: unit tests suite for SFA
95 Group: Applications/System
96 Requires: sfa
97
98 %description
99 This package provides the python libraries for the PlanetLab implementation of SFA
100
101 %description plc
102 This package implements the SFA interface which serves as a layer
103 between the existing PlanetLab interfaces and the SFA API.
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description sfatables
110 sfatables is a tool for defining access and admission control policies
111 in an SFA network, in much the same way as iptables is for ip
112 networks. This is the command line interface to manage sfatables
113
114 %description cm
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab NodeManager interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description xmlbuilder
122 This package contains the xmlbuilder python library, packaged for
123 convenience as it is not supported by fedora
124
125 %description tests
126 Provides some binary unit tests in /usr/share/sfa/tests
127
128 %prep
129 %setup -q
130
131 %build
132 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 # sfa and sfatables depend on each other.
143 %{python_sitelib}/sfa
144 /etc/init.d/sfa
145 %{_bindir}/sfa-start.py*
146 %{_bindir}/keyconvert.py*
147 %{_bindir}/sfa-config-tty
148 %config /etc/sfa/default_config.xml
149 %config (noreplace) /etc/sfa/aggregates.xml
150 %config (noreplace) /etc/sfa/registries.xml
151 /usr/share/sfa/sfa.sql
152 /usr/share/sfa/examples
153 /var/www/html/wsdl/*.wsdl
154
155 %files plc
156 %defattr(-,root,root)
157 /etc/sfa/pl.rng
158 /etc/sfa/credential.xsd
159 /etc/sfa/top.xsd
160 /etc/sfa/sig.xsd
161 /etc/sfa/xml.xsd
162 /etc/sfa/protogeni-rspec-common.xsd
163 /etc/sfa/topology
164 %{_bindir}/sfa-import-plc.py*
165 %{_bindir}/sfa-nuke-plc.py*
166 %{_bindir}/sfa-clean-peer-records.py*
167 %{_bindir}/gen-sfa-cm-config.py*
168 %{_bindir}/sfa-ca.py*
169
170 %files client
171 %config (noreplace) /etc/sfa/sfi_config
172 %{_bindir}/sfi*.py*
173 %{_bindir}/sfi
174 %{_bindir}/get*.py*
175 %{_bindir}/setRecord.py*
176 %{_bindir}/sfascan.py*
177 %{_bindir}/sfascan
178 %{_bindir}/sfadump.py*
179
180 %files sfatables
181 /etc/sfatables/*
182 %{_bindir}/sfatables
183 %{python_sitelib}/sfatables
184
185 %files cm
186 /etc/init.d/sfa-cm
187 %{_bindir}/sfa_component_setup.py*
188 # cron jobs here 
189
190 %files flashpolicy
191 %{_bindir}/sfa_flashpolicy.py*
192 /etc/sfa/sfa_flashpolicy_config.xml
193
194 %files xmlbuilder
195 %{python_sitelib}/xmlbuilder
196
197 %files tests
198 %{_datadir}/sfa/tests
199
200 ### sfa-plc installs the 'sfa' service
201 %post plc
202 chkconfig --add sfa
203
204 %preun plc
205 if [ "$1" = 0 ] ; then
206   /sbin/service sfa stop || :
207   /sbin/chkconfig --del sfa || :
208 fi
209
210 %postun plc
211 [ "$1" -ge "1" ] && service sfa restart
212
213 ### sfa-cm installs the 'sfa-cm' service
214 %post cm
215 chkconfig --add sfa-cm
216
217 %preun cm
218 if [ "$1" = 0 ] ; then
219    /sbin/service sfa-cm stop || :
220    /sbin/chkconfig --del sfa-cm || :
221 fi
222
223 %postun cm
224 [ "$1" -ge "1" ] && service sfa-cm restart || :
225
226 %changelog
227 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
228 - screwed up previous tag
229
230 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
231 - client side revisited with a bootstrap library
232 - client side has a new source layout
233 - various (nasty) bug fixes wrt options and call_id
234
235 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
236 - various fixes in rspecs for sfav1&slice tags
237 - uses 'geni_rspec_version' and not just 'rspec_version'
238 - example flavour for the max testbed
239 - embryo for an sfa client library
240 - topology.py moved into plc
241 - sql: table is named records; record_types are enforced
242 - sql: table creation cleaned up
243
244 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
245 - cleaned up all references to SFA_*_TYPE in config
246 - enable cache at the aggregate by default
247 - registry now uses the driver in a sensible way (see managers/driver.py)
248 - slice manager supports sfav1/pgv2 neighbours
249 - get_key renamed into get_key_from_incoming_ip
250 - new sfa.storage module for record/table and all db-related stuff
251 - db schema in sfa.storage.sfa.sql
252 - init.d and cron.d move one step up
253 - cleaned up rspec/ directory
254 - add deps to pyopenssl and myplc-config
255 - start support for new API (return value)
256 - plc.remoteshell removed, use plshell instead
257 - plshell uses a 'capability' auth method whenever possible
258 - various tweaks in rspec elements
259 - made dependency on sfatables softer
260
261 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
262 - sfa should now be started *before* the initial import
263 - sfa to use its own database (default sfa) - can run without myplc
264 - server calls support optional 'options'
265 - client sends options in argument when needed
266 - fix infinite getattr recursion in elements/element.py
267 - error codes in line with geni
268
269 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
270 - fixed links and attributes in rspecs
271 - minor cleanup in the API methods, and more consistent names in manager methods
272
273 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
274 - ongoing refoactoring towards more genericity
275 - passes tests again although known issues remain with attributes/tags
276
277 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
278 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
279 - improvements in the pgv2 rspecs
280 - driver separated from api
281 - code starts moving around where it belongs
282 - sfascan caches getversion across invokations
283 - vini topology extracted as a config file
284
285 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
286 - first support for protogeni rspecs is working
287 - vini no longer needs a specific manager
288 - refactoring underway towards more flexible/generic architecture
289
290 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
291 - Unicode-friendliness for user names with accents/special chars.
292 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
293 - CreaetSliver no longer fails for users that have a capital letter in their URN.
294 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
295 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
296 - Fix bugs and missing imports     
297  
298
299 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
300 - new method record.get_field for sface
301
302 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
303 - new option -c to sfa-nuke-plc.py
304 - CreateSliver fixed for admin-only slice tags
305
306 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
307 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
308 - Fixed holes in certificate verification logic.
309 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
310 - Added 'boot_state' as an attribute of the node element in SFA rspec.
311 - Non authority certificates are marked as CA:FALSE.
312
313 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
314 - fix typo in sfa-1.0-31 tag.
315 - added CreateGid() Registry interface method.
316
317 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
318 - fix typo in sfa-1.0-30 tag
319
320 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
321 - Declare namespace and schema location in the credential.
322 - Fix bug that prevetend connections from timing out.
323 - Fix slice delegation.
324 - Add statistics to slicemaanger listresources/createsliver rspec.
325 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
326   of days a user can extend their slice expiration.
327 - CA certs are only issued to objects of type authority
328    
329 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
330 - tag 1.0-28 was broken due to typo in the changelog
331 - new class sfa/util/httpsProtocol.py that supports timeouts
332
333 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
334 - Resolved issue that caused sfa hold onto idle db connections.
335 - Fix bug that caused the registry to use the wrong type of credential.
336 - Support authority+sm type.
337 - Fix rspec merging bugs.
338 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
339 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
340  planetlab hosted initscripts using the <planetlab:initscript> tag  
341 - Can now handle extraneous whitespace in the rspec without failing.   
342  
343 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
344 - ProtoGENI v2 RSpec updates.
345 - Convert expiration timestamps with timezone info in credentials to utc.
346 - Fixed redundant logging issue. 
347 - Improved SliceManager and SFI client logging.
348 - Support aggregates that don't support the optional 'call_id' argument. 
349 - Only call get_trusted_certs() at aggreage interfaces that support the call.
350 - CreateSliver() now handles MyPLC slice attributes/tags.
351 - Cache now supports persistence.
352 - Hide whitelisted nodes.
353
354 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
355 - fixed issues with sup authority signing
356 - fixed bugs in remove_slivers and SliverStatus
357
358 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
359 - fix typo that prevented aggregates from operating properly
360
361 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
362 - load trusted certs into ssl context prior to handshake
363 - client's logfile lives in ~/.sfi/sfi.log
364
365 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
366 - includes a change on passphrases that was intended in 1.0-22
367
368 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
369 - Added support for ProtoGENI RSpec v2
370  
371 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
372 - stable sfascan
373 - fix in initscript, *ENABLED tags in config now taken into account
374
375 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
376 - some commits had not been pushed in tag 19
377
378 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
379 - GetVersion should now report full URLs with path
380 - scansfa has nicer output and new syntax (entry URLs as args and not options)
381 - dos2unix'ed flash policy pill
382
383 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
384 - fix packaging again for f8
385
386 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
387 - fix packaging (apparently broken in 1.0-16)
388 - first working version of sfascan
389 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
390 - deprecated the sfa_geni_aggregate config category
391
392 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
393 - Fix build problem
394 - First version of SFA scanner
395
396 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
397 - Add support for Flash clients using flashpolicy
398 - Fix problems with tag handling in RSpec
399
400 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
401 - Modifications to the Eucalyptus Aggregate Manager
402 - Fixes for VINI RSpec
403 - Fix tag handling for PL RSpec
404 - Fix XML Schema ordering for <urn> element
405
406 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
407 - just set x509 version to 2
408
409 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
410 - added urn to the node area in rspecs
411 - conversion to urn now exports fqdn
412 - sfa-import-plc.py now creates a unique registry record for each SFA interface
413
414 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
415 - undo broken attempt for python-2.7
416
417 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
418 - SMs avoid duplicates for when call graph has dags;
419 - just based on network's name, when a duplicate occurs, one is just dropped
420 - does not try to merge/aggregate 2 networks
421 - also reviewed logging with the hope to fix the sfa startup msg:
422 - TypeError: not all arguments converted during string formatting
423
424 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
425 - verify credentials against xsd schema
426 - Fix SM to SM communication
427 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
428 - new setting session_key_path
429
430 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
431 - fix registry credential regeneration and handle expiration
432 - support for setting slice tags (min_role=user)
433 - client can display its own version: sfi.py version --local
434 - GetVersion to provide urn in addition to hrn
435 - more code uses plxrn vs previous helper functions
436 - import replaces '+' in email addresses with '_'
437
438 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
439 - fix GetVersion code_tag and add code_url
440
441 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
442 - extend GetVersion towards minimum federation introspection, and expose local tag
443
444 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
445 - fixed some legacy issues (list vs List)
446 - deprecated sfa.util.namespace for xrn and plxrn
447 - unit tests ship as the sfa-tests rpm
448
449 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
450 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
451 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
452 - hrn-urn translations tweaked
453 - fixed 'service sfa status'
454 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
455 - started to repair sfadump - although not usable yet
456 - trust objects now have dump_string method that dump() actually prints
457 - unit tests under review
458 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
459 - binaries now support -v or -vv to increase loglevel
460 - trashed obsolete sfa.util.client
461
462 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
463 - various bugfixes and cleanup, improved/harmonized logging
464
465 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
466 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
467   to avoid returning a PLCAPI exception that might confuse users.
468 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
469 - fix build errors.  
470
471 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
472 - (Architecture) Credential format changed to match ProtoGENI xml format
473 - (Architecture) All interfaces export a new set of methods that are compatible
474    with the ProtoGeni Aggregate spec. These new methods are considered a 
475    replacement  for the pervious methods exported by the interfaces. All 
476    previous methods are still exported and work as normal, but they are 
477    considered deprecated and will not be supported in future releases.  
478 - (Architecture) SFI has been updated to use the new interface methods.
479 - (Architecture) Changed keyconvet implementation from c to python.
480 - (Architecture) Slice Manager now attempts looks for a delegated credential
481   provided by the client before using its own server credential.
482 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
483   This cache now exists only in memory and is cleared when service is restarted
484   or cache lifetime is exceeded.  
485 - (Performance) SliceManager sends request to Aggregates in parallel instead 
486   of sequentially.
487 - (Bug fix) SFA tickets now support the new rspec format.
488 - (Bug fix) SFI only uses cahced credential if they aren't expired.
489 - (Bug fix) Cerdential delegation modified to work with new credential format.
490 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
491   Aggregate instead of relaying through the Slice Manager.
492 - (Enhancement) Simplified caching. Accociated a global cache instance with
493   the api handler on every new server request, making it easier to access the 
494   cache and use in more general ways.     
495
496 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
497 - SfaServer now uses a pool of threads to handle requests concurrently
498 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
499 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
500 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
501 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
502 - Component manager does not install gid files if slice already has them  
503 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
504 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
505 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
506      
507 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
508 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
509 - - sfa-config-tty now has the same features like plc-config-tty
510 - - Contains code to support both urn and hrn
511 - - Cleaned up request_hash related stuff
512 - - SM, AM and Registry code is organized under respective managers
513 - - Site and Slice synchronization across federated aggregates
514 - - Script to generate sfa_component_config
515
516 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
517 - sfa-config-tty now has the same features like plc-config-tty
518 - Contains code to support both urn and hrn
519 - Cleaned up request_hash related stuff
520 - SM, AM and Registry code is organized under respective managers
521 - Slice synchronization across federated aggregates
522 - some bugs are fixed
523
524 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
525 - checkpoint with fewer mentions of geni
526
527 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
528 - checkpointing
529 - this is believed to pass the tests; among other things:
530 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
531
532 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
533 - This tag includes:
534 - - Sfatables
535 - - Preliminary version of hash based authentication
536 - - Initial code for Component Manager
537 - - Authority structure is moved to /var/lib/sfa/
538 - - some bug-fixes
539
540 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
541 - Create_slice and get_resources methods are connected to sfatables.
542 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
543
544 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
545 - Bug fix on update and remove_peer_object methods
546 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
547
548 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
549 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
550
551 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
552 - compatibility with RefreshPeer
553 - incremental mechanism for importing PLC records into SFA tables
554 - unified single database (still inside the underlying PLC db postgresql server)
555 - includes/improves call traceability and logging features
556 - several bug fixes
557
558 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
559 - added libxslt-python dependency
560
561 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
562 - unified single SFA database in the PLC-DB
563 - upcalls from  PLCAPI to SFA methods
564 - SFA call traceability and logging features
565 - many bug fixes
566 - includes first/rough version of sfatables for policy implementation
567
568 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
569 - snapshot after the GEC5 demo
570 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
571
572 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
573 - snapshot july 15 - has gone through superficial manual testing
574 - hopefully a good basis for gec5 demo
575 - multi-dir sfi client tested as well
576
577 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
578 - rename geniwrapper.spec into sfa.spec
579
580 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
581 - clean up in xmlrpc/soap, --protocol option to chose between both
582 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
583 - hopefully more helpful context in case of crashes when importing
584 - bugfixes for using only /etc/sfa for site-dep files
585 - bugfixes in wsdl generation
586
587 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
588 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
589 - config variables in sfa_config now start with SFA_ and not GENI_
590 - config.py can be loaded even with no config present
591
592 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
593 - first step for cleanup and reorganization
594 - mass-renaming from geni to sfa (some are still needed)
595 - sfa/trust implements the security architecture
596
597 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
598 - snapshot for reproducible builds
599
600 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
601 - snapshot for the convenience of alpha users
602
603 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
604 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
605
606 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
607 - ongoing work - snapshot for 4.3-rc9
608
609 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
610 - various fixes
611
612 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
613 - bugfixes - still a work in progress
614
615 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
616 - initial package
617
618
619 %define module_current_branch 0.2