Setting tag sfa-2.0-1
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45  
46 # python 2.5 has uuid module added, for python 2.4 we still need it.
47 # we can't really check for if we can load uuid as a python module,
48 # it'll be installed by "devel.pkgs". we have the epel repository so
49 # python-uuid will be provided. but we can test for the python
50 # version.
51 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
52 # %if %has_py24
53 #
54 # this also didn't work very well. I'll just check for distroname - baris
55 #%if %{distroname} == "centos5"
56 #Requires: python-uuid
57 #%endif
58
59 %package plc
60 Summary: the SFA layer around MyPLC
61 Group: Applications/System
62 Requires: sfa
63 Requires: python-psycopg2
64
65 %package client
66 Summary: the SFA experimenter-side CLI
67 Group: Applications/System
68 Requires: sfa
69 Requires: pyOpenSSL >= 0.7
70
71 %package sfatables
72 Summary: sfatables policy tool for SFA
73 Group: Applications/System
74 Requires: sfa
75
76 %package cm
77 Summary: the SFA layer around MyPLC NodeManager
78 Group: Applications/System
79 Requires: sfa
80 Requires: pyOpenSSL >= 0.6
81
82 %package flashpolicy
83 Summary: SFA support for flash clients
84 Group: Applications/System
85 Requires: sfa
86
87 %package tests
88 Summary: unit tests suite for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %description
93 This package provides the python libraries for the PlanetLab implementation of SFA
94
95 %description plc
96 This package implements the SFA interface which serves as a layer
97 between the existing PlanetLab interfaces and the SFA API.
98
99 %description client
100 This package provides the client side of the SFA API, in particular
101 sfi.py, together with other utilities.
102
103 %description sfatables
104 sfatables is a tool for defining access and admission control policies
105 in an SFA network, in much the same way as iptables is for ip
106 networks. This is the command line interface to manage sfatables
107
108 %description cm
109 This package implements the SFA interface which serves as a layer
110 between the existing PlanetLab NodeManager interfaces and the SFA API.
111  
112 %description flashpolicy
113 This package provides support for adobe flash client applications.  
114  
115 %description tests
116 Provides some binary unit tests in /usr/share/sfa/tests
117
118 %prep
119 %setup -q
120
121 %build
122 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
127 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/*egg-info
128 # this gets duplicated
129 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/sfa/storage/sfa.sql
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 # sfa and sfatables depend on each other.
136 %{python_sitelib}/sfa
137 %{python_sitelib}/xmlbuilder
138 /etc/init.d/sfa
139 %{_bindir}/sfa-start.py*
140 %{_bindir}/keyconvert.py*
141 %{_bindir}/sfa-config-tty
142 %config /etc/sfa/default_config.xml
143 %config (noreplace) /etc/sfa/aggregates.xml
144 %config (noreplace) /etc/sfa/registries.xml
145 /usr/share/sfa/sfa.sql
146 /var/www/html/wsdl/*.wsdl
147
148 %files plc
149 %defattr(-,root,root)
150 /etc/sfa/pl.rng
151 /etc/sfa/credential.xsd
152 /etc/sfa/top.xsd
153 /etc/sfa/sig.xsd
154 /etc/sfa/xml.xsd
155 /etc/sfa/protogeni-rspec-common.xsd
156 /etc/sfa/topology
157 %{_bindir}/sfa-import-plc.py*
158 %{_bindir}/sfa-nuke-plc.py*
159 %{_bindir}/sfa-clean-peer-records.py*
160 %{_bindir}/gen-sfa-cm-config.py*
161 %{_bindir}/sfa-ca.py*
162
163 %files client
164 %config (noreplace) /etc/sfa/sfi_config
165 %{_bindir}/sfi*
166 %{_bindir}/getNodes.py*
167 %{_bindir}/getRecord.py*
168 %{_bindir}/setRecord.py*
169 %{_bindir}/sfadump.py*
170
171 %files sfatables
172 /etc/sfatables/*
173 %{_bindir}/sfatables
174 %{python_sitelib}/sfatables
175
176 %files cm
177 /etc/init.d/sfa-cm
178 %{_bindir}/sfa_component_setup.py*
179 # cron jobs here 
180
181 %files flashpolicy
182 %{_bindir}/sfa_flashpolicy.py*
183 /etc/sfa/sfa_flashpolicy_config.xml
184
185 %files tests
186 %{_datadir}/sfa/tests
187
188 ### sfa-plc installs the 'sfa' service
189 %post plc
190 chkconfig --add sfa
191
192 %preun plc
193 if [ "$1" = 0 ] ; then
194   /sbin/service sfa stop || :
195   /sbin/chkconfig --del sfa || :
196 fi
197
198 %postun plc
199 [ "$1" -ge "1" ] && service sfa restart
200
201 ### sfa-cm installs the 'sfa-cm' service
202 %post cm
203 chkconfig --add sfa-cm
204
205 %preun cm
206 if [ "$1" = 0 ] ; then
207    /sbin/service sfa-cm stop || :
208    /sbin/chkconfig --del sfa-cm || :
209 fi
210
211 %postun cm
212 [ "$1" -ge "1" ] && service sfa-cm restart || :
213
214 %changelog
215 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
216 - cleaned up all references to SFA_*_TYPE in config
217 - enable cache at the aggregate by default
218 - registry now uses the driver in a sensible way (see managers/driver.py)
219 - slice manager supports sfav1/pgv2 neighbours
220 - get_key renamed into get_key_from_incoming_ip
221 - new sfa.storage module for record/table and all db-related stuff
222 - db schema in sfa.storage.sfa.sql
223 - init.d and cron.d move one step up
224 - cleaned up rspec/ directory
225 - add deps to pyopenssl and myplc-config
226 - start support for new API (return value)
227 - plc.remoteshell removed, use plshell instead
228 - plshell uses a 'capability' auth method whenever possible
229 - various tweaks in rspec elements
230 - made dependency on sfatables softer
231
232 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
233 - sfa should now be started *before* the initial import
234 - sfa to use its own database (default sfa) - can run without myplc
235 - server calls support optional 'options'
236 - client sends options in argument when needed
237 - fix infinite getattr recursion in elements/element.py
238 - error codes in line with geni
239
240 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
241 - fixed links and attributes in rspecs
242 - minor cleanup in the API methods, and more consistent names in manager methods
243
244 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
245 - ongoing refoactoring towards more genericity
246 - passes tests again although known issues remain with attributes/tags
247
248 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
249 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
250 - improvements in the pgv2 rspecs
251 - driver separated from api
252 - code starts moving around where it belongs
253 - sfascan caches getversion across invokations
254 - vini topology extracted as a config file
255
256 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
257 - first support for protogeni rspecs is working
258 - vini no longer needs a specific manager
259 - refactoring underway towards more flexible/generic architecture
260
261 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
262 - Unicode-friendliness for user names with accents/special chars.
263 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
264 - CreaetSliver no longer fails for users that have a capital letter in their URN.
265 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
266 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
267 - Fix bugs and missing imports     
268  
269
270 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
271 - new method record.get_field for sface
272
273 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
274 - new option -c to sfa-nuke-plc.py
275 - CreateSliver fixed for admin-only slice tags
276
277 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
278 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
279 - Fixed holes in certificate verification logic.
280 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
281 - Added 'boot_state' as an attribute of the node element in SFA rspec.
282 - Non authority certificates are marked as CA:FALSE.
283
284 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
285 - fix typo in sfa-1.0-31 tag.
286 - added CreateGid() Registry interface method.
287
288 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
289 - fix typo in sfa-1.0-30 tag
290
291 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
292 - Declare namespace and schema location in the credential.
293 - Fix bug that prevetend connections from timing out.
294 - Fix slice delegation.
295 - Add statistics to slicemaanger listresources/createsliver rspec.
296 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
297   of days a user can extend their slice expiration.
298 - CA certs are only issued to objects of type authority
299    
300 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
301 - tag 1.0-28 was broken due to typo in the changelog
302 - new class sfa/util/httpsProtocol.py that supports timeouts
303
304 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
305 - Resolved issue that caused sfa hold onto idle db connections.
306 - Fix bug that caused the registry to use the wrong type of credential.
307 - Support authority+sm type.
308 - Fix rspec merging bugs.
309 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
310 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
311  planetlab hosted initscripts using the <planetlab:initscript> tag  
312 - Can now handle extraneous whitespace in the rspec without failing.   
313  
314 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
315 - ProtoGENI v2 RSpec updates.
316 - Convert expiration timestamps with timezone info in credentials to utc.
317 - Fixed redundant logging issue. 
318 - Improved SliceManager and SFI client logging.
319 - Support aggregates that don't support the optional 'call_id' argument. 
320 - Only call get_trusted_certs() at aggreage interfaces that support the call.
321 - CreateSliver() now handles MyPLC slice attributes/tags.
322 - Cache now supports persistence.
323 - Hide whitelisted nodes.
324
325 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
326 - fixed issues with sup authority signing
327 - fixed bugs in remove_slivers and SliverStatus
328
329 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
330 - fix typo that prevented aggregates from operating properly
331
332 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
333 - load trusted certs into ssl context prior to handshake
334 - client's logfile lives in ~/.sfi/sfi.log
335
336 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
337 - includes a change on passphrases that was intended in 1.0-22
338
339 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
340 - Added support for ProtoGENI RSpec v2
341  
342 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
343 - stable sfascan
344 - fix in initscript, *ENABLED tags in config now taken into account
345
346 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
347 - some commits had not been pushed in tag 19
348
349 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
350 - GetVersion should now report full URLs with path
351 - scansfa has nicer output and new syntax (entry URLs as args and not options)
352 - dos2unix'ed flash policy pill
353
354 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
355 - fix packaging again for f8
356
357 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
358 - fix packaging (apparently broken in 1.0-16)
359 - first working version of sfascan
360 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
361 - deprecated the sfa_geni_aggregate config category
362
363 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
364 - Fix build problem
365 - First version of SFA scanner
366
367 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
368 - Add support for Flash clients using flashpolicy
369 - Fix problems with tag handling in RSpec
370
371 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
372 - Modifications to the Eucalyptus Aggregate Manager
373 - Fixes for VINI RSpec
374 - Fix tag handling for PL RSpec
375 - Fix XML Schema ordering for <urn> element
376
377 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
378 - just set x509 version to 2
379
380 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
381 - added urn to the node area in rspecs
382 - conversion to urn now exports fqdn
383 - sfa-import-plc.py now creates a unique registry record for each SFA interface
384
385 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
386 - undo broken attempt for python-2.7
387
388 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
389 - SMs avoid duplicates for when call graph has dags;
390 - just based on network's name, when a duplicate occurs, one is just dropped
391 - does not try to merge/aggregate 2 networks
392 - also reviewed logging with the hope to fix the sfa startup msg:
393 - TypeError: not all arguments converted during string formatting
394
395 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
396 - verify credentials against xsd schema
397 - Fix SM to SM communication
398 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
399 - new setting session_key_path
400
401 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
402 - fix registry credential regeneration and handle expiration
403 - support for setting slice tags (min_role=user)
404 - client can display its own version: sfi.py version --local
405 - GetVersion to provide urn in addition to hrn
406 - more code uses plxrn vs previous helper functions
407 - import replaces '+' in email addresses with '_'
408
409 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
410 - fix GetVersion code_tag and add code_url
411
412 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
413 - extend GetVersion towards minimum federation introspection, and expose local tag
414
415 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
416 - fixed some legacy issues (list vs List)
417 - deprecated sfa.util.namespace for xrn and plxrn
418 - unit tests ship as the sfa-tests rpm
419
420 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
421 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
422 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
423 - hrn-urn translations tweaked
424 - fixed 'service sfa status'
425 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
426 - started to repair sfadump - although not usable yet
427 - trust objects now have dump_string method that dump() actually prints
428 - unit tests under review
429 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
430 - binaries now support -v or -vv to increase loglevel
431 - trashed obsolete sfa.util.client
432
433 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
434 - various bugfixes and cleanup, improved/harmonized logging
435
436 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
437 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
438   to avoid returning a PLCAPI exception that might confuse users.
439 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
440 - fix build errors.  
441
442 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
443 - (Architecture) Credential format changed to match ProtoGENI xml format
444 - (Architecture) All interfaces export a new set of methods that are compatible
445    with the ProtoGeni Aggregate spec. These new methods are considered a 
446    replacement  for the pervious methods exported by the interfaces. All 
447    previous methods are still exported and work as normal, but they are 
448    considered deprecated and will not be supported in future releases.  
449 - (Architecture) SFI has been updated to use the new interface methods.
450 - (Architecture) Changed keyconvet implementation from c to python.
451 - (Architecture) Slice Manager now attempts looks for a delegated credential
452   provided by the client before using its own server credential.
453 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
454   This cache now exists only in memory and is cleared when service is restarted
455   or cache lifetime is exceeded.  
456 - (Performance) SliceManager sends request to Aggregates in parallel instead 
457   of sequentially.
458 - (Bug fix) SFA tickets now support the new rspec format.
459 - (Bug fix) SFI only uses cahced credential if they aren't expired.
460 - (Bug fix) Cerdential delegation modified to work with new credential format.
461 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
462   Aggregate instead of relaying through the Slice Manager.
463 - (Enhancement) Simplified caching. Accociated a global cache instance with
464   the api handler on every new server request, making it easier to access the 
465   cache and use in more general ways.     
466
467 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
468 - SfaServer now uses a pool of threads to handle requests concurrently
469 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
470 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
471 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
472 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
473 - Component manager does not install gid files if slice already has them  
474 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
475 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
476 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
477      
478 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
479 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
480 - - sfa-config-tty now has the same features like plc-config-tty
481 - - Contains code to support both urn and hrn
482 - - Cleaned up request_hash related stuff
483 - - SM, AM and Registry code is organized under respective managers
484 - - Site and Slice synchronization across federated aggregates
485 - - Script to generate sfa_component_config
486
487 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
488 - sfa-config-tty now has the same features like plc-config-tty
489 - Contains code to support both urn and hrn
490 - Cleaned up request_hash related stuff
491 - SM, AM and Registry code is organized under respective managers
492 - Slice synchronization across federated aggregates
493 - some bugs are fixed
494
495 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
496 - checkpoint with fewer mentions of geni
497
498 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
499 - checkpointing
500 - this is believed to pass the tests; among other things:
501 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
502
503 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
504 - This tag includes:
505 - - Sfatables
506 - - Preliminary version of hash based authentication
507 - - Initial code for Component Manager
508 - - Authority structure is moved to /var/lib/sfa/
509 - - some bug-fixes
510
511 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
512 - Create_slice and get_resources methods are connected to sfatables.
513 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
514
515 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
516 - Bug fix on update and remove_peer_object methods
517 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
518
519 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
520 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
521
522 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
523 - compatibility with RefreshPeer
524 - incremental mechanism for importing PLC records into SFA tables
525 - unified single database (still inside the underlying PLC db postgresql server)
526 - includes/improves call traceability and logging features
527 - several bug fixes
528
529 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
530 - added libxslt-python dependency
531
532 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
533 - unified single SFA database in the PLC-DB
534 - upcalls from  PLCAPI to SFA methods
535 - SFA call traceability and logging features
536 - many bug fixes
537 - includes first/rough version of sfatables for policy implementation
538
539 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
540 - snapshot after the GEC5 demo
541 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
542
543 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
544 - snapshot july 15 - has gone through superficial manual testing
545 - hopefully a good basis for gec5 demo
546 - multi-dir sfi client tested as well
547
548 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
549 - rename geniwrapper.spec into sfa.spec
550
551 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
552 - clean up in xmlrpc/soap, --protocol option to chose between both
553 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
554 - hopefully more helpful context in case of crashes when importing
555 - bugfixes for using only /etc/sfa for site-dep files
556 - bugfixes in wsdl generation
557
558 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
559 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
560 - config variables in sfa_config now start with SFA_ and not GENI_
561 - config.py can be loaded even with no config present
562
563 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
564 - first step for cleanup and reorganization
565 - mass-renaming from geni to sfa (some are still needed)
566 - sfa/trust implements the security architecture
567
568 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
569 - snapshot for reproducible builds
570
571 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
572 - snapshot for the convenience of alpha users
573
574 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
575 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
576
577 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
578 - ongoing work - snapshot for 4.3-rc9
579
580 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
581 - various fixes
582
583 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
584 - bugfixes - still a work in progress
585
586 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
587 - initial package
588
589
590 %define module_current_branch 0.2