Setting tag sfa-1.0-20
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 20
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %Package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart
197
198
199 %changelog
200 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
201 - some commits had not been pushed in tag 19
202
203 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
204 - GetVersion should now report full URLs with path
205 - scansfa has nicer output and new syntax (entry URLs as args and not options)
206 - dos2unix'ed flash policy pill
207
208 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
209 - fix packaging again for f8
210
211 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
212 - fix packaging (apparently broken in 1.0-16)
213 - first working version of sfascan
214 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
215 - deprecated the sfa_geni_aggregate config category
216
217 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
218 - Fix build problem
219 - First version of SFA scanner
220
221 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
222 - Add support for Flash clients using flashpolicy
223 - Fix problems with tag handling in RSpec
224
225 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
226 - Modifications to the Eucalyptus Aggregate Manager
227 - Fixes for VINI RSpec
228 - Fix tag handling for PL RSpec
229 - Fix XML Schema ordering for <urn> element
230
231 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
232 - just set x509 version to 2
233
234 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
235 - added urn to the node area in rspecs
236 - conversion to urn now exports fqdn
237 - sfa-import-plc.py now creates a unique registry record for each SFA interface
238
239 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
240 - undo broken attempt for python-2.7
241
242 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
243 - SMs avoid duplicates for when call graph has dags;
244 - just based on network's name, when a duplicate occurs, one is just dropped
245 - does not try to merge/aggregate 2 networks
246 - also reviewed logging with the hope to fix the sfa startup msg:
247 - TypeError: not all arguments converted during string formatting
248
249 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
250 - verify credentials against xsd schema
251 - Fix SM to SM communication
252 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
253 - new setting session_key_path
254
255 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
256 - fix registry credential regeneration and handle expiration
257 - support for setting slice tags (min_role=user)
258 - client can display its own version: sfi.py version --local
259 - GetVersion to provide urn in addition to hrn
260 - more code uses plxrn vs previous helper functions
261 - import replaces '+' in email addresses with '_'
262
263 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
264 - fix GetVersion code_tag and add code_url
265
266 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
267 - extend GetVersion towards minimum federation introspection, and expose local tag
268
269 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
270 - fixed some legacy issues (list vs List)
271 - deprecated sfa.util.namespace for xrn and plxrn
272 - unit tests ship as the sfa-tests rpm
273
274 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
275 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
276 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
277 - hrn-urn translations tweaked
278 - fixed 'service sfa status'
279 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
280 - started to repair sfadump - although not usable yet
281 - trust objects now have dump_string method that dump() actually prints
282 - unit tests under review
283 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
284 - binaries now support -v or -vv to increase loglevel
285 - trashed obsolete sfa.util.client
286
287 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
288 - various bugfixes and cleanup, improved/harmonized logging
289
290 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
291 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
292   to avoid returning a PLCAPI exception that might confuse users.
293 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
294 - fix build errors.  
295
296 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
297 - (Architecture) Credential format changed to match ProtoGENI xml format
298 - (Architecture) All interfaces export a new set of methods that are compatible
299    with the ProtoGeni Aggregate spec. These new methods are considered a 
300    replacement  for the pervious methods exported by the interfaces. All 
301    previous methods are still exported and work as normal, but they are 
302    considered deprecated and will not be supported in future releases.  
303 - (Architecture) SFI has been updated to use the new interface methods.
304 - (Architecture) Changed keyconvet implementation from c to python.
305 - (Architecture) Slice Manager now attempts looks for a delegated credential
306   provided by the client before using its own server credential.
307 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
308   This cache now exists only in memory and is cleared when service is restarted
309   or cache lifetime is exceeded.  
310 - (Performance) SliceManager sends request to Aggregates in parallel instead 
311   of sequentially.
312 - (Bug fix) SFA tickets now support the new rspec format.
313 - (Bug fix) SFI only uses cahced credential if they aren't expired.
314 - (Bug fix) Cerdential delegation modified to work with new credential format.
315 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
316   Aggregate instead of relaying through the Slice Manager.
317 - (Enhancement) Simplified caching. Accociated a global cache instance with
318   the api handler on every new server request, making it easier to access the 
319   cache and use in more general ways.     
320
321 %changelog
322 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
323 - some commits had not been pushed in tag 19
324
325 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
326 - GetVersion should now report full URLs with path
327 - scansfa has nicer output and new syntax (entry URLs as args and not options)
328 - dos2unix'ed flash policy pill
329
330 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
331 - fix packaging again for f8
332
333 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
334 - fix packaging (apparently broken in 1.0-16)
335 - first working version of sfascan
336 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
337 - deprecated the sfa_geni_aggregate config category
338
339 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
340 - Fix build problem
341 - First version of SFA scanner
342
343 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
344 - Add support for Flash clients using flashpolicy
345 - Fix problems with tag handling in RSpec
346
347 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
348 - Modifications to the Eucalyptus Aggregate Manager
349 - Fixes for VINI RSpec
350 - Fix tag handling for PL RSpec
351 - Fix XML Schema ordering for <urn> element
352
353 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
354 - just set x509 version to 2
355
356 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
357 - added urn to the node area in rspecs
358 - conversion to urn now exports fqdn
359 - sfa-import-plc.py now creates a unique registry record for each SFA interface
360
361 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
362 - undo broken attempt for python-2.7
363
364 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
365 - SMs avoid duplicates for when call graph has dags;
366 - just based on network's name, when a duplicate occurs, one is just dropped
367 - does not try to merge/aggregate 2 networks
368 - also reviewed logging with the hope to fix the sfa startup msg:
369 - TypeError: not all arguments converted during string formatting
370
371 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
372 - verify credentials against xsd schema
373 - Fix SM to SM communication
374 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
375 - new setting session_key_path
376
377 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
378 - fix registry credential regeneration and handle expiration
379 - support for setting slice tags (min_role=user)
380 - client can display its own version: sfi.py version --local
381 - GetVersion to provide urn in addition to hrn
382 - more code uses plxrn vs previous helper functions
383 - import replaces '+' in email addresses with '_'
384
385 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
386 - fix GetVersion code_tag and add code_url
387
388 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
389 - extend GetVersion towards minimum federation introspection, and expose local tag
390
391 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
392 - fixed some legacy issues (list vs List)
393 - deprecated sfa.util.namespace for xrn and plxrn
394 - unit tests ship as the sfa-tests rpm
395
396 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
397 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
398 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
399 - hrn-urn translations tweaked
400 - fixed 'service sfa status'
401 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
402 - started to repair sfadump - although not usable yet
403 - trust objects now have dump_string method that dump() actually prints
404 - unit tests under review
405 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
406 - binaries now support -v or -vv to increase loglevel
407 - trashed obsolete sfa.util.client
408
409 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
410 - various bugfixes and cleanup, improved/harmonized logging
411
412 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
413 - SfaServer now uses a pool of threads to handle requests concurrently
414 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
415 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
416 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
417 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
418 - Component manager does not install gid files if slice already has them  
419 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
420 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
421 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
422      
423 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
424 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
425 - - sfa-config-tty now has the same features like plc-config-tty
426 - - Contains code to support both urn and hrn
427 - - Cleaned up request_hash related stuff
428 - - SM, AM and Registry code is organized under respective managers
429 - - Site and Slice synchronization across federated aggregates
430 - - Script to generate sfa_component_config
431
432 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
433 - sfa-config-tty now has the same features like plc-config-tty
434 - Contains code to support both urn and hrn
435 - Cleaned up request_hash related stuff
436 - SM, AM and Registry code is organized under respective managers
437 - Slice synchronization across federated aggregates
438 - some bugs are fixed
439
440 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
441 - checkpoint with fewer mentions of geni
442
443 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
444 - checkpointing
445 - this is believed to pass the tests; among other things:
446 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
447
448 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
449 - This tag includes:
450 - - Sfatables
451 - - Preliminary version of hash based authentication
452 - - Initial code for Component Manager
453 - - Authority structure is moved to /var/lib/sfa/
454 - - some bug-fixes
455
456 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
457 - Create_slice and get_resources methods are connected to sfatables.
458 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
459
460 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
461 - Bug fix on update and remove_peer_object methods
462 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
463
464 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
465 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
466
467 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
468 - compatibility with RefreshPeer
469 - incremental mechanism for importing PLC records into SFA tables
470 - unified single database (still inside the underlying PLC db postgresql server)
471 - includes/improves call traceability and logging features
472 - several bug fixes
473
474 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
475 - added libxslt-python dependency
476
477 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
478 - unified single SFA database in the PLC-DB
479 - upcalls from  PLCAPI to SFA methods
480 - SFA call traceability and logging features
481 - many bug fixes
482 - includes first/rough version of sfatables for policy implementation
483
484 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
485 - snapshot after the GEC5 demo
486 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
487
488 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
489 - snapshot july 15 - has gone through superficial manual testing
490 - hopefully a good basis for gec5 demo
491 - multi-dir sfi client tested as well
492
493 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
494 - rename geniwrapper.spec into sfa.spec
495
496 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
497 - clean up in xmlrpc/soap, --protocol option to chose between both
498 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
499 - hopefully more helpful context in case of crashes when importing
500 - bugfixes for using only /etc/sfa for site-dep files
501 - bugfixes in wsdl generation
502
503 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
504 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
505 - config variables in sfa_config now start with SFA_ and not GENI_
506 - config.py can be loaded even with no config present
507
508 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
509 - first step for cleanup and reorganization
510 - mass-renaming from geni to sfa (some are still needed)
511 - sfa/trust implements the security architecture
512
513 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
514 - snapshot for reproducible builds
515
516 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
517 - snapshot for the convenience of alpha users
518
519 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
520 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
521
522 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
523 - ongoing work - snapshot for 4.3-rc9
524
525 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
526 - various fixes
527
528 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
529 - bugfixes - still a work in progress
530
531 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
532 - initial package
533
534
535 %define module_current_branch 0.2