Setting tag sfa-2.1-12
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 12
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package flashpolicy
66 Summary: SFA support for flash clients
67 Group: Applications/System
68 Requires: sfa
69
70 %package client
71 Summary: the SFA experimenter-side CLI
72 Group: Applications/System
73 Requires: sfa
74 Requires: pyOpenSSL >= 0.7
75
76 %package plc
77 Summary: the SFA layer around MyPLC
78 Group: Applications/System
79 Requires: sfa
80
81 %package cm
82 Summary: the SFA layer around MyPLC NodeManager
83 Group: Applications/System
84 Requires: sfa
85 Requires: pyOpenSSL >= 0.6
86
87 %package federica
88 Summary: the SFA layer around Federica
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa
106
107 %description
108 This package provides the python libraries for the PlanetLab implementation of SFA
109
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112
113 %description client
114 This package provides the client side of the SFA API, in particular
115 sfi.py, together with other utilities.
116
117 %description plc
118 This package implements the SFA interface which serves as a layer
119 between the existing PlanetLab interfaces and the SFA API.
120
121 %description cm
122 This package implements the SFA interface which serves as a layer
123 between the existing PlanetLab NodeManager interfaces and the SFA API.
124
125 %description federica
126 The SFA driver for FEDERICA.
127
128 %description sfatables
129 sfatables is a tool for defining access and admission control policies
130 in an SFA network, in much the same way as iptables is for ip
131 networks. This is the command line interface to manage sfatables
132
133 %description xmlbuilder
134 This package contains the xmlbuilder python library, packaged for
135 convenience as it is not supported by fedora
136
137 %description tests
138 Provides some binary unit tests in /usr/share/sfa/tests
139
140 %prep
141 %setup -q
142
143 %build
144 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %{python_sitelib}/sfa/__init__.py*
155 %{python_sitelib}/sfa/trust
156 %{python_sitelib}/sfa/storage
157 %{python_sitelib}/sfa/util
158 %{python_sitelib}/sfa/server
159 %{python_sitelib}/sfa/methods
160 %{python_sitelib}/sfa/generic
161 %{python_sitelib}/sfa/managers
162 %{python_sitelib}/sfa/importer
163 %{python_sitelib}/sfa/rspecs
164 %{python_sitelib}/sfa/client
165 /etc/init.d/sfa
166 %{_bindir}/sfa-start.py*
167 %{_bindir}/sfaadmin.py*
168 %{_bindir}/sfaadmin
169 %{_bindir}/keyconvert.py*
170 %{_bindir}/sfa-config-tty
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 /usr/share/sfa/migrations
175 /usr/share/sfa/examples
176 /var/www/html/wsdl/*.wsdl
177
178 %files flashpolicy
179 %{_bindir}/sfa_flashpolicy.py*
180 /etc/sfa/sfa_flashpolicy_config.xml
181
182 %files client
183 %config (noreplace) /etc/sfa/sfi_config
184 %{_bindir}/sfi*.py*
185 %{_bindir}/sfi
186 %{_bindir}/get*.py*
187 %{_bindir}/setRecord.py*
188 %{_bindir}/sfascan.py*
189 %{_bindir}/sfascan
190 %{_bindir}/sfadump.py*
191
192 %files plc
193 %defattr(-,root,root)
194 %{python_sitelib}/sfa/planetlab
195 %{python_sitelib}/sfa/openstack
196 /etc/sfa/pl.rng
197 /etc/sfa/credential.xsd
198 /etc/sfa/top.xsd
199 /etc/sfa/sig.xsd
200 /etc/sfa/xml.xsd
201 /etc/sfa/protogeni-rspec-common.xsd
202 /etc/sfa/topology
203 %{_bindir}/gen-sfa-cm-config.py*
204
205 %files cm
206 /etc/init.d/sfa-cm
207 %{_bindir}/sfa_component_setup.py*
208 # cron jobs here 
209
210 %files federica
211 %{python_sitelib}/sfa/federica
212
213 %files sfatables
214 /etc/sfatables/*
215 %{_bindir}/sfatables
216 %{python_sitelib}/sfatables
217
218 %files xmlbuilder
219 %{python_sitelib}/xmlbuilder
220
221 %files tests
222 %{_datadir}/sfa/tests
223
224 ### sfa installs the 'sfa' service
225 %post 
226 chkconfig --add sfa
227
228 %preun 
229 if [ "$1" = 0 ] ; then
230   /sbin/service sfa stop || :
231   /sbin/chkconfig --del sfa || :
232 fi
233
234 %postun
235 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
236
237 ### sfa-cm installs the 'sfa-cm' service
238 %post cm
239 chkconfig --add sfa-cm
240
241 %preun cm
242 if [ "$1" = 0 ] ; then
243    /sbin/service sfa-cm stop || :
244    /sbin/chkconfig --del sfa-cm || :
245 fi
246
247 %postun cm
248 [ "$1" -ge "1" ] && service sfa-cm restart || :
249
250 %changelog
251 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
252 - Update Openstack driver to support Essex release/
253 - Fix authority xrn bug.
254   
255
256 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
257 - review packaging - site-packages/planetlab now come with sfa-plc
258 - new package sfa-federica
259 - clientbin moved one step upwards
260
261 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
262 - fix bug in sfi update()
263
264 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
265 - fix broken sfa.util.xrn class for lowercase
266
267 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
268 - new 'void' generic_flavour for running in registry-only mode
269 - first shot at refactoring importers - probably needs more work
270 - openstack: various enhancements
271 - sfi interface to registry not based on xml files anymore
272 - sfi show sorts result on record key
273 - bugfix in sfa update on users with a pl-backed registry
274
275 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
276 - renamed sfa/plc into sfa/planetlab
277 - plxrn moved in sfa/planetlab as well
278 - bugfix for sfaadmin reg update --pi <>
279
280 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
281 - native data model now has a authority x user (PI) relationship
282 - no call to 'augment_records_with_testbed_info' for GetCredential
283 - which means, registry can now be used without an underlying testbed
284 - reviewed code about relationships b/w objects and related in pl driver
285 - reviewed PL import wrt roles and pis
286 - removed mentions to is_enabled in driver
287 - small changes in update_relation* in driver interface
288 - sfaadmin: can create authorities and attach pi users to them
289 - sfaadmin: categories can be abbreviated
290 - sfi list and sfaadmin list have a new -r/--recursive option
291 - this means that List now supports an (optional) 'options' argument
292 - sfi config can display config vars
293 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
294
295 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
296 - make sync now supports vserver or lxc.
297 - Added slice expiration and login info to SliverStatus response. 
298 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
299   the 'component_name' attribute.
300 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
301   
302 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
303 - Introduced new administrative command line script, sfaadmin.py. Removed various single
304  purpose scripts and migrated their functionality into sfaadmin.py.
305 - Refactored Registry import scripts.
306 - Removed SQLAlchemy dependency from sfi.py.
307 - Fixed bugs in sfi.py
308 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
309
310 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
311 - slice x researcher rel. in database,
312 - plimporter to maintain that, as well as user.email, and more robust
313 - ongoing draft for sfaadmin tool
314 - support for a federica driver
315 - support for a nova/euca driver
316 - no more sfa-clean-peer-records script
317
318 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
319 - registry database has user's keys and mail (known as v0 for migrate)
320 - pl importer properly maintains user's keys and mail
321 - pl driver now to handle 'role' when adding person record (exp.)
322 - first draft of federica driver with config section
323 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
324 - plus, from master as of tag merged-in-sfa-2.1-2:
325 - disk_image revisited
326 - new nova_shell nova_driver & various tweaks for openstack
327
328 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
329 - uses sqlalchemy and related migrate
330 - thorough migration and upgrade scheme
331 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
332 - trashed dbinfo stuff in auth hierarchy
333 - data model still has little more than plain records
334 - checkpoint tag, not yet intended for release
335
336 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
337 - client: added -R --raw sfi cmdline option that displays raw server response.
338 - client: request GENI RSpec by default. 
339 - server: remove database dependencies from sfa.server.sfaapi.
340 - server: increased default credential lifetime to 31 days.
341 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
342 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
343 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
344  
345 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
346 - bugfix: 'geni_api' should be in the top level struct, not the code struct
347 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
348           output returned by the Aggregate Manager.
349 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
350 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
351 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
352           there is extra whitespace in the schemaLocation field.
353 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
354           advertisement rspecs.
355 - bugfix: <login> RSpec element should contain the 'username' attribute.
356 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
357  
358 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
359 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
360   exit when it encountered a user with an invalid public key.
361 - server: imporved logging in sfa-import-plc.py
362  
363 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
364 - bugfix: Fixed appending public keys in CreateSliver
365 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
366 - client: -c --current option allows users to request the current/uncached rspec.
367 - server: Added 'geni_api_versions' field to GetVersion() output.
368 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
369    
370 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
371 - bugfix: sfi was not sending call_id with ListResources to v2 servers
372 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
373 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
374
375 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
376 - client: sfi -a / -p deprecated (use -s instead)
377 - client: sfi cleaned up
378 - client: sfi has backward support for APIv1 aggregates again
379 - server: only APIv2 is supported and should be rather strict
380 - server: settings for turning on/off caching in sm or am
381 - server: plc-dependant code has moved from aggregate to pldriver
382 - server: driver interface extended accordingly
383
384 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
385 - screwed up previous tag
386
387 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
388 - client side revisited with a bootstrap library
389 - client side has a new source layout
390 - various (nasty) bug fixes wrt options and call_id
391
392 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
393 - various fixes in rspecs for sfav1&slice tags
394 - uses 'geni_rspec_version' and not just 'rspec_version'
395 - example flavour for the max testbed
396 - embryo for an sfa client library
397 - topology.py moved into plc
398 - sql: table is named records; record_types are enforced
399 - sql: table creation cleaned up
400
401 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
402 - cleaned up all references to SFA_*_TYPE in config
403 - enable cache at the aggregate by default
404 - registry now uses the driver in a sensible way (see managers/driver.py)
405 - slice manager supports sfav1/pgv2 neighbours
406 - get_key renamed into get_key_from_incoming_ip
407 - new sfa.storage module for record/table and all db-related stuff
408 - db schema in sfa.storage.sfa.sql
409 - init.d and cron.d move one step up
410 - cleaned up rspec/ directory
411 - add deps to pyopenssl and myplc-config
412 - start support for new API (return value)
413 - plc.remoteshell removed, use plshell instead
414 - plshell uses a 'capability' auth method whenever possible
415 - various tweaks in rspec elements
416 - made dependency on sfatables softer
417
418 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
419 - sfa should now be started *before* the initial import
420 - sfa to use its own database (default sfa) - can run without myplc
421 - server calls support optional 'options'
422 - client sends options in argument when needed
423 - fix infinite getattr recursion in elements/element.py
424 - error codes in line with geni
425
426 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
427 - fixed links and attributes in rspecs
428 - minor cleanup in the API methods, and more consistent names in manager methods
429
430 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
431 - ongoing refoactoring towards more genericity
432 - passes tests again although known issues remain with attributes/tags
433
434 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
435 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
436 - improvements in the pgv2 rspecs
437 - driver separated from api
438 - code starts moving around where it belongs
439 - sfascan caches getversion across invokations
440 - vini topology extracted as a config file
441
442 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
443 - first support for protogeni rspecs is working
444 - vini no longer needs a specific manager
445 - refactoring underway towards more flexible/generic architecture
446
447 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
448 - Unicode-friendliness for user names with accents/special chars.
449 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
450 - CreaetSliver no longer fails for users that have a capital letter in their URN.
451 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
452 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
453 - Fix bugs and missing imports     
454  
455
456 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
457 - new method record.get_field for sface
458
459 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
460 - new option -c to sfa-nuke-plc.py
461 - CreateSliver fixed for admin-only slice tags
462
463 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
464 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
465 - Fixed holes in certificate verification logic.
466 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
467 - Added 'boot_state' as an attribute of the node element in SFA rspec.
468 - Non authority certificates are marked as CA:FALSE.
469
470 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
471 - fix typo in sfa-1.0-31 tag.
472 - added CreateGid() Registry interface method.
473
474 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
475 - fix typo in sfa-1.0-30 tag
476
477 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
478 - Declare namespace and schema location in the credential.
479 - Fix bug that prevetend connections from timing out.
480 - Fix slice delegation.
481 - Add statistics to slicemaanger listresources/createsliver rspec.
482 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
483   of days a user can extend their slice expiration.
484 - CA certs are only issued to objects of type authority
485    
486 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
487 - tag 1.0-28 was broken due to typo in the changelog
488 - new class sfa/util/httpsProtocol.py that supports timeouts
489
490 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
491 - Resolved issue that caused sfa hold onto idle db connections.
492 - Fix bug that caused the registry to use the wrong type of credential.
493 - Support authority+sm type.
494 - Fix rspec merging bugs.
495 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
496 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
497  planetlab hosted initscripts using the <planetlab:initscript> tag  
498 - Can now handle extraneous whitespace in the rspec without failing.   
499  
500 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
501 - ProtoGENI v2 RSpec updates.
502 - Convert expiration timestamps with timezone info in credentials to utc.
503 - Fixed redundant logging issue. 
504 - Improved SliceManager and SFI client logging.
505 - Support aggregates that don't support the optional 'call_id' argument. 
506 - Only call get_trusted_certs() at aggreage interfaces that support the call.
507 - CreateSliver() now handles MyPLC slice attributes/tags.
508 - Cache now supports persistence.
509 - Hide whitelisted nodes.
510
511 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
512 - fixed issues with sup authority signing
513 - fixed bugs in remove_slivers and SliverStatus
514
515 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
516 - fix typo that prevented aggregates from operating properly
517
518 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
519 - load trusted certs into ssl context prior to handshake
520 - client's logfile lives in ~/.sfi/sfi.log
521
522 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
523 - includes a change on passphrases that was intended in 1.0-22
524
525 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
526 - Added support for ProtoGENI RSpec v2
527  
528 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
529 - stable sfascan
530 - fix in initscript, *ENABLED tags in config now taken into account
531
532 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
533 - some commits had not been pushed in tag 19
534
535 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
536 - GetVersion should now report full URLs with path
537 - scansfa has nicer output and new syntax (entry URLs as args and not options)
538 - dos2unix'ed flash policy pill
539
540 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
541 - fix packaging again for f8
542
543 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
544 - fix packaging (apparently broken in 1.0-16)
545 - first working version of sfascan
546 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
547 - deprecated the sfa_geni_aggregate config category
548
549 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
550 - Fix build problem
551 - First version of SFA scanner
552
553 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
554 - Add support for Flash clients using flashpolicy
555 - Fix problems with tag handling in RSpec
556
557 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
558 - Modifications to the Eucalyptus Aggregate Manager
559 - Fixes for VINI RSpec
560 - Fix tag handling for PL RSpec
561 - Fix XML Schema ordering for <urn> element
562
563 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
564 - just set x509 version to 2
565
566 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
567 - added urn to the node area in rspecs
568 - conversion to urn now exports fqdn
569 - sfa-import-plc.py now creates a unique registry record for each SFA interface
570
571 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
572 - undo broken attempt for python-2.7
573
574 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
575 - SMs avoid duplicates for when call graph has dags;
576 - just based on network's name, when a duplicate occurs, one is just dropped
577 - does not try to merge/aggregate 2 networks
578 - also reviewed logging with the hope to fix the sfa startup msg:
579 - TypeError: not all arguments converted during string formatting
580
581 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
582 - verify credentials against xsd schema
583 - Fix SM to SM communication
584 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
585 - new setting session_key_path
586
587 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
588 - fix registry credential regeneration and handle expiration
589 - support for setting slice tags (min_role=user)
590 - client can display its own version: sfi.py version --local
591 - GetVersion to provide urn in addition to hrn
592 - more code uses plxrn vs previous helper functions
593 - import replaces '+' in email addresses with '_'
594
595 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
596 - fix GetVersion code_tag and add code_url
597
598 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
599 - extend GetVersion towards minimum federation introspection, and expose local tag
600
601 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
602 - fixed some legacy issues (list vs List)
603 - deprecated sfa.util.namespace for xrn and plxrn
604 - unit tests ship as the sfa-tests rpm
605
606 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
607 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
608 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
609 - hrn-urn translations tweaked
610 - fixed 'service sfa status'
611 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
612 - started to repair sfadump - although not usable yet
613 - trust objects now have dump_string method that dump() actually prints
614 - unit tests under review
615 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
616 - binaries now support -v or -vv to increase loglevel
617 - trashed obsolete sfa.util.client
618
619 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
620 - various bugfixes and cleanup, improved/harmonized logging
621
622 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
623 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
624   to avoid returning a PLCAPI exception that might confuse users.
625 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
626 - fix build errors.  
627
628 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
629 - (Architecture) Credential format changed to match ProtoGENI xml format
630 - (Architecture) All interfaces export a new set of methods that are compatible
631    with the ProtoGeni Aggregate spec. These new methods are considered a 
632    replacement  for the pervious methods exported by the interfaces. All 
633    previous methods are still exported and work as normal, but they are 
634    considered deprecated and will not be supported in future releases.  
635 - (Architecture) SFI has been updated to use the new interface methods.
636 - (Architecture) Changed keyconvet implementation from c to python.
637 - (Architecture) Slice Manager now attempts looks for a delegated credential
638   provided by the client before using its own server credential.
639 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
640   This cache now exists only in memory and is cleared when service is restarted
641   or cache lifetime is exceeded.  
642 - (Performance) SliceManager sends request to Aggregates in parallel instead 
643   of sequentially.
644 - (Bug fix) SFA tickets now support the new rspec format.
645 - (Bug fix) SFI only uses cahced credential if they aren't expired.
646 - (Bug fix) Cerdential delegation modified to work with new credential format.
647 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
648   Aggregate instead of relaying through the Slice Manager.
649 - (Enhancement) Simplified caching. Accociated a global cache instance with
650   the api handler on every new server request, making it easier to access the 
651   cache and use in more general ways.     
652
653 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
654 - SfaServer now uses a pool of threads to handle requests concurrently
655 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
656 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
657 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
658 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
659 - Component manager does not install gid files if slice already has them  
660 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
661 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
662 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
663      
664 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
665 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
666 - - sfa-config-tty now has the same features like plc-config-tty
667 - - Contains code to support both urn and hrn
668 - - Cleaned up request_hash related stuff
669 - - SM, AM and Registry code is organized under respective managers
670 - - Site and Slice synchronization across federated aggregates
671 - - Script to generate sfa_component_config
672
673 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
674 - sfa-config-tty now has the same features like plc-config-tty
675 - Contains code to support both urn and hrn
676 - Cleaned up request_hash related stuff
677 - SM, AM and Registry code is organized under respective managers
678 - Slice synchronization across federated aggregates
679 - some bugs are fixed
680
681 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
682 - checkpoint with fewer mentions of geni
683
684 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
685 - checkpointing
686 - this is believed to pass the tests; among other things:
687 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
688
689 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
690 - This tag includes:
691 - - Sfatables
692 - - Preliminary version of hash based authentication
693 - - Initial code for Component Manager
694 - - Authority structure is moved to /var/lib/sfa/
695 - - some bug-fixes
696
697 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
698 - Create_slice and get_resources methods are connected to sfatables.
699 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
700
701 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
702 - Bug fix on update and remove_peer_object methods
703 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
704
705 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
706 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
707
708 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
709 - compatibility with RefreshPeer
710 - incremental mechanism for importing PLC records into SFA tables
711 - unified single database (still inside the underlying PLC db postgresql server)
712 - includes/improves call traceability and logging features
713 - several bug fixes
714
715 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
716 - added libxslt-python dependency
717
718 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
719 - unified single SFA database in the PLC-DB
720 - upcalls from  PLCAPI to SFA methods
721 - SFA call traceability and logging features
722 - many bug fixes
723 - includes first/rough version of sfatables for policy implementation
724
725 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
726 - snapshot after the GEC5 demo
727 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
728
729 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
730 - snapshot july 15 - has gone through superficial manual testing
731 - hopefully a good basis for gec5 demo
732 - multi-dir sfi client tested as well
733
734 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
735 - rename geniwrapper.spec into sfa.spec
736
737 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
738 - clean up in xmlrpc/soap, --protocol option to chose between both
739 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
740 - hopefully more helpful context in case of crashes when importing
741 - bugfixes for using only /etc/sfa for site-dep files
742 - bugfixes in wsdl generation
743
744 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
745 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
746 - config variables in sfa_config now start with SFA_ and not GENI_
747 - config.py can be loaded even with no config present
748
749 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
750 - first step for cleanup and reorganization
751 - mass-renaming from geni to sfa (some are still needed)
752 - sfa/trust implements the security architecture
753
754 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
755 - snapshot for reproducible builds
756
757 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
758 - snapshot for the convenience of alpha users
759
760 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
761 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
762
763 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
764 - ongoing work - snapshot for 4.3-rc9
765
766 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
767 - various fixes
768
769 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
770 - bugfixes - still a work in progress
771
772 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
773 - initial package
774
775
776 %define module_current_branch 0.2