Merge branch 'master' of git://git.onelab.eu/sfa into upmc
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 17
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package nitos
92 Summary: the SFA layer around NITOS
93 Group: Applications/System
94 Requires: sfa
95
96 %package dummy
97 Summary: the SFA layer around a Dummy Testbed 
98 Group: Applications/System
99 Requires: sfa
100
101 %package sfatables
102 Summary: sfatables policy tool for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %package xmlbuilder
107 Summary: third-party xmlbuilder tool
108 Group: Applications/System
109 Provides: python-xmlbuilder
110
111 %package tests
112 Summary: unit tests suite for SFA
113 Group: Applications/System
114 Requires: sfa
115
116 %description
117 This package provides the python libraries for the PlanetLab implementation of SFA
118
119 %description flashpolicy
120 This package provides support for adobe flash client applications.  
121
122 %description client
123 This package provides the client side of the SFA API, in particular
124 sfi.py, together with other utilities.
125
126 %description plc
127 This package implements the SFA interface which serves as a layer
128 between the existing PlanetLab interfaces and the SFA API.
129
130 %description cm
131 This package implements the SFA interface which serves as a layer
132 between the existing PlanetLab NodeManager interfaces and the SFA API.
133
134 %description federica
135 The SFA driver for FEDERICA.
136
137 %description nitos
138 The SFA driver for NITOS.
139
140 %description dummy
141 The SFA driver for a Dummy Testbed.
142
143 %description sfatables
144 sfatables is a tool for defining access and admission control policies
145 in an SFA network, in much the same way as iptables is for ip
146 networks. This is the command line interface to manage sfatables
147
148 %description xmlbuilder
149 This package contains the xmlbuilder python library, packaged for
150 convenience as it is not supported by fedora
151
152 %description tests
153 Provides some binary unit tests in /usr/share/sfa/tests
154
155 %prep
156 %setup -q
157
158 %build
159 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %{python_sitelib}/sfa/__init__.py*
170 %{python_sitelib}/sfa/trust
171 %{python_sitelib}/sfa/storage
172 %{python_sitelib}/sfa/util
173 %{python_sitelib}/sfa/server
174 %{python_sitelib}/sfa/methods
175 %{python_sitelib}/sfa/generic
176 %{python_sitelib}/sfa/managers
177 %{python_sitelib}/sfa/importer
178 %{python_sitelib}/sfa/rspecs
179 %{python_sitelib}/sfa/client
180 /etc/init.d/sfa
181 %{_bindir}/sfa-start.py*
182 %{_bindir}/sfaadmin.py*
183 %{_bindir}/sfaadmin
184 %{_bindir}/keyconvert.py*
185 %{_bindir}/sfa-config-tty
186 %{_bindir}/sfa-config
187 %config /etc/sfa/default_config.xml
188 %config (noreplace) /etc/sfa/aggregates.xml
189 %config (noreplace) /etc/sfa/registries.xml
190 /usr/share/sfa/migrations
191 /usr/share/sfa/examples
192 /var/www/html/wsdl/*.wsdl
193
194 %files flashpolicy
195 %{_bindir}/sfa_flashpolicy.py*
196 /etc/sfa/sfa_flashpolicy_config.xml
197
198 %files client
199 %config (noreplace) /etc/sfa/sfi_config
200 %{_bindir}/sfi*.py*
201 %{_bindir}/sfi
202 %{_bindir}/get*.py*
203 %{_bindir}/setRecord.py*
204 %{_bindir}/sfascan.py*
205 %{_bindir}/sfascan
206 %{_bindir}/sfadump.py*
207
208 %files plc
209 %defattr(-,root,root)
210 %{python_sitelib}/sfa/planetlab
211 %{python_sitelib}/sfa/openstack
212 /etc/sfa/pl.rng
213 /etc/sfa/credential.xsd
214 /etc/sfa/top.xsd
215 /etc/sfa/sig.xsd
216 /etc/sfa/xml.xsd
217 /etc/sfa/protogeni-rspec-common.xsd
218 /etc/sfa/topology
219 %{_bindir}/gen-sfa-cm-config.py*
220
221 %files cm
222 /etc/init.d/sfa-cm
223 %{_bindir}/sfa_component_setup.py*
224 # cron jobs here 
225
226 %files federica
227 %{python_sitelib}/sfa/federica
228
229 %files nitos
230 %{python_sitelib}/sfa/nitos
231
232 %files dummy
233 %{python_sitelib}/sfa/dummy
234
235 %files sfatables
236 /etc/sfatables/*
237 %{_bindir}/sfatables
238 %{python_sitelib}/sfatables
239
240 %files xmlbuilder
241 %{python_sitelib}/xmlbuilder
242
243 %files tests
244 %{_datadir}/sfa/tests
245
246 ### sfa installs the 'sfa' service
247 %post 
248 chkconfig --add sfa
249
250 %preun 
251 if [ "$1" = 0 ] ; then
252   /sbin/service sfa stop || :
253   /sbin/chkconfig --del sfa || :
254 fi
255
256 %postun
257 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
258
259 ### sfa-cm installs the 'sfa-cm' service
260 %post cm
261 chkconfig --add sfa-cm
262
263 %preun cm
264 if [ "$1" = 0 ] ; then
265    /sbin/service sfa-cm stop || :
266    /sbin/chkconfig --del sfa-cm || :
267 fi
268
269 %postun cm
270 [ "$1" -ge "1" ] && service sfa-cm restart || :
271
272 %changelog
273 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
274 - bugfix in forwarding Resolve requests
275 - various fixes in the nitos driver wrt keys and users
276
277 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
278 - various tweaks for the nitos driver
279
280 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
281 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
282 - deeper cleanup of the data-dependencies between SFA and the testbed
283 - in particular, sfi create issues Resolve(details=False)
284 - for that purpose, Resolve exposes reg-* keys for SFA builtins
285 - which in turn allows sfi list to show PIs, slice members and keys
286 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
287 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
288
289 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
290 - configurable data-dir (/var/lib/sfa)
291 - no more dependent on myplc-config
292 - some support for hrns with _ instead of \.
293 - fix for PL importing in presence of gpg keys
294 - DeleteSliver returns True instead of 1 in case of success
295 - Various improvements on the openstack/nova side
296 - new package sfa-nitos
297
298 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
299 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
300 - sfi to remove expired credentials
301
302 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
303 - Update Openstack driver to support Essex release/
304 - Fix authority xrn bug.
305   
306
307 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
308 - review packaging - site-packages/planetlab now come with sfa-plc
309 - new package sfa-federica
310 - clientbin moved one step upwards
311
312 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
313 - fix bug in sfi update()
314
315 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
316 - fix broken sfa.util.xrn class for lowercase
317
318 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
319 - new 'void' generic_flavour for running in registry-only mode
320 - first shot at refactoring importers - probably needs more work
321 - openstack: various enhancements
322 - sfi interface to registry not based on xml files anymore
323 - sfi show sorts result on record key
324 - bugfix in sfa update on users with a pl-backed registry
325
326 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
327 - renamed sfa/plc into sfa/planetlab
328 - plxrn moved in sfa/planetlab as well
329 - bugfix for sfaadmin reg update --pi <>
330
331 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
332 - native data model now has a authority x user (PI) relationship
333 - no call to 'augment_records_with_testbed_info' for GetCredential
334 - which means, registry can now be used without an underlying testbed
335 - reviewed code about relationships b/w objects and related in pl driver
336 - reviewed PL import wrt roles and pis
337 - removed mentions to is_enabled in driver
338 - small changes in update_relation* in driver interface
339 - sfaadmin: can create authorities and attach pi users to them
340 - sfaadmin: categories can be abbreviated
341 - sfi list and sfaadmin list have a new -r/--recursive option
342 - this means that List now supports an (optional) 'options' argument
343 - sfi config can display config vars
344 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
345
346 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
347 - make sync now supports vserver or lxc.
348 - Added slice expiration and login info to SliverStatus response. 
349 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
350   the 'component_name' attribute.
351 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
352   
353 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
354 - Introduced new administrative command line script, sfaadmin.py. Removed various single
355  purpose scripts and migrated their functionality into sfaadmin.py.
356 - Refactored Registry import scripts.
357 - Removed SQLAlchemy dependency from sfi.py.
358 - Fixed bugs in sfi.py
359 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
360
361 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
362 - slice x researcher rel. in database,
363 - plimporter to maintain that, as well as user.email, and more robust
364 - ongoing draft for sfaadmin tool
365 - support for a federica driver
366 - support for a nova/euca driver
367 - no more sfa-clean-peer-records script
368
369 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
370 - registry database has user's keys and mail (known as v0 for migrate)
371 - pl importer properly maintains user's keys and mail
372 - pl driver now to handle 'role' when adding person record (exp.)
373 - first draft of federica driver with config section
374 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
375 - plus, from master as of tag merged-in-sfa-2.1-2:
376 - disk_image revisited
377 - new nova_shell nova_driver & various tweaks for openstack
378
379 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
380 - uses sqlalchemy and related migrate
381 - thorough migration and upgrade scheme
382 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
383 - trashed dbinfo stuff in auth hierarchy
384 - data model still has little more than plain records
385 - checkpoint tag, not yet intended for release
386
387 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
388 - client: added -R --raw sfi cmdline option that displays raw server response.
389 - client: request GENI RSpec by default. 
390 - server: remove database dependencies from sfa.server.sfaapi.
391 - server: increased default credential lifetime to 31 days.
392 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
393 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
394 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
395  
396 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
397 - bugfix: 'geni_api' should be in the top level struct, not the code struct
398 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
399           output returned by the Aggregate Manager.
400 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
401 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
402 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
403           there is extra whitespace in the schemaLocation field.
404 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
405           advertisement rspecs.
406 - bugfix: <login> RSpec element should contain the 'username' attribute.
407 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
408  
409 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
410 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
411   exit when it encountered a user with an invalid public key.
412 - server: imporved logging in sfa-import-plc.py
413  
414 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
415 - bugfix: Fixed appending public keys in CreateSliver
416 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
417 - client: -c --current option allows users to request the current/uncached rspec.
418 - server: Added 'geni_api_versions' field to GetVersion() output.
419 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
420    
421 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
422 - bugfix: sfi was not sending call_id with ListResources to v2 servers
423 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
424 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
425
426 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
427 - client: sfi -a / -p deprecated (use -s instead)
428 - client: sfi cleaned up
429 - client: sfi has backward support for APIv1 aggregates again
430 - server: only APIv2 is supported and should be rather strict
431 - server: settings for turning on/off caching in sm or am
432 - server: plc-dependant code has moved from aggregate to pldriver
433 - server: driver interface extended accordingly
434
435 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
436 - screwed up previous tag
437
438 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
439 - client side revisited with a bootstrap library
440 - client side has a new source layout
441 - various (nasty) bug fixes wrt options and call_id
442
443 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
444 - various fixes in rspecs for sfav1&slice tags
445 - uses 'geni_rspec_version' and not just 'rspec_version'
446 - example flavour for the max testbed
447 - embryo for an sfa client library
448 - topology.py moved into plc
449 - sql: table is named records; record_types are enforced
450 - sql: table creation cleaned up
451
452 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
453 - cleaned up all references to SFA_*_TYPE in config
454 - enable cache at the aggregate by default
455 - registry now uses the driver in a sensible way (see managers/driver.py)
456 - slice manager supports sfav1/pgv2 neighbours
457 - get_key renamed into get_key_from_incoming_ip
458 - new sfa.storage module for record/table and all db-related stuff
459 - db schema in sfa.storage.sfa.sql
460 - init.d and cron.d move one step up
461 - cleaned up rspec/ directory
462 - add deps to pyopenssl and myplc-config
463 - start support for new API (return value)
464 - plc.remoteshell removed, use plshell instead
465 - plshell uses a 'capability' auth method whenever possible
466 - various tweaks in rspec elements
467 - made dependency on sfatables softer
468
469 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
470 - sfa should now be started *before* the initial import
471 - sfa to use its own database (default sfa) - can run without myplc
472 - server calls support optional 'options'
473 - client sends options in argument when needed
474 - fix infinite getattr recursion in elements/element.py
475 - error codes in line with geni
476
477 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
478 - fixed links and attributes in rspecs
479 - minor cleanup in the API methods, and more consistent names in manager methods
480
481 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
482 - ongoing refoactoring towards more genericity
483 - passes tests again although known issues remain with attributes/tags
484
485 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
486 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
487 - improvements in the pgv2 rspecs
488 - driver separated from api
489 - code starts moving around where it belongs
490 - sfascan caches getversion across invokations
491 - vini topology extracted as a config file
492
493 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
494 - first support for protogeni rspecs is working
495 - vini no longer needs a specific manager
496 - refactoring underway towards more flexible/generic architecture
497
498 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
499 - Unicode-friendliness for user names with accents/special chars.
500 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
501 - CreaetSliver no longer fails for users that have a capital letter in their URN.
502 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
503 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
504 - Fix bugs and missing imports     
505  
506
507 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
508 - new method record.get_field for sface
509
510 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
511 - new option -c to sfa-nuke-plc.py
512 - CreateSliver fixed for admin-only slice tags
513
514 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
515 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
516 - Fixed holes in certificate verification logic.
517 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
518 - Added 'boot_state' as an attribute of the node element in SFA rspec.
519 - Non authority certificates are marked as CA:FALSE.
520
521 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
522 - fix typo in sfa-1.0-31 tag.
523 - added CreateGid() Registry interface method.
524
525 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
526 - fix typo in sfa-1.0-30 tag
527
528 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
529 - Declare namespace and schema location in the credential.
530 - Fix bug that prevetend connections from timing out.
531 - Fix slice delegation.
532 - Add statistics to slicemaanger listresources/createsliver rspec.
533 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
534   of days a user can extend their slice expiration.
535 - CA certs are only issued to objects of type authority
536    
537 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
538 - tag 1.0-28 was broken due to typo in the changelog
539 - new class sfa/util/httpsProtocol.py that supports timeouts
540
541 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
542 - Resolved issue that caused sfa hold onto idle db connections.
543 - Fix bug that caused the registry to use the wrong type of credential.
544 - Support authority+sm type.
545 - Fix rspec merging bugs.
546 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
547 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
548  planetlab hosted initscripts using the <planetlab:initscript> tag  
549 - Can now handle extraneous whitespace in the rspec without failing.   
550  
551 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
552 - ProtoGENI v2 RSpec updates.
553 - Convert expiration timestamps with timezone info in credentials to utc.
554 - Fixed redundant logging issue. 
555 - Improved SliceManager and SFI client logging.
556 - Support aggregates that don't support the optional 'call_id' argument. 
557 - Only call get_trusted_certs() at aggreage interfaces that support the call.
558 - CreateSliver() now handles MyPLC slice attributes/tags.
559 - Cache now supports persistence.
560 - Hide whitelisted nodes.
561
562 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
563 - fixed issues with sup authority signing
564 - fixed bugs in remove_slivers and SliverStatus
565
566 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
567 - fix typo that prevented aggregates from operating properly
568
569 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
570 - load trusted certs into ssl context prior to handshake
571 - client's logfile lives in ~/.sfi/sfi.log
572
573 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
574 - includes a change on passphrases that was intended in 1.0-22
575
576 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
577 - Added support for ProtoGENI RSpec v2
578  
579 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
580 - stable sfascan
581 - fix in initscript, *ENABLED tags in config now taken into account
582
583 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
584 - some commits had not been pushed in tag 19
585
586 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
587 - GetVersion should now report full URLs with path
588 - scansfa has nicer output and new syntax (entry URLs as args and not options)
589 - dos2unix'ed flash policy pill
590
591 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
592 - fix packaging again for f8
593
594 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
595 - fix packaging (apparently broken in 1.0-16)
596 - first working version of sfascan
597 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
598 - deprecated the sfa_geni_aggregate config category
599
600 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
601 - Fix build problem
602 - First version of SFA scanner
603
604 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
605 - Add support for Flash clients using flashpolicy
606 - Fix problems with tag handling in RSpec
607
608 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
609 - Modifications to the Eucalyptus Aggregate Manager
610 - Fixes for VINI RSpec
611 - Fix tag handling for PL RSpec
612 - Fix XML Schema ordering for <urn> element
613
614 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
615 - just set x509 version to 2
616
617 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
618 - added urn to the node area in rspecs
619 - conversion to urn now exports fqdn
620 - sfa-import-plc.py now creates a unique registry record for each SFA interface
621
622 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
623 - undo broken attempt for python-2.7
624
625 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
626 - SMs avoid duplicates for when call graph has dags;
627 - just based on network's name, when a duplicate occurs, one is just dropped
628 - does not try to merge/aggregate 2 networks
629 - also reviewed logging with the hope to fix the sfa startup msg:
630 - TypeError: not all arguments converted during string formatting
631
632 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
633 - verify credentials against xsd schema
634 - Fix SM to SM communication
635 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
636 - new setting session_key_path
637
638 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
639 - fix registry credential regeneration and handle expiration
640 - support for setting slice tags (min_role=user)
641 - client can display its own version: sfi.py version --local
642 - GetVersion to provide urn in addition to hrn
643 - more code uses plxrn vs previous helper functions
644 - import replaces '+' in email addresses with '_'
645
646 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
647 - fix GetVersion code_tag and add code_url
648
649 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
650 - extend GetVersion towards minimum federation introspection, and expose local tag
651
652 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
653 - fixed some legacy issues (list vs List)
654 - deprecated sfa.util.namespace for xrn and plxrn
655 - unit tests ship as the sfa-tests rpm
656
657 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
658 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
659 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
660 - hrn-urn translations tweaked
661 - fixed 'service sfa status'
662 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
663 - started to repair sfadump - although not usable yet
664 - trust objects now have dump_string method that dump() actually prints
665 - unit tests under review
666 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
667 - binaries now support -v or -vv to increase loglevel
668 - trashed obsolete sfa.util.client
669
670 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
671 - various bugfixes and cleanup, improved/harmonized logging
672
673 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
674 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
675   to avoid returning a PLCAPI exception that might confuse users.
676 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
677 - fix build errors.  
678
679 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
680 - (Architecture) Credential format changed to match ProtoGENI xml format
681 - (Architecture) All interfaces export a new set of methods that are compatible
682    with the ProtoGeni Aggregate spec. These new methods are considered a 
683    replacement  for the pervious methods exported by the interfaces. All 
684    previous methods are still exported and work as normal, but they are 
685    considered deprecated and will not be supported in future releases.  
686 - (Architecture) SFI has been updated to use the new interface methods.
687 - (Architecture) Changed keyconvet implementation from c to python.
688 - (Architecture) Slice Manager now attempts looks for a delegated credential
689   provided by the client before using its own server credential.
690 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
691   This cache now exists only in memory and is cleared when service is restarted
692   or cache lifetime is exceeded.  
693 - (Performance) SliceManager sends request to Aggregates in parallel instead 
694   of sequentially.
695 - (Bug fix) SFA tickets now support the new rspec format.
696 - (Bug fix) SFI only uses cahced credential if they aren't expired.
697 - (Bug fix) Cerdential delegation modified to work with new credential format.
698 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
699   Aggregate instead of relaying through the Slice Manager.
700 - (Enhancement) Simplified caching. Accociated a global cache instance with
701   the api handler on every new server request, making it easier to access the 
702   cache and use in more general ways.     
703
704 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
705 - SfaServer now uses a pool of threads to handle requests concurrently
706 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
707 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
708 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
709 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
710 - Component manager does not install gid files if slice already has them  
711 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
712 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
713 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
714      
715 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
716 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
717 - - sfa-config-tty now has the same features like plc-config-tty
718 - - Contains code to support both urn and hrn
719 - - Cleaned up request_hash related stuff
720 - - SM, AM and Registry code is organized under respective managers
721 - - Site and Slice synchronization across federated aggregates
722 - - Script to generate sfa_component_config
723
724 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
725 - sfa-config-tty now has the same features like plc-config-tty
726 - Contains code to support both urn and hrn
727 - Cleaned up request_hash related stuff
728 - SM, AM and Registry code is organized under respective managers
729 - Slice synchronization across federated aggregates
730 - some bugs are fixed
731
732 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
733 - checkpoint with fewer mentions of geni
734
735 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
736 - checkpointing
737 - this is believed to pass the tests; among other things:
738 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
739
740 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
741 - This tag includes:
742 - - Sfatables
743 - - Preliminary version of hash based authentication
744 - - Initial code for Component Manager
745 - - Authority structure is moved to /var/lib/sfa/
746 - - some bug-fixes
747
748 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
749 - Create_slice and get_resources methods are connected to sfatables.
750 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
751
752 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
753 - Bug fix on update and remove_peer_object methods
754 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
755
756 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
757 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
758
759 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
760 - compatibility with RefreshPeer
761 - incremental mechanism for importing PLC records into SFA tables
762 - unified single database (still inside the underlying PLC db postgresql server)
763 - includes/improves call traceability and logging features
764 - several bug fixes
765
766 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
767 - added libxslt-python dependency
768
769 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
770 - unified single SFA database in the PLC-DB
771 - upcalls from  PLCAPI to SFA methods
772 - SFA call traceability and logging features
773 - many bug fixes
774 - includes first/rough version of sfatables for policy implementation
775
776 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
777 - snapshot after the GEC5 demo
778 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
779
780 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
781 - snapshot july 15 - has gone through superficial manual testing
782 - hopefully a good basis for gec5 demo
783 - multi-dir sfi client tested as well
784
785 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
786 - rename geniwrapper.spec into sfa.spec
787
788 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
789 - clean up in xmlrpc/soap, --protocol option to chose between both
790 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
791 - hopefully more helpful context in case of crashes when importing
792 - bugfixes for using only /etc/sfa for site-dep files
793 - bugfixes in wsdl generation
794
795 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
796 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
797 - config variables in sfa_config now start with SFA_ and not GENI_
798 - config.py can be loaded even with no config present
799
800 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
801 - first step for cleanup and reorganization
802 - mass-renaming from geni to sfa (some are still needed)
803 - sfa/trust implements the security architecture
804
805 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
806 - snapshot for reproducible builds
807
808 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
809 - snapshot for the convenience of alpha users
810
811 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
812 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
813
814 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
815 - ongoing work - snapshot for 4.3-rc9
816
817 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
818 - various fixes
819
820 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
821 - bugfixes - still a work in progress
822
823 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
824 - initial package
825
826
827 %define module_current_branch 0.2