fix merge problem
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA layer around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA layer around MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-start.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 /etc/sfa/topology
148 %{_bindir}/sfa-config-tty
149 %{_bindir}/sfa-import-plc.py*
150 %{_bindir}/sfa-clean-peer-records.py*
151 %{_bindir}/sfa-nuke-plc.py*
152 %{_bindir}/gen-sfa-cm-config.py*
153 %{_bindir}/sfa-ca.py*
154
155 %files client
156 %config (noreplace) /etc/sfa/sfi_config
157 %{_bindir}/sfi*
158 %{_bindir}/getNodes.py*
159 %{_bindir}/getRecord.py*
160 %{_bindir}/setRecord.py*
161 %{_bindir}/sfadump.py*
162
163 %files sfatables
164 %{_bindir}/sfatables
165
166 %files flashpolicy
167 %{_bindir}/sfa_flashpolicy.py*
168 /etc/sfa/sfa_flashpolicy_config.xml
169
170 %files tests
171 %{_datadir}/sfa/tests
172
173 ### sfa-plc installs the 'sfa' service
174 %post plc
175 chkconfig --add sfa
176
177 %preun plc
178 if [ "$1" = 0 ] ; then
179   /sbin/service sfa stop || :
180   /sbin/chkconfig --del sfa || :
181 fi
182
183 %postun plc
184 [ "$1" -ge "1" ] && service sfa restart
185
186 ### sfa-cm installs the 'sfa-cm' service
187 %post cm
188 chkconfig --add sfa-cm
189
190 %preun cm
191 if [ "$1" = 0 ] ; then
192    /sbin/service sfa-cm stop || :
193    /sbin/chkconfig --del sfa-cm || :
194 fi
195
196 %postun cm
197 [ "$1" -ge "1" ] && service sfa-cm restart || :
198
199 %changelog
200 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
201 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
202 - improvements in the pgv2 rspecs
203 - driver separated from api
204 - code starts moving around where it belongs
205 - sfascan caches getversion across invokations
206 - vini topology extracted as a config file
207
208 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
209 - first support for protogeni rspecs is working
210 - vini no longer needs a specific manager
211 - refactoring underway towards more flexible/generic architecture
212
213 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
214 - Unicode-friendliness for user names with accents/special chars.
215 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
216 - CreaetSliver no longer fails for users that have a capital letter in their URN.
217 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
218 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
219 - Fix bugs and missing imports     
220  
221
222 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
223 - new method record.get_field for sface
224
225 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
226 - new option -c to sfa-nuke-plc.py
227 - CreateSliver fixed for admin-only slice tags
228
229 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
230 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
231 - Fixed holes in certificate verification logic.
232 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
233 - Added 'boot_state' as an attribute of the node element in SFA rspec.
234 - Non authority certificates are marked as CA:FALSE.
235
236 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
237 - fix typo in sfa-1.0-31 tag.
238 - added CreateGid() Registry interface method.
239
240 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
241 - fix typo in sfa-1.0-30 tag
242
243 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
244 - Declare namespace and schema location in the credential.
245 - Fix bug that prevetend connections from timing out.
246 - Fix slice delegation.
247 - Add statistics to slicemaanger listresources/createsliver rspec.
248 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
249   of days a user can extend their slice expiration.
250 - CA certs are only issued to objects of type authority
251    
252 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
253 - tag 1.0-28 was broken due to typo in the changelog
254 - new class sfa/util/httpsProtocol.py that supports timeouts
255
256 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
257 - Resolved issue that caused sfa hold onto idle db connections.
258 - Fix bug that caused the registry to use the wrong type of credential.
259 - Support authority+sm type.
260 - Fix rspec merging bugs.
261 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
262 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
263  planetlab hosted initscripts using the <planetlab:initscript> tag  
264 - Can now handle extraneous whitespace in the rspec without failing.   
265  
266 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
267 - ProtoGENI v2 RSpec updates.
268 - Convert expiration timestamps with timezone info in credentials to utc.
269 - Fixed redundant logging issue. 
270 - Improved SliceManager and SFI client logging.
271 - Support aggregates that don't support the optional 'call_id' argument. 
272 - Only call get_trusted_certs() at aggreage interfaces that support the call.
273 - CreateSliver() now handles MyPLC slice attributes/tags.
274 - Cache now supports persistence.
275 - Hide whitelisted nodes.
276
277 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
278 - fixed issues with sup authority signing
279 - fixed bugs in remove_slivers and SliverStatus
280
281 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
282 - fix typo that prevented aggregates from operating properly
283
284 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
285 - load trusted certs into ssl context prior to handshake
286 - client's logfile lives in ~/.sfi/sfi.log
287
288 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
289 - includes a change on passphrases that was intended in 1.0-22
290
291 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
292 - Added support for ProtoGENI RSpec v2
293  
294 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
295 - stable sfascan
296 - fix in initscript, *ENABLED tags in config now taken into account
297
298 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
299 - some commits had not been pushed in tag 19
300
301 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
302 - GetVersion should now report full URLs with path
303 - scansfa has nicer output and new syntax (entry URLs as args and not options)
304 - dos2unix'ed flash policy pill
305
306 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
307 - fix packaging again for f8
308
309 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
310 - fix packaging (apparently broken in 1.0-16)
311 - first working version of sfascan
312 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
313 - deprecated the sfa_geni_aggregate config category
314
315 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
316 - Fix build problem
317 - First version of SFA scanner
318
319 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
320 - Add support for Flash clients using flashpolicy
321 - Fix problems with tag handling in RSpec
322
323 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
324 - Modifications to the Eucalyptus Aggregate Manager
325 - Fixes for VINI RSpec
326 - Fix tag handling for PL RSpec
327 - Fix XML Schema ordering for <urn> element
328
329 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
330 - just set x509 version to 2
331
332 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
333 - added urn to the node area in rspecs
334 - conversion to urn now exports fqdn
335 - sfa-import-plc.py now creates a unique registry record for each SFA interface
336
337 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
338 - undo broken attempt for python-2.7
339
340 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
341 - SMs avoid duplicates for when call graph has dags;
342 - just based on network's name, when a duplicate occurs, one is just dropped
343 - does not try to merge/aggregate 2 networks
344 - also reviewed logging with the hope to fix the sfa startup msg:
345 - TypeError: not all arguments converted during string formatting
346
347 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
348 - verify credentials against xsd schema
349 - Fix SM to SM communication
350 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
351 - new setting session_key_path
352
353 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
354 - fix registry credential regeneration and handle expiration
355 - support for setting slice tags (min_role=user)
356 - client can display its own version: sfi.py version --local
357 - GetVersion to provide urn in addition to hrn
358 - more code uses plxrn vs previous helper functions
359 - import replaces '+' in email addresses with '_'
360
361 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
362 - fix GetVersion code_tag and add code_url
363
364 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
365 - extend GetVersion towards minimum federation introspection, and expose local tag
366
367 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
368 - fixed some legacy issues (list vs List)
369 - deprecated sfa.util.namespace for xrn and plxrn
370 - unit tests ship as the sfa-tests rpm
371
372 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
373 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
374 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
375 - hrn-urn translations tweaked
376 - fixed 'service sfa status'
377 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
378 - started to repair sfadump - although not usable yet
379 - trust objects now have dump_string method that dump() actually prints
380 - unit tests under review
381 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
382 - binaries now support -v or -vv to increase loglevel
383 - trashed obsolete sfa.util.client
384
385 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
386 - various bugfixes and cleanup, improved/harmonized logging
387
388 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
389 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
390   to avoid returning a PLCAPI exception that might confuse users.
391 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
392 - fix build errors.  
393
394 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
395 - (Architecture) Credential format changed to match ProtoGENI xml format
396 - (Architecture) All interfaces export a new set of methods that are compatible
397    with the ProtoGeni Aggregate spec. These new methods are considered a 
398    replacement  for the pervious methods exported by the interfaces. All 
399    previous methods are still exported and work as normal, but they are 
400    considered deprecated and will not be supported in future releases.  
401 - (Architecture) SFI has been updated to use the new interface methods.
402 - (Architecture) Changed keyconvet implementation from c to python.
403 - (Architecture) Slice Manager now attempts looks for a delegated credential
404   provided by the client before using its own server credential.
405 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
406   This cache now exists only in memory and is cleared when service is restarted
407   or cache lifetime is exceeded.  
408 - (Performance) SliceManager sends request to Aggregates in parallel instead 
409   of sequentially.
410 - (Bug fix) SFA tickets now support the new rspec format.
411 - (Bug fix) SFI only uses cahced credential if they aren't expired.
412 - (Bug fix) Cerdential delegation modified to work with new credential format.
413 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
414   Aggregate instead of relaying through the Slice Manager.
415 - (Enhancement) Simplified caching. Accociated a global cache instance with
416   the api handler on every new server request, making it easier to access the 
417   cache and use in more general ways.     
418
419 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
420 - SfaServer now uses a pool of threads to handle requests concurrently
421 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
422 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
423 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
424 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
425 - Component manager does not install gid files if slice already has them  
426 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
427 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
428 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
429      
430 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
431 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
432 - - sfa-config-tty now has the same features like plc-config-tty
433 - - Contains code to support both urn and hrn
434 - - Cleaned up request_hash related stuff
435 - - SM, AM and Registry code is organized under respective managers
436 - - Site and Slice synchronization across federated aggregates
437 - - Script to generate sfa_component_config
438
439 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
440 - sfa-config-tty now has the same features like plc-config-tty
441 - Contains code to support both urn and hrn
442 - Cleaned up request_hash related stuff
443 - SM, AM and Registry code is organized under respective managers
444 - Slice synchronization across federated aggregates
445 - some bugs are fixed
446
447 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
448 - checkpoint with fewer mentions of geni
449
450 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
451 - checkpointing
452 - this is believed to pass the tests; among other things:
453 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
454
455 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
456 - This tag includes:
457 - - Sfatables
458 - - Preliminary version of hash based authentication
459 - - Initial code for Component Manager
460 - - Authority structure is moved to /var/lib/sfa/
461 - - some bug-fixes
462
463 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
464 - Create_slice and get_resources methods are connected to sfatables.
465 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
466
467 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
468 - Bug fix on update and remove_peer_object methods
469 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
470
471 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
472 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
473
474 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
475 - compatibility with RefreshPeer
476 - incremental mechanism for importing PLC records into SFA tables
477 - unified single database (still inside the underlying PLC db postgresql server)
478 - includes/improves call traceability and logging features
479 - several bug fixes
480
481 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
482 - added libxslt-python dependency
483
484 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
485 - unified single SFA database in the PLC-DB
486 - upcalls from  PLCAPI to SFA methods
487 - SFA call traceability and logging features
488 - many bug fixes
489 - includes first/rough version of sfatables for policy implementation
490
491 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
492 - snapshot after the GEC5 demo
493 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
494
495 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
496 - snapshot july 15 - has gone through superficial manual testing
497 - hopefully a good basis for gec5 demo
498 - multi-dir sfi client tested as well
499
500 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
501 - rename geniwrapper.spec into sfa.spec
502
503 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
504 - clean up in xmlrpc/soap, --protocol option to chose between both
505 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
506 - hopefully more helpful context in case of crashes when importing
507 - bugfixes for using only /etc/sfa for site-dep files
508 - bugfixes in wsdl generation
509
510 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
511 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
512 - config variables in sfa_config now start with SFA_ and not GENI_
513 - config.py can be loaded even with no config present
514
515 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
516 - first step for cleanup and reorganization
517 - mass-renaming from geni to sfa (some are still needed)
518 - sfa/trust implements the security architecture
519
520 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
521 - snapshot for reproducible builds
522
523 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
524 - snapshot for the convenience of alpha users
525
526 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
527 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
528
529 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
530 - ongoing work - snapshot for 4.3-rc9
531
532 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
533 - various fixes
534
535 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
536 - bugfixes - still a work in progress
537
538 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
539 - initial package
540
541
542 %define module_current_branch 0.2