Setting tag sfa-2.1-4
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/sfaadmin.py*
152 %{_bindir}/keyconvert.py*
153 %{_bindir}/sfa-config-tty
154 %config /etc/sfa/default_config.xml
155 %config (noreplace) /etc/sfa/aggregates.xml
156 %config (noreplace) /etc/sfa/registries.xml
157 /usr/share/sfa/migrations
158 /usr/share/sfa/examples
159 /var/www/html/wsdl/*.wsdl
160
161 %files plc
162 %defattr(-,root,root)
163 /etc/sfa/pl.rng
164 /etc/sfa/credential.xsd
165 /etc/sfa/top.xsd
166 /etc/sfa/sig.xsd
167 /etc/sfa/xml.xsd
168 /etc/sfa/protogeni-rspec-common.xsd
169 /etc/sfa/topology
170 %{_bindir}/gen-sfa-cm-config.py*
171
172 %files client
173 %config (noreplace) /etc/sfa/sfi_config
174 %{_bindir}/sfi*.py*
175 %{_bindir}/sfi
176 %{_bindir}/get*.py*
177 %{_bindir}/setRecord.py*
178 %{_bindir}/sfascan.py*
179 %{_bindir}/sfascan
180 %{_bindir}/sfadump.py*
181
182 %files sfatables
183 /etc/sfatables/*
184 %{_bindir}/sfatables
185 %{python_sitelib}/sfatables
186
187 %files cm
188 /etc/init.d/sfa-cm
189 %{_bindir}/sfa_component_setup.py*
190 # cron jobs here 
191
192 %files flashpolicy
193 %{_bindir}/sfa_flashpolicy.py*
194 /etc/sfa/sfa_flashpolicy_config.xml
195
196 %files xmlbuilder
197 %{python_sitelib}/xmlbuilder
198
199 %files tests
200 %{_datadir}/sfa/tests
201
202 ### sfa installs the 'sfa' service
203 %post 
204 chkconfig --add sfa
205
206 %preun 
207 if [ "$1" = 0 ] ; then
208   /sbin/service sfa stop || :
209   /sbin/chkconfig --del sfa || :
210 fi
211
212 %postun
213 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
214
215 ### sfa-cm installs the 'sfa-cm' service
216 %post cm
217 chkconfig --add sfa-cm
218
219 %preun cm
220 if [ "$1" = 0 ] ; then
221    /sbin/service sfa-cm stop || :
222    /sbin/chkconfig --del sfa-cm || :
223 fi
224
225 %postun cm
226 [ "$1" -ge "1" ] && service sfa-cm restart || :
227
228 %changelog
229 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
230 - Introduced new administrative command line script, sfaadmin.py. Removed various single
231  purpose scripts and migrated their functionality into sfaadmin.py.
232 - Refactored Registry import scripts.
233 - Removed SQLAlchemy dependency from sfi.py.
234 - Fixed bugs in sfi.py
235 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
236
237 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
238 - slice x researcher rel. in database,
239 - plimporter to maintain that, as well as user.email, and more robust
240 - ongoing draft for sfaadmin tool
241 - support for a federica driver
242 - support for a nova/euca driver
243 - no more sfa-clean-peer-records script
244
245 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
246 - registry database has user's keys and mail (known as v0 for migrate)
247 - pl importer properly maintains user's keys and mail
248 - pl driver now to handle 'role' when adding person record (exp.)
249 - first draft of federica driver with config section
250 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
251 - plus, from master as of tag merged-in-sfa-2.1-2:
252 - disk_image revisited
253 - new nova_shell nova_driver & various tweaks for openstack
254
255 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
256 - uses sqlalchemy and related migrate
257 - thorough migration and upgrade scheme
258 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
259 - trashed dbinfo stuff in auth hierarchy
260 - data model still has little more than plain records
261 - checkpoint tag, not yet intended for release
262
263 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
264 - client: added -R --raw sfi cmdline option that displays raw server response.
265 - client: request GENI RSpec by default. 
266 - server: remove database dependencies from sfa.server.sfaapi.
267 - server: increased default credential lifetime to 31 days.
268 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
269 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
270 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
271  
272 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
273 - bugfix: 'geni_api' should be in the top level struct, not the code struct
274 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
275           output returned by the Aggregate Manager.
276 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
277 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
278 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
279           there is extra whitespace in the schemaLocation field.
280 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
281           advertisement rspecs.
282 - bugfix: <login> RSpec element should contain the 'username' attribute.
283 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
284  
285 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
286 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
287   exit when it encountered a user with an invalid public key.
288 - server: imporved logging in sfa-import-plc.py
289  
290 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
291 - bugfix: Fixed appending public keys in CreateSliver
292 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
293 - client: -c --current option allows users to request the current/uncached rspec.
294 - server: Added 'geni_api_versions' field to GetVersion() output.
295 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
296    
297 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
298 - bugfix: sfi was not sending call_id with ListResources to v2 servers
299 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
300 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
301
302 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
303 - client: sfi -a / -p deprecated (use -s instead)
304 - client: sfi cleaned up
305 - client: sfi has backward support for APIv1 aggregates again
306 - server: only APIv2 is supported and should be rather strict
307 - server: settings for turning on/off caching in sm or am
308 - server: plc-dependant code has moved from aggregate to pldriver
309 - server: driver interface extended accordingly
310
311 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
312 - screwed up previous tag
313
314 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
315 - client side revisited with a bootstrap library
316 - client side has a new source layout
317 - various (nasty) bug fixes wrt options and call_id
318
319 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
320 - various fixes in rspecs for sfav1&slice tags
321 - uses 'geni_rspec_version' and not just 'rspec_version'
322 - example flavour for the max testbed
323 - embryo for an sfa client library
324 - topology.py moved into plc
325 - sql: table is named records; record_types are enforced
326 - sql: table creation cleaned up
327
328 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
329 - cleaned up all references to SFA_*_TYPE in config
330 - enable cache at the aggregate by default
331 - registry now uses the driver in a sensible way (see managers/driver.py)
332 - slice manager supports sfav1/pgv2 neighbours
333 - get_key renamed into get_key_from_incoming_ip
334 - new sfa.storage module for record/table and all db-related stuff
335 - db schema in sfa.storage.sfa.sql
336 - init.d and cron.d move one step up
337 - cleaned up rspec/ directory
338 - add deps to pyopenssl and myplc-config
339 - start support for new API (return value)
340 - plc.remoteshell removed, use plshell instead
341 - plshell uses a 'capability' auth method whenever possible
342 - various tweaks in rspec elements
343 - made dependency on sfatables softer
344
345 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
346 - sfa should now be started *before* the initial import
347 - sfa to use its own database (default sfa) - can run without myplc
348 - server calls support optional 'options'
349 - client sends options in argument when needed
350 - fix infinite getattr recursion in elements/element.py
351 - error codes in line with geni
352
353 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
354 - fixed links and attributes in rspecs
355 - minor cleanup in the API methods, and more consistent names in manager methods
356
357 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
358 - ongoing refoactoring towards more genericity
359 - passes tests again although known issues remain with attributes/tags
360
361 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
362 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
363 - improvements in the pgv2 rspecs
364 - driver separated from api
365 - code starts moving around where it belongs
366 - sfascan caches getversion across invokations
367 - vini topology extracted as a config file
368
369 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
370 - first support for protogeni rspecs is working
371 - vini no longer needs a specific manager
372 - refactoring underway towards more flexible/generic architecture
373
374 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
375 - Unicode-friendliness for user names with accents/special chars.
376 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
377 - CreaetSliver no longer fails for users that have a capital letter in their URN.
378 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
379 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
380 - Fix bugs and missing imports     
381  
382
383 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
384 - new method record.get_field for sface
385
386 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
387 - new option -c to sfa-nuke-plc.py
388 - CreateSliver fixed for admin-only slice tags
389
390 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
391 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
392 - Fixed holes in certificate verification logic.
393 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
394 - Added 'boot_state' as an attribute of the node element in SFA rspec.
395 - Non authority certificates are marked as CA:FALSE.
396
397 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
398 - fix typo in sfa-1.0-31 tag.
399 - added CreateGid() Registry interface method.
400
401 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
402 - fix typo in sfa-1.0-30 tag
403
404 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
405 - Declare namespace and schema location in the credential.
406 - Fix bug that prevetend connections from timing out.
407 - Fix slice delegation.
408 - Add statistics to slicemaanger listresources/createsliver rspec.
409 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
410   of days a user can extend their slice expiration.
411 - CA certs are only issued to objects of type authority
412    
413 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
414 - tag 1.0-28 was broken due to typo in the changelog
415 - new class sfa/util/httpsProtocol.py that supports timeouts
416
417 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
418 - Resolved issue that caused sfa hold onto idle db connections.
419 - Fix bug that caused the registry to use the wrong type of credential.
420 - Support authority+sm type.
421 - Fix rspec merging bugs.
422 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
423 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
424  planetlab hosted initscripts using the <planetlab:initscript> tag  
425 - Can now handle extraneous whitespace in the rspec without failing.   
426  
427 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
428 - ProtoGENI v2 RSpec updates.
429 - Convert expiration timestamps with timezone info in credentials to utc.
430 - Fixed redundant logging issue. 
431 - Improved SliceManager and SFI client logging.
432 - Support aggregates that don't support the optional 'call_id' argument. 
433 - Only call get_trusted_certs() at aggreage interfaces that support the call.
434 - CreateSliver() now handles MyPLC slice attributes/tags.
435 - Cache now supports persistence.
436 - Hide whitelisted nodes.
437
438 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
439 - fixed issues with sup authority signing
440 - fixed bugs in remove_slivers and SliverStatus
441
442 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
443 - fix typo that prevented aggregates from operating properly
444
445 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
446 - load trusted certs into ssl context prior to handshake
447 - client's logfile lives in ~/.sfi/sfi.log
448
449 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
450 - includes a change on passphrases that was intended in 1.0-22
451
452 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
453 - Added support for ProtoGENI RSpec v2
454  
455 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
456 - stable sfascan
457 - fix in initscript, *ENABLED tags in config now taken into account
458
459 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
460 - some commits had not been pushed in tag 19
461
462 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
463 - GetVersion should now report full URLs with path
464 - scansfa has nicer output and new syntax (entry URLs as args and not options)
465 - dos2unix'ed flash policy pill
466
467 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
468 - fix packaging again for f8
469
470 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
471 - fix packaging (apparently broken in 1.0-16)
472 - first working version of sfascan
473 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
474 - deprecated the sfa_geni_aggregate config category
475
476 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
477 - Fix build problem
478 - First version of SFA scanner
479
480 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
481 - Add support for Flash clients using flashpolicy
482 - Fix problems with tag handling in RSpec
483
484 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
485 - Modifications to the Eucalyptus Aggregate Manager
486 - Fixes for VINI RSpec
487 - Fix tag handling for PL RSpec
488 - Fix XML Schema ordering for <urn> element
489
490 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
491 - just set x509 version to 2
492
493 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
494 - added urn to the node area in rspecs
495 - conversion to urn now exports fqdn
496 - sfa-import-plc.py now creates a unique registry record for each SFA interface
497
498 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
499 - undo broken attempt for python-2.7
500
501 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
502 - SMs avoid duplicates for when call graph has dags;
503 - just based on network's name, when a duplicate occurs, one is just dropped
504 - does not try to merge/aggregate 2 networks
505 - also reviewed logging with the hope to fix the sfa startup msg:
506 - TypeError: not all arguments converted during string formatting
507
508 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
509 - verify credentials against xsd schema
510 - Fix SM to SM communication
511 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
512 - new setting session_key_path
513
514 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
515 - fix registry credential regeneration and handle expiration
516 - support for setting slice tags (min_role=user)
517 - client can display its own version: sfi.py version --local
518 - GetVersion to provide urn in addition to hrn
519 - more code uses plxrn vs previous helper functions
520 - import replaces '+' in email addresses with '_'
521
522 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
523 - fix GetVersion code_tag and add code_url
524
525 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
526 - extend GetVersion towards minimum federation introspection, and expose local tag
527
528 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
529 - fixed some legacy issues (list vs List)
530 - deprecated sfa.util.namespace for xrn and plxrn
531 - unit tests ship as the sfa-tests rpm
532
533 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
534 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
535 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
536 - hrn-urn translations tweaked
537 - fixed 'service sfa status'
538 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
539 - started to repair sfadump - although not usable yet
540 - trust objects now have dump_string method that dump() actually prints
541 - unit tests under review
542 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
543 - binaries now support -v or -vv to increase loglevel
544 - trashed obsolete sfa.util.client
545
546 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
547 - various bugfixes and cleanup, improved/harmonized logging
548
549 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
550 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
551   to avoid returning a PLCAPI exception that might confuse users.
552 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
553 - fix build errors.  
554
555 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
556 - (Architecture) Credential format changed to match ProtoGENI xml format
557 - (Architecture) All interfaces export a new set of methods that are compatible
558    with the ProtoGeni Aggregate spec. These new methods are considered a 
559    replacement  for the pervious methods exported by the interfaces. All 
560    previous methods are still exported and work as normal, but they are 
561    considered deprecated and will not be supported in future releases.  
562 - (Architecture) SFI has been updated to use the new interface methods.
563 - (Architecture) Changed keyconvet implementation from c to python.
564 - (Architecture) Slice Manager now attempts looks for a delegated credential
565   provided by the client before using its own server credential.
566 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
567   This cache now exists only in memory and is cleared when service is restarted
568   or cache lifetime is exceeded.  
569 - (Performance) SliceManager sends request to Aggregates in parallel instead 
570   of sequentially.
571 - (Bug fix) SFA tickets now support the new rspec format.
572 - (Bug fix) SFI only uses cahced credential if they aren't expired.
573 - (Bug fix) Cerdential delegation modified to work with new credential format.
574 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
575   Aggregate instead of relaying through the Slice Manager.
576 - (Enhancement) Simplified caching. Accociated a global cache instance with
577   the api handler on every new server request, making it easier to access the 
578   cache and use in more general ways.     
579
580 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
581 - SfaServer now uses a pool of threads to handle requests concurrently
582 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
583 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
584 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
585 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
586 - Component manager does not install gid files if slice already has them  
587 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
588 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
589 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
590      
591 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
592 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
593 - - sfa-config-tty now has the same features like plc-config-tty
594 - - Contains code to support both urn and hrn
595 - - Cleaned up request_hash related stuff
596 - - SM, AM and Registry code is organized under respective managers
597 - - Site and Slice synchronization across federated aggregates
598 - - Script to generate sfa_component_config
599
600 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
601 - sfa-config-tty now has the same features like plc-config-tty
602 - Contains code to support both urn and hrn
603 - Cleaned up request_hash related stuff
604 - SM, AM and Registry code is organized under respective managers
605 - Slice synchronization across federated aggregates
606 - some bugs are fixed
607
608 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
609 - checkpoint with fewer mentions of geni
610
611 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
612 - checkpointing
613 - this is believed to pass the tests; among other things:
614 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
615
616 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
617 - This tag includes:
618 - - Sfatables
619 - - Preliminary version of hash based authentication
620 - - Initial code for Component Manager
621 - - Authority structure is moved to /var/lib/sfa/
622 - - some bug-fixes
623
624 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
625 - Create_slice and get_resources methods are connected to sfatables.
626 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
627
628 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
629 - Bug fix on update and remove_peer_object methods
630 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
631
632 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
633 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
634
635 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
636 - compatibility with RefreshPeer
637 - incremental mechanism for importing PLC records into SFA tables
638 - unified single database (still inside the underlying PLC db postgresql server)
639 - includes/improves call traceability and logging features
640 - several bug fixes
641
642 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
643 - added libxslt-python dependency
644
645 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
646 - unified single SFA database in the PLC-DB
647 - upcalls from  PLCAPI to SFA methods
648 - SFA call traceability and logging features
649 - many bug fixes
650 - includes first/rough version of sfatables for policy implementation
651
652 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
653 - snapshot after the GEC5 demo
654 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
655
656 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
657 - snapshot july 15 - has gone through superficial manual testing
658 - hopefully a good basis for gec5 demo
659 - multi-dir sfi client tested as well
660
661 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
662 - rename geniwrapper.spec into sfa.spec
663
664 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
665 - clean up in xmlrpc/soap, --protocol option to chose between both
666 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
667 - hopefully more helpful context in case of crashes when importing
668 - bugfixes for using only /etc/sfa for site-dep files
669 - bugfixes in wsdl generation
670
671 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
672 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
673 - config variables in sfa_config now start with SFA_ and not GENI_
674 - config.py can be loaded even with no config present
675
676 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
677 - first step for cleanup and reorganization
678 - mass-renaming from geni to sfa (some are still needed)
679 - sfa/trust implements the security architecture
680
681 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
682 - snapshot for reproducible builds
683
684 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
685 - snapshot for the convenience of alpha users
686
687 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
688 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
689
690 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
691 - ongoing work - snapshot for 4.3-rc9
692
693 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
694 - various fixes
695
696 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
697 - bugfixes - still a work in progress
698
699 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
700 - initial package
701
702
703 %define module_current_branch 0.2