Merge branch 'master' of ssh://git.planet-lab.org/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 23
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart
197
198
199 %changelog
200 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
201 - includes a change on passphrases that was intended in 1.0-22
202
203 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
204 - Added support for ProtoGENI RSpec v2
205  
206 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
207 - stable sfascan
208 - fix in initscript, *ENABLED tags in config now taken into account
209
210 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
211 - some commits had not been pushed in tag 19
212
213 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
214 - GetVersion should now report full URLs with path
215 - scansfa has nicer output and new syntax (entry URLs as args and not options)
216 - dos2unix'ed flash policy pill
217
218 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
219 - fix packaging again for f8
220
221 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
222 - fix packaging (apparently broken in 1.0-16)
223 - first working version of sfascan
224 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
225 - deprecated the sfa_geni_aggregate config category
226
227 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
228 - Fix build problem
229 - First version of SFA scanner
230
231 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
232 - Add support for Flash clients using flashpolicy
233 - Fix problems with tag handling in RSpec
234
235 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
236 - Modifications to the Eucalyptus Aggregate Manager
237 - Fixes for VINI RSpec
238 - Fix tag handling for PL RSpec
239 - Fix XML Schema ordering for <urn> element
240
241 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
242 - just set x509 version to 2
243
244 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
245 - added urn to the node area in rspecs
246 - conversion to urn now exports fqdn
247 - sfa-import-plc.py now creates a unique registry record for each SFA interface
248
249 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
250 - undo broken attempt for python-2.7
251
252 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
253 - SMs avoid duplicates for when call graph has dags;
254 - just based on network's name, when a duplicate occurs, one is just dropped
255 - does not try to merge/aggregate 2 networks
256 - also reviewed logging with the hope to fix the sfa startup msg:
257 - TypeError: not all arguments converted during string formatting
258
259 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
260 - verify credentials against xsd schema
261 - Fix SM to SM communication
262 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
263 - new setting session_key_path
264
265 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
266 - fix registry credential regeneration and handle expiration
267 - support for setting slice tags (min_role=user)
268 - client can display its own version: sfi.py version --local
269 - GetVersion to provide urn in addition to hrn
270 - more code uses plxrn vs previous helper functions
271 - import replaces '+' in email addresses with '_'
272
273 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
274 - fix GetVersion code_tag and add code_url
275
276 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
277 - extend GetVersion towards minimum federation introspection, and expose local tag
278
279 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
280 - fixed some legacy issues (list vs List)
281 - deprecated sfa.util.namespace for xrn and plxrn
282 - unit tests ship as the sfa-tests rpm
283
284 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
285 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
286 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
287 - hrn-urn translations tweaked
288 - fixed 'service sfa status'
289 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
290 - started to repair sfadump - although not usable yet
291 - trust objects now have dump_string method that dump() actually prints
292 - unit tests under review
293 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
294 - binaries now support -v or -vv to increase loglevel
295 - trashed obsolete sfa.util.client
296
297 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
298 - various bugfixes and cleanup, improved/harmonized logging
299
300 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
301 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
302   to avoid returning a PLCAPI exception that might confuse users.
303 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
304 - fix build errors.  
305
306 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
307 - (Architecture) Credential format changed to match ProtoGENI xml format
308 - (Architecture) All interfaces export a new set of methods that are compatible
309    with the ProtoGeni Aggregate spec. These new methods are considered a 
310    replacement  for the pervious methods exported by the interfaces. All 
311    previous methods are still exported and work as normal, but they are 
312    considered deprecated and will not be supported in future releases.  
313 - (Architecture) SFI has been updated to use the new interface methods.
314 - (Architecture) Changed keyconvet implementation from c to python.
315 - (Architecture) Slice Manager now attempts looks for a delegated credential
316   provided by the client before using its own server credential.
317 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
318   This cache now exists only in memory and is cleared when service is restarted
319   or cache lifetime is exceeded.  
320 - (Performance) SliceManager sends request to Aggregates in parallel instead 
321   of sequentially.
322 - (Bug fix) SFA tickets now support the new rspec format.
323 - (Bug fix) SFI only uses cahced credential if they aren't expired.
324 - (Bug fix) Cerdential delegation modified to work with new credential format.
325 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
326   Aggregate instead of relaying through the Slice Manager.
327 - (Enhancement) Simplified caching. Accociated a global cache instance with
328   the api handler on every new server request, making it easier to access the 
329   cache and use in more general ways.     
330
331 %changelog
332 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
333 - includes a change on passphrases that was intended in 1.0-22
334
335 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
336 - stable sfascan
337 - fix in initscript, *ENABLED tags in config now taken into account
338
339 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
340 - some commits had not been pushed in tag 19
341
342 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
343 - GetVersion should now report full URLs with path
344 - scansfa has nicer output and new syntax (entry URLs as args and not options)
345 - dos2unix'ed flash policy pill
346
347 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
348 - fix packaging again for f8
349
350 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
351 - fix packaging (apparently broken in 1.0-16)
352 - first working version of sfascan
353 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
354 - deprecated the sfa_geni_aggregate config category
355
356 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
357 - Fix build problem
358 - First version of SFA scanner
359
360 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
361 - Add support for Flash clients using flashpolicy
362 - Fix problems with tag handling in RSpec
363
364 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
365 - Modifications to the Eucalyptus Aggregate Manager
366 - Fixes for VINI RSpec
367 - Fix tag handling for PL RSpec
368 - Fix XML Schema ordering for <urn> element
369
370 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
371 - just set x509 version to 2
372
373 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
374 - added urn to the node area in rspecs
375 - conversion to urn now exports fqdn
376 - sfa-import-plc.py now creates a unique registry record for each SFA interface
377
378 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
379 - undo broken attempt for python-2.7
380
381 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
382 - SMs avoid duplicates for when call graph has dags;
383 - just based on network's name, when a duplicate occurs, one is just dropped
384 - does not try to merge/aggregate 2 networks
385 - also reviewed logging with the hope to fix the sfa startup msg:
386 - TypeError: not all arguments converted during string formatting
387
388 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
389 - verify credentials against xsd schema
390 - Fix SM to SM communication
391 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
392 - new setting session_key_path
393
394 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
395 - fix registry credential regeneration and handle expiration
396 - support for setting slice tags (min_role=user)
397 - client can display its own version: sfi.py version --local
398 - GetVersion to provide urn in addition to hrn
399 - more code uses plxrn vs previous helper functions
400 - import replaces '+' in email addresses with '_'
401
402 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
403 - fix GetVersion code_tag and add code_url
404
405 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
406 - extend GetVersion towards minimum federation introspection, and expose local tag
407
408 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
409 - fixed some legacy issues (list vs List)
410 - deprecated sfa.util.namespace for xrn and plxrn
411 - unit tests ship as the sfa-tests rpm
412
413 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
414 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
415 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
416 - hrn-urn translations tweaked
417 - fixed 'service sfa status'
418 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
419 - started to repair sfadump - although not usable yet
420 - trust objects now have dump_string method that dump() actually prints
421 - unit tests under review
422 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
423 - binaries now support -v or -vv to increase loglevel
424 - trashed obsolete sfa.util.client
425
426 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
427 - various bugfixes and cleanup, improved/harmonized logging
428
429 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
430 - SfaServer now uses a pool of threads to handle requests concurrently
431 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
432 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
433 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
434 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
435 - Component manager does not install gid files if slice already has them  
436 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
437 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
438 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
439      
440 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
441 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
442 - - sfa-config-tty now has the same features like plc-config-tty
443 - - Contains code to support both urn and hrn
444 - - Cleaned up request_hash related stuff
445 - - SM, AM and Registry code is organized under respective managers
446 - - Site and Slice synchronization across federated aggregates
447 - - Script to generate sfa_component_config
448
449 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
450 - sfa-config-tty now has the same features like plc-config-tty
451 - Contains code to support both urn and hrn
452 - Cleaned up request_hash related stuff
453 - SM, AM and Registry code is organized under respective managers
454 - Slice synchronization across federated aggregates
455 - some bugs are fixed
456
457 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
458 - checkpoint with fewer mentions of geni
459
460 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
461 - checkpointing
462 - this is believed to pass the tests; among other things:
463 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
464
465 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
466 - This tag includes:
467 - - Sfatables
468 - - Preliminary version of hash based authentication
469 - - Initial code for Component Manager
470 - - Authority structure is moved to /var/lib/sfa/
471 - - some bug-fixes
472
473 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
474 - Create_slice and get_resources methods are connected to sfatables.
475 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
476
477 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
478 - Bug fix on update and remove_peer_object methods
479 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
480
481 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
482 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
483
484 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
485 - compatibility with RefreshPeer
486 - incremental mechanism for importing PLC records into SFA tables
487 - unified single database (still inside the underlying PLC db postgresql server)
488 - includes/improves call traceability and logging features
489 - several bug fixes
490
491 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
492 - added libxslt-python dependency
493
494 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
495 - unified single SFA database in the PLC-DB
496 - upcalls from  PLCAPI to SFA methods
497 - SFA call traceability and logging features
498 - many bug fixes
499 - includes first/rough version of sfatables for policy implementation
500
501 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
502 - snapshot after the GEC5 demo
503 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
504
505 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
506 - snapshot july 15 - has gone through superficial manual testing
507 - hopefully a good basis for gec5 demo
508 - multi-dir sfi client tested as well
509
510 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
511 - rename geniwrapper.spec into sfa.spec
512
513 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
514 - clean up in xmlrpc/soap, --protocol option to chose between both
515 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
516 - hopefully more helpful context in case of crashes when importing
517 - bugfixes for using only /etc/sfa for site-dep files
518 - bugfixes in wsdl generation
519
520 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
521 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
522 - config variables in sfa_config now start with SFA_ and not GENI_
523 - config.py can be loaded even with no config present
524
525 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
526 - first step for cleanup and reorganization
527 - mass-renaming from geni to sfa (some are still needed)
528 - sfa/trust implements the security architecture
529
530 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
531 - snapshot for reproducible builds
532
533 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
534 - snapshot for the convenience of alpha users
535
536 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
537 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
538
539 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
540 - ongoing work - snapshot for 4.3-rc9
541
542 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
543 - various fixes
544
545 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
546 - bugfixes - still a work in progress
547
548 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
549 - initial package
550
551
552 %define module_current_branch 0.2