sql schema is managed under sqlalchemy, no need for the .sql file anymore
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 9
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package plc
65 Summary: the SFA layer around MyPLC
66 Group: Applications/System
67 Requires: sfa
68 Requires: python-psycopg2
69
70 %package client
71 Summary: the SFA experimenter-side CLI
72 Group: Applications/System
73 Requires: sfa
74 Requires: pyOpenSSL >= 0.7
75
76 %package sfatables
77 Summary: sfatables policy tool for SFA
78 Group: Applications/System
79 Requires: sfa
80
81 %package cm
82 Summary: the SFA layer around MyPLC NodeManager
83 Group: Applications/System
84 Requires: sfa
85 Requires: pyOpenSSL >= 0.6
86
87 %package flashpolicy
88 Summary: SFA support for flash clients
89 Group: Applications/System
90 Requires: sfa
91
92 %package xmlbuilder
93 Summary: third-party xmlbuilder tool
94 Group: Applications/System
95 Provides: python-xmlbuilder
96
97 %package tests
98 Summary: unit tests suite for SFA
99 Group: Applications/System
100 Requires: sfa
101
102 %description
103 This package provides the python libraries for the PlanetLab implementation of SFA
104
105 %description plc
106 This package implements the SFA interface which serves as a layer
107 between the existing PlanetLab interfaces and the SFA API.
108
109 %description client
110 This package provides the client side of the SFA API, in particular
111 sfi.py, together with other utilities.
112
113 %description sfatables
114 sfatables is a tool for defining access and admission control policies
115 in an SFA network, in much the same way as iptables is for ip
116 networks. This is the command line interface to manage sfatables
117
118 %description cm
119 This package implements the SFA interface which serves as a layer
120 between the existing PlanetLab NodeManager interfaces and the SFA API.
121
122 %description flashpolicy
123 This package provides support for adobe flash client applications.  
124
125 %description xmlbuilder
126 This package contains the xmlbuilder python library, packaged for
127 convenience as it is not supported by fedora
128
129 %description tests
130 Provides some binary unit tests in /usr/share/sfa/tests
131
132 %prep
133 %setup -q
134
135 %build
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files
146 # sfa and sfatables depend on each other.
147 %{python_sitelib}/sfa
148 /etc/init.d/sfa
149 %{_bindir}/sfa-start.py*
150 %{_bindir}/keyconvert.py*
151 %{_bindir}/sfa-config-tty
152 %config /etc/sfa/default_config.xml
153 %config (noreplace) /etc/sfa/aggregates.xml
154 %config (noreplace) /etc/sfa/registries.xml
155 /usr/share/sfa/examples
156 /var/www/html/wsdl/*.wsdl
157
158 %files plc
159 %defattr(-,root,root)
160 /etc/sfa/pl.rng
161 /etc/sfa/credential.xsd
162 /etc/sfa/top.xsd
163 /etc/sfa/sig.xsd
164 /etc/sfa/xml.xsd
165 /etc/sfa/protogeni-rspec-common.xsd
166 /etc/sfa/topology
167 %{_bindir}/sfa-import-plc.py*
168 %{_bindir}/sfa-nuke-plc.py*
169 %{_bindir}/sfa-clean-peer-records.py*
170 %{_bindir}/gen-sfa-cm-config.py*
171 %{_bindir}/sfa-ca.py*
172
173 %files client
174 %config (noreplace) /etc/sfa/sfi_config
175 %{_bindir}/sfi*.py*
176 %{_bindir}/sfi
177 %{_bindir}/get*.py*
178 %{_bindir}/setRecord.py*
179 %{_bindir}/sfascan.py*
180 %{_bindir}/sfascan
181 %{_bindir}/sfadump.py*
182
183 %files sfatables
184 /etc/sfatables/*
185 %{_bindir}/sfatables
186 %{python_sitelib}/sfatables
187
188 %files cm
189 /etc/init.d/sfa-cm
190 %{_bindir}/sfa_component_setup.py*
191 # cron jobs here 
192
193 %files flashpolicy
194 %{_bindir}/sfa_flashpolicy.py*
195 /etc/sfa/sfa_flashpolicy_config.xml
196
197 %files xmlbuilder
198 %{python_sitelib}/xmlbuilder
199
200 %files tests
201 %{_datadir}/sfa/tests
202
203 ### sfa-plc installs the 'sfa' service
204 %post plc
205 chkconfig --add sfa
206
207 %preun plc
208 if [ "$1" = 0 ] ; then
209   /sbin/service sfa stop || :
210   /sbin/chkconfig --del sfa || :
211 fi
212
213 %postun plc
214 [ "$1" -ge "1" ] && service sfa restart
215
216 ### sfa-cm installs the 'sfa-cm' service
217 %post cm
218 chkconfig --add sfa-cm
219
220 %preun cm
221 if [ "$1" = 0 ] ; then
222    /sbin/service sfa-cm stop || :
223    /sbin/chkconfig --del sfa-cm || :
224 fi
225
226 %postun cm
227 [ "$1" -ge "1" ] && service sfa-cm restart || :
228
229 %changelog
230 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
231 - bugfix: 'geni_api' should be in the top level struct, not the code struct
232 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
233           output returned by the Aggregate Manager.
234 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
235 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
236 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
237           there is extra whitespace in the schemaLocation field.
238 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
239           advertisement rspecs.
240 - bugfix: <login> RSpec element should contain the 'username' attribute.
241 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
242  
243 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
244 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
245   exit when it encountered a user with an invalid public key.
246 - server: imporved logging in sfa-import-plc.py
247  
248 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
249 - bugfix: Fixed appending public keys in CreateSliver
250 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
251 - client: -c --current option allows users to request the current/uncached rspec.
252 - server: Added 'geni_api_versions' field to GetVersion() output.
253 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
254    
255 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
256 - bugfix: sfi was not sending call_id with ListResources to v2 servers
257 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
258 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
259
260 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
261 - client: sfi -a / -p deprecated (use -s instead)
262 - client: sfi cleaned up
263 - client: sfi has backward support for APIv1 aggregates again
264 - server: only APIv2 is supported and should be rather strict
265 - server: settings for turning on/off caching in sm or am
266 - server: plc-dependant code has moved from aggregate to pldriver
267 - server: driver interface extended accordingly
268
269 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
270 - screwed up previous tag
271
272 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
273 - client side revisited with a bootstrap library
274 - client side has a new source layout
275 - various (nasty) bug fixes wrt options and call_id
276
277 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
278 - various fixes in rspecs for sfav1&slice tags
279 - uses 'geni_rspec_version' and not just 'rspec_version'
280 - example flavour for the max testbed
281 - embryo for an sfa client library
282 - topology.py moved into plc
283 - sql: table is named records; record_types are enforced
284 - sql: table creation cleaned up
285
286 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
287 - cleaned up all references to SFA_*_TYPE in config
288 - enable cache at the aggregate by default
289 - registry now uses the driver in a sensible way (see managers/driver.py)
290 - slice manager supports sfav1/pgv2 neighbours
291 - get_key renamed into get_key_from_incoming_ip
292 - new sfa.storage module for record/table and all db-related stuff
293 - db schema in sfa.storage.sfa.sql
294 - init.d and cron.d move one step up
295 - cleaned up rspec/ directory
296 - add deps to pyopenssl and myplc-config
297 - start support for new API (return value)
298 - plc.remoteshell removed, use plshell instead
299 - plshell uses a 'capability' auth method whenever possible
300 - various tweaks in rspec elements
301 - made dependency on sfatables softer
302
303 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
304 - sfa should now be started *before* the initial import
305 - sfa to use its own database (default sfa) - can run without myplc
306 - server calls support optional 'options'
307 - client sends options in argument when needed
308 - fix infinite getattr recursion in elements/element.py
309 - error codes in line with geni
310
311 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
312 - fixed links and attributes in rspecs
313 - minor cleanup in the API methods, and more consistent names in manager methods
314
315 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
316 - ongoing refoactoring towards more genericity
317 - passes tests again although known issues remain with attributes/tags
318
319 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
320 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
321 - improvements in the pgv2 rspecs
322 - driver separated from api
323 - code starts moving around where it belongs
324 - sfascan caches getversion across invokations
325 - vini topology extracted as a config file
326
327 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
328 - first support for protogeni rspecs is working
329 - vini no longer needs a specific manager
330 - refactoring underway towards more flexible/generic architecture
331
332 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
333 - Unicode-friendliness for user names with accents/special chars.
334 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
335 - CreaetSliver no longer fails for users that have a capital letter in their URN.
336 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
337 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
338 - Fix bugs and missing imports     
339  
340
341 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
342 - new method record.get_field for sface
343
344 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
345 - new option -c to sfa-nuke-plc.py
346 - CreateSliver fixed for admin-only slice tags
347
348 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
349 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
350 - Fixed holes in certificate verification logic.
351 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
352 - Added 'boot_state' as an attribute of the node element in SFA rspec.
353 - Non authority certificates are marked as CA:FALSE.
354
355 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
356 - fix typo in sfa-1.0-31 tag.
357 - added CreateGid() Registry interface method.
358
359 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
360 - fix typo in sfa-1.0-30 tag
361
362 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
363 - Declare namespace and schema location in the credential.
364 - Fix bug that prevetend connections from timing out.
365 - Fix slice delegation.
366 - Add statistics to slicemaanger listresources/createsliver rspec.
367 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
368   of days a user can extend their slice expiration.
369 - CA certs are only issued to objects of type authority
370    
371 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
372 - tag 1.0-28 was broken due to typo in the changelog
373 - new class sfa/util/httpsProtocol.py that supports timeouts
374
375 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
376 - Resolved issue that caused sfa hold onto idle db connections.
377 - Fix bug that caused the registry to use the wrong type of credential.
378 - Support authority+sm type.
379 - Fix rspec merging bugs.
380 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
381 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
382  planetlab hosted initscripts using the <planetlab:initscript> tag  
383 - Can now handle extraneous whitespace in the rspec without failing.   
384  
385 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
386 - ProtoGENI v2 RSpec updates.
387 - Convert expiration timestamps with timezone info in credentials to utc.
388 - Fixed redundant logging issue. 
389 - Improved SliceManager and SFI client logging.
390 - Support aggregates that don't support the optional 'call_id' argument. 
391 - Only call get_trusted_certs() at aggreage interfaces that support the call.
392 - CreateSliver() now handles MyPLC slice attributes/tags.
393 - Cache now supports persistence.
394 - Hide whitelisted nodes.
395
396 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
397 - fixed issues with sup authority signing
398 - fixed bugs in remove_slivers and SliverStatus
399
400 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
401 - fix typo that prevented aggregates from operating properly
402
403 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
404 - load trusted certs into ssl context prior to handshake
405 - client's logfile lives in ~/.sfi/sfi.log
406
407 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
408 - includes a change on passphrases that was intended in 1.0-22
409
410 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
411 - Added support for ProtoGENI RSpec v2
412  
413 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
414 - stable sfascan
415 - fix in initscript, *ENABLED tags in config now taken into account
416
417 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
418 - some commits had not been pushed in tag 19
419
420 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
421 - GetVersion should now report full URLs with path
422 - scansfa has nicer output and new syntax (entry URLs as args and not options)
423 - dos2unix'ed flash policy pill
424
425 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
426 - fix packaging again for f8
427
428 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
429 - fix packaging (apparently broken in 1.0-16)
430 - first working version of sfascan
431 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
432 - deprecated the sfa_geni_aggregate config category
433
434 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
435 - Fix build problem
436 - First version of SFA scanner
437
438 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
439 - Add support for Flash clients using flashpolicy
440 - Fix problems with tag handling in RSpec
441
442 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
443 - Modifications to the Eucalyptus Aggregate Manager
444 - Fixes for VINI RSpec
445 - Fix tag handling for PL RSpec
446 - Fix XML Schema ordering for <urn> element
447
448 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
449 - just set x509 version to 2
450
451 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
452 - added urn to the node area in rspecs
453 - conversion to urn now exports fqdn
454 - sfa-import-plc.py now creates a unique registry record for each SFA interface
455
456 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
457 - undo broken attempt for python-2.7
458
459 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
460 - SMs avoid duplicates for when call graph has dags;
461 - just based on network's name, when a duplicate occurs, one is just dropped
462 - does not try to merge/aggregate 2 networks
463 - also reviewed logging with the hope to fix the sfa startup msg:
464 - TypeError: not all arguments converted during string formatting
465
466 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
467 - verify credentials against xsd schema
468 - Fix SM to SM communication
469 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
470 - new setting session_key_path
471
472 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
473 - fix registry credential regeneration and handle expiration
474 - support for setting slice tags (min_role=user)
475 - client can display its own version: sfi.py version --local
476 - GetVersion to provide urn in addition to hrn
477 - more code uses plxrn vs previous helper functions
478 - import replaces '+' in email addresses with '_'
479
480 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
481 - fix GetVersion code_tag and add code_url
482
483 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
484 - extend GetVersion towards minimum federation introspection, and expose local tag
485
486 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
487 - fixed some legacy issues (list vs List)
488 - deprecated sfa.util.namespace for xrn and plxrn
489 - unit tests ship as the sfa-tests rpm
490
491 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
492 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
493 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
494 - hrn-urn translations tweaked
495 - fixed 'service sfa status'
496 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
497 - started to repair sfadump - although not usable yet
498 - trust objects now have dump_string method that dump() actually prints
499 - unit tests under review
500 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
501 - binaries now support -v or -vv to increase loglevel
502 - trashed obsolete sfa.util.client
503
504 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
505 - various bugfixes and cleanup, improved/harmonized logging
506
507 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
508 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
509   to avoid returning a PLCAPI exception that might confuse users.
510 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
511 - fix build errors.  
512
513 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
514 - (Architecture) Credential format changed to match ProtoGENI xml format
515 - (Architecture) All interfaces export a new set of methods that are compatible
516    with the ProtoGeni Aggregate spec. These new methods are considered a 
517    replacement  for the pervious methods exported by the interfaces. All 
518    previous methods are still exported and work as normal, but they are 
519    considered deprecated and will not be supported in future releases.  
520 - (Architecture) SFI has been updated to use the new interface methods.
521 - (Architecture) Changed keyconvet implementation from c to python.
522 - (Architecture) Slice Manager now attempts looks for a delegated credential
523   provided by the client before using its own server credential.
524 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
525   This cache now exists only in memory and is cleared when service is restarted
526   or cache lifetime is exceeded.  
527 - (Performance) SliceManager sends request to Aggregates in parallel instead 
528   of sequentially.
529 - (Bug fix) SFA tickets now support the new rspec format.
530 - (Bug fix) SFI only uses cahced credential if they aren't expired.
531 - (Bug fix) Cerdential delegation modified to work with new credential format.
532 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
533   Aggregate instead of relaying through the Slice Manager.
534 - (Enhancement) Simplified caching. Accociated a global cache instance with
535   the api handler on every new server request, making it easier to access the 
536   cache and use in more general ways.     
537
538 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
539 - SfaServer now uses a pool of threads to handle requests concurrently
540 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
541 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
542 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
543 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
544 - Component manager does not install gid files if slice already has them  
545 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
546 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
547 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
548      
549 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
550 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
551 - - sfa-config-tty now has the same features like plc-config-tty
552 - - Contains code to support both urn and hrn
553 - - Cleaned up request_hash related stuff
554 - - SM, AM and Registry code is organized under respective managers
555 - - Site and Slice synchronization across federated aggregates
556 - - Script to generate sfa_component_config
557
558 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
559 - sfa-config-tty now has the same features like plc-config-tty
560 - Contains code to support both urn and hrn
561 - Cleaned up request_hash related stuff
562 - SM, AM and Registry code is organized under respective managers
563 - Slice synchronization across federated aggregates
564 - some bugs are fixed
565
566 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
567 - checkpoint with fewer mentions of geni
568
569 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
570 - checkpointing
571 - this is believed to pass the tests; among other things:
572 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
573
574 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
575 - This tag includes:
576 - - Sfatables
577 - - Preliminary version of hash based authentication
578 - - Initial code for Component Manager
579 - - Authority structure is moved to /var/lib/sfa/
580 - - some bug-fixes
581
582 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
583 - Create_slice and get_resources methods are connected to sfatables.
584 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
585
586 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
587 - Bug fix on update and remove_peer_object methods
588 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
589
590 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
591 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
592
593 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
594 - compatibility with RefreshPeer
595 - incremental mechanism for importing PLC records into SFA tables
596 - unified single database (still inside the underlying PLC db postgresql server)
597 - includes/improves call traceability and logging features
598 - several bug fixes
599
600 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
601 - added libxslt-python dependency
602
603 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
604 - unified single SFA database in the PLC-DB
605 - upcalls from  PLCAPI to SFA methods
606 - SFA call traceability and logging features
607 - many bug fixes
608 - includes first/rough version of sfatables for policy implementation
609
610 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
611 - snapshot after the GEC5 demo
612 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
613
614 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
615 - snapshot july 15 - has gone through superficial manual testing
616 - hopefully a good basis for gec5 demo
617 - multi-dir sfi client tested as well
618
619 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
620 - rename geniwrapper.spec into sfa.spec
621
622 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
623 - clean up in xmlrpc/soap, --protocol option to chose between both
624 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
625 - hopefully more helpful context in case of crashes when importing
626 - bugfixes for using only /etc/sfa for site-dep files
627 - bugfixes in wsdl generation
628
629 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
630 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
631 - config variables in sfa_config now start with SFA_ and not GENI_
632 - config.py can be loaded even with no config present
633
634 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
635 - first step for cleanup and reorganization
636 - mass-renaming from geni to sfa (some are still needed)
637 - sfa/trust implements the security architecture
638
639 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
640 - snapshot for reproducible builds
641
642 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
643 - snapshot for the convenience of alpha users
644
645 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
646 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
647
648 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
649 - ongoing work - snapshot for 4.3-rc9
650
651 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
652 - various fixes
653
654 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
655 - bugfixes - still a work in progress
656
657 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
658 - initial package
659
660
661 %define module_current_branch 0.2