Setting tag sfa-2.0-10
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 10
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45 Requires: python-xmlbuilder
46  
47 # python 2.5 has uuid module added, for python 2.4 we still need it.
48 # we can't really check for if we can load uuid as a python module,
49 # it'll be installed by "devel.pkgs". we have the epel repository so
50 # python-uuid will be provided. but we can test for the python
51 # version.
52 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
53 # %if %has_py24
54 #
55 # this also didn't work very well. I'll just check for distroname - baris
56 #%if %{distroname} == "centos5"
57 #Requires: python-uuid
58 #%endif
59
60 %package plc
61 Summary: the SFA layer around MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package cm
78 Summary: the SFA layer around MyPLC NodeManager
79 Group: Applications/System
80 Requires: sfa
81 Requires: pyOpenSSL >= 0.6
82
83 %package flashpolicy
84 Summary: SFA support for flash clients
85 Group: Applications/System
86 Requires: sfa
87
88 %package xmlbuilder
89 Summary: third-party xmlbuilder tool
90 Group: Applications/System
91 Provides: python-xmlbuilder
92
93 %package tests
94 Summary: unit tests suite for SFA
95 Group: Applications/System
96 Requires: sfa
97
98 %description
99 This package provides the python libraries for the PlanetLab implementation of SFA
100
101 %description plc
102 This package implements the SFA interface which serves as a layer
103 between the existing PlanetLab interfaces and the SFA API.
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description sfatables
110 sfatables is a tool for defining access and admission control policies
111 in an SFA network, in much the same way as iptables is for ip
112 networks. This is the command line interface to manage sfatables
113
114 %description cm
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab NodeManager interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description xmlbuilder
122 This package contains the xmlbuilder python library, packaged for
123 convenience as it is not supported by fedora
124
125 %description tests
126 Provides some binary unit tests in /usr/share/sfa/tests
127
128 %prep
129 %setup -q
130
131 %build
132 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 # sfa and sfatables depend on each other.
143 %{python_sitelib}/sfa
144 /etc/init.d/sfa
145 %{_bindir}/sfa-start.py*
146 %{_bindir}/keyconvert.py*
147 %{_bindir}/sfa-config-tty
148 %config /etc/sfa/default_config.xml
149 %config (noreplace) /etc/sfa/aggregates.xml
150 %config (noreplace) /etc/sfa/registries.xml
151 /usr/share/sfa/sfa.sql
152 /usr/share/sfa/examples
153 /var/www/html/wsdl/*.wsdl
154
155 %files plc
156 %defattr(-,root,root)
157 /etc/sfa/pl.rng
158 /etc/sfa/credential.xsd
159 /etc/sfa/top.xsd
160 /etc/sfa/sig.xsd
161 /etc/sfa/xml.xsd
162 /etc/sfa/protogeni-rspec-common.xsd
163 /etc/sfa/topology
164 %{_bindir}/sfa-import-plc.py*
165 %{_bindir}/sfa-nuke-plc.py*
166 %{_bindir}/sfa-clean-peer-records.py*
167 %{_bindir}/gen-sfa-cm-config.py*
168 %{_bindir}/sfa-ca.py*
169
170 %files client
171 %config (noreplace) /etc/sfa/sfi_config
172 %{_bindir}/sfi*.py*
173 %{_bindir}/sfi
174 %{_bindir}/get*.py*
175 %{_bindir}/setRecord.py*
176 %{_bindir}/sfascan.py*
177 %{_bindir}/sfascan
178 %{_bindir}/sfadump.py*
179
180 %files sfatables
181 /etc/sfatables/*
182 %{_bindir}/sfatables
183 %{python_sitelib}/sfatables
184
185 %files cm
186 /etc/init.d/sfa-cm
187 %{_bindir}/sfa_component_setup.py*
188 # cron jobs here 
189
190 %files flashpolicy
191 %{_bindir}/sfa_flashpolicy.py*
192 /etc/sfa/sfa_flashpolicy_config.xml
193
194 %files xmlbuilder
195 %{python_sitelib}/xmlbuilder
196
197 %files tests
198 %{_datadir}/sfa/tests
199
200 ### sfa-plc installs the 'sfa' service
201 %post plc
202 chkconfig --add sfa
203
204 %preun plc
205 if [ "$1" = 0 ] ; then
206   /sbin/service sfa stop || :
207   /sbin/chkconfig --del sfa || :
208 fi
209
210 %postun plc
211 [ "$1" -ge "1" ] && service sfa restart
212
213 ### sfa-cm installs the 'sfa-cm' service
214 %post cm
215 chkconfig --add sfa-cm
216
217 %preun cm
218 if [ "$1" = 0 ] ; then
219    /sbin/service sfa-cm stop || :
220    /sbin/chkconfig --del sfa-cm || :
221 fi
222
223 %postun cm
224 [ "$1" -ge "1" ] && service sfa-cm restart || :
225
226 %changelog
227 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
228 - client: added -R --raw sfi cmdline option that displays raw server response.
229 - client: request GENI RSpec by default. 
230 - server: remove database dependencies from sfa.server.sfaapi.
231 - server: increased default credential lifetime to 31 days.
232 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
233 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
234 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
235  
236 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
237 - bugfix: 'geni_api' should be in the top level struct, not the code struct
238 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
239           output returned by the Aggregate Manager.
240 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
241 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
242 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
243           there is extra whitespace in the schemaLocation field.
244 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
245           advertisement rspecs.
246 - bugfix: <login> RSpec element should contain the 'username' attribute.
247 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
248  
249 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
250 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
251   exit when it encountered a user with an invalid public key.
252 - server: imporved logging in sfa-import-plc.py
253  
254 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
255 - bugfix: Fixed appending public keys in CreateSliver
256 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
257 - client: -c --current option allows users to request the current/uncached rspec.
258 - server: Added 'geni_api_versions' field to GetVersion() output.
259 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
260    
261 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
262 - bugfix: sfi was not sending call_id with ListResources to v2 servers
263 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
264 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
265
266 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
267 - client: sfi -a / -p deprecated (use -s instead)
268 - client: sfi cleaned up
269 - client: sfi has backward support for APIv1 aggregates again
270 - server: only APIv2 is supported and should be rather strict
271 - server: settings for turning on/off caching in sm or am
272 - server: plc-dependant code has moved from aggregate to pldriver
273 - server: driver interface extended accordingly
274
275 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
276 - screwed up previous tag
277
278 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
279 - client side revisited with a bootstrap library
280 - client side has a new source layout
281 - various (nasty) bug fixes wrt options and call_id
282
283 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
284 - various fixes in rspecs for sfav1&slice tags
285 - uses 'geni_rspec_version' and not just 'rspec_version'
286 - example flavour for the max testbed
287 - embryo for an sfa client library
288 - topology.py moved into plc
289 - sql: table is named records; record_types are enforced
290 - sql: table creation cleaned up
291
292 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
293 - cleaned up all references to SFA_*_TYPE in config
294 - enable cache at the aggregate by default
295 - registry now uses the driver in a sensible way (see managers/driver.py)
296 - slice manager supports sfav1/pgv2 neighbours
297 - get_key renamed into get_key_from_incoming_ip
298 - new sfa.storage module for record/table and all db-related stuff
299 - db schema in sfa.storage.sfa.sql
300 - init.d and cron.d move one step up
301 - cleaned up rspec/ directory
302 - add deps to pyopenssl and myplc-config
303 - start support for new API (return value)
304 - plc.remoteshell removed, use plshell instead
305 - plshell uses a 'capability' auth method whenever possible
306 - various tweaks in rspec elements
307 - made dependency on sfatables softer
308
309 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
310 - sfa should now be started *before* the initial import
311 - sfa to use its own database (default sfa) - can run without myplc
312 - server calls support optional 'options'
313 - client sends options in argument when needed
314 - fix infinite getattr recursion in elements/element.py
315 - error codes in line with geni
316
317 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
318 - fixed links and attributes in rspecs
319 - minor cleanup in the API methods, and more consistent names in manager methods
320
321 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
322 - ongoing refoactoring towards more genericity
323 - passes tests again although known issues remain with attributes/tags
324
325 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
326 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
327 - improvements in the pgv2 rspecs
328 - driver separated from api
329 - code starts moving around where it belongs
330 - sfascan caches getversion across invokations
331 - vini topology extracted as a config file
332
333 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
334 - first support for protogeni rspecs is working
335 - vini no longer needs a specific manager
336 - refactoring underway towards more flexible/generic architecture
337
338 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
339 - Unicode-friendliness for user names with accents/special chars.
340 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
341 - CreaetSliver no longer fails for users that have a capital letter in their URN.
342 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
343 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
344 - Fix bugs and missing imports     
345  
346
347 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
348 - new method record.get_field for sface
349
350 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
351 - new option -c to sfa-nuke-plc.py
352 - CreateSliver fixed for admin-only slice tags
353
354 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
355 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
356 - Fixed holes in certificate verification logic.
357 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
358 - Added 'boot_state' as an attribute of the node element in SFA rspec.
359 - Non authority certificates are marked as CA:FALSE.
360
361 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
362 - fix typo in sfa-1.0-31 tag.
363 - added CreateGid() Registry interface method.
364
365 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
366 - fix typo in sfa-1.0-30 tag
367
368 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
369 - Declare namespace and schema location in the credential.
370 - Fix bug that prevetend connections from timing out.
371 - Fix slice delegation.
372 - Add statistics to slicemaanger listresources/createsliver rspec.
373 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
374   of days a user can extend their slice expiration.
375 - CA certs are only issued to objects of type authority
376    
377 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
378 - tag 1.0-28 was broken due to typo in the changelog
379 - new class sfa/util/httpsProtocol.py that supports timeouts
380
381 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
382 - Resolved issue that caused sfa hold onto idle db connections.
383 - Fix bug that caused the registry to use the wrong type of credential.
384 - Support authority+sm type.
385 - Fix rspec merging bugs.
386 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
387 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
388  planetlab hosted initscripts using the <planetlab:initscript> tag  
389 - Can now handle extraneous whitespace in the rspec without failing.   
390  
391 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
392 - ProtoGENI v2 RSpec updates.
393 - Convert expiration timestamps with timezone info in credentials to utc.
394 - Fixed redundant logging issue. 
395 - Improved SliceManager and SFI client logging.
396 - Support aggregates that don't support the optional 'call_id' argument. 
397 - Only call get_trusted_certs() at aggreage interfaces that support the call.
398 - CreateSliver() now handles MyPLC slice attributes/tags.
399 - Cache now supports persistence.
400 - Hide whitelisted nodes.
401
402 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
403 - fixed issues with sup authority signing
404 - fixed bugs in remove_slivers and SliverStatus
405
406 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
407 - fix typo that prevented aggregates from operating properly
408
409 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
410 - load trusted certs into ssl context prior to handshake
411 - client's logfile lives in ~/.sfi/sfi.log
412
413 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
414 - includes a change on passphrases that was intended in 1.0-22
415
416 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
417 - Added support for ProtoGENI RSpec v2
418  
419 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
420 - stable sfascan
421 - fix in initscript, *ENABLED tags in config now taken into account
422
423 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
424 - some commits had not been pushed in tag 19
425
426 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
427 - GetVersion should now report full URLs with path
428 - scansfa has nicer output and new syntax (entry URLs as args and not options)
429 - dos2unix'ed flash policy pill
430
431 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
432 - fix packaging again for f8
433
434 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
435 - fix packaging (apparently broken in 1.0-16)
436 - first working version of sfascan
437 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
438 - deprecated the sfa_geni_aggregate config category
439
440 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
441 - Fix build problem
442 - First version of SFA scanner
443
444 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
445 - Add support for Flash clients using flashpolicy
446 - Fix problems with tag handling in RSpec
447
448 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
449 - Modifications to the Eucalyptus Aggregate Manager
450 - Fixes for VINI RSpec
451 - Fix tag handling for PL RSpec
452 - Fix XML Schema ordering for <urn> element
453
454 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
455 - just set x509 version to 2
456
457 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
458 - added urn to the node area in rspecs
459 - conversion to urn now exports fqdn
460 - sfa-import-plc.py now creates a unique registry record for each SFA interface
461
462 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
463 - undo broken attempt for python-2.7
464
465 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
466 - SMs avoid duplicates for when call graph has dags;
467 - just based on network's name, when a duplicate occurs, one is just dropped
468 - does not try to merge/aggregate 2 networks
469 - also reviewed logging with the hope to fix the sfa startup msg:
470 - TypeError: not all arguments converted during string formatting
471
472 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
473 - verify credentials against xsd schema
474 - Fix SM to SM communication
475 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
476 - new setting session_key_path
477
478 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
479 - fix registry credential regeneration and handle expiration
480 - support for setting slice tags (min_role=user)
481 - client can display its own version: sfi.py version --local
482 - GetVersion to provide urn in addition to hrn
483 - more code uses plxrn vs previous helper functions
484 - import replaces '+' in email addresses with '_'
485
486 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
487 - fix GetVersion code_tag and add code_url
488
489 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
490 - extend GetVersion towards minimum federation introspection, and expose local tag
491
492 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
493 - fixed some legacy issues (list vs List)
494 - deprecated sfa.util.namespace for xrn and plxrn
495 - unit tests ship as the sfa-tests rpm
496
497 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
498 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
499 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
500 - hrn-urn translations tweaked
501 - fixed 'service sfa status'
502 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
503 - started to repair sfadump - although not usable yet
504 - trust objects now have dump_string method that dump() actually prints
505 - unit tests under review
506 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
507 - binaries now support -v or -vv to increase loglevel
508 - trashed obsolete sfa.util.client
509
510 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
511 - various bugfixes and cleanup, improved/harmonized logging
512
513 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
514 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
515   to avoid returning a PLCAPI exception that might confuse users.
516 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
517 - fix build errors.  
518
519 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
520 - (Architecture) Credential format changed to match ProtoGENI xml format
521 - (Architecture) All interfaces export a new set of methods that are compatible
522    with the ProtoGeni Aggregate spec. These new methods are considered a 
523    replacement  for the pervious methods exported by the interfaces. All 
524    previous methods are still exported and work as normal, but they are 
525    considered deprecated and will not be supported in future releases.  
526 - (Architecture) SFI has been updated to use the new interface methods.
527 - (Architecture) Changed keyconvet implementation from c to python.
528 - (Architecture) Slice Manager now attempts looks for a delegated credential
529   provided by the client before using its own server credential.
530 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
531   This cache now exists only in memory and is cleared when service is restarted
532   or cache lifetime is exceeded.  
533 - (Performance) SliceManager sends request to Aggregates in parallel instead 
534   of sequentially.
535 - (Bug fix) SFA tickets now support the new rspec format.
536 - (Bug fix) SFI only uses cahced credential if they aren't expired.
537 - (Bug fix) Cerdential delegation modified to work with new credential format.
538 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
539   Aggregate instead of relaying through the Slice Manager.
540 - (Enhancement) Simplified caching. Accociated a global cache instance with
541   the api handler on every new server request, making it easier to access the 
542   cache and use in more general ways.     
543
544 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
545 - SfaServer now uses a pool of threads to handle requests concurrently
546 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
547 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
548 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
549 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
550 - Component manager does not install gid files if slice already has them  
551 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
552 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
553 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
554      
555 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
556 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
557 - - sfa-config-tty now has the same features like plc-config-tty
558 - - Contains code to support both urn and hrn
559 - - Cleaned up request_hash related stuff
560 - - SM, AM and Registry code is organized under respective managers
561 - - Site and Slice synchronization across federated aggregates
562 - - Script to generate sfa_component_config
563
564 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
565 - sfa-config-tty now has the same features like plc-config-tty
566 - Contains code to support both urn and hrn
567 - Cleaned up request_hash related stuff
568 - SM, AM and Registry code is organized under respective managers
569 - Slice synchronization across federated aggregates
570 - some bugs are fixed
571
572 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
573 - checkpoint with fewer mentions of geni
574
575 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
576 - checkpointing
577 - this is believed to pass the tests; among other things:
578 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
579
580 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
581 - This tag includes:
582 - - Sfatables
583 - - Preliminary version of hash based authentication
584 - - Initial code for Component Manager
585 - - Authority structure is moved to /var/lib/sfa/
586 - - some bug-fixes
587
588 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
589 - Create_slice and get_resources methods are connected to sfatables.
590 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
591
592 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
593 - Bug fix on update and remove_peer_object methods
594 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
595
596 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
597 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
598
599 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
600 - compatibility with RefreshPeer
601 - incremental mechanism for importing PLC records into SFA tables
602 - unified single database (still inside the underlying PLC db postgresql server)
603 - includes/improves call traceability and logging features
604 - several bug fixes
605
606 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
607 - added libxslt-python dependency
608
609 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
610 - unified single SFA database in the PLC-DB
611 - upcalls from  PLCAPI to SFA methods
612 - SFA call traceability and logging features
613 - many bug fixes
614 - includes first/rough version of sfatables for policy implementation
615
616 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
617 - snapshot after the GEC5 demo
618 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
619
620 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
621 - snapshot july 15 - has gone through superficial manual testing
622 - hopefully a good basis for gec5 demo
623 - multi-dir sfi client tested as well
624
625 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
626 - rename geniwrapper.spec into sfa.spec
627
628 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
629 - clean up in xmlrpc/soap, --protocol option to chose between both
630 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
631 - hopefully more helpful context in case of crashes when importing
632 - bugfixes for using only /etc/sfa for site-dep files
633 - bugfixes in wsdl generation
634
635 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
636 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
637 - config variables in sfa_config now start with SFA_ and not GENI_
638 - config.py can be loaded even with no config present
639
640 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
641 - first step for cleanup and reorganization
642 - mass-renaming from geni to sfa (some are still needed)
643 - sfa/trust implements the security architecture
644
645 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
646 - snapshot for reproducible builds
647
648 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
649 - snapshot for the convenience of alpha users
650
651 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
652 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
653
654 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
655 - ongoing work - snapshot for 4.3-rc9
656
657 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
658 - various fixes
659
660 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
661 - bugfixes - still a work in progress
662
663 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
664 - initial package
665
666
667 %define module_current_branch 0.2