installing sfa-clean-peer-records.py
[sfa.git] / sfa.spec
1
2 #
3 # $Id$
4 #
5
6 %define url $URL$
7
8 %define name sfa
9 %define version 0.9
10 %define taglevel 2
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
15
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 Source0: %{name}-%{version}.tar.bz2
20 License: GPL
21 Group: Applications/System
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
24 Vendor: PlanetLab
25 Packager: PlanetLab Central <support@planet-lab.org>
26 Distribution: PlanetLab %{plrelease}
27 URL: %(echo %{url} | cut -d ' ' -f 2)
28 Summary: the SFA python libraries
29 Group: Applications/System
30
31 BuildRequires: make
32 Requires: python
33 Requires: pyOpenSSL >= 0.7
34 Requires: m2crypto
35 Requires: libxslt-python
36
37 # python 2.5 has uuid module added, for python 2.4 we still need it 
38 %define uuid_missing %(`python -c "import uuid" 2> /dev/null ; echo $?`)
39 %if uuid_missing
40 Requires: python-uuid
41 %endif
42
43 %package plc
44 Summary: the SFA wrapper arounf MyPLC
45 Group: Applications/System
46 Requires: sfa
47
48 %package client
49 Summary: the SFA experimenter-side CLI
50 Group: Applications/System
51 Requires: sfa
52
53 %package sfatables
54 Summary: sfatables policy tool for SFA
55 Group: Applications/System
56 Requires: sfa
57
58 %description
59 This package provides the python libraries that the SFA implementation requires
60
61 %description plc
62 Geniwrapper implements the SFA interface which serves as a layer
63 between the existing PlanetLab interfaces and the SFA API.
64
65 %description client
66 This package provides the client side of the SFA API, in particular
67 sfi.py, together with other utilities.
68
69 %description sfatables
70 sfatables is a tool for defining access and admission control policies
71 in an SFA network, in much the same way as iptables is for ip
72 networks.
73
74 %prep
75 %setup -q
76
77 %build
78 make
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 make install DESTDIR="$RPM_BUILD_ROOT"
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %{python_sitelib}/*
89 /usr/bin/keyconvert
90 /var/www/html/wsdl/*.wsdl
91
92 %files plc
93 %defattr(-,root,root)
94 %config (noreplace) /etc/sfa/sfa_config
95 %config (noreplace) /etc/sfa/aggregates.xml
96 %config (noreplace) /etc/sfa/registries.xml
97 /etc/init.d/sfa
98 %{_bindir}/sfa-config-tty
99 %{_bindir}/sfa-import-plc.py*
100 %{_bindir}/sfa-clean-peer-records.py*
101 %{_bindir}/sfa-nuke-plc.py*
102 %{_bindir}/sfa-server.py*
103
104 %files client
105 %config (noreplace) /etc/sfa/sfi_config
106 %{_bindir}/sfi.py*
107 %{_bindir}/getNodes.py*
108 %{_bindir}/getRecord.py*
109 %{_bindir}/setRecord.py*
110 %{_bindir}/genidump.py*
111
112 %files sfatables
113 /etc/sfatables/*
114 %{_bindir}/sfatables
115 %{python_sitelib}/sfatables/*
116
117 %pre plc
118 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
119
120 %post plc
121 chkconfig --add sfa
122
123 %changelog
124 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
125 - compatibility with RefreshPeer
126 - incremental mechanism for importing PLC records into SFA tables
127 - unified single database (still inside the underlying PLC db postgresql server)
128 - includes/improves call traceability and logging features
129 - several bug fixes
130
131 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
132 - added libxslt-python dependency
133
134 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
135 - unified single SFA database in the PLC-DB
136 - upcalls from  PLCAPI to SFA methods
137 - SFA call traceability and logging features
138 - many bug fixes
139 - includes first/rough version of sfatables for policy implementation
140
141 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
142 - snapshot after the GEC5 demo
143 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
144
145 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
146 - snapshot july 15 - has gone through superficial manual testing
147 - hopefully a good basis for gec5 demo
148 - multi-dir sfi client tested as well
149
150 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
151 - rename geniwrapper.spec into sfa.spec
152
153 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
154 - clean up in xmlrpc/soap, --protocol option to chose between both
155 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
156 - hopefully more helpful context in case of crashes when importing
157 - bugfixes for using only /etc/sfa for site-dep files
158 - bugfixes in wsdl generation
159
160 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
161 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
162 - config variables in sfa_config now start with SFA_ and not GENI_
163 - config.py can be loaded even with no config present
164
165 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
166 - first step for cleanup and reorganization
167 - mass-renaming from geni to sfa (some are still needed)
168 - sfa/trust implements the security architecture
169
170 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
171 - snapshot for reproducible builds
172
173 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
174 - snapshot for the convenience of alpha users
175
176 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
177 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
178
179 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
180 - ongoing work - snapshot for 4.3-rc9
181
182 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
183 - various fixes
184
185 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
186 - bugfixes - still a work in progress
187
188 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
189 - initial package
190
191
192 %define module_current_branch 0.2