Merge branch 'master' into senslab2
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 17
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package nitos
92 Summary: the SFA layer around NITOS
93 Group: Applications/System
94 Requires: sfa
95
96 %package sfatables
97 Summary: sfatables policy tool for SFA
98 Group: Applications/System
99 Requires: sfa
100
101 %package xmlbuilder
102 Summary: third-party xmlbuilder tool
103 Group: Applications/System
104 Provides: python-xmlbuilder
105
106 %package tests
107 Summary: unit tests suite for SFA
108 Group: Applications/System
109 Requires: sfa
110
111 %description
112 This package provides the python libraries for the PlanetLab implementation of SFA
113
114 %description flashpolicy
115 This package provides support for adobe flash client applications.  
116
117 %description client
118 This package provides the client side of the SFA API, in particular
119 sfi.py, together with other utilities.
120
121 %description plc
122 This package implements the SFA interface which serves as a layer
123 between the existing PlanetLab interfaces and the SFA API.
124
125 %description cm
126 This package implements the SFA interface which serves as a layer
127 between the existing PlanetLab NodeManager interfaces and the SFA API.
128
129 %description federica
130 The SFA driver for FEDERICA.
131
132 %description nitos
133 The SFA driver for NITOS.
134
135 %description sfatables
136 sfatables is a tool for defining access and admission control policies
137 in an SFA network, in much the same way as iptables is for ip
138 networks. This is the command line interface to manage sfatables
139
140 %description xmlbuilder
141 This package contains the xmlbuilder python library, packaged for
142 convenience as it is not supported by fedora
143
144 %description tests
145 Provides some binary unit tests in /usr/share/sfa/tests
146
147 %prep
148 %setup -q
149
150 %build
151 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %files
161 %{python_sitelib}/sfa/__init__.py*
162 %{python_sitelib}/sfa/trust
163 %{python_sitelib}/sfa/storage
164 %{python_sitelib}/sfa/util
165 %{python_sitelib}/sfa/server
166 %{python_sitelib}/sfa/methods
167 %{python_sitelib}/sfa/generic
168 %{python_sitelib}/sfa/managers
169 %{python_sitelib}/sfa/importer
170 %{python_sitelib}/sfa/rspecs
171 %{python_sitelib}/sfa/client
172 /etc/init.d/sfa
173 %{_bindir}/sfa-start.py*
174 %{_bindir}/sfaadmin.py*
175 %{_bindir}/sfaadmin
176 %{_bindir}/keyconvert.py*
177 %{_bindir}/sfa-config-tty
178 %{_bindir}/sfa-config
179 %config /etc/sfa/default_config.xml
180 %config (noreplace) /etc/sfa/aggregates.xml
181 %config (noreplace) /etc/sfa/registries.xml
182 /usr/share/sfa/migrations
183 /usr/share/sfa/examples
184 /var/www/html/wsdl/*.wsdl
185
186 %files flashpolicy
187 %{_bindir}/sfa_flashpolicy.py*
188 /etc/sfa/sfa_flashpolicy_config.xml
189
190 %files client
191 %config (noreplace) /etc/sfa/sfi_config
192 %{_bindir}/sfi*.py*
193 %{_bindir}/sfi
194 %{_bindir}/get*.py*
195 %{_bindir}/setRecord.py*
196 %{_bindir}/sfascan.py*
197 %{_bindir}/sfascan
198 %{_bindir}/sfadump.py*
199
200 %files plc
201 %defattr(-,root,root)
202 %{python_sitelib}/sfa/planetlab
203 %{python_sitelib}/sfa/openstack
204 /etc/sfa/pl.rng
205 /etc/sfa/credential.xsd
206 /etc/sfa/top.xsd
207 /etc/sfa/sig.xsd
208 /etc/sfa/xml.xsd
209 /etc/sfa/protogeni-rspec-common.xsd
210 /etc/sfa/topology
211 %{_bindir}/gen-sfa-cm-config.py*
212
213 %files cm
214 /etc/init.d/sfa-cm
215 %{_bindir}/sfa_component_setup.py*
216 # cron jobs here 
217
218 %files federica
219 %{python_sitelib}/sfa/federica
220
221 %files nitos
222 %{python_sitelib}/sfa/nitos
223
224 %files sfatables
225 /etc/sfatables/*
226 %{_bindir}/sfatables
227 %{python_sitelib}/sfatables
228
229 %files xmlbuilder
230 %{python_sitelib}/xmlbuilder
231
232 %files tests
233 %{_datadir}/sfa/tests
234
235 ### sfa installs the 'sfa' service
236 %post 
237 chkconfig --add sfa
238
239 %preun 
240 if [ "$1" = 0 ] ; then
241   /sbin/service sfa stop || :
242   /sbin/chkconfig --del sfa || :
243 fi
244
245 %postun
246 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
247
248 ### sfa-cm installs the 'sfa-cm' service
249 %post cm
250 chkconfig --add sfa-cm
251
252 %preun cm
253 if [ "$1" = 0 ] ; then
254    /sbin/service sfa-cm stop || :
255    /sbin/chkconfig --del sfa-cm || :
256 fi
257
258 %postun cm
259 [ "$1" -ge "1" ] && service sfa-cm restart || :
260
261 %changelog
262 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
263 - bugfix in forwarding Resolve requests
264 - various fixes in the nitos driver wrt keys and users
265
266 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
267 - various tweaks for the nitos driver
268
269 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
270 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
271 - deeper cleanup of the data-dependencies between SFA and the testbed
272 - in particular, sfi create issues Resolve(details=False)
273 - for that purpose, Resolve exposes reg-* keys for SFA builtins
274 - which in turn allows sfi list to show PIs, slice members and keys
275 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
276 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
277
278 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
279 - configurable data-dir (/var/lib/sfa)
280 - no more dependent on myplc-config
281 - some support for hrns with _ instead of \.
282 - fix for PL importing in presence of gpg keys
283 - DeleteSliver returns True instead of 1 in case of success
284 - Various improvements on the openstack/nova side
285 - new package sfa-nitos
286
287 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
288 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
289 - sfi to remove expired credentials
290
291 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
292 - Update Openstack driver to support Essex release/
293 - Fix authority xrn bug.
294   
295
296 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
297 - review packaging - site-packages/planetlab now come with sfa-plc
298 - new package sfa-federica
299 - clientbin moved one step upwards
300
301 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
302 - fix bug in sfi update()
303
304 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
305 - fix broken sfa.util.xrn class for lowercase
306
307 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
308 - new 'void' generic_flavour for running in registry-only mode
309 - first shot at refactoring importers - probably needs more work
310 - openstack: various enhancements
311 - sfi interface to registry not based on xml files anymore
312 - sfi show sorts result on record key
313 - bugfix in sfa update on users with a pl-backed registry
314
315 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
316 - renamed sfa/plc into sfa/planetlab
317 - plxrn moved in sfa/planetlab as well
318 - bugfix for sfaadmin reg update --pi <>
319
320 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
321 - native data model now has a authority x user (PI) relationship
322 - no call to 'augment_records_with_testbed_info' for GetCredential
323 - which means, registry can now be used without an underlying testbed
324 - reviewed code about relationships b/w objects and related in pl driver
325 - reviewed PL import wrt roles and pis
326 - removed mentions to is_enabled in driver
327 - small changes in update_relation* in driver interface
328 - sfaadmin: can create authorities and attach pi users to them
329 - sfaadmin: categories can be abbreviated
330 - sfi list and sfaadmin list have a new -r/--recursive option
331 - this means that List now supports an (optional) 'options' argument
332 - sfi config can display config vars
333 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
334
335 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
336 - make sync now supports vserver or lxc.
337 - Added slice expiration and login info to SliverStatus response. 
338 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
339   the 'component_name' attribute.
340 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
341   
342 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
343 - Introduced new administrative command line script, sfaadmin.py. Removed various single
344  purpose scripts and migrated their functionality into sfaadmin.py.
345 - Refactored Registry import scripts.
346 - Removed SQLAlchemy dependency from sfi.py.
347 - Fixed bugs in sfi.py
348 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
349
350 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
351 - slice x researcher rel. in database,
352 - plimporter to maintain that, as well as user.email, and more robust
353 - ongoing draft for sfaadmin tool
354 - support for a federica driver
355 - support for a nova/euca driver
356 - no more sfa-clean-peer-records script
357
358 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
359 - registry database has user's keys and mail (known as v0 for migrate)
360 - pl importer properly maintains user's keys and mail
361 - pl driver now to handle 'role' when adding person record (exp.)
362 - first draft of federica driver with config section
363 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
364 - plus, from master as of tag merged-in-sfa-2.1-2:
365 - disk_image revisited
366 - new nova_shell nova_driver & various tweaks for openstack
367
368 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
369 - uses sqlalchemy and related migrate
370 - thorough migration and upgrade scheme
371 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
372 - trashed dbinfo stuff in auth hierarchy
373 - data model still has little more than plain records
374 - checkpoint tag, not yet intended for release
375
376 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
377 - client: added -R --raw sfi cmdline option that displays raw server response.
378 - client: request GENI RSpec by default. 
379 - server: remove database dependencies from sfa.server.sfaapi.
380 - server: increased default credential lifetime to 31 days.
381 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
382 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
383 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
384  
385 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
386 - bugfix: 'geni_api' should be in the top level struct, not the code struct
387 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
388           output returned by the Aggregate Manager.
389 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
390 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
391 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
392           there is extra whitespace in the schemaLocation field.
393 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
394           advertisement rspecs.
395 - bugfix: <login> RSpec element should contain the 'username' attribute.
396 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
397  
398 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
399 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
400   exit when it encountered a user with an invalid public key.
401 - server: imporved logging in sfa-import-plc.py
402  
403 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
404 - bugfix: Fixed appending public keys in CreateSliver
405 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
406 - client: -c --current option allows users to request the current/uncached rspec.
407 - server: Added 'geni_api_versions' field to GetVersion() output.
408 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
409    
410 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
411 - bugfix: sfi was not sending call_id with ListResources to v2 servers
412 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
413 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
414
415 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
416 - client: sfi -a / -p deprecated (use -s instead)
417 - client: sfi cleaned up
418 - client: sfi has backward support for APIv1 aggregates again
419 - server: only APIv2 is supported and should be rather strict
420 - server: settings for turning on/off caching in sm or am
421 - server: plc-dependant code has moved from aggregate to pldriver
422 - server: driver interface extended accordingly
423
424 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
425 - screwed up previous tag
426
427 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
428 - client side revisited with a bootstrap library
429 - client side has a new source layout
430 - various (nasty) bug fixes wrt options and call_id
431
432 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
433 - various fixes in rspecs for sfav1&slice tags
434 - uses 'geni_rspec_version' and not just 'rspec_version'
435 - example flavour for the max testbed
436 - embryo for an sfa client library
437 - topology.py moved into plc
438 - sql: table is named records; record_types are enforced
439 - sql: table creation cleaned up
440
441 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
442 - cleaned up all references to SFA_*_TYPE in config
443 - enable cache at the aggregate by default
444 - registry now uses the driver in a sensible way (see managers/driver.py)
445 - slice manager supports sfav1/pgv2 neighbours
446 - get_key renamed into get_key_from_incoming_ip
447 - new sfa.storage module for record/table and all db-related stuff
448 - db schema in sfa.storage.sfa.sql
449 - init.d and cron.d move one step up
450 - cleaned up rspec/ directory
451 - add deps to pyopenssl and myplc-config
452 - start support for new API (return value)
453 - plc.remoteshell removed, use plshell instead
454 - plshell uses a 'capability' auth method whenever possible
455 - various tweaks in rspec elements
456 - made dependency on sfatables softer
457
458 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
459 - sfa should now be started *before* the initial import
460 - sfa to use its own database (default sfa) - can run without myplc
461 - server calls support optional 'options'
462 - client sends options in argument when needed
463 - fix infinite getattr recursion in elements/element.py
464 - error codes in line with geni
465
466 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
467 - fixed links and attributes in rspecs
468 - minor cleanup in the API methods, and more consistent names in manager methods
469
470 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
471 - ongoing refoactoring towards more genericity
472 - passes tests again although known issues remain with attributes/tags
473
474 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
475 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
476 - improvements in the pgv2 rspecs
477 - driver separated from api
478 - code starts moving around where it belongs
479 - sfascan caches getversion across invokations
480 - vini topology extracted as a config file
481
482 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
483 - first support for protogeni rspecs is working
484 - vini no longer needs a specific manager
485 - refactoring underway towards more flexible/generic architecture
486
487 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
488 - Unicode-friendliness for user names with accents/special chars.
489 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
490 - CreaetSliver no longer fails for users that have a capital letter in their URN.
491 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
492 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
493 - Fix bugs and missing imports     
494  
495
496 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
497 - new method record.get_field for sface
498
499 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
500 - new option -c to sfa-nuke-plc.py
501 - CreateSliver fixed for admin-only slice tags
502
503 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
504 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
505 - Fixed holes in certificate verification logic.
506 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
507 - Added 'boot_state' as an attribute of the node element in SFA rspec.
508 - Non authority certificates are marked as CA:FALSE.
509
510 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
511 - fix typo in sfa-1.0-31 tag.
512 - added CreateGid() Registry interface method.
513
514 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
515 - fix typo in sfa-1.0-30 tag
516
517 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
518 - Declare namespace and schema location in the credential.
519 - Fix bug that prevetend connections from timing out.
520 - Fix slice delegation.
521 - Add statistics to slicemaanger listresources/createsliver rspec.
522 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
523   of days a user can extend their slice expiration.
524 - CA certs are only issued to objects of type authority
525    
526 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
527 - tag 1.0-28 was broken due to typo in the changelog
528 - new class sfa/util/httpsProtocol.py that supports timeouts
529
530 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
531 - Resolved issue that caused sfa hold onto idle db connections.
532 - Fix bug that caused the registry to use the wrong type of credential.
533 - Support authority+sm type.
534 - Fix rspec merging bugs.
535 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
536 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
537  planetlab hosted initscripts using the <planetlab:initscript> tag  
538 - Can now handle extraneous whitespace in the rspec without failing.   
539  
540 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
541 - ProtoGENI v2 RSpec updates.
542 - Convert expiration timestamps with timezone info in credentials to utc.
543 - Fixed redundant logging issue. 
544 - Improved SliceManager and SFI client logging.
545 - Support aggregates that don't support the optional 'call_id' argument. 
546 - Only call get_trusted_certs() at aggreage interfaces that support the call.
547 - CreateSliver() now handles MyPLC slice attributes/tags.
548 - Cache now supports persistence.
549 - Hide whitelisted nodes.
550
551 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
552 - fixed issues with sup authority signing
553 - fixed bugs in remove_slivers and SliverStatus
554
555 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
556 - fix typo that prevented aggregates from operating properly
557
558 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
559 - load trusted certs into ssl context prior to handshake
560 - client's logfile lives in ~/.sfi/sfi.log
561
562 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
563 - includes a change on passphrases that was intended in 1.0-22
564
565 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
566 - Added support for ProtoGENI RSpec v2
567  
568 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
569 - stable sfascan
570 - fix in initscript, *ENABLED tags in config now taken into account
571
572 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
573 - some commits had not been pushed in tag 19
574
575 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
576 - GetVersion should now report full URLs with path
577 - scansfa has nicer output and new syntax (entry URLs as args and not options)
578 - dos2unix'ed flash policy pill
579
580 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
581 - fix packaging again for f8
582
583 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
584 - fix packaging (apparently broken in 1.0-16)
585 - first working version of sfascan
586 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
587 - deprecated the sfa_geni_aggregate config category
588
589 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
590 - Fix build problem
591 - First version of SFA scanner
592
593 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
594 - Add support for Flash clients using flashpolicy
595 - Fix problems with tag handling in RSpec
596
597 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
598 - Modifications to the Eucalyptus Aggregate Manager
599 - Fixes for VINI RSpec
600 - Fix tag handling for PL RSpec
601 - Fix XML Schema ordering for <urn> element
602
603 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
604 - just set x509 version to 2
605
606 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
607 - added urn to the node area in rspecs
608 - conversion to urn now exports fqdn
609 - sfa-import-plc.py now creates a unique registry record for each SFA interface
610
611 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
612 - undo broken attempt for python-2.7
613
614 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
615 - SMs avoid duplicates for when call graph has dags;
616 - just based on network's name, when a duplicate occurs, one is just dropped
617 - does not try to merge/aggregate 2 networks
618 - also reviewed logging with the hope to fix the sfa startup msg:
619 - TypeError: not all arguments converted during string formatting
620
621 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
622 - verify credentials against xsd schema
623 - Fix SM to SM communication
624 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
625 - new setting session_key_path
626
627 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
628 - fix registry credential regeneration and handle expiration
629 - support for setting slice tags (min_role=user)
630 - client can display its own version: sfi.py version --local
631 - GetVersion to provide urn in addition to hrn
632 - more code uses plxrn vs previous helper functions
633 - import replaces '+' in email addresses with '_'
634
635 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
636 - fix GetVersion code_tag and add code_url
637
638 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
639 - extend GetVersion towards minimum federation introspection, and expose local tag
640
641 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
642 - fixed some legacy issues (list vs List)
643 - deprecated sfa.util.namespace for xrn and plxrn
644 - unit tests ship as the sfa-tests rpm
645
646 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
647 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
648 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
649 - hrn-urn translations tweaked
650 - fixed 'service sfa status'
651 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
652 - started to repair sfadump - although not usable yet
653 - trust objects now have dump_string method that dump() actually prints
654 - unit tests under review
655 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
656 - binaries now support -v or -vv to increase loglevel
657 - trashed obsolete sfa.util.client
658
659 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
660 - various bugfixes and cleanup, improved/harmonized logging
661
662 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
663 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
664   to avoid returning a PLCAPI exception that might confuse users.
665 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
666 - fix build errors.  
667
668 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
669 - (Architecture) Credential format changed to match ProtoGENI xml format
670 - (Architecture) All interfaces export a new set of methods that are compatible
671    with the ProtoGeni Aggregate spec. These new methods are considered a 
672    replacement  for the pervious methods exported by the interfaces. All 
673    previous methods are still exported and work as normal, but they are 
674    considered deprecated and will not be supported in future releases.  
675 - (Architecture) SFI has been updated to use the new interface methods.
676 - (Architecture) Changed keyconvet implementation from c to python.
677 - (Architecture) Slice Manager now attempts looks for a delegated credential
678   provided by the client before using its own server credential.
679 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
680   This cache now exists only in memory and is cleared when service is restarted
681   or cache lifetime is exceeded.  
682 - (Performance) SliceManager sends request to Aggregates in parallel instead 
683   of sequentially.
684 - (Bug fix) SFA tickets now support the new rspec format.
685 - (Bug fix) SFI only uses cahced credential if they aren't expired.
686 - (Bug fix) Cerdential delegation modified to work with new credential format.
687 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
688   Aggregate instead of relaying through the Slice Manager.
689 - (Enhancement) Simplified caching. Accociated a global cache instance with
690   the api handler on every new server request, making it easier to access the 
691   cache and use in more general ways.     
692
693 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
694 - SfaServer now uses a pool of threads to handle requests concurrently
695 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
696 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
697 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
698 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
699 - Component manager does not install gid files if slice already has them  
700 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
701 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
702 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
703      
704 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
705 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
706 - - sfa-config-tty now has the same features like plc-config-tty
707 - - Contains code to support both urn and hrn
708 - - Cleaned up request_hash related stuff
709 - - SM, AM and Registry code is organized under respective managers
710 - - Site and Slice synchronization across federated aggregates
711 - - Script to generate sfa_component_config
712
713 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
714 - sfa-config-tty now has the same features like plc-config-tty
715 - Contains code to support both urn and hrn
716 - Cleaned up request_hash related stuff
717 - SM, AM and Registry code is organized under respective managers
718 - Slice synchronization across federated aggregates
719 - some bugs are fixed
720
721 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
722 - checkpoint with fewer mentions of geni
723
724 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
725 - checkpointing
726 - this is believed to pass the tests; among other things:
727 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
728
729 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
730 - This tag includes:
731 - - Sfatables
732 - - Preliminary version of hash based authentication
733 - - Initial code for Component Manager
734 - - Authority structure is moved to /var/lib/sfa/
735 - - some bug-fixes
736
737 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
738 - Create_slice and get_resources methods are connected to sfatables.
739 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
740
741 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
742 - Bug fix on update and remove_peer_object methods
743 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
744
745 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
746 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
747
748 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
749 - compatibility with RefreshPeer
750 - incremental mechanism for importing PLC records into SFA tables
751 - unified single database (still inside the underlying PLC db postgresql server)
752 - includes/improves call traceability and logging features
753 - several bug fixes
754
755 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
756 - added libxslt-python dependency
757
758 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
759 - unified single SFA database in the PLC-DB
760 - upcalls from  PLCAPI to SFA methods
761 - SFA call traceability and logging features
762 - many bug fixes
763 - includes first/rough version of sfatables for policy implementation
764
765 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
766 - snapshot after the GEC5 demo
767 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
768
769 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
770 - snapshot july 15 - has gone through superficial manual testing
771 - hopefully a good basis for gec5 demo
772 - multi-dir sfi client tested as well
773
774 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
775 - rename geniwrapper.spec into sfa.spec
776
777 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
778 - clean up in xmlrpc/soap, --protocol option to chose between both
779 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
780 - hopefully more helpful context in case of crashes when importing
781 - bugfixes for using only /etc/sfa for site-dep files
782 - bugfixes in wsdl generation
783
784 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
785 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
786 - config variables in sfa_config now start with SFA_ and not GENI_
787 - config.py can be loaded even with no config present
788
789 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
790 - first step for cleanup and reorganization
791 - mass-renaming from geni to sfa (some are still needed)
792 - sfa/trust implements the security architecture
793
794 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
795 - snapshot for reproducible builds
796
797 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
798 - snapshot for the convenience of alpha users
799
800 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
801 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
802
803 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
804 - ongoing work - snapshot for 4.3-rc9
805
806 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
807 - various fixes
808
809 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
810 - bugfixes - still a work in progress
811
812 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
813 - initial package
814
815
816 %define module_current_branch 0.2