Setting tag sfa-1.0-14
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 14
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %Package tests
74 Summary: unit tests suite for SFA
75 Group: Applications/System
76 Requires: sfa
77
78 %description
79 This package provides the python libraries for the PlanetLab implementation of SFA
80
81 %description cm
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
84  
85 %description plc
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
88
89 %description client
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
92
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
97
98 %description tests
99 Provides some binary unit tests in /usr/share/sfa/tests
100
101 %prep
102 %setup -q
103
104 %build
105 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 # sfa and sfatables depend each other.
116 %{_bindir}/sfa-server.py*
117 /etc/sfatables/*
118 %{python_sitelib}/*
119 %{_bindir}/keyconvert.py*
120 /var/www/html/wsdl/*.wsdl
121
122 %files cm
123 /etc/init.d/sfa-cm
124 %{_bindir}/sfa_component_setup.py*
125 # cron jobs here 
126
127 %files plc
128 %defattr(-,root,root)
129 %config /etc/sfa/default_config.xml
130 %config (noreplace) /etc/sfa/aggregates.xml
131 %config (noreplace) /etc/sfa/registries.xml
132 /etc/init.d/sfa
133 /etc/sfa/pl.rng
134 /etc/sfa/credential.xsd
135 /etc/sfa/top.xsd
136 /etc/sfa/sig.xsd
137 /etc/sfa/xml.xsd
138 /etc/sfa/protogeni-rspec-common.xsd
139 %{_bindir}/sfa-config-tty
140 %{_bindir}/sfa-import-plc.py*
141 %{_bindir}/sfa-clean-peer-records.py*
142 %{_bindir}/sfa-nuke-plc.py*
143 %{_bindir}/gen-sfa-cm-config.py*
144 %{_bindir}/sfa-ca.py*
145
146 %files client
147 %config (noreplace) /etc/sfa/sfi_config
148 %{_bindir}/sfi*
149 %{_bindir}/getNodes.py*
150 %{_bindir}/getRecord.py*
151 %{_bindir}/setRecord.py*
152 %{_bindir}/sfadump.py*
153
154 %files sfatables
155 %{_bindir}/sfatables
156
157 %files tests
158 %{_datadir}/sfa/tests
159
160 ### sfa-plc installs the 'sfa' service
161 %post plc
162 chkconfig --add sfa
163
164 %preun plc
165 if [ "$1" = 0 ] ; then
166   /sbin/service sfa stop || :
167   /sbin/chkconfig --del sfa || :
168 fi
169
170 %postun plc
171 [ "$1" -ge "1" ] && service sfa restart
172
173 ### sfa-cm installs the 'sfa-cm' service
174 %post cm
175 chkconfig --add sfa-cm
176
177 %preun cm
178 if [ "$1" = 0 ] ; then
179    /sbin/service sfa-cm stop || :
180    /sbin/chkconfig --del sfa-cm || :
181 fi
182
183 %postun cm
184 [ "$1" -ge "1" ] && service sfa-cm restart
185
186
187 %changelog
188 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
189 - Modifications to the Eucalyptus Aggregate Manager
190 - Fixes for VINI RSpec
191 - Fix tag handling for PL RSpec
192 - Fix XML Schema ordering for <urn> element
193
194 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
195 - just set x509 version to 2
196
197 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
198 - added urn to the node area in rspecs
199 - conversion to urn now exports fqdn
200 - sfa-import-plc.py now creates a unique registry record for each SFA interface
201
202 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
203 - undo broken attempt for python-2.7
204
205 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
206 - SMs avoid duplicates for when call graph has dags;
207 - just based on network's name, when a duplicate occurs, one is just dropped
208 - does not try to merge/aggregate 2 networks
209 - also reviewed logging with the hope to fix the sfa startup msg:
210 - TypeError: not all arguments converted during string formatting
211
212 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
213 - verify credentials against xsd schema
214 - Fix SM to SM communication
215 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
216 - new setting session_key_path
217
218 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
219 - fix registry credential regeneration and handle expiration
220 - support for setting slice tags (min_role=user)
221 - client can display its own version: sfi.py version --local
222 - GetVersion to provide urn in addition to hrn
223 - more code uses plxrn vs previous helper functions
224 - import replaces '+' in email addresses with '_'
225
226 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
227 - fix GetVersion code_tag and add code_url
228
229 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
230 - extend GetVersion towards minimum federation introspection, and expose local tag
231
232 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
233 - fixed some legacy issues (list vs List)
234 - deprecated sfa.util.namespace for xrn and plxrn
235 - unit tests ship as the sfa-tests rpm
236
237 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
238 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
239 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
240 - hrn-urn translations tweaked
241 - fixed 'service sfa status'
242 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
243 - started to repair sfadump - although not usable yet
244 - trust objects now have dump_string method that dump() actually prints
245 - unit tests under review
246 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
247 - binaries now support -v or -vv to increase loglevel
248 - trashed obsolete sfa.util.client
249
250 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
251 - various bugfixes and cleanup, improved/harmonized logging
252
253 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
254 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
255   to avoid returning a PLCAPI exception that might confuse users.
256 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
257 - fix build errors.  
258
259 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
260 - (Architecture) Credential format changed to match ProtoGENI xml format
261 - (Architecture) All interfaces export a new set of methods that are compatible
262    with the ProtoGeni Aggregate spec. These new methods are considered a 
263    replacement  for the pervious methods exported by the interfaces. All 
264    previous methods are still exported and work as normal, but they are 
265    considered deprecated and will not be supported in future releases.  
266 - (Architecture) SFI has been updated to use the new interface methods.
267 - (Architecture) Changed keyconvet implementation from c to python.
268 - (Architecture) Slice Manager now attempts looks for a delegated credential
269   provided by the client before using its own server credential.
270 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
271   This cache now exists only in memory and is cleared when service is restarted
272   or cache lifetime is exceeded.  
273 - (Performance) SliceManager sends request to Aggregates in parallel instead 
274   of sequentially.
275 - (Bug fix) SFA tickets now support the new rspec format.
276 - (Bug fix) SFI only uses cahced credential if they aren't expired.
277 - (Bug fix) Cerdential delegation modified to work with new credential format.
278 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
279   Aggregate instead of relaying through the Slice Manager.
280 - (Enhancement) Simplified caching. Accociated a global cache instance with
281   the api handler on every new server request, making it easier to access the 
282   cache and use in more general ways.     
283
284 %changelog
285 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
286 - Modifications to the Eucalyptus Aggregate Manager
287 - Fixes for VINI RSpec
288 - Fix tag handling for PL RSpec
289 - Fix XML Schema ordering for <urn> element
290
291 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
292 - just set x509 version to 2
293
294 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
295 - added urn to the node area in rspecs
296 - conversion to urn now exports fqdn
297 - sfa-import-plc.py now creates a unique registry record for each SFA interface
298
299 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
300 - undo broken attempt for python-2.7
301
302 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
303 - SMs avoid duplicates for when call graph has dags;
304 - just based on network's name, when a duplicate occurs, one is just dropped
305 - does not try to merge/aggregate 2 networks
306 - also reviewed logging with the hope to fix the sfa startup msg:
307 - TypeError: not all arguments converted during string formatting
308
309 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
310 - verify credentials against xsd schema
311 - Fix SM to SM communication
312 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
313 - new setting session_key_path
314
315 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
316 - fix registry credential regeneration and handle expiration
317 - support for setting slice tags (min_role=user)
318 - client can display its own version: sfi.py version --local
319 - GetVersion to provide urn in addition to hrn
320 - more code uses plxrn vs previous helper functions
321 - import replaces '+' in email addresses with '_'
322
323 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
324 - fix GetVersion code_tag and add code_url
325
326 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
327 - extend GetVersion towards minimum federation introspection, and expose local tag
328
329 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
330 - fixed some legacy issues (list vs List)
331 - deprecated sfa.util.namespace for xrn and plxrn
332 - unit tests ship as the sfa-tests rpm
333
334 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
335 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
336 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
337 - hrn-urn translations tweaked
338 - fixed 'service sfa status'
339 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
340 - started to repair sfadump - although not usable yet
341 - trust objects now have dump_string method that dump() actually prints
342 - unit tests under review
343 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
344 - binaries now support -v or -vv to increase loglevel
345 - trashed obsolete sfa.util.client
346
347 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
348 - various bugfixes and cleanup, improved/harmonized logging
349
350 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
351 - SfaServer now uses a pool of threads to handle requests concurrently
352 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
353 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
354 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
355 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
356 - Component manager does not install gid files if slice already has them  
357 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
358 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
359 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
360      
361 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
362 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
363 - - sfa-config-tty now has the same features like plc-config-tty
364 - - Contains code to support both urn and hrn
365 - - Cleaned up request_hash related stuff
366 - - SM, AM and Registry code is organized under respective managers
367 - - Site and Slice synchronization across federated aggregates
368 - - Script to generate sfa_component_config
369
370 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
371 - sfa-config-tty now has the same features like plc-config-tty
372 - Contains code to support both urn and hrn
373 - Cleaned up request_hash related stuff
374 - SM, AM and Registry code is organized under respective managers
375 - Slice synchronization across federated aggregates
376 - some bugs are fixed
377
378 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
379 - checkpoint with fewer mentions of geni
380
381 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
382 - checkpointing
383 - this is believed to pass the tests; among other things:
384 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
385
386 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
387 - This tag includes:
388 - - Sfatables
389 - - Preliminary version of hash based authentication
390 - - Initial code for Component Manager
391 - - Authority structure is moved to /var/lib/sfa/
392 - - some bug-fixes
393
394 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
395 - Create_slice and get_resources methods are connected to sfatables.
396 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
397
398 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
399 - Bug fix on update and remove_peer_object methods
400 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
401
402 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
403 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
404
405 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
406 - compatibility with RefreshPeer
407 - incremental mechanism for importing PLC records into SFA tables
408 - unified single database (still inside the underlying PLC db postgresql server)
409 - includes/improves call traceability and logging features
410 - several bug fixes
411
412 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
413 - added libxslt-python dependency
414
415 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
416 - unified single SFA database in the PLC-DB
417 - upcalls from  PLCAPI to SFA methods
418 - SFA call traceability and logging features
419 - many bug fixes
420 - includes first/rough version of sfatables for policy implementation
421
422 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
423 - snapshot after the GEC5 demo
424 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
425
426 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
427 - snapshot july 15 - has gone through superficial manual testing
428 - hopefully a good basis for gec5 demo
429 - multi-dir sfi client tested as well
430
431 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
432 - rename geniwrapper.spec into sfa.spec
433
434 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
435 - clean up in xmlrpc/soap, --protocol option to chose between both
436 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
437 - hopefully more helpful context in case of crashes when importing
438 - bugfixes for using only /etc/sfa for site-dep files
439 - bugfixes in wsdl generation
440
441 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
442 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
443 - config variables in sfa_config now start with SFA_ and not GENI_
444 - config.py can be loaded even with no config present
445
446 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
447 - first step for cleanup and reorganization
448 - mass-renaming from geni to sfa (some are still needed)
449 - sfa/trust implements the security architecture
450
451 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
452 - snapshot for reproducible builds
453
454 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
455 - snapshot for the convenience of alpha users
456
457 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
458 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
459
460 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
461 - ongoing work - snapshot for 4.3-rc9
462
463 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
464 - various fixes
465
466 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
467 - bugfixes - still a work in progress
468
469 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
470 - initial package
471
472
473 %define module_current_branch 0.2