setting sfa-1.0-32 tag
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 32
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart || :
197
198 %changelog
199 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
200 - fix typo in sfa-1.0-31 tag.
201 - added CreateGid() Registry interface method.
202
203 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
204 - fix typo in sfa-1.0-30 tag
205
206 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
207 - Declare namespace and schema location in the credential.
208 - Fix bug that prevetend connections from timing out.
209 - Fix slice delegation.
210 - Add statistics to slicemaanger listresources/createsliver rspec.
211 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
212   of days a user can extend their slice expiration.
213 - CA certs are only issued to objects of type authority
214    
215 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
216 - tag 1.0-28 was broken due to typo in the changelog
217 - new class sfa/util/httpsProtocol.py that supports timeouts
218
219 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
220 - Resolved issue that caused sfa hold onto idle db connections.
221 - Fix bug that caused the registry to use the wrong type of credential.
222 - Support authority+sm type.
223 - Fix rspec merging bugs.
224 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
225 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
226  planetlab hosted initscripts using the <planetlab:initscript> tag  
227 - Can now handle extraneous whitespace in the rspec without failing.   
228  
229 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
230 - ProtoGENI v2 RSpec updates.
231 - Convert expiration timestamps with timezone info in credentials to utc.
232 - Fixed redundant logging issue. 
233 - Improved SliceManager and SFI client logging.
234 - Support aggregates that don't support the optional 'call_id' argument. 
235 - Only call get_trusted_certs() at aggreage interfaces that support the call.
236 - CreateSliver() now handles MyPLC slice attributes/tags.
237 - Cache now supports persistence.
238 - Hide whitelisted nodes.
239
240 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
241 - fixed issues with sup authority signing
242 - fixed bugs in remove_slivers and SliverStatus
243
244 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
245 - fix typo that prevented aggregates from operating properly
246
247 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
248 - load trusted certs into ssl context prior to handshake
249 - client's logfile lives in ~/.sfi/sfi.log
250
251 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
252 - includes a change on passphrases that was intended in 1.0-22
253
254 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
255 - Added support for ProtoGENI RSpec v2
256  
257 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
258 - stable sfascan
259 - fix in initscript, *ENABLED tags in config now taken into account
260
261 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
262 - some commits had not been pushed in tag 19
263
264 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
265 - GetVersion should now report full URLs with path
266 - scansfa has nicer output and new syntax (entry URLs as args and not options)
267 - dos2unix'ed flash policy pill
268
269 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
270 - fix packaging again for f8
271
272 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
273 - fix packaging (apparently broken in 1.0-16)
274 - first working version of sfascan
275 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
276 - deprecated the sfa_geni_aggregate config category
277
278 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
279 - Fix build problem
280 - First version of SFA scanner
281
282 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
283 - Add support for Flash clients using flashpolicy
284 - Fix problems with tag handling in RSpec
285
286 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
287 - Modifications to the Eucalyptus Aggregate Manager
288 - Fixes for VINI RSpec
289 - Fix tag handling for PL RSpec
290 - Fix XML Schema ordering for <urn> element
291
292 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
293 - just set x509 version to 2
294
295 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
296 - added urn to the node area in rspecs
297 - conversion to urn now exports fqdn
298 - sfa-import-plc.py now creates a unique registry record for each SFA interface
299
300 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
301 - undo broken attempt for python-2.7
302
303 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
304 - SMs avoid duplicates for when call graph has dags;
305 - just based on network's name, when a duplicate occurs, one is just dropped
306 - does not try to merge/aggregate 2 networks
307 - also reviewed logging with the hope to fix the sfa startup msg:
308 - TypeError: not all arguments converted during string formatting
309
310 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
311 - verify credentials against xsd schema
312 - Fix SM to SM communication
313 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
314 - new setting session_key_path
315
316 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
317 - fix registry credential regeneration and handle expiration
318 - support for setting slice tags (min_role=user)
319 - client can display its own version: sfi.py version --local
320 - GetVersion to provide urn in addition to hrn
321 - more code uses plxrn vs previous helper functions
322 - import replaces '+' in email addresses with '_'
323
324 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
325 - fix GetVersion code_tag and add code_url
326
327 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
328 - extend GetVersion towards minimum federation introspection, and expose local tag
329
330 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
331 - fixed some legacy issues (list vs List)
332 - deprecated sfa.util.namespace for xrn and plxrn
333 - unit tests ship as the sfa-tests rpm
334
335 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
336 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
337 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
338 - hrn-urn translations tweaked
339 - fixed 'service sfa status'
340 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
341 - started to repair sfadump - although not usable yet
342 - trust objects now have dump_string method that dump() actually prints
343 - unit tests under review
344 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
345 - binaries now support -v or -vv to increase loglevel
346 - trashed obsolete sfa.util.client
347
348 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
349 - various bugfixes and cleanup, improved/harmonized logging
350
351 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
352 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
353   to avoid returning a PLCAPI exception that might confuse users.
354 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
355 - fix build errors.  
356
357 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
358 - (Architecture) Credential format changed to match ProtoGENI xml format
359 - (Architecture) All interfaces export a new set of methods that are compatible
360    with the ProtoGeni Aggregate spec. These new methods are considered a 
361    replacement  for the pervious methods exported by the interfaces. All 
362    previous methods are still exported and work as normal, but they are 
363    considered deprecated and will not be supported in future releases.  
364 - (Architecture) SFI has been updated to use the new interface methods.
365 - (Architecture) Changed keyconvet implementation from c to python.
366 - (Architecture) Slice Manager now attempts looks for a delegated credential
367   provided by the client before using its own server credential.
368 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
369   This cache now exists only in memory and is cleared when service is restarted
370   or cache lifetime is exceeded.  
371 - (Performance) SliceManager sends request to Aggregates in parallel instead 
372   of sequentially.
373 - (Bug fix) SFA tickets now support the new rspec format.
374 - (Bug fix) SFI only uses cahced credential if they aren't expired.
375 - (Bug fix) Cerdential delegation modified to work with new credential format.
376 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
377   Aggregate instead of relaying through the Slice Manager.
378 - (Enhancement) Simplified caching. Accociated a global cache instance with
379   the api handler on every new server request, making it easier to access the 
380   cache and use in more general ways.     
381
382 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
383 - SfaServer now uses a pool of threads to handle requests concurrently
384 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
385 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
386 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
387 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
388 - Component manager does not install gid files if slice already has them  
389 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
390 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
391 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
392      
393 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
394 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
395 - - sfa-config-tty now has the same features like plc-config-tty
396 - - Contains code to support both urn and hrn
397 - - Cleaned up request_hash related stuff
398 - - SM, AM and Registry code is organized under respective managers
399 - - Site and Slice synchronization across federated aggregates
400 - - Script to generate sfa_component_config
401
402 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
403 - sfa-config-tty now has the same features like plc-config-tty
404 - Contains code to support both urn and hrn
405 - Cleaned up request_hash related stuff
406 - SM, AM and Registry code is organized under respective managers
407 - Slice synchronization across federated aggregates
408 - some bugs are fixed
409
410 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
411 - checkpoint with fewer mentions of geni
412
413 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
414 - checkpointing
415 - this is believed to pass the tests; among other things:
416 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
417
418 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
419 - This tag includes:
420 - - Sfatables
421 - - Preliminary version of hash based authentication
422 - - Initial code for Component Manager
423 - - Authority structure is moved to /var/lib/sfa/
424 - - some bug-fixes
425
426 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
427 - Create_slice and get_resources methods are connected to sfatables.
428 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
429
430 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
431 - Bug fix on update and remove_peer_object methods
432 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
433
434 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
435 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
436
437 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
438 - compatibility with RefreshPeer
439 - incremental mechanism for importing PLC records into SFA tables
440 - unified single database (still inside the underlying PLC db postgresql server)
441 - includes/improves call traceability and logging features
442 - several bug fixes
443
444 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
445 - added libxslt-python dependency
446
447 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
448 - unified single SFA database in the PLC-DB
449 - upcalls from  PLCAPI to SFA methods
450 - SFA call traceability and logging features
451 - many bug fixes
452 - includes first/rough version of sfatables for policy implementation
453
454 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
455 - snapshot after the GEC5 demo
456 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
457
458 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
459 - snapshot july 15 - has gone through superficial manual testing
460 - hopefully a good basis for gec5 demo
461 - multi-dir sfi client tested as well
462
463 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
464 - rename geniwrapper.spec into sfa.spec
465
466 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
467 - clean up in xmlrpc/soap, --protocol option to chose between both
468 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
469 - hopefully more helpful context in case of crashes when importing
470 - bugfixes for using only /etc/sfa for site-dep files
471 - bugfixes in wsdl generation
472
473 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
474 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
475 - config variables in sfa_config now start with SFA_ and not GENI_
476 - config.py can be loaded even with no config present
477
478 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
479 - first step for cleanup and reorganization
480 - mass-renaming from geni to sfa (some are still needed)
481 - sfa/trust implements the security architecture
482
483 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
484 - snapshot for reproducible builds
485
486 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
487 - snapshot for the convenience of alpha users
488
489 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
490 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
491
492 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
493 - ongoing work - snapshot for 4.3-rc9
494
495 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
496 - various fixes
497
498 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
499 - bugfixes - still a work in progress
500
501 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
502 - initial package
503
504
505 %define module_current_branch 0.2