added the sfa-cm package
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 10
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python
32 Requires: m2crypto
33 Requires: libxslt-python
34 Requires: python-ZSI
35
36 # python 2.5 has uuid module added, for python 2.4 we still need it
37 %define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
38 %if has_uuid
39 %else
40 Requires: python-uuid
41 %endif
42
43 %package cm
44 Summary: the SFA wrapper around MyPLC's NodeManager
45 Group: Applications/System
46 Requires: sfa
47 Requires: pyOpenSSL >= 0.6
48
49 %package plc
50 Summary: the SFA wrapper arounf MyPLC
51 Group: Applications/System
52 Requires: sfa
53 Requires: python-psycopg2
54 Requires: myplc-config
55 Requires: pyOpenSSL >= 0.7
56
57 %package client
58 Summary: the SFA experimenter-side CLI
59 Group: Applications/System
60 Requires: sfa
61 Requires: pyOpenSSL >= 0.7
62
63 %package sfatables
64 Summary: sfatables policy tool for SFA
65 Group: Applications/System
66 Requires: sfa
67
68 %description
69 This package provides the python libraries that the SFA implementation requires
70
71 %description cm
72 This package implements the SFA interface which serves as a layer
73 between the existing PlanetLab NodeManager interfaces and the SFA API.
74  
75 %description plc
76 This package implements the SFA interface which serves as a layer
77 between the existing PlanetLab interfaces and the SFA API.
78
79 %description client
80 This package provides the client side of the SFA API, in particular
81 sfi.py, together with other utilities.
82
83 %description sfatables
84 sfatables is a tool for defining access and admission control policies
85 in an SFA network, in much the same way as iptables is for ip
86 networks. This is the command line interface to manage sfatables
87
88 %prep
89 %setup -q
90
91 %build
92 make
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 make install DESTDIR="$RPM_BUILD_ROOT"
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 # sfa and sfatables depend each other.
103 /etc/sfatables/*
104 %{python_sitelib}/*
105 /usr/bin/keyconvert
106 /var/www/html/wsdl/*.wsdl
107
108 %files cm
109 /etc/init.d/sfa_cm
110 # cron jobs here 
111
112 %files plc
113 %defattr(-,root,root)
114 %config /etc/sfa/default_config.xml
115 %config (noreplace) /etc/sfa/aggregates.xml
116 %config (noreplace) /etc/sfa/registries.xml
117 /etc/init.d/sfa
118 %{_bindir}/sfa-config-tty
119 %{_bindir}/sfa-import-plc.py*
120 %{_bindir}/sfa-clean-peer-records.py*
121 %{_bindir}/sfa-nuke-plc.py*
122 %{_bindir}/sfa-server.py*
123 %{_bindir}/gen-sfa-cm-config.py*
124
125 %files client
126 %config (noreplace) /etc/sfa/sfi_config
127 %{_bindir}/sfi.py*
128 %{_bindir}/getNodes.py*
129 %{_bindir}/getRecord.py*
130 %{_bindir}/setRecord.py*
131 %{_bindir}/sfadump.py*
132
133 %files sfatables
134 %{_bindir}/sfatables
135
136 %pre plc
137 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
138
139 %pre cm
140 [ -f %{_sysconfdir}/init.d/sfacm ] && service sfacm stop ||:
141
142 %post plc
143 chkconfig --add sfa
144
145 %post cm
146 chkconfig --add sfacm
147 %changelog
148 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
149 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
150 - - sfa-config-tty now has the same features like plc-config-tty
151 - - Contains code to support both urn and hrn
152 - - Cleaned up request_hash related stuff
153 - - SM, AM and Registry code is organized under respective managers
154 - - Site and Slice synchronization across federated aggregates
155 - - Script to generate sfa_component_config
156
157 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
158 - sfa-config-tty now has the same features like plc-config-tty
159 - Contains code to support both urn and hrn
160 - Cleaned up request_hash related stuff
161 - SM, AM and Registry code is organized under respective managers
162 - Slice synchronization across federated aggregates
163 - some bugs are fixed
164
165 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
166 - checkpoint with fewer mentions of geni
167
168 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
169 - checkpointing
170 - this is believed to pass the tests; among other things:
171 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
172
173 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
174 - This tag includes:
175 - - Sfatables
176 - - Preliminary version of hash based authentication
177 - - Initial code for Component Manager
178 - - Authority structure is moved to /var/lib/sfa/
179 - - some bug-fixes
180
181 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
182 - Create_slice and get_resources methods are connected to sfatables.
183 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
184
185 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
186 - Bug fix on update and remove_peer_object methods
187 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
188
189 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
190 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
191
192 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
193 - compatibility with RefreshPeer
194 - incremental mechanism for importing PLC records into SFA tables
195 - unified single database (still inside the underlying PLC db postgresql server)
196 - includes/improves call traceability and logging features
197 - several bug fixes
198
199 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
200 - added libxslt-python dependency
201
202 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
203 - unified single SFA database in the PLC-DB
204 - upcalls from  PLCAPI to SFA methods
205 - SFA call traceability and logging features
206 - many bug fixes
207 - includes first/rough version of sfatables for policy implementation
208
209 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
210 - snapshot after the GEC5 demo
211 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
212
213 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
214 - snapshot july 15 - has gone through superficial manual testing
215 - hopefully a good basis for gec5 demo
216 - multi-dir sfi client tested as well
217
218 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
219 - rename geniwrapper.spec into sfa.spec
220
221 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
222 - clean up in xmlrpc/soap, --protocol option to chose between both
223 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
224 - hopefully more helpful context in case of crashes when importing
225 - bugfixes for using only /etc/sfa for site-dep files
226 - bugfixes in wsdl generation
227
228 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
229 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
230 - config variables in sfa_config now start with SFA_ and not GENI_
231 - config.py can be loaded even with no config present
232
233 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
234 - first step for cleanup and reorganization
235 - mass-renaming from geni to sfa (some are still needed)
236 - sfa/trust implements the security architecture
237
238 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
239 - snapshot for reproducible builds
240
241 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
242 - snapshot for the convenience of alpha users
243
244 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
245 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
246
247 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
248 - ongoing work - snapshot for 4.3-rc9
249
250 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
251 - various fixes
252
253 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
254 - bugfixes - still a work in progress
255
256 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
257 - initial package
258
259
260 %define module_current_branch 0.2