Setting tag sfa-1.0-24
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 24
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart
197
198
199 %changelog
200 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
201 - load trusted certs into ssl context prior to handshake
202 - client's logfile lives in ~/.sfi/sfi.log
203
204 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
205 - includes a change on passphrases that was intended in 1.0-22
206
207 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
208 - Added support for ProtoGENI RSpec v2
209  
210 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
211 - stable sfascan
212 - fix in initscript, *ENABLED tags in config now taken into account
213
214 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
215 - some commits had not been pushed in tag 19
216
217 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
218 - GetVersion should now report full URLs with path
219 - scansfa has nicer output and new syntax (entry URLs as args and not options)
220 - dos2unix'ed flash policy pill
221
222 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
223 - fix packaging again for f8
224
225 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
226 - fix packaging (apparently broken in 1.0-16)
227 - first working version of sfascan
228 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
229 - deprecated the sfa_geni_aggregate config category
230
231 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
232 - Fix build problem
233 - First version of SFA scanner
234
235 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
236 - Add support for Flash clients using flashpolicy
237 - Fix problems with tag handling in RSpec
238
239 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
240 - Modifications to the Eucalyptus Aggregate Manager
241 - Fixes for VINI RSpec
242 - Fix tag handling for PL RSpec
243 - Fix XML Schema ordering for <urn> element
244
245 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
246 - just set x509 version to 2
247
248 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
249 - added urn to the node area in rspecs
250 - conversion to urn now exports fqdn
251 - sfa-import-plc.py now creates a unique registry record for each SFA interface
252
253 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
254 - undo broken attempt for python-2.7
255
256 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
257 - SMs avoid duplicates for when call graph has dags;
258 - just based on network's name, when a duplicate occurs, one is just dropped
259 - does not try to merge/aggregate 2 networks
260 - also reviewed logging with the hope to fix the sfa startup msg:
261 - TypeError: not all arguments converted during string formatting
262
263 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
264 - verify credentials against xsd schema
265 - Fix SM to SM communication
266 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
267 - new setting session_key_path
268
269 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
270 - fix registry credential regeneration and handle expiration
271 - support for setting slice tags (min_role=user)
272 - client can display its own version: sfi.py version --local
273 - GetVersion to provide urn in addition to hrn
274 - more code uses plxrn vs previous helper functions
275 - import replaces '+' in email addresses with '_'
276
277 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
278 - fix GetVersion code_tag and add code_url
279
280 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
281 - extend GetVersion towards minimum federation introspection, and expose local tag
282
283 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
284 - fixed some legacy issues (list vs List)
285 - deprecated sfa.util.namespace for xrn and plxrn
286 - unit tests ship as the sfa-tests rpm
287
288 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
289 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
290 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
291 - hrn-urn translations tweaked
292 - fixed 'service sfa status'
293 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
294 - started to repair sfadump - although not usable yet
295 - trust objects now have dump_string method that dump() actually prints
296 - unit tests under review
297 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
298 - binaries now support -v or -vv to increase loglevel
299 - trashed obsolete sfa.util.client
300
301 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
302 - various bugfixes and cleanup, improved/harmonized logging
303
304 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
305 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
306   to avoid returning a PLCAPI exception that might confuse users.
307 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
308 - fix build errors.  
309
310 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
311 - (Architecture) Credential format changed to match ProtoGENI xml format
312 - (Architecture) All interfaces export a new set of methods that are compatible
313    with the ProtoGeni Aggregate spec. These new methods are considered a 
314    replacement  for the pervious methods exported by the interfaces. All 
315    previous methods are still exported and work as normal, but they are 
316    considered deprecated and will not be supported in future releases.  
317 - (Architecture) SFI has been updated to use the new interface methods.
318 - (Architecture) Changed keyconvet implementation from c to python.
319 - (Architecture) Slice Manager now attempts looks for a delegated credential
320   provided by the client before using its own server credential.
321 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
322   This cache now exists only in memory and is cleared when service is restarted
323   or cache lifetime is exceeded.  
324 - (Performance) SliceManager sends request to Aggregates in parallel instead 
325   of sequentially.
326 - (Bug fix) SFA tickets now support the new rspec format.
327 - (Bug fix) SFI only uses cahced credential if they aren't expired.
328 - (Bug fix) Cerdential delegation modified to work with new credential format.
329 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
330   Aggregate instead of relaying through the Slice Manager.
331 - (Enhancement) Simplified caching. Accociated a global cache instance with
332   the api handler on every new server request, making it easier to access the 
333   cache and use in more general ways.     
334
335 %changelog
336 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
337 - load trusted certs into ssl context prior to handshake
338 - client's logfile lives in ~/.sfi/sfi.log
339
340 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
341 - includes a change on passphrases that was intended in 1.0-22
342
343 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
344 - stable sfascan
345 - fix in initscript, *ENABLED tags in config now taken into account
346
347 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
348 - some commits had not been pushed in tag 19
349
350 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
351 - GetVersion should now report full URLs with path
352 - scansfa has nicer output and new syntax (entry URLs as args and not options)
353 - dos2unix'ed flash policy pill
354
355 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
356 - fix packaging again for f8
357
358 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
359 - fix packaging (apparently broken in 1.0-16)
360 - first working version of sfascan
361 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
362 - deprecated the sfa_geni_aggregate config category
363
364 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
365 - Fix build problem
366 - First version of SFA scanner
367
368 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
369 - Add support for Flash clients using flashpolicy
370 - Fix problems with tag handling in RSpec
371
372 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
373 - Modifications to the Eucalyptus Aggregate Manager
374 - Fixes for VINI RSpec
375 - Fix tag handling for PL RSpec
376 - Fix XML Schema ordering for <urn> element
377
378 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
379 - just set x509 version to 2
380
381 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
382 - added urn to the node area in rspecs
383 - conversion to urn now exports fqdn
384 - sfa-import-plc.py now creates a unique registry record for each SFA interface
385
386 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
387 - undo broken attempt for python-2.7
388
389 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
390 - SMs avoid duplicates for when call graph has dags;
391 - just based on network's name, when a duplicate occurs, one is just dropped
392 - does not try to merge/aggregate 2 networks
393 - also reviewed logging with the hope to fix the sfa startup msg:
394 - TypeError: not all arguments converted during string formatting
395
396 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
397 - verify credentials against xsd schema
398 - Fix SM to SM communication
399 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
400 - new setting session_key_path
401
402 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
403 - fix registry credential regeneration and handle expiration
404 - support for setting slice tags (min_role=user)
405 - client can display its own version: sfi.py version --local
406 - GetVersion to provide urn in addition to hrn
407 - more code uses plxrn vs previous helper functions
408 - import replaces '+' in email addresses with '_'
409
410 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
411 - fix GetVersion code_tag and add code_url
412
413 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
414 - extend GetVersion towards minimum federation introspection, and expose local tag
415
416 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
417 - fixed some legacy issues (list vs List)
418 - deprecated sfa.util.namespace for xrn and plxrn
419 - unit tests ship as the sfa-tests rpm
420
421 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
422 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
423 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
424 - hrn-urn translations tweaked
425 - fixed 'service sfa status'
426 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
427 - started to repair sfadump - although not usable yet
428 - trust objects now have dump_string method that dump() actually prints
429 - unit tests under review
430 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
431 - binaries now support -v or -vv to increase loglevel
432 - trashed obsolete sfa.util.client
433
434 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
435 - various bugfixes and cleanup, improved/harmonized logging
436
437 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
438 - SfaServer now uses a pool of threads to handle requests concurrently
439 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
440 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
441 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
442 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
443 - Component manager does not install gid files if slice already has them  
444 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
445 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
446 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
447      
448 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
449 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
450 - - sfa-config-tty now has the same features like plc-config-tty
451 - - Contains code to support both urn and hrn
452 - - Cleaned up request_hash related stuff
453 - - SM, AM and Registry code is organized under respective managers
454 - - Site and Slice synchronization across federated aggregates
455 - - Script to generate sfa_component_config
456
457 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
458 - sfa-config-tty now has the same features like plc-config-tty
459 - Contains code to support both urn and hrn
460 - Cleaned up request_hash related stuff
461 - SM, AM and Registry code is organized under respective managers
462 - Slice synchronization across federated aggregates
463 - some bugs are fixed
464
465 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
466 - checkpoint with fewer mentions of geni
467
468 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
469 - checkpointing
470 - this is believed to pass the tests; among other things:
471 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
472
473 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
474 - This tag includes:
475 - - Sfatables
476 - - Preliminary version of hash based authentication
477 - - Initial code for Component Manager
478 - - Authority structure is moved to /var/lib/sfa/
479 - - some bug-fixes
480
481 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
482 - Create_slice and get_resources methods are connected to sfatables.
483 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
484
485 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
486 - Bug fix on update and remove_peer_object methods
487 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
488
489 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
490 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
491
492 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
493 - compatibility with RefreshPeer
494 - incremental mechanism for importing PLC records into SFA tables
495 - unified single database (still inside the underlying PLC db postgresql server)
496 - includes/improves call traceability and logging features
497 - several bug fixes
498
499 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
500 - added libxslt-python dependency
501
502 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
503 - unified single SFA database in the PLC-DB
504 - upcalls from  PLCAPI to SFA methods
505 - SFA call traceability and logging features
506 - many bug fixes
507 - includes first/rough version of sfatables for policy implementation
508
509 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
510 - snapshot after the GEC5 demo
511 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
512
513 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
514 - snapshot july 15 - has gone through superficial manual testing
515 - hopefully a good basis for gec5 demo
516 - multi-dir sfi client tested as well
517
518 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
519 - rename geniwrapper.spec into sfa.spec
520
521 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
522 - clean up in xmlrpc/soap, --protocol option to chose between both
523 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
524 - hopefully more helpful context in case of crashes when importing
525 - bugfixes for using only /etc/sfa for site-dep files
526 - bugfixes in wsdl generation
527
528 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
529 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
530 - config variables in sfa_config now start with SFA_ and not GENI_
531 - config.py can be loaded even with no config present
532
533 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
534 - first step for cleanup and reorganization
535 - mass-renaming from geni to sfa (some are still needed)
536 - sfa/trust implements the security architecture
537
538 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
539 - snapshot for reproducible builds
540
541 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
542 - snapshot for the convenience of alpha users
543
544 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
545 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
546
547 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
548 - ongoing work - snapshot for 4.3-rc9
549
550 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
551 - various fixes
552
553 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
554 - bugfixes - still a work in progress
555
556 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
557 - initial package
558
559
560 %define module_current_branch 0.2