Setting tag sfa-2.1-14
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 14
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package sfatables
92 Summary: sfatables policy tool for SFA
93 Group: Applications/System
94 Requires: sfa
95
96 %package xmlbuilder
97 Summary: third-party xmlbuilder tool
98 Group: Applications/System
99 Provides: python-xmlbuilder
100
101 %package tests
102 Summary: unit tests suite for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %description
107 This package provides the python libraries for the PlanetLab implementation of SFA
108
109 %description flashpolicy
110 This package provides support for adobe flash client applications.  
111
112 %description client
113 This package provides the client side of the SFA API, in particular
114 sfi.py, together with other utilities.
115
116 %description plc
117 This package implements the SFA interface which serves as a layer
118 between the existing PlanetLab interfaces and the SFA API.
119
120 %description cm
121 This package implements the SFA interface which serves as a layer
122 between the existing PlanetLab NodeManager interfaces and the SFA API.
123
124 %description federica
125 The SFA driver for FEDERICA.
126
127 %description sfatables
128 sfatables is a tool for defining access and admission control policies
129 in an SFA network, in much the same way as iptables is for ip
130 networks. This is the command line interface to manage sfatables
131
132 %description xmlbuilder
133 This package contains the xmlbuilder python library, packaged for
134 convenience as it is not supported by fedora
135
136 %description tests
137 Provides some binary unit tests in /usr/share/sfa/tests
138
139 %prep
140 %setup -q
141
142 %build
143 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %{python_sitelib}/sfa/__init__.py*
154 %{python_sitelib}/sfa/trust
155 %{python_sitelib}/sfa/storage
156 %{python_sitelib}/sfa/util
157 %{python_sitelib}/sfa/server
158 %{python_sitelib}/sfa/methods
159 %{python_sitelib}/sfa/generic
160 %{python_sitelib}/sfa/managers
161 %{python_sitelib}/sfa/importer
162 %{python_sitelib}/sfa/rspecs
163 %{python_sitelib}/sfa/client
164 /etc/init.d/sfa
165 %{_bindir}/sfa-start.py*
166 %{_bindir}/sfaadmin.py*
167 %{_bindir}/sfaadmin
168 %{_bindir}/keyconvert.py*
169 %{_bindir}/sfa-config-tty
170 %{_bindir}/sfa-config
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 /usr/share/sfa/migrations
175 /usr/share/sfa/examples
176 /var/www/html/wsdl/*.wsdl
177
178 %files flashpolicy
179 %{_bindir}/sfa_flashpolicy.py*
180 /etc/sfa/sfa_flashpolicy_config.xml
181
182 %files client
183 %config (noreplace) /etc/sfa/sfi_config
184 %{_bindir}/sfi*.py*
185 %{_bindir}/sfi
186 %{_bindir}/get*.py*
187 %{_bindir}/setRecord.py*
188 %{_bindir}/sfascan.py*
189 %{_bindir}/sfascan
190 %{_bindir}/sfadump.py*
191
192 %files plc
193 %defattr(-,root,root)
194 %{python_sitelib}/sfa/planetlab
195 %{python_sitelib}/sfa/openstack
196 /etc/sfa/pl.rng
197 /etc/sfa/credential.xsd
198 /etc/sfa/top.xsd
199 /etc/sfa/sig.xsd
200 /etc/sfa/xml.xsd
201 /etc/sfa/protogeni-rspec-common.xsd
202 /etc/sfa/topology
203 %{_bindir}/gen-sfa-cm-config.py*
204
205 %files cm
206 /etc/init.d/sfa-cm
207 %{_bindir}/sfa_component_setup.py*
208 # cron jobs here 
209
210 %files federica
211 %{python_sitelib}/sfa/federica
212
213 %files sfatables
214 /etc/sfatables/*
215 %{_bindir}/sfatables
216 %{python_sitelib}/sfatables
217
218 %files xmlbuilder
219 %{python_sitelib}/xmlbuilder
220
221 %files tests
222 %{_datadir}/sfa/tests
223
224 ### sfa installs the 'sfa' service
225 %post 
226 chkconfig --add sfa
227
228 %preun 
229 if [ "$1" = 0 ] ; then
230   /sbin/service sfa stop || :
231   /sbin/chkconfig --del sfa || :
232 fi
233
234 %postun
235 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
236
237 ### sfa-cm installs the 'sfa-cm' service
238 %post cm
239 chkconfig --add sfa-cm
240
241 %preun cm
242 if [ "$1" = 0 ] ; then
243    /sbin/service sfa-cm stop || :
244    /sbin/chkconfig --del sfa-cm || :
245 fi
246
247 %postun cm
248 [ "$1" -ge "1" ] && service sfa-cm restart || :
249
250 %changelog
251 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
252 - configurable data-dir (/var/lib/sfa)
253 - no more dependent on myplc-config
254 - some support for hrns with _ instead of \.
255 - fix for PL importing in presence of gpg keys
256 - DeleteSliver returns True instead of 1 in case of success
257 - Various improvements on the openstack/nova side
258
259 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
260 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
261 - sfi to remove expired credentials
262
263 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
264 - Update Openstack driver to support Essex release/
265 - Fix authority xrn bug.
266   
267
268 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
269 - review packaging - site-packages/planetlab now come with sfa-plc
270 - new package sfa-federica
271 - clientbin moved one step upwards
272
273 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
274 - fix bug in sfi update()
275
276 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
277 - fix broken sfa.util.xrn class for lowercase
278
279 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
280 - new 'void' generic_flavour for running in registry-only mode
281 - first shot at refactoring importers - probably needs more work
282 - openstack: various enhancements
283 - sfi interface to registry not based on xml files anymore
284 - sfi show sorts result on record key
285 - bugfix in sfa update on users with a pl-backed registry
286
287 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
288 - renamed sfa/plc into sfa/planetlab
289 - plxrn moved in sfa/planetlab as well
290 - bugfix for sfaadmin reg update --pi <>
291
292 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
293 - native data model now has a authority x user (PI) relationship
294 - no call to 'augment_records_with_testbed_info' for GetCredential
295 - which means, registry can now be used without an underlying testbed
296 - reviewed code about relationships b/w objects and related in pl driver
297 - reviewed PL import wrt roles and pis
298 - removed mentions to is_enabled in driver
299 - small changes in update_relation* in driver interface
300 - sfaadmin: can create authorities and attach pi users to them
301 - sfaadmin: categories can be abbreviated
302 - sfi list and sfaadmin list have a new -r/--recursive option
303 - this means that List now supports an (optional) 'options' argument
304 - sfi config can display config vars
305 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
306
307 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
308 - make sync now supports vserver or lxc.
309 - Added slice expiration and login info to SliverStatus response. 
310 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
311   the 'component_name' attribute.
312 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
313   
314 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
315 - Introduced new administrative command line script, sfaadmin.py. Removed various single
316  purpose scripts and migrated their functionality into sfaadmin.py.
317 - Refactored Registry import scripts.
318 - Removed SQLAlchemy dependency from sfi.py.
319 - Fixed bugs in sfi.py
320 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
321
322 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
323 - slice x researcher rel. in database,
324 - plimporter to maintain that, as well as user.email, and more robust
325 - ongoing draft for sfaadmin tool
326 - support for a federica driver
327 - support for a nova/euca driver
328 - no more sfa-clean-peer-records script
329
330 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
331 - registry database has user's keys and mail (known as v0 for migrate)
332 - pl importer properly maintains user's keys and mail
333 - pl driver now to handle 'role' when adding person record (exp.)
334 - first draft of federica driver with config section
335 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
336 - plus, from master as of tag merged-in-sfa-2.1-2:
337 - disk_image revisited
338 - new nova_shell nova_driver & various tweaks for openstack
339
340 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
341 - uses sqlalchemy and related migrate
342 - thorough migration and upgrade scheme
343 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
344 - trashed dbinfo stuff in auth hierarchy
345 - data model still has little more than plain records
346 - checkpoint tag, not yet intended for release
347
348 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
349 - client: added -R --raw sfi cmdline option that displays raw server response.
350 - client: request GENI RSpec by default. 
351 - server: remove database dependencies from sfa.server.sfaapi.
352 - server: increased default credential lifetime to 31 days.
353 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
354 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
355 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
356  
357 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
358 - bugfix: 'geni_api' should be in the top level struct, not the code struct
359 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
360           output returned by the Aggregate Manager.
361 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
362 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
363 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
364           there is extra whitespace in the schemaLocation field.
365 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
366           advertisement rspecs.
367 - bugfix: <login> RSpec element should contain the 'username' attribute.
368 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
369  
370 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
371 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
372   exit when it encountered a user with an invalid public key.
373 - server: imporved logging in sfa-import-plc.py
374  
375 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
376 - bugfix: Fixed appending public keys in CreateSliver
377 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
378 - client: -c --current option allows users to request the current/uncached rspec.
379 - server: Added 'geni_api_versions' field to GetVersion() output.
380 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
381    
382 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
383 - bugfix: sfi was not sending call_id with ListResources to v2 servers
384 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
385 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
386
387 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
388 - client: sfi -a / -p deprecated (use -s instead)
389 - client: sfi cleaned up
390 - client: sfi has backward support for APIv1 aggregates again
391 - server: only APIv2 is supported and should be rather strict
392 - server: settings for turning on/off caching in sm or am
393 - server: plc-dependant code has moved from aggregate to pldriver
394 - server: driver interface extended accordingly
395
396 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
397 - screwed up previous tag
398
399 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
400 - client side revisited with a bootstrap library
401 - client side has a new source layout
402 - various (nasty) bug fixes wrt options and call_id
403
404 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
405 - various fixes in rspecs for sfav1&slice tags
406 - uses 'geni_rspec_version' and not just 'rspec_version'
407 - example flavour for the max testbed
408 - embryo for an sfa client library
409 - topology.py moved into plc
410 - sql: table is named records; record_types are enforced
411 - sql: table creation cleaned up
412
413 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
414 - cleaned up all references to SFA_*_TYPE in config
415 - enable cache at the aggregate by default
416 - registry now uses the driver in a sensible way (see managers/driver.py)
417 - slice manager supports sfav1/pgv2 neighbours
418 - get_key renamed into get_key_from_incoming_ip
419 - new sfa.storage module for record/table and all db-related stuff
420 - db schema in sfa.storage.sfa.sql
421 - init.d and cron.d move one step up
422 - cleaned up rspec/ directory
423 - add deps to pyopenssl and myplc-config
424 - start support for new API (return value)
425 - plc.remoteshell removed, use plshell instead
426 - plshell uses a 'capability' auth method whenever possible
427 - various tweaks in rspec elements
428 - made dependency on sfatables softer
429
430 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
431 - sfa should now be started *before* the initial import
432 - sfa to use its own database (default sfa) - can run without myplc
433 - server calls support optional 'options'
434 - client sends options in argument when needed
435 - fix infinite getattr recursion in elements/element.py
436 - error codes in line with geni
437
438 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
439 - fixed links and attributes in rspecs
440 - minor cleanup in the API methods, and more consistent names in manager methods
441
442 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
443 - ongoing refoactoring towards more genericity
444 - passes tests again although known issues remain with attributes/tags
445
446 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
447 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
448 - improvements in the pgv2 rspecs
449 - driver separated from api
450 - code starts moving around where it belongs
451 - sfascan caches getversion across invokations
452 - vini topology extracted as a config file
453
454 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
455 - first support for protogeni rspecs is working
456 - vini no longer needs a specific manager
457 - refactoring underway towards more flexible/generic architecture
458
459 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
460 - Unicode-friendliness for user names with accents/special chars.
461 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
462 - CreaetSliver no longer fails for users that have a capital letter in their URN.
463 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
464 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
465 - Fix bugs and missing imports     
466  
467
468 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
469 - new method record.get_field for sface
470
471 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
472 - new option -c to sfa-nuke-plc.py
473 - CreateSliver fixed for admin-only slice tags
474
475 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
476 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
477 - Fixed holes in certificate verification logic.
478 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
479 - Added 'boot_state' as an attribute of the node element in SFA rspec.
480 - Non authority certificates are marked as CA:FALSE.
481
482 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
483 - fix typo in sfa-1.0-31 tag.
484 - added CreateGid() Registry interface method.
485
486 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
487 - fix typo in sfa-1.0-30 tag
488
489 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
490 - Declare namespace and schema location in the credential.
491 - Fix bug that prevetend connections from timing out.
492 - Fix slice delegation.
493 - Add statistics to slicemaanger listresources/createsliver rspec.
494 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
495   of days a user can extend their slice expiration.
496 - CA certs are only issued to objects of type authority
497    
498 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
499 - tag 1.0-28 was broken due to typo in the changelog
500 - new class sfa/util/httpsProtocol.py that supports timeouts
501
502 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
503 - Resolved issue that caused sfa hold onto idle db connections.
504 - Fix bug that caused the registry to use the wrong type of credential.
505 - Support authority+sm type.
506 - Fix rspec merging bugs.
507 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
508 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
509  planetlab hosted initscripts using the <planetlab:initscript> tag  
510 - Can now handle extraneous whitespace in the rspec without failing.   
511  
512 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
513 - ProtoGENI v2 RSpec updates.
514 - Convert expiration timestamps with timezone info in credentials to utc.
515 - Fixed redundant logging issue. 
516 - Improved SliceManager and SFI client logging.
517 - Support aggregates that don't support the optional 'call_id' argument. 
518 - Only call get_trusted_certs() at aggreage interfaces that support the call.
519 - CreateSliver() now handles MyPLC slice attributes/tags.
520 - Cache now supports persistence.
521 - Hide whitelisted nodes.
522
523 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
524 - fixed issues with sup authority signing
525 - fixed bugs in remove_slivers and SliverStatus
526
527 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
528 - fix typo that prevented aggregates from operating properly
529
530 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
531 - load trusted certs into ssl context prior to handshake
532 - client's logfile lives in ~/.sfi/sfi.log
533
534 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
535 - includes a change on passphrases that was intended in 1.0-22
536
537 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
538 - Added support for ProtoGENI RSpec v2
539  
540 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
541 - stable sfascan
542 - fix in initscript, *ENABLED tags in config now taken into account
543
544 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
545 - some commits had not been pushed in tag 19
546
547 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
548 - GetVersion should now report full URLs with path
549 - scansfa has nicer output and new syntax (entry URLs as args and not options)
550 - dos2unix'ed flash policy pill
551
552 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
553 - fix packaging again for f8
554
555 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
556 - fix packaging (apparently broken in 1.0-16)
557 - first working version of sfascan
558 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
559 - deprecated the sfa_geni_aggregate config category
560
561 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
562 - Fix build problem
563 - First version of SFA scanner
564
565 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
566 - Add support for Flash clients using flashpolicy
567 - Fix problems with tag handling in RSpec
568
569 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
570 - Modifications to the Eucalyptus Aggregate Manager
571 - Fixes for VINI RSpec
572 - Fix tag handling for PL RSpec
573 - Fix XML Schema ordering for <urn> element
574
575 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
576 - just set x509 version to 2
577
578 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
579 - added urn to the node area in rspecs
580 - conversion to urn now exports fqdn
581 - sfa-import-plc.py now creates a unique registry record for each SFA interface
582
583 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
584 - undo broken attempt for python-2.7
585
586 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
587 - SMs avoid duplicates for when call graph has dags;
588 - just based on network's name, when a duplicate occurs, one is just dropped
589 - does not try to merge/aggregate 2 networks
590 - also reviewed logging with the hope to fix the sfa startup msg:
591 - TypeError: not all arguments converted during string formatting
592
593 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
594 - verify credentials against xsd schema
595 - Fix SM to SM communication
596 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
597 - new setting session_key_path
598
599 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
600 - fix registry credential regeneration and handle expiration
601 - support for setting slice tags (min_role=user)
602 - client can display its own version: sfi.py version --local
603 - GetVersion to provide urn in addition to hrn
604 - more code uses plxrn vs previous helper functions
605 - import replaces '+' in email addresses with '_'
606
607 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
608 - fix GetVersion code_tag and add code_url
609
610 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
611 - extend GetVersion towards minimum federation introspection, and expose local tag
612
613 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
614 - fixed some legacy issues (list vs List)
615 - deprecated sfa.util.namespace for xrn and plxrn
616 - unit tests ship as the sfa-tests rpm
617
618 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
619 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
620 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
621 - hrn-urn translations tweaked
622 - fixed 'service sfa status'
623 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
624 - started to repair sfadump - although not usable yet
625 - trust objects now have dump_string method that dump() actually prints
626 - unit tests under review
627 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
628 - binaries now support -v or -vv to increase loglevel
629 - trashed obsolete sfa.util.client
630
631 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
632 - various bugfixes and cleanup, improved/harmonized logging
633
634 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
635 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
636   to avoid returning a PLCAPI exception that might confuse users.
637 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
638 - fix build errors.  
639
640 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
641 - (Architecture) Credential format changed to match ProtoGENI xml format
642 - (Architecture) All interfaces export a new set of methods that are compatible
643    with the ProtoGeni Aggregate spec. These new methods are considered a 
644    replacement  for the pervious methods exported by the interfaces. All 
645    previous methods are still exported and work as normal, but they are 
646    considered deprecated and will not be supported in future releases.  
647 - (Architecture) SFI has been updated to use the new interface methods.
648 - (Architecture) Changed keyconvet implementation from c to python.
649 - (Architecture) Slice Manager now attempts looks for a delegated credential
650   provided by the client before using its own server credential.
651 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
652   This cache now exists only in memory and is cleared when service is restarted
653   or cache lifetime is exceeded.  
654 - (Performance) SliceManager sends request to Aggregates in parallel instead 
655   of sequentially.
656 - (Bug fix) SFA tickets now support the new rspec format.
657 - (Bug fix) SFI only uses cahced credential if they aren't expired.
658 - (Bug fix) Cerdential delegation modified to work with new credential format.
659 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
660   Aggregate instead of relaying through the Slice Manager.
661 - (Enhancement) Simplified caching. Accociated a global cache instance with
662   the api handler on every new server request, making it easier to access the 
663   cache and use in more general ways.     
664
665 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
666 - SfaServer now uses a pool of threads to handle requests concurrently
667 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
668 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
669 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
670 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
671 - Component manager does not install gid files if slice already has them  
672 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
673 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
674 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
675      
676 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
677 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
678 - - sfa-config-tty now has the same features like plc-config-tty
679 - - Contains code to support both urn and hrn
680 - - Cleaned up request_hash related stuff
681 - - SM, AM and Registry code is organized under respective managers
682 - - Site and Slice synchronization across federated aggregates
683 - - Script to generate sfa_component_config
684
685 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
686 - sfa-config-tty now has the same features like plc-config-tty
687 - Contains code to support both urn and hrn
688 - Cleaned up request_hash related stuff
689 - SM, AM and Registry code is organized under respective managers
690 - Slice synchronization across federated aggregates
691 - some bugs are fixed
692
693 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
694 - checkpoint with fewer mentions of geni
695
696 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
697 - checkpointing
698 - this is believed to pass the tests; among other things:
699 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
700
701 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
702 - This tag includes:
703 - - Sfatables
704 - - Preliminary version of hash based authentication
705 - - Initial code for Component Manager
706 - - Authority structure is moved to /var/lib/sfa/
707 - - some bug-fixes
708
709 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
710 - Create_slice and get_resources methods are connected to sfatables.
711 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
712
713 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
714 - Bug fix on update and remove_peer_object methods
715 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
716
717 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
718 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
719
720 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
721 - compatibility with RefreshPeer
722 - incremental mechanism for importing PLC records into SFA tables
723 - unified single database (still inside the underlying PLC db postgresql server)
724 - includes/improves call traceability and logging features
725 - several bug fixes
726
727 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
728 - added libxslt-python dependency
729
730 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
731 - unified single SFA database in the PLC-DB
732 - upcalls from  PLCAPI to SFA methods
733 - SFA call traceability and logging features
734 - many bug fixes
735 - includes first/rough version of sfatables for policy implementation
736
737 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
738 - snapshot after the GEC5 demo
739 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
740
741 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
742 - snapshot july 15 - has gone through superficial manual testing
743 - hopefully a good basis for gec5 demo
744 - multi-dir sfi client tested as well
745
746 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
747 - rename geniwrapper.spec into sfa.spec
748
749 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
750 - clean up in xmlrpc/soap, --protocol option to chose between both
751 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
752 - hopefully more helpful context in case of crashes when importing
753 - bugfixes for using only /etc/sfa for site-dep files
754 - bugfixes in wsdl generation
755
756 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
757 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
758 - config variables in sfa_config now start with SFA_ and not GENI_
759 - config.py can be loaded even with no config present
760
761 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
762 - first step for cleanup and reorganization
763 - mass-renaming from geni to sfa (some are still needed)
764 - sfa/trust implements the security architecture
765
766 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
767 - snapshot for reproducible builds
768
769 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
770 - snapshot for the convenience of alpha users
771
772 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
773 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
774
775 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
776 - ongoing work - snapshot for 4.3-rc9
777
778 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
779 - various fixes
780
781 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
782 - bugfixes - still a work in progress
783
784 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
785 - initial package
786
787
788 %define module_current_branch 0.2