Merge branch 'master' of ssh://git.planet-lab.org/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 22
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart
197
198
199 %changelog
200 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
201 - Added support for ProtoGENI RSpec v2
202  
203 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
204 - stable sfascan
205 - fix in initscript, *ENABLED tags in config now taken into account
206
207 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
208 - some commits had not been pushed in tag 19
209
210 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
211 - GetVersion should now report full URLs with path
212 - scansfa has nicer output and new syntax (entry URLs as args and not options)
213 - dos2unix'ed flash policy pill
214
215 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
216 - fix packaging again for f8
217
218 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
219 - fix packaging (apparently broken in 1.0-16)
220 - first working version of sfascan
221 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
222 - deprecated the sfa_geni_aggregate config category
223
224 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
225 - Fix build problem
226 - First version of SFA scanner
227
228 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
229 - Add support for Flash clients using flashpolicy
230 - Fix problems with tag handling in RSpec
231
232 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
233 - Modifications to the Eucalyptus Aggregate Manager
234 - Fixes for VINI RSpec
235 - Fix tag handling for PL RSpec
236 - Fix XML Schema ordering for <urn> element
237
238 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
239 - just set x509 version to 2
240
241 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
242 - added urn to the node area in rspecs
243 - conversion to urn now exports fqdn
244 - sfa-import-plc.py now creates a unique registry record for each SFA interface
245
246 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
247 - undo broken attempt for python-2.7
248
249 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
250 - SMs avoid duplicates for when call graph has dags;
251 - just based on network's name, when a duplicate occurs, one is just dropped
252 - does not try to merge/aggregate 2 networks
253 - also reviewed logging with the hope to fix the sfa startup msg:
254 - TypeError: not all arguments converted during string formatting
255
256 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
257 - verify credentials against xsd schema
258 - Fix SM to SM communication
259 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
260 - new setting session_key_path
261
262 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
263 - fix registry credential regeneration and handle expiration
264 - support for setting slice tags (min_role=user)
265 - client can display its own version: sfi.py version --local
266 - GetVersion to provide urn in addition to hrn
267 - more code uses plxrn vs previous helper functions
268 - import replaces '+' in email addresses with '_'
269
270 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
271 - fix GetVersion code_tag and add code_url
272
273 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
274 - extend GetVersion towards minimum federation introspection, and expose local tag
275
276 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
277 - fixed some legacy issues (list vs List)
278 - deprecated sfa.util.namespace for xrn and plxrn
279 - unit tests ship as the sfa-tests rpm
280
281 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
282 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
283 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
284 - hrn-urn translations tweaked
285 - fixed 'service sfa status'
286 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
287 - started to repair sfadump - although not usable yet
288 - trust objects now have dump_string method that dump() actually prints
289 - unit tests under review
290 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
291 - binaries now support -v or -vv to increase loglevel
292 - trashed obsolete sfa.util.client
293
294 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
295 - various bugfixes and cleanup, improved/harmonized logging
296
297 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
298 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
299   to avoid returning a PLCAPI exception that might confuse users.
300 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
301 - fix build errors.  
302
303 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
304 - (Architecture) Credential format changed to match ProtoGENI xml format
305 - (Architecture) All interfaces export a new set of methods that are compatible
306    with the ProtoGeni Aggregate spec. These new methods are considered a 
307    replacement  for the pervious methods exported by the interfaces. All 
308    previous methods are still exported and work as normal, but they are 
309    considered deprecated and will not be supported in future releases.  
310 - (Architecture) SFI has been updated to use the new interface methods.
311 - (Architecture) Changed keyconvet implementation from c to python.
312 - (Architecture) Slice Manager now attempts looks for a delegated credential
313   provided by the client before using its own server credential.
314 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
315   This cache now exists only in memory and is cleared when service is restarted
316   or cache lifetime is exceeded.  
317 - (Performance) SliceManager sends request to Aggregates in parallel instead 
318   of sequentially.
319 - (Bug fix) SFA tickets now support the new rspec format.
320 - (Bug fix) SFI only uses cahced credential if they aren't expired.
321 - (Bug fix) Cerdential delegation modified to work with new credential format.
322 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
323   Aggregate instead of relaying through the Slice Manager.
324 - (Enhancement) Simplified caching. Accociated a global cache instance with
325   the api handler on every new server request, making it easier to access the 
326   cache and use in more general ways.     
327
328 %changelog
329 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
330 - stable sfascan
331 - fix in initscript, *ENABLED tags in config now taken into account
332
333 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
334 - some commits had not been pushed in tag 19
335
336 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
337 - GetVersion should now report full URLs with path
338 - scansfa has nicer output and new syntax (entry URLs as args and not options)
339 - dos2unix'ed flash policy pill
340
341 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
342 - fix packaging again for f8
343
344 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
345 - fix packaging (apparently broken in 1.0-16)
346 - first working version of sfascan
347 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
348 - deprecated the sfa_geni_aggregate config category
349
350 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
351 - Fix build problem
352 - First version of SFA scanner
353
354 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
355 - Add support for Flash clients using flashpolicy
356 - Fix problems with tag handling in RSpec
357
358 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
359 - Modifications to the Eucalyptus Aggregate Manager
360 - Fixes for VINI RSpec
361 - Fix tag handling for PL RSpec
362 - Fix XML Schema ordering for <urn> element
363
364 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
365 - just set x509 version to 2
366
367 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
368 - added urn to the node area in rspecs
369 - conversion to urn now exports fqdn
370 - sfa-import-plc.py now creates a unique registry record for each SFA interface
371
372 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
373 - undo broken attempt for python-2.7
374
375 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
376 - SMs avoid duplicates for when call graph has dags;
377 - just based on network's name, when a duplicate occurs, one is just dropped
378 - does not try to merge/aggregate 2 networks
379 - also reviewed logging with the hope to fix the sfa startup msg:
380 - TypeError: not all arguments converted during string formatting
381
382 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
383 - verify credentials against xsd schema
384 - Fix SM to SM communication
385 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
386 - new setting session_key_path
387
388 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
389 - fix registry credential regeneration and handle expiration
390 - support for setting slice tags (min_role=user)
391 - client can display its own version: sfi.py version --local
392 - GetVersion to provide urn in addition to hrn
393 - more code uses plxrn vs previous helper functions
394 - import replaces '+' in email addresses with '_'
395
396 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
397 - fix GetVersion code_tag and add code_url
398
399 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
400 - extend GetVersion towards minimum federation introspection, and expose local tag
401
402 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
403 - fixed some legacy issues (list vs List)
404 - deprecated sfa.util.namespace for xrn and plxrn
405 - unit tests ship as the sfa-tests rpm
406
407 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
408 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
409 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
410 - hrn-urn translations tweaked
411 - fixed 'service sfa status'
412 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
413 - started to repair sfadump - although not usable yet
414 - trust objects now have dump_string method that dump() actually prints
415 - unit tests under review
416 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
417 - binaries now support -v or -vv to increase loglevel
418 - trashed obsolete sfa.util.client
419
420 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
421 - various bugfixes and cleanup, improved/harmonized logging
422
423 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
424 - SfaServer now uses a pool of threads to handle requests concurrently
425 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
426 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
427 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
428 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
429 - Component manager does not install gid files if slice already has them  
430 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
431 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
432 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
433      
434 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
435 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
436 - - sfa-config-tty now has the same features like plc-config-tty
437 - - Contains code to support both urn and hrn
438 - - Cleaned up request_hash related stuff
439 - - SM, AM and Registry code is organized under respective managers
440 - - Site and Slice synchronization across federated aggregates
441 - - Script to generate sfa_component_config
442
443 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
444 - sfa-config-tty now has the same features like plc-config-tty
445 - Contains code to support both urn and hrn
446 - Cleaned up request_hash related stuff
447 - SM, AM and Registry code is organized under respective managers
448 - Slice synchronization across federated aggregates
449 - some bugs are fixed
450
451 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
452 - checkpoint with fewer mentions of geni
453
454 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
455 - checkpointing
456 - this is believed to pass the tests; among other things:
457 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
458
459 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
460 - This tag includes:
461 - - Sfatables
462 - - Preliminary version of hash based authentication
463 - - Initial code for Component Manager
464 - - Authority structure is moved to /var/lib/sfa/
465 - - some bug-fixes
466
467 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
468 - Create_slice and get_resources methods are connected to sfatables.
469 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
470
471 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
472 - Bug fix on update and remove_peer_object methods
473 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
474
475 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
476 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
477
478 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
479 - compatibility with RefreshPeer
480 - incremental mechanism for importing PLC records into SFA tables
481 - unified single database (still inside the underlying PLC db postgresql server)
482 - includes/improves call traceability and logging features
483 - several bug fixes
484
485 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
486 - added libxslt-python dependency
487
488 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
489 - unified single SFA database in the PLC-DB
490 - upcalls from  PLCAPI to SFA methods
491 - SFA call traceability and logging features
492 - many bug fixes
493 - includes first/rough version of sfatables for policy implementation
494
495 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
496 - snapshot after the GEC5 demo
497 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
498
499 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
500 - snapshot july 15 - has gone through superficial manual testing
501 - hopefully a good basis for gec5 demo
502 - multi-dir sfi client tested as well
503
504 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
505 - rename geniwrapper.spec into sfa.spec
506
507 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
508 - clean up in xmlrpc/soap, --protocol option to chose between both
509 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
510 - hopefully more helpful context in case of crashes when importing
511 - bugfixes for using only /etc/sfa for site-dep files
512 - bugfixes in wsdl generation
513
514 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
515 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
516 - config variables in sfa_config now start with SFA_ and not GENI_
517 - config.py can be loaded even with no config present
518
519 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
520 - first step for cleanup and reorganization
521 - mass-renaming from geni to sfa (some are still needed)
522 - sfa/trust implements the security architecture
523
524 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
525 - snapshot for reproducible builds
526
527 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
528 - snapshot for the convenience of alpha users
529
530 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
531 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
532
533 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
534 - ongoing work - snapshot for 4.3-rc9
535
536 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
537 - various fixes
538
539 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
540 - bugfixes - still a work in progress
541
542 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
543 - initial package
544
545
546 %define module_current_branch 0.2