Merge branch 'master' of ssh://git.onelab.eu/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 8
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45 Requires: python-xmlbuilder
46  
47 # python 2.5 has uuid module added, for python 2.4 we still need it.
48 # we can't really check for if we can load uuid as a python module,
49 # it'll be installed by "devel.pkgs". we have the epel repository so
50 # python-uuid will be provided. but we can test for the python
51 # version.
52 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
53 # %if %has_py24
54 #
55 # this also didn't work very well. I'll just check for distroname - baris
56 #%if %{distroname} == "centos5"
57 #Requires: python-uuid
58 #%endif
59
60 %package plc
61 Summary: the SFA layer around MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package cm
78 Summary: the SFA layer around MyPLC NodeManager
79 Group: Applications/System
80 Requires: sfa
81 Requires: pyOpenSSL >= 0.6
82
83 %package flashpolicy
84 Summary: SFA support for flash clients
85 Group: Applications/System
86 Requires: sfa
87
88 %package xmlbuilder
89 Summary: third-party xmlbuilder tool
90 Group: Applications/System
91 Provides: python-xmlbuilder
92
93 %package tests
94 Summary: unit tests suite for SFA
95 Group: Applications/System
96 Requires: sfa
97
98 %description
99 This package provides the python libraries for the PlanetLab implementation of SFA
100
101 %description plc
102 This package implements the SFA interface which serves as a layer
103 between the existing PlanetLab interfaces and the SFA API.
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description sfatables
110 sfatables is a tool for defining access and admission control policies
111 in an SFA network, in much the same way as iptables is for ip
112 networks. This is the command line interface to manage sfatables
113
114 %description cm
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab NodeManager interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description xmlbuilder
122 This package contains the xmlbuilder python library, packaged for
123 convenience as it is not supported by fedora
124
125 %description tests
126 Provides some binary unit tests in /usr/share/sfa/tests
127
128 %prep
129 %setup -q
130
131 %build
132 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 # sfa and sfatables depend on each other.
143 %{python_sitelib}/sfa
144 /etc/init.d/sfa
145 %{_bindir}/sfa-start.py*
146 %{_bindir}/keyconvert.py*
147 %{_bindir}/sfa-config-tty
148 %config /etc/sfa/default_config.xml
149 %config (noreplace) /etc/sfa/aggregates.xml
150 %config (noreplace) /etc/sfa/registries.xml
151 /usr/share/sfa/sfa.sql
152 /usr/share/sfa/examples
153 /var/www/html/wsdl/*.wsdl
154
155 %files plc
156 %defattr(-,root,root)
157 /etc/sfa/pl.rng
158 /etc/sfa/credential.xsd
159 /etc/sfa/top.xsd
160 /etc/sfa/sig.xsd
161 /etc/sfa/xml.xsd
162 /etc/sfa/protogeni-rspec-common.xsd
163 /etc/sfa/topology
164 %{_bindir}/sfa-import-plc.py*
165 %{_bindir}/sfa-nuke-plc.py*
166 %{_bindir}/sfa-clean-peer-records.py*
167 %{_bindir}/gen-sfa-cm-config.py*
168 %{_bindir}/sfa-ca.py*
169
170 %files client
171 %config (noreplace) /etc/sfa/sfi_config
172 %{_bindir}/sfi*.py*
173 %{_bindir}/sfi
174 %{_bindir}/get*.py*
175 %{_bindir}/setRecord.py*
176 %{_bindir}/sfascan.py*
177 %{_bindir}/sfascan
178 %{_bindir}/sfadump.py*
179
180 %files sfatables
181 /etc/sfatables/*
182 %{_bindir}/sfatables
183 %{python_sitelib}/sfatables
184
185 %files cm
186 /etc/init.d/sfa-cm
187 %{_bindir}/sfa_component_setup.py*
188 # cron jobs here 
189
190 %files flashpolicy
191 %{_bindir}/sfa_flashpolicy.py*
192 /etc/sfa/sfa_flashpolicy_config.xml
193
194 %files xmlbuilder
195 %{python_sitelib}/xmlbuilder
196
197 %files tests
198 %{_datadir}/sfa/tests
199
200 ### sfa-plc installs the 'sfa' service
201 %post plc
202 chkconfig --add sfa
203
204 %preun plc
205 if [ "$1" = 0 ] ; then
206   /sbin/service sfa stop || :
207   /sbin/chkconfig --del sfa || :
208 fi
209
210 %postun plc
211 [ "$1" -ge "1" ] && service sfa restart
212
213 ### sfa-cm installs the 'sfa-cm' service
214 %post cm
215 chkconfig --add sfa-cm
216
217 %preun cm
218 if [ "$1" = 0 ] ; then
219    /sbin/service sfa-cm stop || :
220    /sbin/chkconfig --del sfa-cm || :
221 fi
222
223 %postun cm
224 [ "$1" -ge "1" ] && service sfa-cm restart || :
225
226 %changelog
227 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
228 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
229   exit when it encountered a user with an invalid public key.
230 - server: imporved logging in sfa-import-plc.py
231  
232 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
233 - bugfix: Fixed appending public keys in CreateSliver
234 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
235 - client: -c --current option allows users to request the current/uncached rspec.
236 - server: Added 'geni_api_versions' field to GetVersion() output.
237 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
238    
239 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
240 - bugfix: sfi was not sending call_id with ListResources to v2 servers
241 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
242 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
243
244 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
245 - client: sfi -a / -p deprecated (use -s instead)
246 - client: sfi cleaned up
247 - client: sfi has backward support for APIv1 aggregates again
248 - server: only APIv2 is supported and should be rather strict
249 - server: settings for turning on/off caching in sm or am
250 - server: plc-dependant code has moved from aggregate to pldriver
251 - server: driver interface extended accordingly
252
253 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
254 - screwed up previous tag
255
256 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
257 - client side revisited with a bootstrap library
258 - client side has a new source layout
259 - various (nasty) bug fixes wrt options and call_id
260
261 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
262 - various fixes in rspecs for sfav1&slice tags
263 - uses 'geni_rspec_version' and not just 'rspec_version'
264 - example flavour for the max testbed
265 - embryo for an sfa client library
266 - topology.py moved into plc
267 - sql: table is named records; record_types are enforced
268 - sql: table creation cleaned up
269
270 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
271 - cleaned up all references to SFA_*_TYPE in config
272 - enable cache at the aggregate by default
273 - registry now uses the driver in a sensible way (see managers/driver.py)
274 - slice manager supports sfav1/pgv2 neighbours
275 - get_key renamed into get_key_from_incoming_ip
276 - new sfa.storage module for record/table and all db-related stuff
277 - db schema in sfa.storage.sfa.sql
278 - init.d and cron.d move one step up
279 - cleaned up rspec/ directory
280 - add deps to pyopenssl and myplc-config
281 - start support for new API (return value)
282 - plc.remoteshell removed, use plshell instead
283 - plshell uses a 'capability' auth method whenever possible
284 - various tweaks in rspec elements
285 - made dependency on sfatables softer
286
287 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
288 - sfa should now be started *before* the initial import
289 - sfa to use its own database (default sfa) - can run without myplc
290 - server calls support optional 'options'
291 - client sends options in argument when needed
292 - fix infinite getattr recursion in elements/element.py
293 - error codes in line with geni
294
295 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
296 - fixed links and attributes in rspecs
297 - minor cleanup in the API methods, and more consistent names in manager methods
298
299 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
300 - ongoing refoactoring towards more genericity
301 - passes tests again although known issues remain with attributes/tags
302
303 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
304 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
305 - improvements in the pgv2 rspecs
306 - driver separated from api
307 - code starts moving around where it belongs
308 - sfascan caches getversion across invokations
309 - vini topology extracted as a config file
310
311 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
312 - first support for protogeni rspecs is working
313 - vini no longer needs a specific manager
314 - refactoring underway towards more flexible/generic architecture
315
316 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
317 - Unicode-friendliness for user names with accents/special chars.
318 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
319 - CreaetSliver no longer fails for users that have a capital letter in their URN.
320 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
321 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
322 - Fix bugs and missing imports     
323  
324
325 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
326 - new method record.get_field for sface
327
328 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
329 - new option -c to sfa-nuke-plc.py
330 - CreateSliver fixed for admin-only slice tags
331
332 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
333 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
334 - Fixed holes in certificate verification logic.
335 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
336 - Added 'boot_state' as an attribute of the node element in SFA rspec.
337 - Non authority certificates are marked as CA:FALSE.
338
339 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
340 - fix typo in sfa-1.0-31 tag.
341 - added CreateGid() Registry interface method.
342
343 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
344 - fix typo in sfa-1.0-30 tag
345
346 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
347 - Declare namespace and schema location in the credential.
348 - Fix bug that prevetend connections from timing out.
349 - Fix slice delegation.
350 - Add statistics to slicemaanger listresources/createsliver rspec.
351 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
352   of days a user can extend their slice expiration.
353 - CA certs are only issued to objects of type authority
354    
355 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
356 - tag 1.0-28 was broken due to typo in the changelog
357 - new class sfa/util/httpsProtocol.py that supports timeouts
358
359 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
360 - Resolved issue that caused sfa hold onto idle db connections.
361 - Fix bug that caused the registry to use the wrong type of credential.
362 - Support authority+sm type.
363 - Fix rspec merging bugs.
364 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
365 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
366  planetlab hosted initscripts using the <planetlab:initscript> tag  
367 - Can now handle extraneous whitespace in the rspec without failing.   
368  
369 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
370 - ProtoGENI v2 RSpec updates.
371 - Convert expiration timestamps with timezone info in credentials to utc.
372 - Fixed redundant logging issue. 
373 - Improved SliceManager and SFI client logging.
374 - Support aggregates that don't support the optional 'call_id' argument. 
375 - Only call get_trusted_certs() at aggreage interfaces that support the call.
376 - CreateSliver() now handles MyPLC slice attributes/tags.
377 - Cache now supports persistence.
378 - Hide whitelisted nodes.
379
380 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
381 - fixed issues with sup authority signing
382 - fixed bugs in remove_slivers and SliverStatus
383
384 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
385 - fix typo that prevented aggregates from operating properly
386
387 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
388 - load trusted certs into ssl context prior to handshake
389 - client's logfile lives in ~/.sfi/sfi.log
390
391 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
392 - includes a change on passphrases that was intended in 1.0-22
393
394 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
395 - Added support for ProtoGENI RSpec v2
396  
397 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
398 - stable sfascan
399 - fix in initscript, *ENABLED tags in config now taken into account
400
401 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
402 - some commits had not been pushed in tag 19
403
404 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
405 - GetVersion should now report full URLs with path
406 - scansfa has nicer output and new syntax (entry URLs as args and not options)
407 - dos2unix'ed flash policy pill
408
409 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
410 - fix packaging again for f8
411
412 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
413 - fix packaging (apparently broken in 1.0-16)
414 - first working version of sfascan
415 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
416 - deprecated the sfa_geni_aggregate config category
417
418 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
419 - Fix build problem
420 - First version of SFA scanner
421
422 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
423 - Add support for Flash clients using flashpolicy
424 - Fix problems with tag handling in RSpec
425
426 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
427 - Modifications to the Eucalyptus Aggregate Manager
428 - Fixes for VINI RSpec
429 - Fix tag handling for PL RSpec
430 - Fix XML Schema ordering for <urn> element
431
432 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
433 - just set x509 version to 2
434
435 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
436 - added urn to the node area in rspecs
437 - conversion to urn now exports fqdn
438 - sfa-import-plc.py now creates a unique registry record for each SFA interface
439
440 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
441 - undo broken attempt for python-2.7
442
443 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
444 - SMs avoid duplicates for when call graph has dags;
445 - just based on network's name, when a duplicate occurs, one is just dropped
446 - does not try to merge/aggregate 2 networks
447 - also reviewed logging with the hope to fix the sfa startup msg:
448 - TypeError: not all arguments converted during string formatting
449
450 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
451 - verify credentials against xsd schema
452 - Fix SM to SM communication
453 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
454 - new setting session_key_path
455
456 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
457 - fix registry credential regeneration and handle expiration
458 - support for setting slice tags (min_role=user)
459 - client can display its own version: sfi.py version --local
460 - GetVersion to provide urn in addition to hrn
461 - more code uses plxrn vs previous helper functions
462 - import replaces '+' in email addresses with '_'
463
464 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
465 - fix GetVersion code_tag and add code_url
466
467 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
468 - extend GetVersion towards minimum federation introspection, and expose local tag
469
470 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
471 - fixed some legacy issues (list vs List)
472 - deprecated sfa.util.namespace for xrn and plxrn
473 - unit tests ship as the sfa-tests rpm
474
475 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
476 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
477 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
478 - hrn-urn translations tweaked
479 - fixed 'service sfa status'
480 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
481 - started to repair sfadump - although not usable yet
482 - trust objects now have dump_string method that dump() actually prints
483 - unit tests under review
484 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
485 - binaries now support -v or -vv to increase loglevel
486 - trashed obsolete sfa.util.client
487
488 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
489 - various bugfixes and cleanup, improved/harmonized logging
490
491 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
492 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
493   to avoid returning a PLCAPI exception that might confuse users.
494 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
495 - fix build errors.  
496
497 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
498 - (Architecture) Credential format changed to match ProtoGENI xml format
499 - (Architecture) All interfaces export a new set of methods that are compatible
500    with the ProtoGeni Aggregate spec. These new methods are considered a 
501    replacement  for the pervious methods exported by the interfaces. All 
502    previous methods are still exported and work as normal, but they are 
503    considered deprecated and will not be supported in future releases.  
504 - (Architecture) SFI has been updated to use the new interface methods.
505 - (Architecture) Changed keyconvet implementation from c to python.
506 - (Architecture) Slice Manager now attempts looks for a delegated credential
507   provided by the client before using its own server credential.
508 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
509   This cache now exists only in memory and is cleared when service is restarted
510   or cache lifetime is exceeded.  
511 - (Performance) SliceManager sends request to Aggregates in parallel instead 
512   of sequentially.
513 - (Bug fix) SFA tickets now support the new rspec format.
514 - (Bug fix) SFI only uses cahced credential if they aren't expired.
515 - (Bug fix) Cerdential delegation modified to work with new credential format.
516 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
517   Aggregate instead of relaying through the Slice Manager.
518 - (Enhancement) Simplified caching. Accociated a global cache instance with
519   the api handler on every new server request, making it easier to access the 
520   cache and use in more general ways.     
521
522 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
523 - SfaServer now uses a pool of threads to handle requests concurrently
524 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
525 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
526 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
527 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
528 - Component manager does not install gid files if slice already has them  
529 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
530 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
531 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
532      
533 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
534 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
535 - - sfa-config-tty now has the same features like plc-config-tty
536 - - Contains code to support both urn and hrn
537 - - Cleaned up request_hash related stuff
538 - - SM, AM and Registry code is organized under respective managers
539 - - Site and Slice synchronization across federated aggregates
540 - - Script to generate sfa_component_config
541
542 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
543 - sfa-config-tty now has the same features like plc-config-tty
544 - Contains code to support both urn and hrn
545 - Cleaned up request_hash related stuff
546 - SM, AM and Registry code is organized under respective managers
547 - Slice synchronization across federated aggregates
548 - some bugs are fixed
549
550 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
551 - checkpoint with fewer mentions of geni
552
553 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
554 - checkpointing
555 - this is believed to pass the tests; among other things:
556 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
557
558 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
559 - This tag includes:
560 - - Sfatables
561 - - Preliminary version of hash based authentication
562 - - Initial code for Component Manager
563 - - Authority structure is moved to /var/lib/sfa/
564 - - some bug-fixes
565
566 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
567 - Create_slice and get_resources methods are connected to sfatables.
568 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
569
570 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
571 - Bug fix on update and remove_peer_object methods
572 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
573
574 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
575 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
576
577 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
578 - compatibility with RefreshPeer
579 - incremental mechanism for importing PLC records into SFA tables
580 - unified single database (still inside the underlying PLC db postgresql server)
581 - includes/improves call traceability and logging features
582 - several bug fixes
583
584 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
585 - added libxslt-python dependency
586
587 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
588 - unified single SFA database in the PLC-DB
589 - upcalls from  PLCAPI to SFA methods
590 - SFA call traceability and logging features
591 - many bug fixes
592 - includes first/rough version of sfatables for policy implementation
593
594 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
595 - snapshot after the GEC5 demo
596 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
597
598 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
599 - snapshot july 15 - has gone through superficial manual testing
600 - hopefully a good basis for gec5 demo
601 - multi-dir sfi client tested as well
602
603 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
604 - rename geniwrapper.spec into sfa.spec
605
606 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
607 - clean up in xmlrpc/soap, --protocol option to chose between both
608 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
609 - hopefully more helpful context in case of crashes when importing
610 - bugfixes for using only /etc/sfa for site-dep files
611 - bugfixes in wsdl generation
612
613 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
614 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
615 - config variables in sfa_config now start with SFA_ and not GENI_
616 - config.py can be loaded even with no config present
617
618 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
619 - first step for cleanup and reorganization
620 - mass-renaming from geni to sfa (some are still needed)
621 - sfa/trust implements the security architecture
622
623 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
624 - snapshot for reproducible builds
625
626 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
627 - snapshot for the convenience of alpha users
628
629 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
630 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
631
632 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
633 - ongoing work - snapshot for 4.3-rc9
634
635 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
636 - various fixes
637
638 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
639 - bugfixes - still a work in progress
640
641 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
642 - initial package
643
644
645 %define module_current_branch 0.2