Merge branch 'geni-v2' of ssh://git.onelab.eu/git/sfa into geni-v2
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 19
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package nitos
92 Summary: the SFA layer around NITOS
93 Group: Applications/System
94 Requires: sfa
95
96 %package dummy
97 Summary: the SFA layer around a Dummy Testbed 
98 Group: Applications/System
99 Requires: sfa
100
101 %package sfatables
102 Summary: sfatables policy tool for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %package xmlbuilder
107 Summary: third-party xmlbuilder tool
108 Group: Applications/System
109 Provides: python-xmlbuilder
110
111 %package tests
112 Summary: unit tests suite for SFA
113 Group: Applications/System
114 Requires: sfa
115
116 %description
117 This package provides the python libraries for the PlanetLab implementation of SFA
118
119 %description flashpolicy
120 This package provides support for adobe flash client applications.  
121
122 %description client
123 This package provides the client side of the SFA API, in particular
124 sfi.py, together with other utilities.
125
126 %description plc
127 This package implements the SFA interface which serves as a layer
128 between the existing PlanetLab interfaces and the SFA API.
129
130 %description cm
131 This package implements the SFA interface which serves as a layer
132 between the existing PlanetLab NodeManager interfaces and the SFA API.
133
134 %description federica
135 The SFA driver for FEDERICA.
136
137 %description nitos
138 The SFA driver for NITOS.
139
140 %description dummy
141 The SFA driver for a Dummy Testbed.
142
143 %description sfatables
144 sfatables is a tool for defining access and admission control policies
145 in an SFA network, in much the same way as iptables is for ip
146 networks. This is the command line interface to manage sfatables
147
148 %description xmlbuilder
149 This package contains the xmlbuilder python library, packaged for
150 convenience as it is not supported by fedora
151
152 %description tests
153 Provides some binary unit tests in /usr/share/sfa/tests
154
155 %prep
156 %setup -q
157
158 %build
159 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %{python_sitelib}/sfa/__init__.py*
170 %{python_sitelib}/sfa/trust
171 %{python_sitelib}/sfa/storage
172 %{python_sitelib}/sfa/util
173 %{python_sitelib}/sfa/server
174 %{python_sitelib}/sfa/methods
175 %{python_sitelib}/sfa/generic
176 %{python_sitelib}/sfa/managers
177 %{python_sitelib}/sfa/importer
178 %{python_sitelib}/sfa/rspecs
179 %{python_sitelib}/sfa/client
180 /etc/init.d/sfa
181 %{_bindir}/sfa-start.py*
182 %{_bindir}/sfaadmin.py*
183 %{_bindir}/sfaadmin
184 %{_bindir}/keyconvert.py*
185 %{_bindir}/sfa-config-tty
186 %{_bindir}/sfa-config
187 %config /etc/sfa/default_config.xml
188 %config (noreplace) /etc/sfa/aggregates.xml
189 %config (noreplace) /etc/sfa/registries.xml
190 /usr/share/sfa/migrations
191 /usr/share/sfa/examples
192 /var/www/html/wsdl/*.wsdl
193
194 %files flashpolicy
195 %{_bindir}/sfa_flashpolicy.py*
196 /etc/sfa/sfa_flashpolicy_config.xml
197
198 %files client
199 %config (noreplace) /etc/sfa/sfi_config
200 %{_bindir}/sfi*.py*
201 %{_bindir}/sfi
202 %{_bindir}/get*.py*
203 %{_bindir}/setRecord.py*
204 %{_bindir}/sfascan.py*
205 %{_bindir}/sfascan
206 %{_bindir}/sfadump.py*
207
208 %files plc
209 %defattr(-,root,root)
210 %{python_sitelib}/sfa/planetlab
211 %{python_sitelib}/sfa/openstack
212 /etc/sfa/pl.rng
213 /etc/sfa/credential.xsd
214 /etc/sfa/top.xsd
215 /etc/sfa/sig.xsd
216 /etc/sfa/xml.xsd
217 /etc/sfa/protogeni-rspec-common.xsd
218 /etc/sfa/topology
219 %{_bindir}/gen-sfa-cm-config.py*
220
221 %files cm
222 /etc/init.d/sfa-cm
223 %{_bindir}/sfa_component_setup.py*
224 # cron jobs here 
225
226 %files federica
227 %{python_sitelib}/sfa/federica
228
229 %files nitos
230 %{python_sitelib}/sfa/nitos
231
232 %files dummy
233 %{python_sitelib}/sfa/dummy
234
235 %files sfatables
236 /etc/sfatables/*
237 %{_bindir}/sfatables
238 %{python_sitelib}/sfatables
239
240 %files xmlbuilder
241 %{python_sitelib}/xmlbuilder
242
243 %files tests
244 %{_datadir}/sfa/tests
245
246 ### sfa installs the 'sfa' service
247 %post 
248 chkconfig --add sfa
249
250 %preun 
251 if [ "$1" = 0 ] ; then
252   /sbin/service sfa stop || :
253   /sbin/chkconfig --del sfa || :
254 fi
255
256 %postun
257 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
258
259 ### sfa-cm installs the 'sfa-cm' service
260 %post cm
261 chkconfig --add sfa-cm
262
263 %preun cm
264 if [ "$1" = 0 ] ; then
265    /sbin/service sfa-cm stop || :
266    /sbin/chkconfig --del sfa-cm || :
267 fi
268
269 %postun cm
270 [ "$1" -ge "1" ] && service sfa-cm restart || :
271
272 %changelog
273 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
274 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
275
276 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
277 - support fordelegation in sfaclientlib
278 - sfi delegate fixed
279 - other delegation-related sfi option trashed
280 - new config (based on ini format)
281 - new dummy driver and related package
282 - pl importer has more explicit error messages
283 - credential dump shows expiration
284
285 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
286 - bugfix in forwarding Resolve requests
287 - various fixes in the nitos driver wrt keys and users
288
289 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
290 - various tweaks for the nitos driver
291
292 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
293 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
294 - deeper cleanup of the data-dependencies between SFA and the testbed
295 - in particular, sfi create issues Resolve(details=False)
296 - for that purpose, Resolve exposes reg-* keys for SFA builtins
297 - which in turn allows sfi list to show PIs, slice members and keys
298 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
299 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
300
301 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
302 - configurable data-dir (/var/lib/sfa)
303 - no more dependent on myplc-config
304 - some support for hrns with _ instead of \.
305 - fix for PL importing in presence of gpg keys
306 - DeleteSliver returns True instead of 1 in case of success
307 - Various improvements on the openstack/nova side
308 - new package sfa-nitos
309
310 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
311 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
312 - sfi to remove expired credentials
313
314 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
315 - Update Openstack driver to support Essex release/
316 - Fix authority xrn bug.
317   
318
319 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
320 - review packaging - site-packages/planetlab now come with sfa-plc
321 - new package sfa-federica
322 - clientbin moved one step upwards
323
324 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
325 - fix bug in sfi update()
326
327 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
328 - fix broken sfa.util.xrn class for lowercase
329
330 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
331 - new 'void' generic_flavour for running in registry-only mode
332 - first shot at refactoring importers - probably needs more work
333 - openstack: various enhancements
334 - sfi interface to registry not based on xml files anymore
335 - sfi show sorts result on record key
336 - bugfix in sfa update on users with a pl-backed registry
337
338 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
339 - renamed sfa/plc into sfa/planetlab
340 - plxrn moved in sfa/planetlab as well
341 - bugfix for sfaadmin reg update --pi <>
342
343 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
344 - native data model now has a authority x user (PI) relationship
345 - no call to 'augment_records_with_testbed_info' for GetCredential
346 - which means, registry can now be used without an underlying testbed
347 - reviewed code about relationships b/w objects and related in pl driver
348 - reviewed PL import wrt roles and pis
349 - removed mentions to is_enabled in driver
350 - small changes in update_relation* in driver interface
351 - sfaadmin: can create authorities and attach pi users to them
352 - sfaadmin: categories can be abbreviated
353 - sfi list and sfaadmin list have a new -r/--recursive option
354 - this means that List now supports an (optional) 'options' argument
355 - sfi config can display config vars
356 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
357
358 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
359 - make sync now supports vserver or lxc.
360 - Added slice expiration and login info to SliverStatus response. 
361 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
362   the 'component_name' attribute.
363 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
364   
365 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
366 - Introduced new administrative command line script, sfaadmin.py. Removed various single
367  purpose scripts and migrated their functionality into sfaadmin.py.
368 - Refactored Registry import scripts.
369 - Removed SQLAlchemy dependency from sfi.py.
370 - Fixed bugs in sfi.py
371 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
372
373 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
374 - slice x researcher rel. in database,
375 - plimporter to maintain that, as well as user.email, and more robust
376 - ongoing draft for sfaadmin tool
377 - support for a federica driver
378 - support for a nova/euca driver
379 - no more sfa-clean-peer-records script
380
381 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
382 - registry database has user's keys and mail (known as v0 for migrate)
383 - pl importer properly maintains user's keys and mail
384 - pl driver now to handle 'role' when adding person record (exp.)
385 - first draft of federica driver with config section
386 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
387 - plus, from master as of tag merged-in-sfa-2.1-2:
388 - disk_image revisited
389 - new nova_shell nova_driver & various tweaks for openstack
390
391 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
392 - uses sqlalchemy and related migrate
393 - thorough migration and upgrade scheme
394 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
395 - trashed dbinfo stuff in auth hierarchy
396 - data model still has little more than plain records
397 - checkpoint tag, not yet intended for release
398
399 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
400 - client: added -R --raw sfi cmdline option that displays raw server response.
401 - client: request GENI RSpec by default. 
402 - server: remove database dependencies from sfa.server.sfaapi.
403 - server: increased default credential lifetime to 31 days.
404 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
405 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
406 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
407  
408 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
409 - bugfix: 'geni_api' should be in the top level struct, not the code struct
410 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
411           output returned by the Aggregate Manager.
412 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
413 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
414 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
415           there is extra whitespace in the schemaLocation field.
416 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
417           advertisement rspecs.
418 - bugfix: <login> RSpec element should contain the 'username' attribute.
419 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
420  
421 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
422 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
423   exit when it encountered a user with an invalid public key.
424 - server: imporved logging in sfa-import-plc.py
425  
426 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
427 - bugfix: Fixed appending public keys in CreateSliver
428 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
429 - client: -c --current option allows users to request the current/uncached rspec.
430 - server: Added 'geni_api_versions' field to GetVersion() output.
431 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
432    
433 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
434 - bugfix: sfi was not sending call_id with ListResources to v2 servers
435 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
436 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
437
438 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
439 - client: sfi -a / -p deprecated (use -s instead)
440 - client: sfi cleaned up
441 - client: sfi has backward support for APIv1 aggregates again
442 - server: only APIv2 is supported and should be rather strict
443 - server: settings for turning on/off caching in sm or am
444 - server: plc-dependant code has moved from aggregate to pldriver
445 - server: driver interface extended accordingly
446
447 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
448 - screwed up previous tag
449
450 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
451 - client side revisited with a bootstrap library
452 - client side has a new source layout
453 - various (nasty) bug fixes wrt options and call_id
454
455 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
456 - various fixes in rspecs for sfav1&slice tags
457 - uses 'geni_rspec_version' and not just 'rspec_version'
458 - example flavour for the max testbed
459 - embryo for an sfa client library
460 - topology.py moved into plc
461 - sql: table is named records; record_types are enforced
462 - sql: table creation cleaned up
463
464 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
465 - cleaned up all references to SFA_*_TYPE in config
466 - enable cache at the aggregate by default
467 - registry now uses the driver in a sensible way (see managers/driver.py)
468 - slice manager supports sfav1/pgv2 neighbours
469 - get_key renamed into get_key_from_incoming_ip
470 - new sfa.storage module for record/table and all db-related stuff
471 - db schema in sfa.storage.sfa.sql
472 - init.d and cron.d move one step up
473 - cleaned up rspec/ directory
474 - add deps to pyopenssl and myplc-config
475 - start support for new API (return value)
476 - plc.remoteshell removed, use plshell instead
477 - plshell uses a 'capability' auth method whenever possible
478 - various tweaks in rspec elements
479 - made dependency on sfatables softer
480
481 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
482 - sfa should now be started *before* the initial import
483 - sfa to use its own database (default sfa) - can run without myplc
484 - server calls support optional 'options'
485 - client sends options in argument when needed
486 - fix infinite getattr recursion in elements/element.py
487 - error codes in line with geni
488
489 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
490 - fixed links and attributes in rspecs
491 - minor cleanup in the API methods, and more consistent names in manager methods
492
493 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
494 - ongoing refoactoring towards more genericity
495 - passes tests again although known issues remain with attributes/tags
496
497 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
498 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
499 - improvements in the pgv2 rspecs
500 - driver separated from api
501 - code starts moving around where it belongs
502 - sfascan caches getversion across invokations
503 - vini topology extracted as a config file
504
505 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
506 - first support for protogeni rspecs is working
507 - vini no longer needs a specific manager
508 - refactoring underway towards more flexible/generic architecture
509
510 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
511 - Unicode-friendliness for user names with accents/special chars.
512 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
513 - CreaetSliver no longer fails for users that have a capital letter in their URN.
514 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
515 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
516 - Fix bugs and missing imports     
517  
518
519 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
520 - new method record.get_field for sface
521
522 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
523 - new option -c to sfa-nuke-plc.py
524 - CreateSliver fixed for admin-only slice tags
525
526 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
527 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
528 - Fixed holes in certificate verification logic.
529 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
530 - Added 'boot_state' as an attribute of the node element in SFA rspec.
531 - Non authority certificates are marked as CA:FALSE.
532
533 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
534 - fix typo in sfa-1.0-31 tag.
535 - added CreateGid() Registry interface method.
536
537 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
538 - fix typo in sfa-1.0-30 tag
539
540 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
541 - Declare namespace and schema location in the credential.
542 - Fix bug that prevetend connections from timing out.
543 - Fix slice delegation.
544 - Add statistics to slicemaanger listresources/createsliver rspec.
545 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
546   of days a user can extend their slice expiration.
547 - CA certs are only issued to objects of type authority
548    
549 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
550 - tag 1.0-28 was broken due to typo in the changelog
551 - new class sfa/util/httpsProtocol.py that supports timeouts
552
553 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
554 - Resolved issue that caused sfa hold onto idle db connections.
555 - Fix bug that caused the registry to use the wrong type of credential.
556 - Support authority+sm type.
557 - Fix rspec merging bugs.
558 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
559 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
560  planetlab hosted initscripts using the <planetlab:initscript> tag  
561 - Can now handle extraneous whitespace in the rspec without failing.   
562  
563 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
564 - ProtoGENI v2 RSpec updates.
565 - Convert expiration timestamps with timezone info in credentials to utc.
566 - Fixed redundant logging issue. 
567 - Improved SliceManager and SFI client logging.
568 - Support aggregates that don't support the optional 'call_id' argument. 
569 - Only call get_trusted_certs() at aggreage interfaces that support the call.
570 - CreateSliver() now handles MyPLC slice attributes/tags.
571 - Cache now supports persistence.
572 - Hide whitelisted nodes.
573
574 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
575 - fixed issues with sup authority signing
576 - fixed bugs in remove_slivers and SliverStatus
577
578 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
579 - fix typo that prevented aggregates from operating properly
580
581 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
582 - load trusted certs into ssl context prior to handshake
583 - client's logfile lives in ~/.sfi/sfi.log
584
585 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
586 - includes a change on passphrases that was intended in 1.0-22
587
588 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
589 - Added support for ProtoGENI RSpec v2
590  
591 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
592 - stable sfascan
593 - fix in initscript, *ENABLED tags in config now taken into account
594
595 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
596 - some commits had not been pushed in tag 19
597
598 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
599 - GetVersion should now report full URLs with path
600 - scansfa has nicer output and new syntax (entry URLs as args and not options)
601 - dos2unix'ed flash policy pill
602
603 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
604 - fix packaging again for f8
605
606 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
607 - fix packaging (apparently broken in 1.0-16)
608 - first working version of sfascan
609 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
610 - deprecated the sfa_geni_aggregate config category
611
612 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
613 - Fix build problem
614 - First version of SFA scanner
615
616 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
617 - Add support for Flash clients using flashpolicy
618 - Fix problems with tag handling in RSpec
619
620 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
621 - Modifications to the Eucalyptus Aggregate Manager
622 - Fixes for VINI RSpec
623 - Fix tag handling for PL RSpec
624 - Fix XML Schema ordering for <urn> element
625
626 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
627 - just set x509 version to 2
628
629 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
630 - added urn to the node area in rspecs
631 - conversion to urn now exports fqdn
632 - sfa-import-plc.py now creates a unique registry record for each SFA interface
633
634 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
635 - undo broken attempt for python-2.7
636
637 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
638 - SMs avoid duplicates for when call graph has dags;
639 - just based on network's name, when a duplicate occurs, one is just dropped
640 - does not try to merge/aggregate 2 networks
641 - also reviewed logging with the hope to fix the sfa startup msg:
642 - TypeError: not all arguments converted during string formatting
643
644 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
645 - verify credentials against xsd schema
646 - Fix SM to SM communication
647 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
648 - new setting session_key_path
649
650 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
651 - fix registry credential regeneration and handle expiration
652 - support for setting slice tags (min_role=user)
653 - client can display its own version: sfi.py version --local
654 - GetVersion to provide urn in addition to hrn
655 - more code uses plxrn vs previous helper functions
656 - import replaces '+' in email addresses with '_'
657
658 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
659 - fix GetVersion code_tag and add code_url
660
661 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
662 - extend GetVersion towards minimum federation introspection, and expose local tag
663
664 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
665 - fixed some legacy issues (list vs List)
666 - deprecated sfa.util.namespace for xrn and plxrn
667 - unit tests ship as the sfa-tests rpm
668
669 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
670 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
671 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
672 - hrn-urn translations tweaked
673 - fixed 'service sfa status'
674 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
675 - started to repair sfadump - although not usable yet
676 - trust objects now have dump_string method that dump() actually prints
677 - unit tests under review
678 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
679 - binaries now support -v or -vv to increase loglevel
680 - trashed obsolete sfa.util.client
681
682 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
683 - various bugfixes and cleanup, improved/harmonized logging
684
685 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
686 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
687   to avoid returning a PLCAPI exception that might confuse users.
688 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
689 - fix build errors.  
690
691 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
692 - (Architecture) Credential format changed to match ProtoGENI xml format
693 - (Architecture) All interfaces export a new set of methods that are compatible
694    with the ProtoGeni Aggregate spec. These new methods are considered a 
695    replacement  for the pervious methods exported by the interfaces. All 
696    previous methods are still exported and work as normal, but they are 
697    considered deprecated and will not be supported in future releases.  
698 - (Architecture) SFI has been updated to use the new interface methods.
699 - (Architecture) Changed keyconvet implementation from c to python.
700 - (Architecture) Slice Manager now attempts looks for a delegated credential
701   provided by the client before using its own server credential.
702 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
703   This cache now exists only in memory and is cleared when service is restarted
704   or cache lifetime is exceeded.  
705 - (Performance) SliceManager sends request to Aggregates in parallel instead 
706   of sequentially.
707 - (Bug fix) SFA tickets now support the new rspec format.
708 - (Bug fix) SFI only uses cahced credential if they aren't expired.
709 - (Bug fix) Cerdential delegation modified to work with new credential format.
710 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
711   Aggregate instead of relaying through the Slice Manager.
712 - (Enhancement) Simplified caching. Accociated a global cache instance with
713   the api handler on every new server request, making it easier to access the 
714   cache and use in more general ways.     
715
716 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
717 - SfaServer now uses a pool of threads to handle requests concurrently
718 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
719 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
720 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
721 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
722 - Component manager does not install gid files if slice already has them  
723 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
724 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
725 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
726      
727 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
728 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
729 - - sfa-config-tty now has the same features like plc-config-tty
730 - - Contains code to support both urn and hrn
731 - - Cleaned up request_hash related stuff
732 - - SM, AM and Registry code is organized under respective managers
733 - - Site and Slice synchronization across federated aggregates
734 - - Script to generate sfa_component_config
735
736 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
737 - sfa-config-tty now has the same features like plc-config-tty
738 - Contains code to support both urn and hrn
739 - Cleaned up request_hash related stuff
740 - SM, AM and Registry code is organized under respective managers
741 - Slice synchronization across federated aggregates
742 - some bugs are fixed
743
744 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
745 - checkpoint with fewer mentions of geni
746
747 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
748 - checkpointing
749 - this is believed to pass the tests; among other things:
750 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
751
752 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
753 - This tag includes:
754 - - Sfatables
755 - - Preliminary version of hash based authentication
756 - - Initial code for Component Manager
757 - - Authority structure is moved to /var/lib/sfa/
758 - - some bug-fixes
759
760 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
761 - Create_slice and get_resources methods are connected to sfatables.
762 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
763
764 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
765 - Bug fix on update and remove_peer_object methods
766 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
767
768 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
769 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
770
771 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
772 - compatibility with RefreshPeer
773 - incremental mechanism for importing PLC records into SFA tables
774 - unified single database (still inside the underlying PLC db postgresql server)
775 - includes/improves call traceability and logging features
776 - several bug fixes
777
778 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
779 - added libxslt-python dependency
780
781 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
782 - unified single SFA database in the PLC-DB
783 - upcalls from  PLCAPI to SFA methods
784 - SFA call traceability and logging features
785 - many bug fixes
786 - includes first/rough version of sfatables for policy implementation
787
788 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
789 - snapshot after the GEC5 demo
790 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
791
792 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
793 - snapshot july 15 - has gone through superficial manual testing
794 - hopefully a good basis for gec5 demo
795 - multi-dir sfi client tested as well
796
797 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
798 - rename geniwrapper.spec into sfa.spec
799
800 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
801 - clean up in xmlrpc/soap, --protocol option to chose between both
802 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
803 - hopefully more helpful context in case of crashes when importing
804 - bugfixes for using only /etc/sfa for site-dep files
805 - bugfixes in wsdl generation
806
807 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
808 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
809 - config variables in sfa_config now start with SFA_ and not GENI_
810 - config.py can be loaded even with no config present
811
812 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
813 - first step for cleanup and reorganization
814 - mass-renaming from geni to sfa (some are still needed)
815 - sfa/trust implements the security architecture
816
817 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
818 - snapshot for reproducible builds
819
820 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
821 - snapshot for the convenience of alpha users
822
823 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
824 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
825
826 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
827 - ongoing work - snapshot for 4.3-rc9
828
829 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
830 - various fixes
831
832 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
833 - bugfixes - still a work in progress
834
835 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
836 - initial package
837
838
839 %define module_current_branch 0.2