Setting tag sfa-2.0-6
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45 Requires: python-xmlbuilder
46  
47 # python 2.5 has uuid module added, for python 2.4 we still need it.
48 # we can't really check for if we can load uuid as a python module,
49 # it'll be installed by "devel.pkgs". we have the epel repository so
50 # python-uuid will be provided. but we can test for the python
51 # version.
52 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
53 # %if %has_py24
54 #
55 # this also didn't work very well. I'll just check for distroname - baris
56 #%if %{distroname} == "centos5"
57 #Requires: python-uuid
58 #%endif
59
60 %package plc
61 Summary: the SFA layer around MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package cm
78 Summary: the SFA layer around MyPLC NodeManager
79 Group: Applications/System
80 Requires: sfa
81 Requires: pyOpenSSL >= 0.6
82
83 %package flashpolicy
84 Summary: SFA support for flash clients
85 Group: Applications/System
86 Requires: sfa
87
88 %package xmlbuilder
89 Summary: third-party xmlbuilder tool
90 Group: Applications/System
91 Provides: python-xmlbuilder
92
93 %package tests
94 Summary: unit tests suite for SFA
95 Group: Applications/System
96 Requires: sfa
97
98 %description
99 This package provides the python libraries for the PlanetLab implementation of SFA
100
101 %description plc
102 This package implements the SFA interface which serves as a layer
103 between the existing PlanetLab interfaces and the SFA API.
104
105 %description client
106 This package provides the client side of the SFA API, in particular
107 sfi.py, together with other utilities.
108
109 %description sfatables
110 sfatables is a tool for defining access and admission control policies
111 in an SFA network, in much the same way as iptables is for ip
112 networks. This is the command line interface to manage sfatables
113
114 %description cm
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab NodeManager interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description xmlbuilder
122 This package contains the xmlbuilder python library, packaged for
123 convenience as it is not supported by fedora
124
125 %description tests
126 Provides some binary unit tests in /usr/share/sfa/tests
127
128 %prep
129 %setup -q
130
131 %build
132 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 # sfa and sfatables depend on each other.
143 %{python_sitelib}/sfa
144 /etc/init.d/sfa
145 %{_bindir}/sfa-start.py*
146 %{_bindir}/keyconvert.py*
147 %{_bindir}/sfa-config-tty
148 %config /etc/sfa/default_config.xml
149 %config (noreplace) /etc/sfa/aggregates.xml
150 %config (noreplace) /etc/sfa/registries.xml
151 /usr/share/sfa/sfa.sql
152 /usr/share/sfa/examples
153 /var/www/html/wsdl/*.wsdl
154
155 %files plc
156 %defattr(-,root,root)
157 /etc/sfa/pl.rng
158 /etc/sfa/credential.xsd
159 /etc/sfa/top.xsd
160 /etc/sfa/sig.xsd
161 /etc/sfa/xml.xsd
162 /etc/sfa/protogeni-rspec-common.xsd
163 /etc/sfa/topology
164 %{_bindir}/sfa-import-plc.py*
165 %{_bindir}/sfa-nuke-plc.py*
166 %{_bindir}/sfa-clean-peer-records.py*
167 %{_bindir}/gen-sfa-cm-config.py*
168 %{_bindir}/sfa-ca.py*
169
170 %files client
171 %config (noreplace) /etc/sfa/sfi_config
172 %{_bindir}/sfi*.py*
173 %{_bindir}/sfi
174 %{_bindir}/get*.py*
175 %{_bindir}/setRecord.py*
176 %{_bindir}/sfascan.py*
177 %{_bindir}/sfascan
178 %{_bindir}/sfadump.py*
179
180 %files sfatables
181 /etc/sfatables/*
182 %{_bindir}/sfatables
183 %{python_sitelib}/sfatables
184
185 %files cm
186 /etc/init.d/sfa-cm
187 %{_bindir}/sfa_component_setup.py*
188 # cron jobs here 
189
190 %files flashpolicy
191 %{_bindir}/sfa_flashpolicy.py*
192 /etc/sfa/sfa_flashpolicy_config.xml
193
194 %files xmlbuilder
195 %{python_sitelib}/xmlbuilder
196
197 %files tests
198 %{_datadir}/sfa/tests
199
200 ### sfa-plc installs the 'sfa' service
201 %post plc
202 chkconfig --add sfa
203
204 %preun plc
205 if [ "$1" = 0 ] ; then
206   /sbin/service sfa stop || :
207   /sbin/chkconfig --del sfa || :
208 fi
209
210 %postun plc
211 [ "$1" -ge "1" ] && service sfa restart
212
213 ### sfa-cm installs the 'sfa-cm' service
214 %post cm
215 chkconfig --add sfa-cm
216
217 %preun cm
218 if [ "$1" = 0 ] ; then
219    /sbin/service sfa-cm stop || :
220    /sbin/chkconfig --del sfa-cm || :
221 fi
222
223 %postun cm
224 [ "$1" -ge "1" ] && service sfa-cm restart || :
225
226 %changelog
227 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
228 - bugfix: sfi was not sending call_id with ListResources to v2 servers
229 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
230 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
231
232 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
233 - client: sfi -a / -p deprecated (use -s instead)
234 - client: sfi cleaned up
235 - client: sfi has backward support for APIv1 aggregates again
236 - server: only APIv2 is supported and should be rather strict
237 - server: settings for turning on/off caching in sm or am
238 - server: plc-dependant code has moved from aggregate to pldriver
239 - server: driver interface extended accordingly
240
241 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
242 - screwed up previous tag
243
244 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
245 - client side revisited with a bootstrap library
246 - client side has a new source layout
247 - various (nasty) bug fixes wrt options and call_id
248
249 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
250 - various fixes in rspecs for sfav1&slice tags
251 - uses 'geni_rspec_version' and not just 'rspec_version'
252 - example flavour for the max testbed
253 - embryo for an sfa client library
254 - topology.py moved into plc
255 - sql: table is named records; record_types are enforced
256 - sql: table creation cleaned up
257
258 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
259 - cleaned up all references to SFA_*_TYPE in config
260 - enable cache at the aggregate by default
261 - registry now uses the driver in a sensible way (see managers/driver.py)
262 - slice manager supports sfav1/pgv2 neighbours
263 - get_key renamed into get_key_from_incoming_ip
264 - new sfa.storage module for record/table and all db-related stuff
265 - db schema in sfa.storage.sfa.sql
266 - init.d and cron.d move one step up
267 - cleaned up rspec/ directory
268 - add deps to pyopenssl and myplc-config
269 - start support for new API (return value)
270 - plc.remoteshell removed, use plshell instead
271 - plshell uses a 'capability' auth method whenever possible
272 - various tweaks in rspec elements
273 - made dependency on sfatables softer
274
275 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
276 - sfa should now be started *before* the initial import
277 - sfa to use its own database (default sfa) - can run without myplc
278 - server calls support optional 'options'
279 - client sends options in argument when needed
280 - fix infinite getattr recursion in elements/element.py
281 - error codes in line with geni
282
283 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
284 - fixed links and attributes in rspecs
285 - minor cleanup in the API methods, and more consistent names in manager methods
286
287 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
288 - ongoing refoactoring towards more genericity
289 - passes tests again although known issues remain with attributes/tags
290
291 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
292 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
293 - improvements in the pgv2 rspecs
294 - driver separated from api
295 - code starts moving around where it belongs
296 - sfascan caches getversion across invokations
297 - vini topology extracted as a config file
298
299 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
300 - first support for protogeni rspecs is working
301 - vini no longer needs a specific manager
302 - refactoring underway towards more flexible/generic architecture
303
304 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
305 - Unicode-friendliness for user names with accents/special chars.
306 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
307 - CreaetSliver no longer fails for users that have a capital letter in their URN.
308 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
309 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
310 - Fix bugs and missing imports     
311  
312
313 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
314 - new method record.get_field for sface
315
316 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
317 - new option -c to sfa-nuke-plc.py
318 - CreateSliver fixed for admin-only slice tags
319
320 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
321 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
322 - Fixed holes in certificate verification logic.
323 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
324 - Added 'boot_state' as an attribute of the node element in SFA rspec.
325 - Non authority certificates are marked as CA:FALSE.
326
327 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
328 - fix typo in sfa-1.0-31 tag.
329 - added CreateGid() Registry interface method.
330
331 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
332 - fix typo in sfa-1.0-30 tag
333
334 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
335 - Declare namespace and schema location in the credential.
336 - Fix bug that prevetend connections from timing out.
337 - Fix slice delegation.
338 - Add statistics to slicemaanger listresources/createsliver rspec.
339 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
340   of days a user can extend their slice expiration.
341 - CA certs are only issued to objects of type authority
342    
343 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
344 - tag 1.0-28 was broken due to typo in the changelog
345 - new class sfa/util/httpsProtocol.py that supports timeouts
346
347 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
348 - Resolved issue that caused sfa hold onto idle db connections.
349 - Fix bug that caused the registry to use the wrong type of credential.
350 - Support authority+sm type.
351 - Fix rspec merging bugs.
352 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
353 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
354  planetlab hosted initscripts using the <planetlab:initscript> tag  
355 - Can now handle extraneous whitespace in the rspec without failing.   
356  
357 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
358 - ProtoGENI v2 RSpec updates.
359 - Convert expiration timestamps with timezone info in credentials to utc.
360 - Fixed redundant logging issue. 
361 - Improved SliceManager and SFI client logging.
362 - Support aggregates that don't support the optional 'call_id' argument. 
363 - Only call get_trusted_certs() at aggreage interfaces that support the call.
364 - CreateSliver() now handles MyPLC slice attributes/tags.
365 - Cache now supports persistence.
366 - Hide whitelisted nodes.
367
368 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
369 - fixed issues with sup authority signing
370 - fixed bugs in remove_slivers and SliverStatus
371
372 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
373 - fix typo that prevented aggregates from operating properly
374
375 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
376 - load trusted certs into ssl context prior to handshake
377 - client's logfile lives in ~/.sfi/sfi.log
378
379 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
380 - includes a change on passphrases that was intended in 1.0-22
381
382 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
383 - Added support for ProtoGENI RSpec v2
384  
385 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
386 - stable sfascan
387 - fix in initscript, *ENABLED tags in config now taken into account
388
389 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
390 - some commits had not been pushed in tag 19
391
392 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
393 - GetVersion should now report full URLs with path
394 - scansfa has nicer output and new syntax (entry URLs as args and not options)
395 - dos2unix'ed flash policy pill
396
397 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
398 - fix packaging again for f8
399
400 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
401 - fix packaging (apparently broken in 1.0-16)
402 - first working version of sfascan
403 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
404 - deprecated the sfa_geni_aggregate config category
405
406 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
407 - Fix build problem
408 - First version of SFA scanner
409
410 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
411 - Add support for Flash clients using flashpolicy
412 - Fix problems with tag handling in RSpec
413
414 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
415 - Modifications to the Eucalyptus Aggregate Manager
416 - Fixes for VINI RSpec
417 - Fix tag handling for PL RSpec
418 - Fix XML Schema ordering for <urn> element
419
420 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
421 - just set x509 version to 2
422
423 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
424 - added urn to the node area in rspecs
425 - conversion to urn now exports fqdn
426 - sfa-import-plc.py now creates a unique registry record for each SFA interface
427
428 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
429 - undo broken attempt for python-2.7
430
431 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
432 - SMs avoid duplicates for when call graph has dags;
433 - just based on network's name, when a duplicate occurs, one is just dropped
434 - does not try to merge/aggregate 2 networks
435 - also reviewed logging with the hope to fix the sfa startup msg:
436 - TypeError: not all arguments converted during string formatting
437
438 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
439 - verify credentials against xsd schema
440 - Fix SM to SM communication
441 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
442 - new setting session_key_path
443
444 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
445 - fix registry credential regeneration and handle expiration
446 - support for setting slice tags (min_role=user)
447 - client can display its own version: sfi.py version --local
448 - GetVersion to provide urn in addition to hrn
449 - more code uses plxrn vs previous helper functions
450 - import replaces '+' in email addresses with '_'
451
452 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
453 - fix GetVersion code_tag and add code_url
454
455 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
456 - extend GetVersion towards minimum federation introspection, and expose local tag
457
458 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
459 - fixed some legacy issues (list vs List)
460 - deprecated sfa.util.namespace for xrn and plxrn
461 - unit tests ship as the sfa-tests rpm
462
463 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
464 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
465 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
466 - hrn-urn translations tweaked
467 - fixed 'service sfa status'
468 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
469 - started to repair sfadump - although not usable yet
470 - trust objects now have dump_string method that dump() actually prints
471 - unit tests under review
472 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
473 - binaries now support -v or -vv to increase loglevel
474 - trashed obsolete sfa.util.client
475
476 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
477 - various bugfixes and cleanup, improved/harmonized logging
478
479 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
480 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
481   to avoid returning a PLCAPI exception that might confuse users.
482 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
483 - fix build errors.  
484
485 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
486 - (Architecture) Credential format changed to match ProtoGENI xml format
487 - (Architecture) All interfaces export a new set of methods that are compatible
488    with the ProtoGeni Aggregate spec. These new methods are considered a 
489    replacement  for the pervious methods exported by the interfaces. All 
490    previous methods are still exported and work as normal, but they are 
491    considered deprecated and will not be supported in future releases.  
492 - (Architecture) SFI has been updated to use the new interface methods.
493 - (Architecture) Changed keyconvet implementation from c to python.
494 - (Architecture) Slice Manager now attempts looks for a delegated credential
495   provided by the client before using its own server credential.
496 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
497   This cache now exists only in memory and is cleared when service is restarted
498   or cache lifetime is exceeded.  
499 - (Performance) SliceManager sends request to Aggregates in parallel instead 
500   of sequentially.
501 - (Bug fix) SFA tickets now support the new rspec format.
502 - (Bug fix) SFI only uses cahced credential if they aren't expired.
503 - (Bug fix) Cerdential delegation modified to work with new credential format.
504 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
505   Aggregate instead of relaying through the Slice Manager.
506 - (Enhancement) Simplified caching. Accociated a global cache instance with
507   the api handler on every new server request, making it easier to access the 
508   cache and use in more general ways.     
509
510 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
511 - SfaServer now uses a pool of threads to handle requests concurrently
512 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
513 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
514 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
515 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
516 - Component manager does not install gid files if slice already has them  
517 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
518 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
519 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
520      
521 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
522 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
523 - - sfa-config-tty now has the same features like plc-config-tty
524 - - Contains code to support both urn and hrn
525 - - Cleaned up request_hash related stuff
526 - - SM, AM and Registry code is organized under respective managers
527 - - Site and Slice synchronization across federated aggregates
528 - - Script to generate sfa_component_config
529
530 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
531 - sfa-config-tty now has the same features like plc-config-tty
532 - Contains code to support both urn and hrn
533 - Cleaned up request_hash related stuff
534 - SM, AM and Registry code is organized under respective managers
535 - Slice synchronization across federated aggregates
536 - some bugs are fixed
537
538 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
539 - checkpoint with fewer mentions of geni
540
541 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
542 - checkpointing
543 - this is believed to pass the tests; among other things:
544 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
545
546 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
547 - This tag includes:
548 - - Sfatables
549 - - Preliminary version of hash based authentication
550 - - Initial code for Component Manager
551 - - Authority structure is moved to /var/lib/sfa/
552 - - some bug-fixes
553
554 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
555 - Create_slice and get_resources methods are connected to sfatables.
556 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
557
558 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
559 - Bug fix on update and remove_peer_object methods
560 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
561
562 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
563 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
564
565 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
566 - compatibility with RefreshPeer
567 - incremental mechanism for importing PLC records into SFA tables
568 - unified single database (still inside the underlying PLC db postgresql server)
569 - includes/improves call traceability and logging features
570 - several bug fixes
571
572 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
573 - added libxslt-python dependency
574
575 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
576 - unified single SFA database in the PLC-DB
577 - upcalls from  PLCAPI to SFA methods
578 - SFA call traceability and logging features
579 - many bug fixes
580 - includes first/rough version of sfatables for policy implementation
581
582 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
583 - snapshot after the GEC5 demo
584 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
585
586 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
587 - snapshot july 15 - has gone through superficial manual testing
588 - hopefully a good basis for gec5 demo
589 - multi-dir sfi client tested as well
590
591 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
592 - rename geniwrapper.spec into sfa.spec
593
594 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
595 - clean up in xmlrpc/soap, --protocol option to chose between both
596 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
597 - hopefully more helpful context in case of crashes when importing
598 - bugfixes for using only /etc/sfa for site-dep files
599 - bugfixes in wsdl generation
600
601 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
602 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
603 - config variables in sfa_config now start with SFA_ and not GENI_
604 - config.py can be loaded even with no config present
605
606 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
607 - first step for cleanup and reorganization
608 - mass-renaming from geni to sfa (some are still needed)
609 - sfa/trust implements the security architecture
610
611 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
612 - snapshot for reproducible builds
613
614 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
615 - snapshot for the convenience of alpha users
616
617 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
618 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
619
620 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
621 - ongoing work - snapshot for 4.3-rc9
622
623 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
624 - various fixes
625
626 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
627 - bugfixes - still a work in progress
628
629 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
630 - initial package
631
632
633 %define module_current_branch 0.2