add symlink /usr/bin/sfaadmin (without the .py)
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/sfaadmin.py*
152 %{_bindir}/sfaadmin
153 %{_bindir}/keyconvert.py*
154 %{_bindir}/sfa-config-tty
155 %config /etc/sfa/default_config.xml
156 %config (noreplace) /etc/sfa/aggregates.xml
157 %config (noreplace) /etc/sfa/registries.xml
158 /usr/share/sfa/migrations
159 /usr/share/sfa/examples
160 /var/www/html/wsdl/*.wsdl
161
162 %files plc
163 %defattr(-,root,root)
164 /etc/sfa/pl.rng
165 /etc/sfa/credential.xsd
166 /etc/sfa/top.xsd
167 /etc/sfa/sig.xsd
168 /etc/sfa/xml.xsd
169 /etc/sfa/protogeni-rspec-common.xsd
170 /etc/sfa/topology
171 %{_bindir}/gen-sfa-cm-config.py*
172
173 %files client
174 %config (noreplace) /etc/sfa/sfi_config
175 %{_bindir}/sfi*.py*
176 %{_bindir}/sfi
177 %{_bindir}/get*.py*
178 %{_bindir}/setRecord.py*
179 %{_bindir}/sfascan.py*
180 %{_bindir}/sfascan
181 %{_bindir}/sfadump.py*
182
183 %files sfatables
184 /etc/sfatables/*
185 %{_bindir}/sfatables
186 %{python_sitelib}/sfatables
187
188 %files cm
189 /etc/init.d/sfa-cm
190 %{_bindir}/sfa_component_setup.py*
191 # cron jobs here 
192
193 %files flashpolicy
194 %{_bindir}/sfa_flashpolicy.py*
195 /etc/sfa/sfa_flashpolicy_config.xml
196
197 %files xmlbuilder
198 %{python_sitelib}/xmlbuilder
199
200 %files tests
201 %{_datadir}/sfa/tests
202
203 ### sfa installs the 'sfa' service
204 %post 
205 chkconfig --add sfa
206
207 %preun 
208 if [ "$1" = 0 ] ; then
209   /sbin/service sfa stop || :
210   /sbin/chkconfig --del sfa || :
211 fi
212
213 %postun
214 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
215
216 ### sfa-cm installs the 'sfa-cm' service
217 %post cm
218 chkconfig --add sfa-cm
219
220 %preun cm
221 if [ "$1" = 0 ] ; then
222    /sbin/service sfa-cm stop || :
223    /sbin/chkconfig --del sfa-cm || :
224 fi
225
226 %postun cm
227 [ "$1" -ge "1" ] && service sfa-cm restart || :
228
229 %changelog
230 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
231 - make sync now supports vserver or lxc.
232 - Added slice expiration and login info to SliverStatus response. 
233 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
234   the 'component_name' attribute.
235 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
236   
237 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
238 - Introduced new administrative command line script, sfaadmin.py. Removed various single
239  purpose scripts and migrated their functionality into sfaadmin.py.
240 - Refactored Registry import scripts.
241 - Removed SQLAlchemy dependency from sfi.py.
242 - Fixed bugs in sfi.py
243 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
244
245 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
246 - slice x researcher rel. in database,
247 - plimporter to maintain that, as well as user.email, and more robust
248 - ongoing draft for sfaadmin tool
249 - support for a federica driver
250 - support for a nova/euca driver
251 - no more sfa-clean-peer-records script
252
253 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
254 - registry database has user's keys and mail (known as v0 for migrate)
255 - pl importer properly maintains user's keys and mail
256 - pl driver now to handle 'role' when adding person record (exp.)
257 - first draft of federica driver with config section
258 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
259 - plus, from master as of tag merged-in-sfa-2.1-2:
260 - disk_image revisited
261 - new nova_shell nova_driver & various tweaks for openstack
262
263 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
264 - uses sqlalchemy and related migrate
265 - thorough migration and upgrade scheme
266 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
267 - trashed dbinfo stuff in auth hierarchy
268 - data model still has little more than plain records
269 - checkpoint tag, not yet intended for release
270
271 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
272 - client: added -R --raw sfi cmdline option that displays raw server response.
273 - client: request GENI RSpec by default. 
274 - server: remove database dependencies from sfa.server.sfaapi.
275 - server: increased default credential lifetime to 31 days.
276 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
277 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
278 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
279  
280 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
281 - bugfix: 'geni_api' should be in the top level struct, not the code struct
282 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
283           output returned by the Aggregate Manager.
284 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
285 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
286 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
287           there is extra whitespace in the schemaLocation field.
288 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
289           advertisement rspecs.
290 - bugfix: <login> RSpec element should contain the 'username' attribute.
291 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
292  
293 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
294 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
295   exit when it encountered a user with an invalid public key.
296 - server: imporved logging in sfa-import-plc.py
297  
298 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
299 - bugfix: Fixed appending public keys in CreateSliver
300 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
301 - client: -c --current option allows users to request the current/uncached rspec.
302 - server: Added 'geni_api_versions' field to GetVersion() output.
303 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
304    
305 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
306 - bugfix: sfi was not sending call_id with ListResources to v2 servers
307 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
308 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
309
310 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
311 - client: sfi -a / -p deprecated (use -s instead)
312 - client: sfi cleaned up
313 - client: sfi has backward support for APIv1 aggregates again
314 - server: only APIv2 is supported and should be rather strict
315 - server: settings for turning on/off caching in sm or am
316 - server: plc-dependant code has moved from aggregate to pldriver
317 - server: driver interface extended accordingly
318
319 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
320 - screwed up previous tag
321
322 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
323 - client side revisited with a bootstrap library
324 - client side has a new source layout
325 - various (nasty) bug fixes wrt options and call_id
326
327 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
328 - various fixes in rspecs for sfav1&slice tags
329 - uses 'geni_rspec_version' and not just 'rspec_version'
330 - example flavour for the max testbed
331 - embryo for an sfa client library
332 - topology.py moved into plc
333 - sql: table is named records; record_types are enforced
334 - sql: table creation cleaned up
335
336 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
337 - cleaned up all references to SFA_*_TYPE in config
338 - enable cache at the aggregate by default
339 - registry now uses the driver in a sensible way (see managers/driver.py)
340 - slice manager supports sfav1/pgv2 neighbours
341 - get_key renamed into get_key_from_incoming_ip
342 - new sfa.storage module for record/table and all db-related stuff
343 - db schema in sfa.storage.sfa.sql
344 - init.d and cron.d move one step up
345 - cleaned up rspec/ directory
346 - add deps to pyopenssl and myplc-config
347 - start support for new API (return value)
348 - plc.remoteshell removed, use plshell instead
349 - plshell uses a 'capability' auth method whenever possible
350 - various tweaks in rspec elements
351 - made dependency on sfatables softer
352
353 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
354 - sfa should now be started *before* the initial import
355 - sfa to use its own database (default sfa) - can run without myplc
356 - server calls support optional 'options'
357 - client sends options in argument when needed
358 - fix infinite getattr recursion in elements/element.py
359 - error codes in line with geni
360
361 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
362 - fixed links and attributes in rspecs
363 - minor cleanup in the API methods, and more consistent names in manager methods
364
365 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
366 - ongoing refoactoring towards more genericity
367 - passes tests again although known issues remain with attributes/tags
368
369 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
370 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
371 - improvements in the pgv2 rspecs
372 - driver separated from api
373 - code starts moving around where it belongs
374 - sfascan caches getversion across invokations
375 - vini topology extracted as a config file
376
377 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
378 - first support for protogeni rspecs is working
379 - vini no longer needs a specific manager
380 - refactoring underway towards more flexible/generic architecture
381
382 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
383 - Unicode-friendliness for user names with accents/special chars.
384 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
385 - CreaetSliver no longer fails for users that have a capital letter in their URN.
386 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
387 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
388 - Fix bugs and missing imports     
389  
390
391 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
392 - new method record.get_field for sface
393
394 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
395 - new option -c to sfa-nuke-plc.py
396 - CreateSliver fixed for admin-only slice tags
397
398 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
399 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
400 - Fixed holes in certificate verification logic.
401 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
402 - Added 'boot_state' as an attribute of the node element in SFA rspec.
403 - Non authority certificates are marked as CA:FALSE.
404
405 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
406 - fix typo in sfa-1.0-31 tag.
407 - added CreateGid() Registry interface method.
408
409 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
410 - fix typo in sfa-1.0-30 tag
411
412 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
413 - Declare namespace and schema location in the credential.
414 - Fix bug that prevetend connections from timing out.
415 - Fix slice delegation.
416 - Add statistics to slicemaanger listresources/createsliver rspec.
417 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
418   of days a user can extend their slice expiration.
419 - CA certs are only issued to objects of type authority
420    
421 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
422 - tag 1.0-28 was broken due to typo in the changelog
423 - new class sfa/util/httpsProtocol.py that supports timeouts
424
425 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
426 - Resolved issue that caused sfa hold onto idle db connections.
427 - Fix bug that caused the registry to use the wrong type of credential.
428 - Support authority+sm type.
429 - Fix rspec merging bugs.
430 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
431 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
432  planetlab hosted initscripts using the <planetlab:initscript> tag  
433 - Can now handle extraneous whitespace in the rspec without failing.   
434  
435 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
436 - ProtoGENI v2 RSpec updates.
437 - Convert expiration timestamps with timezone info in credentials to utc.
438 - Fixed redundant logging issue. 
439 - Improved SliceManager and SFI client logging.
440 - Support aggregates that don't support the optional 'call_id' argument. 
441 - Only call get_trusted_certs() at aggreage interfaces that support the call.
442 - CreateSliver() now handles MyPLC slice attributes/tags.
443 - Cache now supports persistence.
444 - Hide whitelisted nodes.
445
446 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
447 - fixed issues with sup authority signing
448 - fixed bugs in remove_slivers and SliverStatus
449
450 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
451 - fix typo that prevented aggregates from operating properly
452
453 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
454 - load trusted certs into ssl context prior to handshake
455 - client's logfile lives in ~/.sfi/sfi.log
456
457 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
458 - includes a change on passphrases that was intended in 1.0-22
459
460 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
461 - Added support for ProtoGENI RSpec v2
462  
463 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
464 - stable sfascan
465 - fix in initscript, *ENABLED tags in config now taken into account
466
467 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
468 - some commits had not been pushed in tag 19
469
470 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
471 - GetVersion should now report full URLs with path
472 - scansfa has nicer output and new syntax (entry URLs as args and not options)
473 - dos2unix'ed flash policy pill
474
475 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
476 - fix packaging again for f8
477
478 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
479 - fix packaging (apparently broken in 1.0-16)
480 - first working version of sfascan
481 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
482 - deprecated the sfa_geni_aggregate config category
483
484 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
485 - Fix build problem
486 - First version of SFA scanner
487
488 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
489 - Add support for Flash clients using flashpolicy
490 - Fix problems with tag handling in RSpec
491
492 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
493 - Modifications to the Eucalyptus Aggregate Manager
494 - Fixes for VINI RSpec
495 - Fix tag handling for PL RSpec
496 - Fix XML Schema ordering for <urn> element
497
498 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
499 - just set x509 version to 2
500
501 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
502 - added urn to the node area in rspecs
503 - conversion to urn now exports fqdn
504 - sfa-import-plc.py now creates a unique registry record for each SFA interface
505
506 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
507 - undo broken attempt for python-2.7
508
509 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
510 - SMs avoid duplicates for when call graph has dags;
511 - just based on network's name, when a duplicate occurs, one is just dropped
512 - does not try to merge/aggregate 2 networks
513 - also reviewed logging with the hope to fix the sfa startup msg:
514 - TypeError: not all arguments converted during string formatting
515
516 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
517 - verify credentials against xsd schema
518 - Fix SM to SM communication
519 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
520 - new setting session_key_path
521
522 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
523 - fix registry credential regeneration and handle expiration
524 - support for setting slice tags (min_role=user)
525 - client can display its own version: sfi.py version --local
526 - GetVersion to provide urn in addition to hrn
527 - more code uses plxrn vs previous helper functions
528 - import replaces '+' in email addresses with '_'
529
530 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
531 - fix GetVersion code_tag and add code_url
532
533 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
534 - extend GetVersion towards minimum federation introspection, and expose local tag
535
536 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
537 - fixed some legacy issues (list vs List)
538 - deprecated sfa.util.namespace for xrn and plxrn
539 - unit tests ship as the sfa-tests rpm
540
541 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
542 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
543 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
544 - hrn-urn translations tweaked
545 - fixed 'service sfa status'
546 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
547 - started to repair sfadump - although not usable yet
548 - trust objects now have dump_string method that dump() actually prints
549 - unit tests under review
550 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
551 - binaries now support -v or -vv to increase loglevel
552 - trashed obsolete sfa.util.client
553
554 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
555 - various bugfixes and cleanup, improved/harmonized logging
556
557 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
558 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
559   to avoid returning a PLCAPI exception that might confuse users.
560 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
561 - fix build errors.  
562
563 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
564 - (Architecture) Credential format changed to match ProtoGENI xml format
565 - (Architecture) All interfaces export a new set of methods that are compatible
566    with the ProtoGeni Aggregate spec. These new methods are considered a 
567    replacement  for the pervious methods exported by the interfaces. All 
568    previous methods are still exported and work as normal, but they are 
569    considered deprecated and will not be supported in future releases.  
570 - (Architecture) SFI has been updated to use the new interface methods.
571 - (Architecture) Changed keyconvet implementation from c to python.
572 - (Architecture) Slice Manager now attempts looks for a delegated credential
573   provided by the client before using its own server credential.
574 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
575   This cache now exists only in memory and is cleared when service is restarted
576   or cache lifetime is exceeded.  
577 - (Performance) SliceManager sends request to Aggregates in parallel instead 
578   of sequentially.
579 - (Bug fix) SFA tickets now support the new rspec format.
580 - (Bug fix) SFI only uses cahced credential if they aren't expired.
581 - (Bug fix) Cerdential delegation modified to work with new credential format.
582 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
583   Aggregate instead of relaying through the Slice Manager.
584 - (Enhancement) Simplified caching. Accociated a global cache instance with
585   the api handler on every new server request, making it easier to access the 
586   cache and use in more general ways.     
587
588 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
589 - SfaServer now uses a pool of threads to handle requests concurrently
590 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
591 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
592 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
593 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
594 - Component manager does not install gid files if slice already has them  
595 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
596 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
597 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
598      
599 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
600 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
601 - - sfa-config-tty now has the same features like plc-config-tty
602 - - Contains code to support both urn and hrn
603 - - Cleaned up request_hash related stuff
604 - - SM, AM and Registry code is organized under respective managers
605 - - Site and Slice synchronization across federated aggregates
606 - - Script to generate sfa_component_config
607
608 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
609 - sfa-config-tty now has the same features like plc-config-tty
610 - Contains code to support both urn and hrn
611 - Cleaned up request_hash related stuff
612 - SM, AM and Registry code is organized under respective managers
613 - Slice synchronization across federated aggregates
614 - some bugs are fixed
615
616 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
617 - checkpoint with fewer mentions of geni
618
619 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
620 - checkpointing
621 - this is believed to pass the tests; among other things:
622 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
623
624 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
625 - This tag includes:
626 - - Sfatables
627 - - Preliminary version of hash based authentication
628 - - Initial code for Component Manager
629 - - Authority structure is moved to /var/lib/sfa/
630 - - some bug-fixes
631
632 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
633 - Create_slice and get_resources methods are connected to sfatables.
634 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
635
636 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
637 - Bug fix on update and remove_peer_object methods
638 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
639
640 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
641 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
642
643 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
644 - compatibility with RefreshPeer
645 - incremental mechanism for importing PLC records into SFA tables
646 - unified single database (still inside the underlying PLC db postgresql server)
647 - includes/improves call traceability and logging features
648 - several bug fixes
649
650 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
651 - added libxslt-python dependency
652
653 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
654 - unified single SFA database in the PLC-DB
655 - upcalls from  PLCAPI to SFA methods
656 - SFA call traceability and logging features
657 - many bug fixes
658 - includes first/rough version of sfatables for policy implementation
659
660 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
661 - snapshot after the GEC5 demo
662 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
663
664 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
665 - snapshot july 15 - has gone through superficial manual testing
666 - hopefully a good basis for gec5 demo
667 - multi-dir sfi client tested as well
668
669 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
670 - rename geniwrapper.spec into sfa.spec
671
672 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
673 - clean up in xmlrpc/soap, --protocol option to chose between both
674 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
675 - hopefully more helpful context in case of crashes when importing
676 - bugfixes for using only /etc/sfa for site-dep files
677 - bugfixes in wsdl generation
678
679 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
680 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
681 - config variables in sfa_config now start with SFA_ and not GENI_
682 - config.py can be loaded even with no config present
683
684 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
685 - first step for cleanup and reorganization
686 - mass-renaming from geni to sfa (some are still needed)
687 - sfa/trust implements the security architecture
688
689 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
690 - snapshot for reproducible builds
691
692 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
693 - snapshot for the convenience of alpha users
694
695 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
696 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
697
698 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
699 - ongoing work - snapshot for 4.3-rc9
700
701 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
702 - various fixes
703
704 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
705 - bugfixes - still a work in progress
706
707 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
708 - initial package
709
710
711 %define module_current_branch 0.2