Merge commit 'origin/master'
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 8
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %Package tests
74 Summary: unit tests suite for SFA
75 Group: Applications/System
76 Requires: sfa
77
78 %description
79 This package provides the python libraries for the PlanetLab implementation of SFA
80
81 %description cm
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
84  
85 %description plc
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
88
89 %description client
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
92
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
97
98 %description tests
99 Provides some binary unit tests in /usr/share/sfa/tests
100
101 %prep
102 %setup -q
103
104 %build
105 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 # sfa and sfatables depend each other.
116 %{_bindir}/sfa-server.py*
117 /etc/sfatables/*
118 %{python_sitelib}/*
119 %{_bindir}/keyconvert.py*
120 /var/www/html/wsdl/*.wsdl
121
122 %files cm
123 /etc/init.d/sfa-cm
124 %{_bindir}/sfa_component_setup.py*
125 # cron jobs here 
126
127 %files plc
128 %defattr(-,root,root)
129 %config /etc/sfa/default_config.xml
130 %config (noreplace) /etc/sfa/aggregates.xml
131 %config (noreplace) /etc/sfa/registries.xml
132 /etc/init.d/sfa
133 /etc/sfa/pl.rng
134 /etc/sfa/credential.xsd
135 /etc/sfa/top.xsd
136 /etc/sfa/xml.xsd
137 /etc/sfa/protogeni-rspec-common.xsd
138 %{_bindir}/sfa-config-tty
139 %{_bindir}/sfa-import-plc.py*
140 %{_bindir}/sfa-clean-peer-records.py*
141 %{_bindir}/sfa-nuke-plc.py*
142 %{_bindir}/gen-sfa-cm-config.py*
143 %{_bindir}/sfa-ca.py*
144
145 %files client
146 %config (noreplace) /etc/sfa/sfi_config
147 %{_bindir}/sfi*
148 %{_bindir}/getNodes.py*
149 %{_bindir}/getRecord.py*
150 %{_bindir}/setRecord.py*
151 %{_bindir}/sfadump.py*
152
153 %files sfatables
154 %{_bindir}/sfatables
155
156 %files tests
157 %{_datadir}/sfa/tests
158
159 ### sfa-plc installs the 'sfa' service
160 %post plc
161 chkconfig --add sfa
162
163 %preun plc
164 if [ "$1" = 0 ] ; then
165   /sbin/service sfa stop || :
166   /sbin/chkconfig --del sfa || :
167 fi
168
169 %postun plc
170 [ "$1" -ge "1" ] && service sfa restart
171
172 ### sfa-cm installs the 'sfa-cm' service
173 %post cm
174 chkconfig --add sfa-cm
175
176 %preun cm
177 if [ "$1" = 0 ] ; then
178    /sbin/service sfa-cm stop || :
179    /sbin/chkconfig --del sfa-cm || :
180 fi
181
182 %postun cm
183 [ "$1" -ge "1" ] && service sfa-cm restart
184
185
186 %changelog
187 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
188 - fix registry credential regeneration and handle expiration
189 - support for setting slice tags (min_role=user)
190 - client can display its own version: sfi.py version --local
191 - GetVersion to provide urn in addition to hrn
192 - more code uses plxrn vs previous helper functions
193 - import replaces '+' in email addresses with '_'
194
195 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
196 - fix GetVersion code_tag and add code_url
197
198 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
199 - extend GetVersion towards minimum federation introspection, and expose local tag
200
201 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
202 - fixed some legacy issues (list vs List)
203 - deprecated sfa.util.namespace for xrn and plxrn
204 - unit tests ship as the sfa-tests rpm
205
206 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
207 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
208 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
209 - hrn-urn translations tweaked
210 - fixed 'service sfa status'
211 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
212 - started to repair sfadump - although not usable yet
213 - trust objects now have dump_string method that dump() actually prints
214 - unit tests under review
215 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
216 - binaries now support -v or -vv to increase loglevel
217 - trashed obsolete sfa.util.client
218
219 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
220 - various bugfixes and cleanup, improved/harmonized logging
221
222 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
223 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
224   to avoid returning a PLCAPI exception that might confuse users.
225 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
226 - fix build errors.  
227
228 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
229 - (Architecture) Credential format changed to match ProtoGENI xml format
230 - (Architecture) All interfaces export a new set of methods that are compatible
231    with the ProtoGeni Aggregate spec. These new methods are considered a 
232    replacement  for the pervious methods exported by the interfaces. All 
233    previous methods are still exported and work as normal, but they are 
234    considered deprecated and will not be supported in future releases.  
235 - (Architecture) SFI has been updated to use the new interface methods.
236 - (Architecture) Changed keyconvet implementation from c to python.
237 - (Architecture) Slice Manager now attempts looks for a delegated credential
238   provided by the client before using its own server credential.
239 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
240   This cache now exists only in memory and is cleared when service is restarted
241   or cache lifetime is exceeded.  
242 - (Performance) SliceManager sends request to Aggregates in parallel instead 
243   of sequentially.
244 - (Bug fix) SFA tickets now support the new rspec format.
245 - (Bug fix) SFI only uses cahced credential if they aren't expired.
246 - (Bug fix) Cerdential delegation modified to work with new credential format.
247 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
248   Aggregate instead of relaying through the Slice Manager.
249 - (Enhancement) Simplified caching. Accociated a global cache instance with
250   the api handler on every new server request, making it easier to access the 
251   cache and use in more general ways.     
252
253 %changelog
254 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
255 - fix registry credential regeneration and handle expiration
256 - support for setting slice tags (min_role=user)
257 - client can display its own version: sfi.py version --local
258 - GetVersion to provide urn in addition to hrn
259 - more code uses plxrn vs previous helper functions
260 - import replaces '+' in email addresses with '_'
261
262 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
263 - fix GetVersion code_tag and add code_url
264
265 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
266 - extend GetVersion towards minimum federation introspection, and expose local tag
267
268 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
269 - fixed some legacy issues (list vs List)
270 - deprecated sfa.util.namespace for xrn and plxrn
271 - unit tests ship as the sfa-tests rpm
272
273 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
274 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
275 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
276 - hrn-urn translations tweaked
277 - fixed 'service sfa status'
278 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
279 - started to repair sfadump - although not usable yet
280 - trust objects now have dump_string method that dump() actually prints
281 - unit tests under review
282 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
283 - binaries now support -v or -vv to increase loglevel
284 - trashed obsolete sfa.util.client
285
286 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
287 - various bugfixes and cleanup, improved/harmonized logging
288
289 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
290 - SfaServer now uses a pool of threads to handle requests concurrently
291 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
292 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
293 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
294 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
295 - Component manager does not install gid files if slice already has them  
296 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
297 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
298 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
299      
300 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
301 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
302 - - sfa-config-tty now has the same features like plc-config-tty
303 - - Contains code to support both urn and hrn
304 - - Cleaned up request_hash related stuff
305 - - SM, AM and Registry code is organized under respective managers
306 - - Site and Slice synchronization across federated aggregates
307 - - Script to generate sfa_component_config
308
309 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
310 - sfa-config-tty now has the same features like plc-config-tty
311 - Contains code to support both urn and hrn
312 - Cleaned up request_hash related stuff
313 - SM, AM and Registry code is organized under respective managers
314 - Slice synchronization across federated aggregates
315 - some bugs are fixed
316
317 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
318 - checkpoint with fewer mentions of geni
319
320 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
321 - checkpointing
322 - this is believed to pass the tests; among other things:
323 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
324
325 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
326 - This tag includes:
327 - - Sfatables
328 - - Preliminary version of hash based authentication
329 - - Initial code for Component Manager
330 - - Authority structure is moved to /var/lib/sfa/
331 - - some bug-fixes
332
333 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
334 - Create_slice and get_resources methods are connected to sfatables.
335 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
336
337 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
338 - Bug fix on update and remove_peer_object methods
339 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
340
341 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
342 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
343
344 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
345 - compatibility with RefreshPeer
346 - incremental mechanism for importing PLC records into SFA tables
347 - unified single database (still inside the underlying PLC db postgresql server)
348 - includes/improves call traceability and logging features
349 - several bug fixes
350
351 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
352 - added libxslt-python dependency
353
354 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
355 - unified single SFA database in the PLC-DB
356 - upcalls from  PLCAPI to SFA methods
357 - SFA call traceability and logging features
358 - many bug fixes
359 - includes first/rough version of sfatables for policy implementation
360
361 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
362 - snapshot after the GEC5 demo
363 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
364
365 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
366 - snapshot july 15 - has gone through superficial manual testing
367 - hopefully a good basis for gec5 demo
368 - multi-dir sfi client tested as well
369
370 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
371 - rename geniwrapper.spec into sfa.spec
372
373 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
374 - clean up in xmlrpc/soap, --protocol option to chose between both
375 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
376 - hopefully more helpful context in case of crashes when importing
377 - bugfixes for using only /etc/sfa for site-dep files
378 - bugfixes in wsdl generation
379
380 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
381 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
382 - config variables in sfa_config now start with SFA_ and not GENI_
383 - config.py can be loaded even with no config present
384
385 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
386 - first step for cleanup and reorganization
387 - mass-renaming from geni to sfa (some are still needed)
388 - sfa/trust implements the security architecture
389
390 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
391 - snapshot for reproducible builds
392
393 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
394 - snapshot for the convenience of alpha users
395
396 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
397 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
398
399 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
400 - ongoing work - snapshot for 4.3-rc9
401
402 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
403 - various fixes
404
405 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
406 - bugfixes - still a work in progress
407
408 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
409 - initial package
410
411
412 %define module_current_branch 0.2