Merge branch 'master' of ssh://git.onelab.eu/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/sfaadmin.py*
152 %{_bindir}/keyconvert.py*
153 %{_bindir}/sfa-config-tty
154 %config /etc/sfa/default_config.xml
155 %config (noreplace) /etc/sfa/aggregates.xml
156 %config (noreplace) /etc/sfa/registries.xml
157 /usr/share/sfa/migrations
158 /usr/share/sfa/examples
159 /var/www/html/wsdl/*.wsdl
160
161 %files plc
162 %defattr(-,root,root)
163 /etc/sfa/pl.rng
164 /etc/sfa/credential.xsd
165 /etc/sfa/top.xsd
166 /etc/sfa/sig.xsd
167 /etc/sfa/xml.xsd
168 /etc/sfa/protogeni-rspec-common.xsd
169 /etc/sfa/topology
170 %{_bindir}/gen-sfa-cm-config.py*
171
172 %files client
173 %config (noreplace) /etc/sfa/sfi_config
174 %{_bindir}/sfi*.py*
175 %{_bindir}/sfi
176 %{_bindir}/get*.py*
177 %{_bindir}/setRecord.py*
178 %{_bindir}/sfascan.py*
179 %{_bindir}/sfascan
180 %{_bindir}/sfadump.py*
181
182 %files sfatables
183 /etc/sfatables/*
184 %{_bindir}/sfatables
185 %{python_sitelib}/sfatables
186
187 %files cm
188 /etc/init.d/sfa-cm
189 %{_bindir}/sfa_component_setup.py*
190 # cron jobs here 
191
192 %files flashpolicy
193 %{_bindir}/sfa_flashpolicy.py*
194 /etc/sfa/sfa_flashpolicy_config.xml
195
196 %files xmlbuilder
197 %{python_sitelib}/xmlbuilder
198
199 %files tests
200 %{_datadir}/sfa/tests
201
202 ### sfa installs the 'sfa' service
203 %post 
204 chkconfig --add sfa
205
206 %preun 
207 if [ "$1" = 0 ] ; then
208   /sbin/service sfa stop || :
209   /sbin/chkconfig --del sfa || :
210 fi
211
212 %postun
213 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
214
215 ### sfa-cm installs the 'sfa-cm' service
216 %post cm
217 chkconfig --add sfa-cm
218
219 %preun cm
220 if [ "$1" = 0 ] ; then
221    /sbin/service sfa-cm stop || :
222    /sbin/chkconfig --del sfa-cm || :
223 fi
224
225 %postun cm
226 [ "$1" -ge "1" ] && service sfa-cm restart || :
227
228 %changelog
229 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
230 - slice x researcher rel. in database,
231 - plimporter to maintain that, as well as user.email, and more robust
232 - ongoing draft for sfaadmin tool
233 - support for a federica driver
234 - support for a nova/euca driver
235 - no more sfa-clean-peer-records script
236
237 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
238 - registry database has user's keys and mail (known as v0 for migrate)
239 - pl importer properly maintains user's keys and mail
240 - pl driver now to handle 'role' when adding person record (exp.)
241 - first draft of federica driver with config section
242 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
243 - plus, from master as of tag merged-in-sfa-2.1-2:
244 - disk_image revisited
245 - new nova_shell nova_driver & various tweaks for openstack
246
247 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
248 - uses sqlalchemy and related migrate
249 - thorough migration and upgrade scheme
250 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
251 - trashed dbinfo stuff in auth hierarchy
252 - data model still has little more than plain records
253 - checkpoint tag, not yet intended for release
254
255 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
256 - client: added -R --raw sfi cmdline option that displays raw server response.
257 - client: request GENI RSpec by default. 
258 - server: remove database dependencies from sfa.server.sfaapi.
259 - server: increased default credential lifetime to 31 days.
260 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
261 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
262 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
263  
264 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
265 - bugfix: 'geni_api' should be in the top level struct, not the code struct
266 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
267           output returned by the Aggregate Manager.
268 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
269 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
270 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
271           there is extra whitespace in the schemaLocation field.
272 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
273           advertisement rspecs.
274 - bugfix: <login> RSpec element should contain the 'username' attribute.
275 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
276  
277 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
278 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
279   exit when it encountered a user with an invalid public key.
280 - server: imporved logging in sfa-import-plc.py
281  
282 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
283 - bugfix: Fixed appending public keys in CreateSliver
284 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
285 - client: -c --current option allows users to request the current/uncached rspec.
286 - server: Added 'geni_api_versions' field to GetVersion() output.
287 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
288    
289 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
290 - bugfix: sfi was not sending call_id with ListResources to v2 servers
291 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
292 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
293
294 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
295 - client: sfi -a / -p deprecated (use -s instead)
296 - client: sfi cleaned up
297 - client: sfi has backward support for APIv1 aggregates again
298 - server: only APIv2 is supported and should be rather strict
299 - server: settings for turning on/off caching in sm or am
300 - server: plc-dependant code has moved from aggregate to pldriver
301 - server: driver interface extended accordingly
302
303 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
304 - screwed up previous tag
305
306 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
307 - client side revisited with a bootstrap library
308 - client side has a new source layout
309 - various (nasty) bug fixes wrt options and call_id
310
311 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
312 - various fixes in rspecs for sfav1&slice tags
313 - uses 'geni_rspec_version' and not just 'rspec_version'
314 - example flavour for the max testbed
315 - embryo for an sfa client library
316 - topology.py moved into plc
317 - sql: table is named records; record_types are enforced
318 - sql: table creation cleaned up
319
320 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
321 - cleaned up all references to SFA_*_TYPE in config
322 - enable cache at the aggregate by default
323 - registry now uses the driver in a sensible way (see managers/driver.py)
324 - slice manager supports sfav1/pgv2 neighbours
325 - get_key renamed into get_key_from_incoming_ip
326 - new sfa.storage module for record/table and all db-related stuff
327 - db schema in sfa.storage.sfa.sql
328 - init.d and cron.d move one step up
329 - cleaned up rspec/ directory
330 - add deps to pyopenssl and myplc-config
331 - start support for new API (return value)
332 - plc.remoteshell removed, use plshell instead
333 - plshell uses a 'capability' auth method whenever possible
334 - various tweaks in rspec elements
335 - made dependency on sfatables softer
336
337 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
338 - sfa should now be started *before* the initial import
339 - sfa to use its own database (default sfa) - can run without myplc
340 - server calls support optional 'options'
341 - client sends options in argument when needed
342 - fix infinite getattr recursion in elements/element.py
343 - error codes in line with geni
344
345 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
346 - fixed links and attributes in rspecs
347 - minor cleanup in the API methods, and more consistent names in manager methods
348
349 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
350 - ongoing refoactoring towards more genericity
351 - passes tests again although known issues remain with attributes/tags
352
353 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
354 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
355 - improvements in the pgv2 rspecs
356 - driver separated from api
357 - code starts moving around where it belongs
358 - sfascan caches getversion across invokations
359 - vini topology extracted as a config file
360
361 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
362 - first support for protogeni rspecs is working
363 - vini no longer needs a specific manager
364 - refactoring underway towards more flexible/generic architecture
365
366 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
367 - Unicode-friendliness for user names with accents/special chars.
368 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
369 - CreaetSliver no longer fails for users that have a capital letter in their URN.
370 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
371 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
372 - Fix bugs and missing imports     
373  
374
375 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
376 - new method record.get_field for sface
377
378 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
379 - new option -c to sfa-nuke-plc.py
380 - CreateSliver fixed for admin-only slice tags
381
382 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
383 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
384 - Fixed holes in certificate verification logic.
385 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
386 - Added 'boot_state' as an attribute of the node element in SFA rspec.
387 - Non authority certificates are marked as CA:FALSE.
388
389 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
390 - fix typo in sfa-1.0-31 tag.
391 - added CreateGid() Registry interface method.
392
393 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
394 - fix typo in sfa-1.0-30 tag
395
396 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
397 - Declare namespace and schema location in the credential.
398 - Fix bug that prevetend connections from timing out.
399 - Fix slice delegation.
400 - Add statistics to slicemaanger listresources/createsliver rspec.
401 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
402   of days a user can extend their slice expiration.
403 - CA certs are only issued to objects of type authority
404    
405 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
406 - tag 1.0-28 was broken due to typo in the changelog
407 - new class sfa/util/httpsProtocol.py that supports timeouts
408
409 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
410 - Resolved issue that caused sfa hold onto idle db connections.
411 - Fix bug that caused the registry to use the wrong type of credential.
412 - Support authority+sm type.
413 - Fix rspec merging bugs.
414 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
415 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
416  planetlab hosted initscripts using the <planetlab:initscript> tag  
417 - Can now handle extraneous whitespace in the rspec without failing.   
418  
419 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
420 - ProtoGENI v2 RSpec updates.
421 - Convert expiration timestamps with timezone info in credentials to utc.
422 - Fixed redundant logging issue. 
423 - Improved SliceManager and SFI client logging.
424 - Support aggregates that don't support the optional 'call_id' argument. 
425 - Only call get_trusted_certs() at aggreage interfaces that support the call.
426 - CreateSliver() now handles MyPLC slice attributes/tags.
427 - Cache now supports persistence.
428 - Hide whitelisted nodes.
429
430 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
431 - fixed issues with sup authority signing
432 - fixed bugs in remove_slivers and SliverStatus
433
434 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
435 - fix typo that prevented aggregates from operating properly
436
437 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
438 - load trusted certs into ssl context prior to handshake
439 - client's logfile lives in ~/.sfi/sfi.log
440
441 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
442 - includes a change on passphrases that was intended in 1.0-22
443
444 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
445 - Added support for ProtoGENI RSpec v2
446  
447 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
448 - stable sfascan
449 - fix in initscript, *ENABLED tags in config now taken into account
450
451 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
452 - some commits had not been pushed in tag 19
453
454 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
455 - GetVersion should now report full URLs with path
456 - scansfa has nicer output and new syntax (entry URLs as args and not options)
457 - dos2unix'ed flash policy pill
458
459 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
460 - fix packaging again for f8
461
462 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
463 - fix packaging (apparently broken in 1.0-16)
464 - first working version of sfascan
465 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
466 - deprecated the sfa_geni_aggregate config category
467
468 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
469 - Fix build problem
470 - First version of SFA scanner
471
472 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
473 - Add support for Flash clients using flashpolicy
474 - Fix problems with tag handling in RSpec
475
476 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
477 - Modifications to the Eucalyptus Aggregate Manager
478 - Fixes for VINI RSpec
479 - Fix tag handling for PL RSpec
480 - Fix XML Schema ordering for <urn> element
481
482 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
483 - just set x509 version to 2
484
485 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
486 - added urn to the node area in rspecs
487 - conversion to urn now exports fqdn
488 - sfa-import-plc.py now creates a unique registry record for each SFA interface
489
490 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
491 - undo broken attempt for python-2.7
492
493 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
494 - SMs avoid duplicates for when call graph has dags;
495 - just based on network's name, when a duplicate occurs, one is just dropped
496 - does not try to merge/aggregate 2 networks
497 - also reviewed logging with the hope to fix the sfa startup msg:
498 - TypeError: not all arguments converted during string formatting
499
500 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
501 - verify credentials against xsd schema
502 - Fix SM to SM communication
503 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
504 - new setting session_key_path
505
506 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
507 - fix registry credential regeneration and handle expiration
508 - support for setting slice tags (min_role=user)
509 - client can display its own version: sfi.py version --local
510 - GetVersion to provide urn in addition to hrn
511 - more code uses plxrn vs previous helper functions
512 - import replaces '+' in email addresses with '_'
513
514 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
515 - fix GetVersion code_tag and add code_url
516
517 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
518 - extend GetVersion towards minimum federation introspection, and expose local tag
519
520 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
521 - fixed some legacy issues (list vs List)
522 - deprecated sfa.util.namespace for xrn and plxrn
523 - unit tests ship as the sfa-tests rpm
524
525 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
526 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
527 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
528 - hrn-urn translations tweaked
529 - fixed 'service sfa status'
530 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
531 - started to repair sfadump - although not usable yet
532 - trust objects now have dump_string method that dump() actually prints
533 - unit tests under review
534 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
535 - binaries now support -v or -vv to increase loglevel
536 - trashed obsolete sfa.util.client
537
538 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
539 - various bugfixes and cleanup, improved/harmonized logging
540
541 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
542 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
543   to avoid returning a PLCAPI exception that might confuse users.
544 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
545 - fix build errors.  
546
547 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
548 - (Architecture) Credential format changed to match ProtoGENI xml format
549 - (Architecture) All interfaces export a new set of methods that are compatible
550    with the ProtoGeni Aggregate spec. These new methods are considered a 
551    replacement  for the pervious methods exported by the interfaces. All 
552    previous methods are still exported and work as normal, but they are 
553    considered deprecated and will not be supported in future releases.  
554 - (Architecture) SFI has been updated to use the new interface methods.
555 - (Architecture) Changed keyconvet implementation from c to python.
556 - (Architecture) Slice Manager now attempts looks for a delegated credential
557   provided by the client before using its own server credential.
558 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
559   This cache now exists only in memory and is cleared when service is restarted
560   or cache lifetime is exceeded.  
561 - (Performance) SliceManager sends request to Aggregates in parallel instead 
562   of sequentially.
563 - (Bug fix) SFA tickets now support the new rspec format.
564 - (Bug fix) SFI only uses cahced credential if they aren't expired.
565 - (Bug fix) Cerdential delegation modified to work with new credential format.
566 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
567   Aggregate instead of relaying through the Slice Manager.
568 - (Enhancement) Simplified caching. Accociated a global cache instance with
569   the api handler on every new server request, making it easier to access the 
570   cache and use in more general ways.     
571
572 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
573 - SfaServer now uses a pool of threads to handle requests concurrently
574 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
575 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
576 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
577 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
578 - Component manager does not install gid files if slice already has them  
579 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
580 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
581 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
582      
583 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
584 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
585 - - sfa-config-tty now has the same features like plc-config-tty
586 - - Contains code to support both urn and hrn
587 - - Cleaned up request_hash related stuff
588 - - SM, AM and Registry code is organized under respective managers
589 - - Site and Slice synchronization across federated aggregates
590 - - Script to generate sfa_component_config
591
592 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
593 - sfa-config-tty now has the same features like plc-config-tty
594 - Contains code to support both urn and hrn
595 - Cleaned up request_hash related stuff
596 - SM, AM and Registry code is organized under respective managers
597 - Slice synchronization across federated aggregates
598 - some bugs are fixed
599
600 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
601 - checkpoint with fewer mentions of geni
602
603 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
604 - checkpointing
605 - this is believed to pass the tests; among other things:
606 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
607
608 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
609 - This tag includes:
610 - - Sfatables
611 - - Preliminary version of hash based authentication
612 - - Initial code for Component Manager
613 - - Authority structure is moved to /var/lib/sfa/
614 - - some bug-fixes
615
616 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
617 - Create_slice and get_resources methods are connected to sfatables.
618 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
619
620 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
621 - Bug fix on update and remove_peer_object methods
622 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
623
624 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
625 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
626
627 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
628 - compatibility with RefreshPeer
629 - incremental mechanism for importing PLC records into SFA tables
630 - unified single database (still inside the underlying PLC db postgresql server)
631 - includes/improves call traceability and logging features
632 - several bug fixes
633
634 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
635 - added libxslt-python dependency
636
637 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
638 - unified single SFA database in the PLC-DB
639 - upcalls from  PLCAPI to SFA methods
640 - SFA call traceability and logging features
641 - many bug fixes
642 - includes first/rough version of sfatables for policy implementation
643
644 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
645 - snapshot after the GEC5 demo
646 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
647
648 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
649 - snapshot july 15 - has gone through superficial manual testing
650 - hopefully a good basis for gec5 demo
651 - multi-dir sfi client tested as well
652
653 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
654 - rename geniwrapper.spec into sfa.spec
655
656 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
657 - clean up in xmlrpc/soap, --protocol option to chose between both
658 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
659 - hopefully more helpful context in case of crashes when importing
660 - bugfixes for using only /etc/sfa for site-dep files
661 - bugfixes in wsdl generation
662
663 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
664 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
665 - config variables in sfa_config now start with SFA_ and not GENI_
666 - config.py can be loaded even with no config present
667
668 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
669 - first step for cleanup and reorganization
670 - mass-renaming from geni to sfa (some are still needed)
671 - sfa/trust implements the security architecture
672
673 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
674 - snapshot for reproducible builds
675
676 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
677 - snapshot for the convenience of alpha users
678
679 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
680 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
681
682 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
683 - ongoing work - snapshot for 4.3-rc9
684
685 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
686 - various fixes
687
688 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
689 - bugfixes - still a work in progress
690
691 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
692 - initial package
693
694
695 %define module_current_branch 0.2