fix packaging of sfaadmin.py
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/sfaadmin.py*
152 %{_bindir}/keyconvert.py*
153 %{_bindir}/sfa-config-tty
154 %config /etc/sfa/default_config.xml
155 %config (noreplace) /etc/sfa/aggregates.xml
156 %config (noreplace) /etc/sfa/registries.xml
157 /usr/share/sfa/migrations
158 /usr/share/sfa/examples
159 /var/www/html/wsdl/*.wsdl
160
161 %files plc
162 %defattr(-,root,root)
163 /etc/sfa/pl.rng
164 /etc/sfa/credential.xsd
165 /etc/sfa/top.xsd
166 /etc/sfa/sig.xsd
167 /etc/sfa/xml.xsd
168 /etc/sfa/protogeni-rspec-common.xsd
169 /etc/sfa/topology
170 %{_bindir}/sfa-import.py*
171 %{_bindir}/sfa-nuke.py*
172 %{_bindir}/gen-sfa-cm-config.py*
173 %{_bindir}/sfa-ca.py*
174
175 %files client
176 %config (noreplace) /etc/sfa/sfi_config
177 %{_bindir}/sfi*.py*
178 %{_bindir}/sfi
179 %{_bindir}/get*.py*
180 %{_bindir}/setRecord.py*
181 %{_bindir}/sfascan.py*
182 %{_bindir}/sfascan
183 %{_bindir}/sfadump.py*
184
185 %files sfatables
186 /etc/sfatables/*
187 %{_bindir}/sfatables
188 %{python_sitelib}/sfatables
189
190 %files cm
191 /etc/init.d/sfa-cm
192 %{_bindir}/sfa_component_setup.py*
193 # cron jobs here 
194
195 %files flashpolicy
196 %{_bindir}/sfa_flashpolicy.py*
197 /etc/sfa/sfa_flashpolicy_config.xml
198
199 %files xmlbuilder
200 %{python_sitelib}/xmlbuilder
201
202 %files tests
203 %{_datadir}/sfa/tests
204
205 ### sfa installs the 'sfa' service
206 %post 
207 chkconfig --add sfa
208
209 %preun 
210 if [ "$1" = 0 ] ; then
211   /sbin/service sfa stop || :
212   /sbin/chkconfig --del sfa || :
213 fi
214
215 %postun
216 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
217
218 ### sfa-cm installs the 'sfa-cm' service
219 %post cm
220 chkconfig --add sfa-cm
221
222 %preun cm
223 if [ "$1" = 0 ] ; then
224    /sbin/service sfa-cm stop || :
225    /sbin/chkconfig --del sfa-cm || :
226 fi
227
228 %postun cm
229 [ "$1" -ge "1" ] && service sfa-cm restart || :
230
231 %changelog
232 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
233 - slice x researcher rel. in database,
234 - plimporter to maintain that, as well as user.email, and more robust
235 - ongoing draft for sfaadmin tool
236 - support for a federica driver
237 - support for a nova/euca driver
238 - no more sfa-clean-peer-records script
239
240 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
241 - registry database has user's keys and mail (known as v0 for migrate)
242 - pl importer properly maintains user's keys and mail
243 - pl driver now to handle 'role' when adding person record (exp.)
244 - first draft of federica driver with config section
245 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
246 - plus, from master as of tag merged-in-sfa-2.1-2:
247 - disk_image revisited
248 - new nova_shell nova_driver & various tweaks for openstack
249
250 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
251 - uses sqlalchemy and related migrate
252 - thorough migration and upgrade scheme
253 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
254 - trashed dbinfo stuff in auth hierarchy
255 - data model still has little more than plain records
256 - checkpoint tag, not yet intended for release
257
258 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
259 - client: added -R --raw sfi cmdline option that displays raw server response.
260 - client: request GENI RSpec by default. 
261 - server: remove database dependencies from sfa.server.sfaapi.
262 - server: increased default credential lifetime to 31 days.
263 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
264 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
265 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
266  
267 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
268 - bugfix: 'geni_api' should be in the top level struct, not the code struct
269 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
270           output returned by the Aggregate Manager.
271 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
272 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
273 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
274           there is extra whitespace in the schemaLocation field.
275 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
276           advertisement rspecs.
277 - bugfix: <login> RSpec element should contain the 'username' attribute.
278 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
279  
280 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
281 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
282   exit when it encountered a user with an invalid public key.
283 - server: imporved logging in sfa-import-plc.py
284  
285 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
286 - bugfix: Fixed appending public keys in CreateSliver
287 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
288 - client: -c --current option allows users to request the current/uncached rspec.
289 - server: Added 'geni_api_versions' field to GetVersion() output.
290 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
291    
292 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
293 - bugfix: sfi was not sending call_id with ListResources to v2 servers
294 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
295 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
296
297 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
298 - client: sfi -a / -p deprecated (use -s instead)
299 - client: sfi cleaned up
300 - client: sfi has backward support for APIv1 aggregates again
301 - server: only APIv2 is supported and should be rather strict
302 - server: settings for turning on/off caching in sm or am
303 - server: plc-dependant code has moved from aggregate to pldriver
304 - server: driver interface extended accordingly
305
306 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
307 - screwed up previous tag
308
309 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
310 - client side revisited with a bootstrap library
311 - client side has a new source layout
312 - various (nasty) bug fixes wrt options and call_id
313
314 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
315 - various fixes in rspecs for sfav1&slice tags
316 - uses 'geni_rspec_version' and not just 'rspec_version'
317 - example flavour for the max testbed
318 - embryo for an sfa client library
319 - topology.py moved into plc
320 - sql: table is named records; record_types are enforced
321 - sql: table creation cleaned up
322
323 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
324 - cleaned up all references to SFA_*_TYPE in config
325 - enable cache at the aggregate by default
326 - registry now uses the driver in a sensible way (see managers/driver.py)
327 - slice manager supports sfav1/pgv2 neighbours
328 - get_key renamed into get_key_from_incoming_ip
329 - new sfa.storage module for record/table and all db-related stuff
330 - db schema in sfa.storage.sfa.sql
331 - init.d and cron.d move one step up
332 - cleaned up rspec/ directory
333 - add deps to pyopenssl and myplc-config
334 - start support for new API (return value)
335 - plc.remoteshell removed, use plshell instead
336 - plshell uses a 'capability' auth method whenever possible
337 - various tweaks in rspec elements
338 - made dependency on sfatables softer
339
340 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
341 - sfa should now be started *before* the initial import
342 - sfa to use its own database (default sfa) - can run without myplc
343 - server calls support optional 'options'
344 - client sends options in argument when needed
345 - fix infinite getattr recursion in elements/element.py
346 - error codes in line with geni
347
348 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
349 - fixed links and attributes in rspecs
350 - minor cleanup in the API methods, and more consistent names in manager methods
351
352 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
353 - ongoing refoactoring towards more genericity
354 - passes tests again although known issues remain with attributes/tags
355
356 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
357 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
358 - improvements in the pgv2 rspecs
359 - driver separated from api
360 - code starts moving around where it belongs
361 - sfascan caches getversion across invokations
362 - vini topology extracted as a config file
363
364 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
365 - first support for protogeni rspecs is working
366 - vini no longer needs a specific manager
367 - refactoring underway towards more flexible/generic architecture
368
369 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
370 - Unicode-friendliness for user names with accents/special chars.
371 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
372 - CreaetSliver no longer fails for users that have a capital letter in their URN.
373 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
374 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
375 - Fix bugs and missing imports     
376  
377
378 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
379 - new method record.get_field for sface
380
381 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
382 - new option -c to sfa-nuke-plc.py
383 - CreateSliver fixed for admin-only slice tags
384
385 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
386 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
387 - Fixed holes in certificate verification logic.
388 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
389 - Added 'boot_state' as an attribute of the node element in SFA rspec.
390 - Non authority certificates are marked as CA:FALSE.
391
392 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
393 - fix typo in sfa-1.0-31 tag.
394 - added CreateGid() Registry interface method.
395
396 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
397 - fix typo in sfa-1.0-30 tag
398
399 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
400 - Declare namespace and schema location in the credential.
401 - Fix bug that prevetend connections from timing out.
402 - Fix slice delegation.
403 - Add statistics to slicemaanger listresources/createsliver rspec.
404 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
405   of days a user can extend their slice expiration.
406 - CA certs are only issued to objects of type authority
407    
408 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
409 - tag 1.0-28 was broken due to typo in the changelog
410 - new class sfa/util/httpsProtocol.py that supports timeouts
411
412 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
413 - Resolved issue that caused sfa hold onto idle db connections.
414 - Fix bug that caused the registry to use the wrong type of credential.
415 - Support authority+sm type.
416 - Fix rspec merging bugs.
417 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
418 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
419  planetlab hosted initscripts using the <planetlab:initscript> tag  
420 - Can now handle extraneous whitespace in the rspec without failing.   
421  
422 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
423 - ProtoGENI v2 RSpec updates.
424 - Convert expiration timestamps with timezone info in credentials to utc.
425 - Fixed redundant logging issue. 
426 - Improved SliceManager and SFI client logging.
427 - Support aggregates that don't support the optional 'call_id' argument. 
428 - Only call get_trusted_certs() at aggreage interfaces that support the call.
429 - CreateSliver() now handles MyPLC slice attributes/tags.
430 - Cache now supports persistence.
431 - Hide whitelisted nodes.
432
433 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
434 - fixed issues with sup authority signing
435 - fixed bugs in remove_slivers and SliverStatus
436
437 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
438 - fix typo that prevented aggregates from operating properly
439
440 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
441 - load trusted certs into ssl context prior to handshake
442 - client's logfile lives in ~/.sfi/sfi.log
443
444 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
445 - includes a change on passphrases that was intended in 1.0-22
446
447 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
448 - Added support for ProtoGENI RSpec v2
449  
450 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
451 - stable sfascan
452 - fix in initscript, *ENABLED tags in config now taken into account
453
454 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
455 - some commits had not been pushed in tag 19
456
457 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
458 - GetVersion should now report full URLs with path
459 - scansfa has nicer output and new syntax (entry URLs as args and not options)
460 - dos2unix'ed flash policy pill
461
462 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
463 - fix packaging again for f8
464
465 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
466 - fix packaging (apparently broken in 1.0-16)
467 - first working version of sfascan
468 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
469 - deprecated the sfa_geni_aggregate config category
470
471 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
472 - Fix build problem
473 - First version of SFA scanner
474
475 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
476 - Add support for Flash clients using flashpolicy
477 - Fix problems with tag handling in RSpec
478
479 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
480 - Modifications to the Eucalyptus Aggregate Manager
481 - Fixes for VINI RSpec
482 - Fix tag handling for PL RSpec
483 - Fix XML Schema ordering for <urn> element
484
485 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
486 - just set x509 version to 2
487
488 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
489 - added urn to the node area in rspecs
490 - conversion to urn now exports fqdn
491 - sfa-import-plc.py now creates a unique registry record for each SFA interface
492
493 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
494 - undo broken attempt for python-2.7
495
496 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
497 - SMs avoid duplicates for when call graph has dags;
498 - just based on network's name, when a duplicate occurs, one is just dropped
499 - does not try to merge/aggregate 2 networks
500 - also reviewed logging with the hope to fix the sfa startup msg:
501 - TypeError: not all arguments converted during string formatting
502
503 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
504 - verify credentials against xsd schema
505 - Fix SM to SM communication
506 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
507 - new setting session_key_path
508
509 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
510 - fix registry credential regeneration and handle expiration
511 - support for setting slice tags (min_role=user)
512 - client can display its own version: sfi.py version --local
513 - GetVersion to provide urn in addition to hrn
514 - more code uses plxrn vs previous helper functions
515 - import replaces '+' in email addresses with '_'
516
517 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
518 - fix GetVersion code_tag and add code_url
519
520 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
521 - extend GetVersion towards minimum federation introspection, and expose local tag
522
523 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
524 - fixed some legacy issues (list vs List)
525 - deprecated sfa.util.namespace for xrn and plxrn
526 - unit tests ship as the sfa-tests rpm
527
528 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
529 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
530 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
531 - hrn-urn translations tweaked
532 - fixed 'service sfa status'
533 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
534 - started to repair sfadump - although not usable yet
535 - trust objects now have dump_string method that dump() actually prints
536 - unit tests under review
537 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
538 - binaries now support -v or -vv to increase loglevel
539 - trashed obsolete sfa.util.client
540
541 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
542 - various bugfixes and cleanup, improved/harmonized logging
543
544 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
545 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
546   to avoid returning a PLCAPI exception that might confuse users.
547 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
548 - fix build errors.  
549
550 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
551 - (Architecture) Credential format changed to match ProtoGENI xml format
552 - (Architecture) All interfaces export a new set of methods that are compatible
553    with the ProtoGeni Aggregate spec. These new methods are considered a 
554    replacement  for the pervious methods exported by the interfaces. All 
555    previous methods are still exported and work as normal, but they are 
556    considered deprecated and will not be supported in future releases.  
557 - (Architecture) SFI has been updated to use the new interface methods.
558 - (Architecture) Changed keyconvet implementation from c to python.
559 - (Architecture) Slice Manager now attempts looks for a delegated credential
560   provided by the client before using its own server credential.
561 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
562   This cache now exists only in memory and is cleared when service is restarted
563   or cache lifetime is exceeded.  
564 - (Performance) SliceManager sends request to Aggregates in parallel instead 
565   of sequentially.
566 - (Bug fix) SFA tickets now support the new rspec format.
567 - (Bug fix) SFI only uses cahced credential if they aren't expired.
568 - (Bug fix) Cerdential delegation modified to work with new credential format.
569 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
570   Aggregate instead of relaying through the Slice Manager.
571 - (Enhancement) Simplified caching. Accociated a global cache instance with
572   the api handler on every new server request, making it easier to access the 
573   cache and use in more general ways.     
574
575 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
576 - SfaServer now uses a pool of threads to handle requests concurrently
577 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
578 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
579 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
580 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
581 - Component manager does not install gid files if slice already has them  
582 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
583 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
584 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
585      
586 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
587 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
588 - - sfa-config-tty now has the same features like plc-config-tty
589 - - Contains code to support both urn and hrn
590 - - Cleaned up request_hash related stuff
591 - - SM, AM and Registry code is organized under respective managers
592 - - Site and Slice synchronization across federated aggregates
593 - - Script to generate sfa_component_config
594
595 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
596 - sfa-config-tty now has the same features like plc-config-tty
597 - Contains code to support both urn and hrn
598 - Cleaned up request_hash related stuff
599 - SM, AM and Registry code is organized under respective managers
600 - Slice synchronization across federated aggregates
601 - some bugs are fixed
602
603 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
604 - checkpoint with fewer mentions of geni
605
606 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
607 - checkpointing
608 - this is believed to pass the tests; among other things:
609 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
610
611 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
612 - This tag includes:
613 - - Sfatables
614 - - Preliminary version of hash based authentication
615 - - Initial code for Component Manager
616 - - Authority structure is moved to /var/lib/sfa/
617 - - some bug-fixes
618
619 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
620 - Create_slice and get_resources methods are connected to sfatables.
621 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
622
623 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
624 - Bug fix on update and remove_peer_object methods
625 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
626
627 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
628 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
629
630 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
631 - compatibility with RefreshPeer
632 - incremental mechanism for importing PLC records into SFA tables
633 - unified single database (still inside the underlying PLC db postgresql server)
634 - includes/improves call traceability and logging features
635 - several bug fixes
636
637 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
638 - added libxslt-python dependency
639
640 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
641 - unified single SFA database in the PLC-DB
642 - upcalls from  PLCAPI to SFA methods
643 - SFA call traceability and logging features
644 - many bug fixes
645 - includes first/rough version of sfatables for policy implementation
646
647 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
648 - snapshot after the GEC5 demo
649 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
650
651 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
652 - snapshot july 15 - has gone through superficial manual testing
653 - hopefully a good basis for gec5 demo
654 - multi-dir sfi client tested as well
655
656 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
657 - rename geniwrapper.spec into sfa.spec
658
659 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
660 - clean up in xmlrpc/soap, --protocol option to chose between both
661 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
662 - hopefully more helpful context in case of crashes when importing
663 - bugfixes for using only /etc/sfa for site-dep files
664 - bugfixes in wsdl generation
665
666 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
667 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
668 - config variables in sfa_config now start with SFA_ and not GENI_
669 - config.py can be loaded even with no config present
670
671 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
672 - first step for cleanup and reorganization
673 - mass-renaming from geni to sfa (some are still needed)
674 - sfa/trust implements the security architecture
675
676 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
677 - snapshot for reproducible builds
678
679 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
680 - snapshot for the convenience of alpha users
681
682 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
683 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
684
685 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
686 - ongoing work - snapshot for 4.3-rc9
687
688 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
689 - various fixes
690
691 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
692 - bugfixes - still a work in progress
693
694 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
695 - initial package
696
697
698 %define module_current_branch 0.2