minor
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45  
46 # python 2.5 has uuid module added, for python 2.4 we still need it.
47 # we can't really check for if we can load uuid as a python module,
48 # it'll be installed by "devel.pkgs". we have the epel repository so
49 # python-uuid will be provided. but we can test for the python
50 # version.
51 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
52 # %if %has_py24
53 #
54 # this also didn't work very well. I'll just check for distroname - baris
55 #%if %{distroname} == "centos5"
56 #Requires: python-uuid
57 #%endif
58
59 %package plc
60 Summary: the SFA layer around MyPLC
61 Group: Applications/System
62 Requires: sfa
63 Requires: python-psycopg2
64
65 %package client
66 Summary: the SFA experimenter-side CLI
67 Group: Applications/System
68 Requires: sfa
69 Requires: pyOpenSSL >= 0.7
70
71 %package sfatables
72 Summary: sfatables policy tool for SFA
73 Group: Applications/System
74 Requires: sfa
75
76 %package cm
77 Summary: the SFA layer around MyPLC NodeManager
78 Group: Applications/System
79 Requires: sfa
80 Requires: pyOpenSSL >= 0.6
81
82 %package flashpolicy
83 Summary: SFA support for flash clients
84 Group: Applications/System
85 Requires: sfa
86
87 %package tests
88 Summary: unit tests suite for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %description
93 This package provides the python libraries for the PlanetLab implementation of SFA
94
95 %description plc
96 This package implements the SFA interface which serves as a layer
97 between the existing PlanetLab interfaces and the SFA API.
98
99 %description client
100 This package provides the client side of the SFA API, in particular
101 sfi.py, together with other utilities.
102
103 %description sfatables
104 sfatables is a tool for defining access and admission control policies
105 in an SFA network, in much the same way as iptables is for ip
106 networks. This is the command line interface to manage sfatables
107
108 %description cm
109 This package implements the SFA interface which serves as a layer
110 between the existing PlanetLab NodeManager interfaces and the SFA API.
111  
112 %description flashpolicy
113 This package provides support for adobe flash client applications.  
114  
115 %description tests
116 Provides some binary unit tests in /usr/share/sfa/tests
117
118 %prep
119 %setup -q
120
121 %build
122 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
127 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/*egg-info
128 # this gets duplicated
129 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/sfa/storage/sfa.sql
130 # create symlinks
131 (cd $RPM_BUILD_ROOT/%{_bindir}; ln -s sfi.py sfi; ln -s sfascan.py sfascan)
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 # sfa and sfatables depend on each other.
138 %{python_sitelib}/sfa
139 %{python_sitelib}/xmlbuilder
140 /etc/init.d/sfa
141 %{_bindir}/sfa-start.py*
142 %{_bindir}/keyconvert.py*
143 %{_bindir}/sfa-config-tty
144 %config /etc/sfa/default_config.xml
145 %config (noreplace) /etc/sfa/aggregates.xml
146 %config (noreplace) /etc/sfa/registries.xml
147 /usr/share/sfa/sfa.sql
148 /var/www/html/wsdl/*.wsdl
149
150 %files plc
151 %defattr(-,root,root)
152 /etc/sfa/pl.rng
153 /etc/sfa/credential.xsd
154 /etc/sfa/top.xsd
155 /etc/sfa/sig.xsd
156 /etc/sfa/xml.xsd
157 /etc/sfa/protogeni-rspec-common.xsd
158 /etc/sfa/topology
159 %{_bindir}/sfa-import-plc.py*
160 %{_bindir}/sfa-nuke-plc.py*
161 %{_bindir}/sfa-clean-peer-records.py*
162 %{_bindir}/gen-sfa-cm-config.py*
163 %{_bindir}/sfa-ca.py*
164
165 %files client
166 %config (noreplace) /etc/sfa/sfi_config
167 %{_bindir}/sfi*.py*
168 %{_bindir}/get*.py*
169 %{_bindir}/setRecord.py*
170 %{_bindir}/sfascan.py*
171 %{_bindir}/sfadump.py*
172
173 %files sfatables
174 /etc/sfatables/*
175 %{_bindir}/sfatables
176 %{python_sitelib}/sfatables
177
178 %files cm
179 /etc/init.d/sfa-cm
180 %{_bindir}/sfa_component_setup.py*
181 # cron jobs here 
182
183 %files flashpolicy
184 %{_bindir}/sfa_flashpolicy.py*
185 /etc/sfa/sfa_flashpolicy_config.xml
186
187 %files tests
188 %{_datadir}/sfa/tests
189
190 ### sfa-plc installs the 'sfa' service
191 %post plc
192 chkconfig --add sfa
193
194 %preun plc
195 if [ "$1" = 0 ] ; then
196   /sbin/service sfa stop || :
197   /sbin/chkconfig --del sfa || :
198 fi
199
200 %postun plc
201 [ "$1" -ge "1" ] && service sfa restart
202
203 ### sfa-cm installs the 'sfa-cm' service
204 %post cm
205 chkconfig --add sfa-cm
206
207 %preun cm
208 if [ "$1" = 0 ] ; then
209    /sbin/service sfa-cm stop || :
210    /sbin/chkconfig --del sfa-cm || :
211 fi
212
213 %postun cm
214 [ "$1" -ge "1" ] && service sfa-cm restart || :
215
216 %changelog
217 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
218 - various fixes in rspecs for sfav1&slice tags
219 - uses 'geni_rspec_version' and not just 'rspec_version'
220 - example flavour for the max testbed
221 - embryo for an sfa client library
222 - topology.py moved into plc
223 - sql: table is named records; record_types are enforced
224 - sql: table creation cleaned up
225
226 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
227 - cleaned up all references to SFA_*_TYPE in config
228 - enable cache at the aggregate by default
229 - registry now uses the driver in a sensible way (see managers/driver.py)
230 - slice manager supports sfav1/pgv2 neighbours
231 - get_key renamed into get_key_from_incoming_ip
232 - new sfa.storage module for record/table and all db-related stuff
233 - db schema in sfa.storage.sfa.sql
234 - init.d and cron.d move one step up
235 - cleaned up rspec/ directory
236 - add deps to pyopenssl and myplc-config
237 - start support for new API (return value)
238 - plc.remoteshell removed, use plshell instead
239 - plshell uses a 'capability' auth method whenever possible
240 - various tweaks in rspec elements
241 - made dependency on sfatables softer
242
243 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
244 - sfa should now be started *before* the initial import
245 - sfa to use its own database (default sfa) - can run without myplc
246 - server calls support optional 'options'
247 - client sends options in argument when needed
248 - fix infinite getattr recursion in elements/element.py
249 - error codes in line with geni
250
251 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
252 - fixed links and attributes in rspecs
253 - minor cleanup in the API methods, and more consistent names in manager methods
254
255 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
256 - ongoing refoactoring towards more genericity
257 - passes tests again although known issues remain with attributes/tags
258
259 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
260 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
261 - improvements in the pgv2 rspecs
262 - driver separated from api
263 - code starts moving around where it belongs
264 - sfascan caches getversion across invokations
265 - vini topology extracted as a config file
266
267 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
268 - first support for protogeni rspecs is working
269 - vini no longer needs a specific manager
270 - refactoring underway towards more flexible/generic architecture
271
272 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
273 - Unicode-friendliness for user names with accents/special chars.
274 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
275 - CreaetSliver no longer fails for users that have a capital letter in their URN.
276 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
277 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
278 - Fix bugs and missing imports     
279  
280
281 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
282 - new method record.get_field for sface
283
284 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
285 - new option -c to sfa-nuke-plc.py
286 - CreateSliver fixed for admin-only slice tags
287
288 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
289 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
290 - Fixed holes in certificate verification logic.
291 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
292 - Added 'boot_state' as an attribute of the node element in SFA rspec.
293 - Non authority certificates are marked as CA:FALSE.
294
295 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
296 - fix typo in sfa-1.0-31 tag.
297 - added CreateGid() Registry interface method.
298
299 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
300 - fix typo in sfa-1.0-30 tag
301
302 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
303 - Declare namespace and schema location in the credential.
304 - Fix bug that prevetend connections from timing out.
305 - Fix slice delegation.
306 - Add statistics to slicemaanger listresources/createsliver rspec.
307 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
308   of days a user can extend their slice expiration.
309 - CA certs are only issued to objects of type authority
310    
311 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
312 - tag 1.0-28 was broken due to typo in the changelog
313 - new class sfa/util/httpsProtocol.py that supports timeouts
314
315 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
316 - Resolved issue that caused sfa hold onto idle db connections.
317 - Fix bug that caused the registry to use the wrong type of credential.
318 - Support authority+sm type.
319 - Fix rspec merging bugs.
320 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
321 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
322  planetlab hosted initscripts using the <planetlab:initscript> tag  
323 - Can now handle extraneous whitespace in the rspec without failing.   
324  
325 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
326 - ProtoGENI v2 RSpec updates.
327 - Convert expiration timestamps with timezone info in credentials to utc.
328 - Fixed redundant logging issue. 
329 - Improved SliceManager and SFI client logging.
330 - Support aggregates that don't support the optional 'call_id' argument. 
331 - Only call get_trusted_certs() at aggreage interfaces that support the call.
332 - CreateSliver() now handles MyPLC slice attributes/tags.
333 - Cache now supports persistence.
334 - Hide whitelisted nodes.
335
336 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
337 - fixed issues with sup authority signing
338 - fixed bugs in remove_slivers and SliverStatus
339
340 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
341 - fix typo that prevented aggregates from operating properly
342
343 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
344 - load trusted certs into ssl context prior to handshake
345 - client's logfile lives in ~/.sfi/sfi.log
346
347 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
348 - includes a change on passphrases that was intended in 1.0-22
349
350 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
351 - Added support for ProtoGENI RSpec v2
352  
353 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
354 - stable sfascan
355 - fix in initscript, *ENABLED tags in config now taken into account
356
357 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
358 - some commits had not been pushed in tag 19
359
360 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
361 - GetVersion should now report full URLs with path
362 - scansfa has nicer output and new syntax (entry URLs as args and not options)
363 - dos2unix'ed flash policy pill
364
365 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
366 - fix packaging again for f8
367
368 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
369 - fix packaging (apparently broken in 1.0-16)
370 - first working version of sfascan
371 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
372 - deprecated the sfa_geni_aggregate config category
373
374 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
375 - Fix build problem
376 - First version of SFA scanner
377
378 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
379 - Add support for Flash clients using flashpolicy
380 - Fix problems with tag handling in RSpec
381
382 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
383 - Modifications to the Eucalyptus Aggregate Manager
384 - Fixes for VINI RSpec
385 - Fix tag handling for PL RSpec
386 - Fix XML Schema ordering for <urn> element
387
388 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
389 - just set x509 version to 2
390
391 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
392 - added urn to the node area in rspecs
393 - conversion to urn now exports fqdn
394 - sfa-import-plc.py now creates a unique registry record for each SFA interface
395
396 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
397 - undo broken attempt for python-2.7
398
399 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
400 - SMs avoid duplicates for when call graph has dags;
401 - just based on network's name, when a duplicate occurs, one is just dropped
402 - does not try to merge/aggregate 2 networks
403 - also reviewed logging with the hope to fix the sfa startup msg:
404 - TypeError: not all arguments converted during string formatting
405
406 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
407 - verify credentials against xsd schema
408 - Fix SM to SM communication
409 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
410 - new setting session_key_path
411
412 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
413 - fix registry credential regeneration and handle expiration
414 - support for setting slice tags (min_role=user)
415 - client can display its own version: sfi.py version --local
416 - GetVersion to provide urn in addition to hrn
417 - more code uses plxrn vs previous helper functions
418 - import replaces '+' in email addresses with '_'
419
420 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
421 - fix GetVersion code_tag and add code_url
422
423 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
424 - extend GetVersion towards minimum federation introspection, and expose local tag
425
426 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
427 - fixed some legacy issues (list vs List)
428 - deprecated sfa.util.namespace for xrn and plxrn
429 - unit tests ship as the sfa-tests rpm
430
431 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
432 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
433 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
434 - hrn-urn translations tweaked
435 - fixed 'service sfa status'
436 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
437 - started to repair sfadump - although not usable yet
438 - trust objects now have dump_string method that dump() actually prints
439 - unit tests under review
440 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
441 - binaries now support -v or -vv to increase loglevel
442 - trashed obsolete sfa.util.client
443
444 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
445 - various bugfixes and cleanup, improved/harmonized logging
446
447 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
448 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
449   to avoid returning a PLCAPI exception that might confuse users.
450 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
451 - fix build errors.  
452
453 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
454 - (Architecture) Credential format changed to match ProtoGENI xml format
455 - (Architecture) All interfaces export a new set of methods that are compatible
456    with the ProtoGeni Aggregate spec. These new methods are considered a 
457    replacement  for the pervious methods exported by the interfaces. All 
458    previous methods are still exported and work as normal, but they are 
459    considered deprecated and will not be supported in future releases.  
460 - (Architecture) SFI has been updated to use the new interface methods.
461 - (Architecture) Changed keyconvet implementation from c to python.
462 - (Architecture) Slice Manager now attempts looks for a delegated credential
463   provided by the client before using its own server credential.
464 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
465   This cache now exists only in memory and is cleared when service is restarted
466   or cache lifetime is exceeded.  
467 - (Performance) SliceManager sends request to Aggregates in parallel instead 
468   of sequentially.
469 - (Bug fix) SFA tickets now support the new rspec format.
470 - (Bug fix) SFI only uses cahced credential if they aren't expired.
471 - (Bug fix) Cerdential delegation modified to work with new credential format.
472 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
473   Aggregate instead of relaying through the Slice Manager.
474 - (Enhancement) Simplified caching. Accociated a global cache instance with
475   the api handler on every new server request, making it easier to access the 
476   cache and use in more general ways.     
477
478 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
479 - SfaServer now uses a pool of threads to handle requests concurrently
480 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
481 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
482 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
483 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
484 - Component manager does not install gid files if slice already has them  
485 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
486 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
487 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
488      
489 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
490 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
491 - - sfa-config-tty now has the same features like plc-config-tty
492 - - Contains code to support both urn and hrn
493 - - Cleaned up request_hash related stuff
494 - - SM, AM and Registry code is organized under respective managers
495 - - Site and Slice synchronization across federated aggregates
496 - - Script to generate sfa_component_config
497
498 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
499 - sfa-config-tty now has the same features like plc-config-tty
500 - Contains code to support both urn and hrn
501 - Cleaned up request_hash related stuff
502 - SM, AM and Registry code is organized under respective managers
503 - Slice synchronization across federated aggregates
504 - some bugs are fixed
505
506 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
507 - checkpoint with fewer mentions of geni
508
509 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
510 - checkpointing
511 - this is believed to pass the tests; among other things:
512 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
513
514 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
515 - This tag includes:
516 - - Sfatables
517 - - Preliminary version of hash based authentication
518 - - Initial code for Component Manager
519 - - Authority structure is moved to /var/lib/sfa/
520 - - some bug-fixes
521
522 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
523 - Create_slice and get_resources methods are connected to sfatables.
524 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
525
526 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
527 - Bug fix on update and remove_peer_object methods
528 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
529
530 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
531 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
532
533 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
534 - compatibility with RefreshPeer
535 - incremental mechanism for importing PLC records into SFA tables
536 - unified single database (still inside the underlying PLC db postgresql server)
537 - includes/improves call traceability and logging features
538 - several bug fixes
539
540 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
541 - added libxslt-python dependency
542
543 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
544 - unified single SFA database in the PLC-DB
545 - upcalls from  PLCAPI to SFA methods
546 - SFA call traceability and logging features
547 - many bug fixes
548 - includes first/rough version of sfatables for policy implementation
549
550 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
551 - snapshot after the GEC5 demo
552 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
553
554 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
555 - snapshot july 15 - has gone through superficial manual testing
556 - hopefully a good basis for gec5 demo
557 - multi-dir sfi client tested as well
558
559 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
560 - rename geniwrapper.spec into sfa.spec
561
562 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
563 - clean up in xmlrpc/soap, --protocol option to chose between both
564 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
565 - hopefully more helpful context in case of crashes when importing
566 - bugfixes for using only /etc/sfa for site-dep files
567 - bugfixes in wsdl generation
568
569 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
570 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
571 - config variables in sfa_config now start with SFA_ and not GENI_
572 - config.py can be loaded even with no config present
573
574 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
575 - first step for cleanup and reorganization
576 - mass-renaming from geni to sfa (some are still needed)
577 - sfa/trust implements the security architecture
578
579 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
580 - snapshot for reproducible builds
581
582 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
583 - snapshot for the convenience of alpha users
584
585 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
586 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
587
588 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
589 - ongoing work - snapshot for 4.3-rc9
590
591 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
592 - various fixes
593
594 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
595 - bugfixes - still a work in progress
596
597 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
598 - initial package
599
600
601 %define module_current_branch 0.2