Setting tag sfa-1.0-12
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 12
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %Package tests
74 Summary: unit tests suite for SFA
75 Group: Applications/System
76 Requires: sfa
77
78 %description
79 This package provides the python libraries for the PlanetLab implementation of SFA
80
81 %description cm
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
84  
85 %description plc
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
88
89 %description client
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
92
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
97
98 %description tests
99 Provides some binary unit tests in /usr/share/sfa/tests
100
101 %prep
102 %setup -q
103
104 %build
105 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 # sfa and sfatables depend each other.
116 %{_bindir}/sfa-server.py*
117 /etc/sfatables/*
118 %{python_sitelib}/*
119 %{_bindir}/keyconvert.py*
120 /var/www/html/wsdl/*.wsdl
121
122 %files cm
123 /etc/init.d/sfa-cm
124 %{_bindir}/sfa_component_setup.py*
125 # cron jobs here 
126
127 %files plc
128 %defattr(-,root,root)
129 %config /etc/sfa/default_config.xml
130 %config (noreplace) /etc/sfa/aggregates.xml
131 %config (noreplace) /etc/sfa/registries.xml
132 /etc/init.d/sfa
133 /etc/sfa/pl.rng
134 /etc/sfa/credential.xsd
135 /etc/sfa/top.xsd
136 /etc/sfa/sig.xsd
137 /etc/sfa/xml.xsd
138 /etc/sfa/protogeni-rspec-common.xsd
139 %{_bindir}/sfa-config-tty
140 %{_bindir}/sfa-import-plc.py*
141 %{_bindir}/sfa-clean-peer-records.py*
142 %{_bindir}/sfa-nuke-plc.py*
143 %{_bindir}/gen-sfa-cm-config.py*
144 %{_bindir}/sfa-ca.py*
145
146 %files client
147 %config (noreplace) /etc/sfa/sfi_config
148 %{_bindir}/sfi*
149 %{_bindir}/getNodes.py*
150 %{_bindir}/getRecord.py*
151 %{_bindir}/setRecord.py*
152 %{_bindir}/sfadump.py*
153
154 %files sfatables
155 %{_bindir}/sfatables
156
157 %files tests
158 %{_datadir}/sfa/tests
159
160 ### sfa-plc installs the 'sfa' service
161 %post plc
162 chkconfig --add sfa
163
164 %preun plc
165 if [ "$1" = 0 ] ; then
166   /sbin/service sfa stop || :
167   /sbin/chkconfig --del sfa || :
168 fi
169
170 %postun plc
171 [ "$1" -ge "1" ] && service sfa restart
172
173 ### sfa-cm installs the 'sfa-cm' service
174 %post cm
175 chkconfig --add sfa-cm
176
177 %preun cm
178 if [ "$1" = 0 ] ; then
179    /sbin/service sfa-cm stop || :
180    /sbin/chkconfig --del sfa-cm || :
181 fi
182
183 %postun cm
184 [ "$1" -ge "1" ] && service sfa-cm restart
185
186
187 %changelog
188 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
189 - added urn to the node area in rspecs
190 - conversion to urn now exports fqdn
191 - sfa-import-plc.py now creates a unique registry record for each SFA interface
192
193 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
194 - undo broken attempt for python-2.7
195
196 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
197 - SMs avoid duplicates for when call graph has dags;
198 - just based on network's name, when a duplicate occurs, one is just dropped
199 - does not try to merge/aggregate 2 networks
200 - also reviewed logging with the hope to fix the sfa startup msg:
201 - TypeError: not all arguments converted during string formatting
202
203 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
204 - verify credentials against xsd schema
205 - Fix SM to SM communication
206 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
207 - new setting session_key_path
208
209 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
210 - fix registry credential regeneration and handle expiration
211 - support for setting slice tags (min_role=user)
212 - client can display its own version: sfi.py version --local
213 - GetVersion to provide urn in addition to hrn
214 - more code uses plxrn vs previous helper functions
215 - import replaces '+' in email addresses with '_'
216
217 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
218 - fix GetVersion code_tag and add code_url
219
220 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
221 - extend GetVersion towards minimum federation introspection, and expose local tag
222
223 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
224 - fixed some legacy issues (list vs List)
225 - deprecated sfa.util.namespace for xrn and plxrn
226 - unit tests ship as the sfa-tests rpm
227
228 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
229 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
230 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
231 - hrn-urn translations tweaked
232 - fixed 'service sfa status'
233 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
234 - started to repair sfadump - although not usable yet
235 - trust objects now have dump_string method that dump() actually prints
236 - unit tests under review
237 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
238 - binaries now support -v or -vv to increase loglevel
239 - trashed obsolete sfa.util.client
240
241 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
242 - various bugfixes and cleanup, improved/harmonized logging
243
244 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
245 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
246   to avoid returning a PLCAPI exception that might confuse users.
247 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
248 - fix build errors.  
249
250 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
251 - (Architecture) Credential format changed to match ProtoGENI xml format
252 - (Architecture) All interfaces export a new set of methods that are compatible
253    with the ProtoGeni Aggregate spec. These new methods are considered a 
254    replacement  for the pervious methods exported by the interfaces. All 
255    previous methods are still exported and work as normal, but they are 
256    considered deprecated and will not be supported in future releases.  
257 - (Architecture) SFI has been updated to use the new interface methods.
258 - (Architecture) Changed keyconvet implementation from c to python.
259 - (Architecture) Slice Manager now attempts looks for a delegated credential
260   provided by the client before using its own server credential.
261 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
262   This cache now exists only in memory and is cleared when service is restarted
263   or cache lifetime is exceeded.  
264 - (Performance) SliceManager sends request to Aggregates in parallel instead 
265   of sequentially.
266 - (Bug fix) SFA tickets now support the new rspec format.
267 - (Bug fix) SFI only uses cahced credential if they aren't expired.
268 - (Bug fix) Cerdential delegation modified to work with new credential format.
269 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
270   Aggregate instead of relaying through the Slice Manager.
271 - (Enhancement) Simplified caching. Accociated a global cache instance with
272   the api handler on every new server request, making it easier to access the 
273   cache and use in more general ways.     
274
275 %changelog
276 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
277 - added urn to the node area in rspecs
278 - conversion to urn now exports fqdn
279 - sfa-import-plc.py now creates a unique registry record for each SFA interface
280
281 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
282 - undo broken attempt for python-2.7
283
284 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
285 - SMs avoid duplicates for when call graph has dags;
286 - just based on network's name, when a duplicate occurs, one is just dropped
287 - does not try to merge/aggregate 2 networks
288 - also reviewed logging with the hope to fix the sfa startup msg:
289 - TypeError: not all arguments converted during string formatting
290
291 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
292 - verify credentials against xsd schema
293 - Fix SM to SM communication
294 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
295 - new setting session_key_path
296
297 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
298 - fix registry credential regeneration and handle expiration
299 - support for setting slice tags (min_role=user)
300 - client can display its own version: sfi.py version --local
301 - GetVersion to provide urn in addition to hrn
302 - more code uses plxrn vs previous helper functions
303 - import replaces '+' in email addresses with '_'
304
305 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
306 - fix GetVersion code_tag and add code_url
307
308 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
309 - extend GetVersion towards minimum federation introspection, and expose local tag
310
311 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
312 - fixed some legacy issues (list vs List)
313 - deprecated sfa.util.namespace for xrn and plxrn
314 - unit tests ship as the sfa-tests rpm
315
316 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
317 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
318 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
319 - hrn-urn translations tweaked
320 - fixed 'service sfa status'
321 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
322 - started to repair sfadump - although not usable yet
323 - trust objects now have dump_string method that dump() actually prints
324 - unit tests under review
325 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
326 - binaries now support -v or -vv to increase loglevel
327 - trashed obsolete sfa.util.client
328
329 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
330 - various bugfixes and cleanup, improved/harmonized logging
331
332 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
333 - SfaServer now uses a pool of threads to handle requests concurrently
334 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
335 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
336 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
337 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
338 - Component manager does not install gid files if slice already has them  
339 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
340 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
341 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
342      
343 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
344 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
345 - - sfa-config-tty now has the same features like plc-config-tty
346 - - Contains code to support both urn and hrn
347 - - Cleaned up request_hash related stuff
348 - - SM, AM and Registry code is organized under respective managers
349 - - Site and Slice synchronization across federated aggregates
350 - - Script to generate sfa_component_config
351
352 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
353 - sfa-config-tty now has the same features like plc-config-tty
354 - Contains code to support both urn and hrn
355 - Cleaned up request_hash related stuff
356 - SM, AM and Registry code is organized under respective managers
357 - Slice synchronization across federated aggregates
358 - some bugs are fixed
359
360 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
361 - checkpoint with fewer mentions of geni
362
363 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
364 - checkpointing
365 - this is believed to pass the tests; among other things:
366 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
367
368 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
369 - This tag includes:
370 - - Sfatables
371 - - Preliminary version of hash based authentication
372 - - Initial code for Component Manager
373 - - Authority structure is moved to /var/lib/sfa/
374 - - some bug-fixes
375
376 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
377 - Create_slice and get_resources methods are connected to sfatables.
378 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
379
380 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
381 - Bug fix on update and remove_peer_object methods
382 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
383
384 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
385 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
386
387 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
388 - compatibility with RefreshPeer
389 - incremental mechanism for importing PLC records into SFA tables
390 - unified single database (still inside the underlying PLC db postgresql server)
391 - includes/improves call traceability and logging features
392 - several bug fixes
393
394 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
395 - added libxslt-python dependency
396
397 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
398 - unified single SFA database in the PLC-DB
399 - upcalls from  PLCAPI to SFA methods
400 - SFA call traceability and logging features
401 - many bug fixes
402 - includes first/rough version of sfatables for policy implementation
403
404 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
405 - snapshot after the GEC5 demo
406 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
407
408 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
409 - snapshot july 15 - has gone through superficial manual testing
410 - hopefully a good basis for gec5 demo
411 - multi-dir sfi client tested as well
412
413 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
414 - rename geniwrapper.spec into sfa.spec
415
416 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
417 - clean up in xmlrpc/soap, --protocol option to chose between both
418 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
419 - hopefully more helpful context in case of crashes when importing
420 - bugfixes for using only /etc/sfa for site-dep files
421 - bugfixes in wsdl generation
422
423 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
424 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
425 - config variables in sfa_config now start with SFA_ and not GENI_
426 - config.py can be loaded even with no config present
427
428 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
429 - first step for cleanup and reorganization
430 - mass-renaming from geni to sfa (some are still needed)
431 - sfa/trust implements the security architecture
432
433 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
434 - snapshot for reproducible builds
435
436 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
437 - snapshot for the convenience of alpha users
438
439 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
440 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
441
442 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
443 - ongoing work - snapshot for 4.3-rc9
444
445 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
446 - various fixes
447
448 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
449 - bugfixes - still a work in progress
450
451 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
452 - initial package
453
454
455 %define module_current_branch 0.2