Setting tag sfa-1.1-5
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # for uuidgen - used in db password generation
31 # on f8 this actually comes with e2fsprogs, go figure
32 Requires: util-linux-ng
33 # xmlbuilder depends on  lxml
34 Requires: python-lxml
35 Requires: python-setuptools
36 Requires: python-dateutil
37 # for the registry
38 Requires: postgresql >= 8.2, postgresql-server >= 8.2
39 Requires: postgresql-python
40 Requires: python-psycopg2
41  
42 # python 2.5 has uuid module added, for python 2.4 we still need it.
43 # we can't really check for if we can load uuid as a python module,
44 # it'll be installed by "devel.pkgs". we have the epel repository so
45 # python-uuid will be provided. but we can test for the python
46 # version.
47 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
48 # %if %has_py24
49 #
50 # this also didn't work very well. I'll just check for distroname - baris
51 #%if %{distroname} == "centos5"
52 #Requires: python-uuid
53 #%endif
54
55 %package cm
56 Summary: the SFA layer around MyPLC NodeManager
57 Group: Applications/System
58 Requires: sfa
59 Requires: pyOpenSSL >= 0.6
60
61 %package plc
62 Summary: the SFA layer around MyPLC
63 Group: Applications/System
64 Requires: sfa
65 Requires: python-psycopg2
66 Requires: myplc-config
67 Requires: pyOpenSSL >= 0.7
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package sfatables
76 Summary: sfatables policy tool for SFA
77 Group: Applications/System
78 Requires: sfa
79
80 %package flashpolicy
81 Summary: SFA support for flash clients
82 Group: Applications/System
83 Requires: sfa
84
85 %package tests
86 Summary: unit tests suite for SFA
87 Group: Applications/System
88 Requires: sfa
89
90 %description
91 This package provides the python libraries for the PlanetLab implementation of SFA
92
93 %description cm
94 This package implements the SFA interface which serves as a layer
95 between the existing PlanetLab NodeManager interfaces and the SFA API.
96  
97 %description plc
98 This package implements the SFA interface which serves as a layer
99 between the existing PlanetLab interfaces and the SFA API.
100
101 %description client
102 This package provides the client side of the SFA API, in particular
103 sfi.py, together with other utilities.
104
105 %description sfatables
106 sfatables is a tool for defining access and admission control policies
107 in an SFA network, in much the same way as iptables is for ip
108 networks. This is the command line interface to manage sfatables
109
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112  
113 %description tests
114 Provides some binary unit tests in /usr/share/sfa/tests
115
116 %prep
117 %setup -q
118
119 %build
120 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 # sfa and sfatables depend each other.
131 %{_bindir}/sfa-start.py*
132 /etc/sfatables/*
133 %{python_sitelib}/*
134 %{_bindir}/keyconvert.py*
135 /var/www/html/wsdl/*.wsdl
136
137 %files cm
138 /etc/init.d/sfa-cm
139 %{_bindir}/sfa_component_setup.py*
140 # cron jobs here 
141
142 %files plc
143 %defattr(-,root,root)
144 %config /etc/sfa/default_config.xml
145 %config (noreplace) /etc/sfa/aggregates.xml
146 %config (noreplace) /etc/sfa/registries.xml
147 /etc/init.d/sfa
148 /etc/sfa/pl.rng
149 /etc/sfa/credential.xsd
150 /etc/sfa/top.xsd
151 /etc/sfa/sig.xsd
152 /etc/sfa/xml.xsd
153 /etc/sfa/protogeni-rspec-common.xsd
154 /etc/sfa/topology
155 %{_bindir}/sfa-config-tty
156 %{_bindir}/sfa-import-plc.py*
157 %{_bindir}/sfa-clean-peer-records.py*
158 %{_bindir}/sfa-nuke-plc.py*
159 %{_bindir}/gen-sfa-cm-config.py*
160 %{_bindir}/sfa-ca.py*
161
162 %files client
163 %config (noreplace) /etc/sfa/sfi_config
164 %{_bindir}/sfi*
165 %{_bindir}/getNodes.py*
166 %{_bindir}/getRecord.py*
167 %{_bindir}/setRecord.py*
168 %{_bindir}/sfadump.py*
169
170 %files sfatables
171 %{_bindir}/sfatables
172
173 %files flashpolicy
174 %{_bindir}/sfa_flashpolicy.py*
175 /etc/sfa/sfa_flashpolicy_config.xml
176
177 %files tests
178 %{_datadir}/sfa/tests
179
180 ### sfa-plc installs the 'sfa' service
181 %post plc
182 chkconfig --add sfa
183
184 %preun plc
185 if [ "$1" = 0 ] ; then
186   /sbin/service sfa stop || :
187   /sbin/chkconfig --del sfa || :
188 fi
189
190 %postun plc
191 [ "$1" -ge "1" ] && service sfa restart
192
193 ### sfa-cm installs the 'sfa-cm' service
194 %post cm
195 chkconfig --add sfa-cm
196
197 %preun cm
198 if [ "$1" = 0 ] ; then
199    /sbin/service sfa-cm stop || :
200    /sbin/chkconfig --del sfa-cm || :
201 fi
202
203 %postun cm
204 [ "$1" -ge "1" ] && service sfa-cm restart || :
205
206 %changelog
207 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
208 - sfa should now be started *before* the initial import
209 - sfa to use its own database (default sfa) - can run without myplc
210 - server calls support optional 'options'
211 - client sends options in argument when needed
212 - fix infinite getattr recursion in elements/element.py
213 - error codes in line with geni
214
215 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
216 - fixed links and attributes in rspecs
217 - minor cleanup in the API methods, and more consistent names in manager methods
218
219 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
220 - ongoing refoactoring towards more genericity
221 - passes tests again although known issues remain with attributes/tags
222
223 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
224 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
225 - improvements in the pgv2 rspecs
226 - driver separated from api
227 - code starts moving around where it belongs
228 - sfascan caches getversion across invokations
229 - vini topology extracted as a config file
230
231 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
232 - first support for protogeni rspecs is working
233 - vini no longer needs a specific manager
234 - refactoring underway towards more flexible/generic architecture
235
236 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
237 - Unicode-friendliness for user names with accents/special chars.
238 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
239 - CreaetSliver no longer fails for users that have a capital letter in their URN.
240 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
241 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
242 - Fix bugs and missing imports     
243  
244
245 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
246 - new method record.get_field for sface
247
248 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
249 - new option -c to sfa-nuke-plc.py
250 - CreateSliver fixed for admin-only slice tags
251
252 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
253 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
254 - Fixed holes in certificate verification logic.
255 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
256 - Added 'boot_state' as an attribute of the node element in SFA rspec.
257 - Non authority certificates are marked as CA:FALSE.
258
259 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
260 - fix typo in sfa-1.0-31 tag.
261 - added CreateGid() Registry interface method.
262
263 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
264 - fix typo in sfa-1.0-30 tag
265
266 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
267 - Declare namespace and schema location in the credential.
268 - Fix bug that prevetend connections from timing out.
269 - Fix slice delegation.
270 - Add statistics to slicemaanger listresources/createsliver rspec.
271 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
272   of days a user can extend their slice expiration.
273 - CA certs are only issued to objects of type authority
274    
275 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
276 - tag 1.0-28 was broken due to typo in the changelog
277 - new class sfa/util/httpsProtocol.py that supports timeouts
278
279 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
280 - Resolved issue that caused sfa hold onto idle db connections.
281 - Fix bug that caused the registry to use the wrong type of credential.
282 - Support authority+sm type.
283 - Fix rspec merging bugs.
284 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
285 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
286  planetlab hosted initscripts using the <planetlab:initscript> tag  
287 - Can now handle extraneous whitespace in the rspec without failing.   
288  
289 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
290 - ProtoGENI v2 RSpec updates.
291 - Convert expiration timestamps with timezone info in credentials to utc.
292 - Fixed redundant logging issue. 
293 - Improved SliceManager and SFI client logging.
294 - Support aggregates that don't support the optional 'call_id' argument. 
295 - Only call get_trusted_certs() at aggreage interfaces that support the call.
296 - CreateSliver() now handles MyPLC slice attributes/tags.
297 - Cache now supports persistence.
298 - Hide whitelisted nodes.
299
300 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
301 - fixed issues with sup authority signing
302 - fixed bugs in remove_slivers and SliverStatus
303
304 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
305 - fix typo that prevented aggregates from operating properly
306
307 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
308 - load trusted certs into ssl context prior to handshake
309 - client's logfile lives in ~/.sfi/sfi.log
310
311 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
312 - includes a change on passphrases that was intended in 1.0-22
313
314 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
315 - Added support for ProtoGENI RSpec v2
316  
317 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
318 - stable sfascan
319 - fix in initscript, *ENABLED tags in config now taken into account
320
321 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
322 - some commits had not been pushed in tag 19
323
324 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
325 - GetVersion should now report full URLs with path
326 - scansfa has nicer output and new syntax (entry URLs as args and not options)
327 - dos2unix'ed flash policy pill
328
329 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
330 - fix packaging again for f8
331
332 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
333 - fix packaging (apparently broken in 1.0-16)
334 - first working version of sfascan
335 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
336 - deprecated the sfa_geni_aggregate config category
337
338 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
339 - Fix build problem
340 - First version of SFA scanner
341
342 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
343 - Add support for Flash clients using flashpolicy
344 - Fix problems with tag handling in RSpec
345
346 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
347 - Modifications to the Eucalyptus Aggregate Manager
348 - Fixes for VINI RSpec
349 - Fix tag handling for PL RSpec
350 - Fix XML Schema ordering for <urn> element
351
352 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
353 - just set x509 version to 2
354
355 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
356 - added urn to the node area in rspecs
357 - conversion to urn now exports fqdn
358 - sfa-import-plc.py now creates a unique registry record for each SFA interface
359
360 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
361 - undo broken attempt for python-2.7
362
363 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
364 - SMs avoid duplicates for when call graph has dags;
365 - just based on network's name, when a duplicate occurs, one is just dropped
366 - does not try to merge/aggregate 2 networks
367 - also reviewed logging with the hope to fix the sfa startup msg:
368 - TypeError: not all arguments converted during string formatting
369
370 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
371 - verify credentials against xsd schema
372 - Fix SM to SM communication
373 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
374 - new setting session_key_path
375
376 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
377 - fix registry credential regeneration and handle expiration
378 - support for setting slice tags (min_role=user)
379 - client can display its own version: sfi.py version --local
380 - GetVersion to provide urn in addition to hrn
381 - more code uses plxrn vs previous helper functions
382 - import replaces '+' in email addresses with '_'
383
384 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
385 - fix GetVersion code_tag and add code_url
386
387 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
388 - extend GetVersion towards minimum federation introspection, and expose local tag
389
390 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
391 - fixed some legacy issues (list vs List)
392 - deprecated sfa.util.namespace for xrn and plxrn
393 - unit tests ship as the sfa-tests rpm
394
395 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
396 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
397 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
398 - hrn-urn translations tweaked
399 - fixed 'service sfa status'
400 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
401 - started to repair sfadump - although not usable yet
402 - trust objects now have dump_string method that dump() actually prints
403 - unit tests under review
404 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
405 - binaries now support -v or -vv to increase loglevel
406 - trashed obsolete sfa.util.client
407
408 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
409 - various bugfixes and cleanup, improved/harmonized logging
410
411 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
412 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
413   to avoid returning a PLCAPI exception that might confuse users.
414 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
415 - fix build errors.  
416
417 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
418 - (Architecture) Credential format changed to match ProtoGENI xml format
419 - (Architecture) All interfaces export a new set of methods that are compatible
420    with the ProtoGeni Aggregate spec. These new methods are considered a 
421    replacement  for the pervious methods exported by the interfaces. All 
422    previous methods are still exported and work as normal, but they are 
423    considered deprecated and will not be supported in future releases.  
424 - (Architecture) SFI has been updated to use the new interface methods.
425 - (Architecture) Changed keyconvet implementation from c to python.
426 - (Architecture) Slice Manager now attempts looks for a delegated credential
427   provided by the client before using its own server credential.
428 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
429   This cache now exists only in memory and is cleared when service is restarted
430   or cache lifetime is exceeded.  
431 - (Performance) SliceManager sends request to Aggregates in parallel instead 
432   of sequentially.
433 - (Bug fix) SFA tickets now support the new rspec format.
434 - (Bug fix) SFI only uses cahced credential if they aren't expired.
435 - (Bug fix) Cerdential delegation modified to work with new credential format.
436 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
437   Aggregate instead of relaying through the Slice Manager.
438 - (Enhancement) Simplified caching. Accociated a global cache instance with
439   the api handler on every new server request, making it easier to access the 
440   cache and use in more general ways.     
441
442 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
443 - SfaServer now uses a pool of threads to handle requests concurrently
444 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
445 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
446 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
447 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
448 - Component manager does not install gid files if slice already has them  
449 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
450 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
451 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
452      
453 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
454 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
455 - - sfa-config-tty now has the same features like plc-config-tty
456 - - Contains code to support both urn and hrn
457 - - Cleaned up request_hash related stuff
458 - - SM, AM and Registry code is organized under respective managers
459 - - Site and Slice synchronization across federated aggregates
460 - - Script to generate sfa_component_config
461
462 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
463 - sfa-config-tty now has the same features like plc-config-tty
464 - Contains code to support both urn and hrn
465 - Cleaned up request_hash related stuff
466 - SM, AM and Registry code is organized under respective managers
467 - Slice synchronization across federated aggregates
468 - some bugs are fixed
469
470 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
471 - checkpoint with fewer mentions of geni
472
473 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
474 - checkpointing
475 - this is believed to pass the tests; among other things:
476 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
477
478 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
479 - This tag includes:
480 - - Sfatables
481 - - Preliminary version of hash based authentication
482 - - Initial code for Component Manager
483 - - Authority structure is moved to /var/lib/sfa/
484 - - some bug-fixes
485
486 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
487 - Create_slice and get_resources methods are connected to sfatables.
488 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
489
490 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
491 - Bug fix on update and remove_peer_object methods
492 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
493
494 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
495 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
496
497 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
498 - compatibility with RefreshPeer
499 - incremental mechanism for importing PLC records into SFA tables
500 - unified single database (still inside the underlying PLC db postgresql server)
501 - includes/improves call traceability and logging features
502 - several bug fixes
503
504 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
505 - added libxslt-python dependency
506
507 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
508 - unified single SFA database in the PLC-DB
509 - upcalls from  PLCAPI to SFA methods
510 - SFA call traceability and logging features
511 - many bug fixes
512 - includes first/rough version of sfatables for policy implementation
513
514 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
515 - snapshot after the GEC5 demo
516 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
517
518 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
519 - snapshot july 15 - has gone through superficial manual testing
520 - hopefully a good basis for gec5 demo
521 - multi-dir sfi client tested as well
522
523 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
524 - rename geniwrapper.spec into sfa.spec
525
526 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
527 - clean up in xmlrpc/soap, --protocol option to chose between both
528 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
529 - hopefully more helpful context in case of crashes when importing
530 - bugfixes for using only /etc/sfa for site-dep files
531 - bugfixes in wsdl generation
532
533 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
534 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
535 - config variables in sfa_config now start with SFA_ and not GENI_
536 - config.py can be loaded even with no config present
537
538 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
539 - first step for cleanup and reorganization
540 - mass-renaming from geni to sfa (some are still needed)
541 - sfa/trust implements the security architecture
542
543 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
544 - snapshot for reproducible builds
545
546 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
547 - snapshot for the convenience of alpha users
548
549 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
550 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
551
552 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
553 - ongoing work - snapshot for 4.3-rc9
554
555 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
556 - various fixes
557
558 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
559 - bugfixes - still a work in progress
560
561 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
562 - initial package
563
564
565 %define module_current_branch 0.2