getting closer to a working packaging
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 9
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/keyconvert.py*
152 %{_bindir}/sfa-config-tty
153 %config /etc/sfa/default_config.xml
154 %config (noreplace) /etc/sfa/aggregates.xml
155 %config (noreplace) /etc/sfa/registries.xml
156 /usr/share/sfa/migrations
157 /usr/share/sfa/examples
158 /var/www/html/wsdl/*.wsdl
159
160 %files plc
161 %defattr(-,root,root)
162 /etc/sfa/pl.rng
163 /etc/sfa/credential.xsd
164 /etc/sfa/top.xsd
165 /etc/sfa/sig.xsd
166 /etc/sfa/xml.xsd
167 /etc/sfa/protogeni-rspec-common.xsd
168 /etc/sfa/topology
169 %{_bindir}/sfa-import-plc.py*
170 %{_bindir}/sfa-nuke-plc.py*
171 %{_bindir}/sfa-clean-peer-records.py*
172 %{_bindir}/gen-sfa-cm-config.py*
173 %{_bindir}/sfa-ca.py*
174
175 %files client
176 %config (noreplace) /etc/sfa/sfi_config
177 %{_bindir}/sfi*.py*
178 %{_bindir}/sfi
179 %{_bindir}/get*.py*
180 %{_bindir}/setRecord.py*
181 %{_bindir}/sfascan.py*
182 %{_bindir}/sfascan
183 %{_bindir}/sfadump.py*
184
185 %files sfatables
186 /etc/sfatables/*
187 %{_bindir}/sfatables
188 %{python_sitelib}/sfatables
189
190 %files cm
191 /etc/init.d/sfa-cm
192 %{_bindir}/sfa_component_setup.py*
193 # cron jobs here 
194
195 %files flashpolicy
196 %{_bindir}/sfa_flashpolicy.py*
197 /etc/sfa/sfa_flashpolicy_config.xml
198
199 %files xmlbuilder
200 %{python_sitelib}/xmlbuilder
201
202 %files tests
203 %{_datadir}/sfa/tests
204
205 ### sfa-plc installs the 'sfa' service
206 %post plc
207 chkconfig --add sfa
208
209 %preun plc
210 if [ "$1" = 0 ] ; then
211   /sbin/service sfa stop || :
212   /sbin/chkconfig --del sfa || :
213 fi
214
215 %postun plc
216 [ "$1" -ge "1" ] && service sfa restart
217
218 ### sfa-cm installs the 'sfa-cm' service
219 %post cm
220 chkconfig --add sfa-cm
221
222 %preun cm
223 if [ "$1" = 0 ] ; then
224    /sbin/service sfa-cm stop || :
225    /sbin/chkconfig --del sfa-cm || :
226 fi
227
228 %postun cm
229 [ "$1" -ge "1" ] && service sfa-cm restart || :
230
231 %changelog
232 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
233 - bugfix: 'geni_api' should be in the top level struct, not the code struct
234 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
235           output returned by the Aggregate Manager.
236 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
237 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
238 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
239           there is extra whitespace in the schemaLocation field.
240 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
241           advertisement rspecs.
242 - bugfix: <login> RSpec element should contain the 'username' attribute.
243 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
244  
245 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
246 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
247   exit when it encountered a user with an invalid public key.
248 - server: imporved logging in sfa-import-plc.py
249  
250 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
251 - bugfix: Fixed appending public keys in CreateSliver
252 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
253 - client: -c --current option allows users to request the current/uncached rspec.
254 - server: Added 'geni_api_versions' field to GetVersion() output.
255 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
256    
257 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
258 - bugfix: sfi was not sending call_id with ListResources to v2 servers
259 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
260 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
261
262 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
263 - client: sfi -a / -p deprecated (use -s instead)
264 - client: sfi cleaned up
265 - client: sfi has backward support for APIv1 aggregates again
266 - server: only APIv2 is supported and should be rather strict
267 - server: settings for turning on/off caching in sm or am
268 - server: plc-dependant code has moved from aggregate to pldriver
269 - server: driver interface extended accordingly
270
271 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
272 - screwed up previous tag
273
274 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
275 - client side revisited with a bootstrap library
276 - client side has a new source layout
277 - various (nasty) bug fixes wrt options and call_id
278
279 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
280 - various fixes in rspecs for sfav1&slice tags
281 - uses 'geni_rspec_version' and not just 'rspec_version'
282 - example flavour for the max testbed
283 - embryo for an sfa client library
284 - topology.py moved into plc
285 - sql: table is named records; record_types are enforced
286 - sql: table creation cleaned up
287
288 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
289 - cleaned up all references to SFA_*_TYPE in config
290 - enable cache at the aggregate by default
291 - registry now uses the driver in a sensible way (see managers/driver.py)
292 - slice manager supports sfav1/pgv2 neighbours
293 - get_key renamed into get_key_from_incoming_ip
294 - new sfa.storage module for record/table and all db-related stuff
295 - db schema in sfa.storage.sfa.sql
296 - init.d and cron.d move one step up
297 - cleaned up rspec/ directory
298 - add deps to pyopenssl and myplc-config
299 - start support for new API (return value)
300 - plc.remoteshell removed, use plshell instead
301 - plshell uses a 'capability' auth method whenever possible
302 - various tweaks in rspec elements
303 - made dependency on sfatables softer
304
305 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
306 - sfa should now be started *before* the initial import
307 - sfa to use its own database (default sfa) - can run without myplc
308 - server calls support optional 'options'
309 - client sends options in argument when needed
310 - fix infinite getattr recursion in elements/element.py
311 - error codes in line with geni
312
313 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
314 - fixed links and attributes in rspecs
315 - minor cleanup in the API methods, and more consistent names in manager methods
316
317 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
318 - ongoing refoactoring towards more genericity
319 - passes tests again although known issues remain with attributes/tags
320
321 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
322 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
323 - improvements in the pgv2 rspecs
324 - driver separated from api
325 - code starts moving around where it belongs
326 - sfascan caches getversion across invokations
327 - vini topology extracted as a config file
328
329 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
330 - first support for protogeni rspecs is working
331 - vini no longer needs a specific manager
332 - refactoring underway towards more flexible/generic architecture
333
334 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
335 - Unicode-friendliness for user names with accents/special chars.
336 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
337 - CreaetSliver no longer fails for users that have a capital letter in their URN.
338 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
339 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
340 - Fix bugs and missing imports     
341  
342
343 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
344 - new method record.get_field for sface
345
346 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
347 - new option -c to sfa-nuke-plc.py
348 - CreateSliver fixed for admin-only slice tags
349
350 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
351 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
352 - Fixed holes in certificate verification logic.
353 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
354 - Added 'boot_state' as an attribute of the node element in SFA rspec.
355 - Non authority certificates are marked as CA:FALSE.
356
357 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
358 - fix typo in sfa-1.0-31 tag.
359 - added CreateGid() Registry interface method.
360
361 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
362 - fix typo in sfa-1.0-30 tag
363
364 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
365 - Declare namespace and schema location in the credential.
366 - Fix bug that prevetend connections from timing out.
367 - Fix slice delegation.
368 - Add statistics to slicemaanger listresources/createsliver rspec.
369 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
370   of days a user can extend their slice expiration.
371 - CA certs are only issued to objects of type authority
372    
373 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
374 - tag 1.0-28 was broken due to typo in the changelog
375 - new class sfa/util/httpsProtocol.py that supports timeouts
376
377 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
378 - Resolved issue that caused sfa hold onto idle db connections.
379 - Fix bug that caused the registry to use the wrong type of credential.
380 - Support authority+sm type.
381 - Fix rspec merging bugs.
382 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
383 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
384  planetlab hosted initscripts using the <planetlab:initscript> tag  
385 - Can now handle extraneous whitespace in the rspec without failing.   
386  
387 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
388 - ProtoGENI v2 RSpec updates.
389 - Convert expiration timestamps with timezone info in credentials to utc.
390 - Fixed redundant logging issue. 
391 - Improved SliceManager and SFI client logging.
392 - Support aggregates that don't support the optional 'call_id' argument. 
393 - Only call get_trusted_certs() at aggreage interfaces that support the call.
394 - CreateSliver() now handles MyPLC slice attributes/tags.
395 - Cache now supports persistence.
396 - Hide whitelisted nodes.
397
398 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
399 - fixed issues with sup authority signing
400 - fixed bugs in remove_slivers and SliverStatus
401
402 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
403 - fix typo that prevented aggregates from operating properly
404
405 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
406 - load trusted certs into ssl context prior to handshake
407 - client's logfile lives in ~/.sfi/sfi.log
408
409 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
410 - includes a change on passphrases that was intended in 1.0-22
411
412 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
413 - Added support for ProtoGENI RSpec v2
414  
415 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
416 - stable sfascan
417 - fix in initscript, *ENABLED tags in config now taken into account
418
419 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
420 - some commits had not been pushed in tag 19
421
422 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
423 - GetVersion should now report full URLs with path
424 - scansfa has nicer output and new syntax (entry URLs as args and not options)
425 - dos2unix'ed flash policy pill
426
427 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
428 - fix packaging again for f8
429
430 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
431 - fix packaging (apparently broken in 1.0-16)
432 - first working version of sfascan
433 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
434 - deprecated the sfa_geni_aggregate config category
435
436 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
437 - Fix build problem
438 - First version of SFA scanner
439
440 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
441 - Add support for Flash clients using flashpolicy
442 - Fix problems with tag handling in RSpec
443
444 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
445 - Modifications to the Eucalyptus Aggregate Manager
446 - Fixes for VINI RSpec
447 - Fix tag handling for PL RSpec
448 - Fix XML Schema ordering for <urn> element
449
450 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
451 - just set x509 version to 2
452
453 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
454 - added urn to the node area in rspecs
455 - conversion to urn now exports fqdn
456 - sfa-import-plc.py now creates a unique registry record for each SFA interface
457
458 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
459 - undo broken attempt for python-2.7
460
461 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
462 - SMs avoid duplicates for when call graph has dags;
463 - just based on network's name, when a duplicate occurs, one is just dropped
464 - does not try to merge/aggregate 2 networks
465 - also reviewed logging with the hope to fix the sfa startup msg:
466 - TypeError: not all arguments converted during string formatting
467
468 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
469 - verify credentials against xsd schema
470 - Fix SM to SM communication
471 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
472 - new setting session_key_path
473
474 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
475 - fix registry credential regeneration and handle expiration
476 - support for setting slice tags (min_role=user)
477 - client can display its own version: sfi.py version --local
478 - GetVersion to provide urn in addition to hrn
479 - more code uses plxrn vs previous helper functions
480 - import replaces '+' in email addresses with '_'
481
482 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
483 - fix GetVersion code_tag and add code_url
484
485 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
486 - extend GetVersion towards minimum federation introspection, and expose local tag
487
488 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
489 - fixed some legacy issues (list vs List)
490 - deprecated sfa.util.namespace for xrn and plxrn
491 - unit tests ship as the sfa-tests rpm
492
493 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
494 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
495 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
496 - hrn-urn translations tweaked
497 - fixed 'service sfa status'
498 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
499 - started to repair sfadump - although not usable yet
500 - trust objects now have dump_string method that dump() actually prints
501 - unit tests under review
502 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
503 - binaries now support -v or -vv to increase loglevel
504 - trashed obsolete sfa.util.client
505
506 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
507 - various bugfixes and cleanup, improved/harmonized logging
508
509 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
510 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
511   to avoid returning a PLCAPI exception that might confuse users.
512 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
513 - fix build errors.  
514
515 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
516 - (Architecture) Credential format changed to match ProtoGENI xml format
517 - (Architecture) All interfaces export a new set of methods that are compatible
518    with the ProtoGeni Aggregate spec. These new methods are considered a 
519    replacement  for the pervious methods exported by the interfaces. All 
520    previous methods are still exported and work as normal, but they are 
521    considered deprecated and will not be supported in future releases.  
522 - (Architecture) SFI has been updated to use the new interface methods.
523 - (Architecture) Changed keyconvet implementation from c to python.
524 - (Architecture) Slice Manager now attempts looks for a delegated credential
525   provided by the client before using its own server credential.
526 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
527   This cache now exists only in memory and is cleared when service is restarted
528   or cache lifetime is exceeded.  
529 - (Performance) SliceManager sends request to Aggregates in parallel instead 
530   of sequentially.
531 - (Bug fix) SFA tickets now support the new rspec format.
532 - (Bug fix) SFI only uses cahced credential if they aren't expired.
533 - (Bug fix) Cerdential delegation modified to work with new credential format.
534 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
535   Aggregate instead of relaying through the Slice Manager.
536 - (Enhancement) Simplified caching. Accociated a global cache instance with
537   the api handler on every new server request, making it easier to access the 
538   cache and use in more general ways.     
539
540 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
541 - SfaServer now uses a pool of threads to handle requests concurrently
542 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
543 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
544 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
545 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
546 - Component manager does not install gid files if slice already has them  
547 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
548 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
549 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
550      
551 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
552 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
553 - - sfa-config-tty now has the same features like plc-config-tty
554 - - Contains code to support both urn and hrn
555 - - Cleaned up request_hash related stuff
556 - - SM, AM and Registry code is organized under respective managers
557 - - Site and Slice synchronization across federated aggregates
558 - - Script to generate sfa_component_config
559
560 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
561 - sfa-config-tty now has the same features like plc-config-tty
562 - Contains code to support both urn and hrn
563 - Cleaned up request_hash related stuff
564 - SM, AM and Registry code is organized under respective managers
565 - Slice synchronization across federated aggregates
566 - some bugs are fixed
567
568 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
569 - checkpoint with fewer mentions of geni
570
571 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
572 - checkpointing
573 - this is believed to pass the tests; among other things:
574 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
575
576 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
577 - This tag includes:
578 - - Sfatables
579 - - Preliminary version of hash based authentication
580 - - Initial code for Component Manager
581 - - Authority structure is moved to /var/lib/sfa/
582 - - some bug-fixes
583
584 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
585 - Create_slice and get_resources methods are connected to sfatables.
586 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
587
588 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
589 - Bug fix on update and remove_peer_object methods
590 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
591
592 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
593 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
594
595 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
596 - compatibility with RefreshPeer
597 - incremental mechanism for importing PLC records into SFA tables
598 - unified single database (still inside the underlying PLC db postgresql server)
599 - includes/improves call traceability and logging features
600 - several bug fixes
601
602 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
603 - added libxslt-python dependency
604
605 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
606 - unified single SFA database in the PLC-DB
607 - upcalls from  PLCAPI to SFA methods
608 - SFA call traceability and logging features
609 - many bug fixes
610 - includes first/rough version of sfatables for policy implementation
611
612 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
613 - snapshot after the GEC5 demo
614 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
615
616 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
617 - snapshot july 15 - has gone through superficial manual testing
618 - hopefully a good basis for gec5 demo
619 - multi-dir sfi client tested as well
620
621 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
622 - rename geniwrapper.spec into sfa.spec
623
624 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
625 - clean up in xmlrpc/soap, --protocol option to chose between both
626 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
627 - hopefully more helpful context in case of crashes when importing
628 - bugfixes for using only /etc/sfa for site-dep files
629 - bugfixes in wsdl generation
630
631 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
632 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
633 - config variables in sfa_config now start with SFA_ and not GENI_
634 - config.py can be loaded even with no config present
635
636 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
637 - first step for cleanup and reorganization
638 - mass-renaming from geni to sfa (some are still needed)
639 - sfa/trust implements the security architecture
640
641 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
642 - snapshot for reproducible builds
643
644 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
645 - snapshot for the convenience of alpha users
646
647 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
648 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
649
650 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
651 - ongoing work - snapshot for 4.3-rc9
652
653 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
654 - various fixes
655
656 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
657 - bugfixes - still a work in progress
658
659 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
660 - initial package
661
662
663 %define module_current_branch 0.2