Merge branch 'master' of ssh://git.onelab.eu/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 19
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %Package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart
197
198
199 %changelog
200 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
201 - GetVersion should now report full URLs with path
202 - scansfa has nicer output and new syntax (entry URLs as args and not options)
203 - dos2unix'ed flash policy pill
204
205 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
206 - fix packaging again for f8
207
208 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
209 - fix packaging (apparently broken in 1.0-16)
210 - first working version of sfascan
211 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
212 - deprecated the sfa_geni_aggregate config category
213
214 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
215 - Fix build problem
216 - First version of SFA scanner
217
218 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
219 - Add support for Flash clients using flashpolicy
220 - Fix problems with tag handling in RSpec
221
222 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
223 - Modifications to the Eucalyptus Aggregate Manager
224 - Fixes for VINI RSpec
225 - Fix tag handling for PL RSpec
226 - Fix XML Schema ordering for <urn> element
227
228 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
229 - just set x509 version to 2
230
231 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
232 - added urn to the node area in rspecs
233 - conversion to urn now exports fqdn
234 - sfa-import-plc.py now creates a unique registry record for each SFA interface
235
236 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
237 - undo broken attempt for python-2.7
238
239 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
240 - SMs avoid duplicates for when call graph has dags;
241 - just based on network's name, when a duplicate occurs, one is just dropped
242 - does not try to merge/aggregate 2 networks
243 - also reviewed logging with the hope to fix the sfa startup msg:
244 - TypeError: not all arguments converted during string formatting
245
246 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
247 - verify credentials against xsd schema
248 - Fix SM to SM communication
249 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
250 - new setting session_key_path
251
252 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
253 - fix registry credential regeneration and handle expiration
254 - support for setting slice tags (min_role=user)
255 - client can display its own version: sfi.py version --local
256 - GetVersion to provide urn in addition to hrn
257 - more code uses plxrn vs previous helper functions
258 - import replaces '+' in email addresses with '_'
259
260 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
261 - fix GetVersion code_tag and add code_url
262
263 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
264 - extend GetVersion towards minimum federation introspection, and expose local tag
265
266 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
267 - fixed some legacy issues (list vs List)
268 - deprecated sfa.util.namespace for xrn and plxrn
269 - unit tests ship as the sfa-tests rpm
270
271 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
272 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
273 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
274 - hrn-urn translations tweaked
275 - fixed 'service sfa status'
276 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
277 - started to repair sfadump - although not usable yet
278 - trust objects now have dump_string method that dump() actually prints
279 - unit tests under review
280 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
281 - binaries now support -v or -vv to increase loglevel
282 - trashed obsolete sfa.util.client
283
284 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
285 - various bugfixes and cleanup, improved/harmonized logging
286
287 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
288 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
289   to avoid returning a PLCAPI exception that might confuse users.
290 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
291 - fix build errors.  
292
293 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
294 - (Architecture) Credential format changed to match ProtoGENI xml format
295 - (Architecture) All interfaces export a new set of methods that are compatible
296    with the ProtoGeni Aggregate spec. These new methods are considered a 
297    replacement  for the pervious methods exported by the interfaces. All 
298    previous methods are still exported and work as normal, but they are 
299    considered deprecated and will not be supported in future releases.  
300 - (Architecture) SFI has been updated to use the new interface methods.
301 - (Architecture) Changed keyconvet implementation from c to python.
302 - (Architecture) Slice Manager now attempts looks for a delegated credential
303   provided by the client before using its own server credential.
304 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
305   This cache now exists only in memory and is cleared when service is restarted
306   or cache lifetime is exceeded.  
307 - (Performance) SliceManager sends request to Aggregates in parallel instead 
308   of sequentially.
309 - (Bug fix) SFA tickets now support the new rspec format.
310 - (Bug fix) SFI only uses cahced credential if they aren't expired.
311 - (Bug fix) Cerdential delegation modified to work with new credential format.
312 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
313   Aggregate instead of relaying through the Slice Manager.
314 - (Enhancement) Simplified caching. Accociated a global cache instance with
315   the api handler on every new server request, making it easier to access the 
316   cache and use in more general ways.     
317
318 %changelog
319 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
320 - GetVersion should now report full URLs with path
321 - scansfa has nicer output and new syntax (entry URLs as args and not options)
322 - dos2unix'ed flash policy pill
323
324 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
325 - fix packaging again for f8
326
327 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
328 - fix packaging (apparently broken in 1.0-16)
329 - first working version of sfascan
330 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
331 - deprecated the sfa_geni_aggregate config category
332
333 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
334 - Fix build problem
335 - First version of SFA scanner
336
337 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
338 - Add support for Flash clients using flashpolicy
339 - Fix problems with tag handling in RSpec
340
341 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
342 - Modifications to the Eucalyptus Aggregate Manager
343 - Fixes for VINI RSpec
344 - Fix tag handling for PL RSpec
345 - Fix XML Schema ordering for <urn> element
346
347 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
348 - just set x509 version to 2
349
350 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
351 - added urn to the node area in rspecs
352 - conversion to urn now exports fqdn
353 - sfa-import-plc.py now creates a unique registry record for each SFA interface
354
355 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
356 - undo broken attempt for python-2.7
357
358 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
359 - SMs avoid duplicates for when call graph has dags;
360 - just based on network's name, when a duplicate occurs, one is just dropped
361 - does not try to merge/aggregate 2 networks
362 - also reviewed logging with the hope to fix the sfa startup msg:
363 - TypeError: not all arguments converted during string formatting
364
365 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
366 - verify credentials against xsd schema
367 - Fix SM to SM communication
368 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
369 - new setting session_key_path
370
371 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
372 - fix registry credential regeneration and handle expiration
373 - support for setting slice tags (min_role=user)
374 - client can display its own version: sfi.py version --local
375 - GetVersion to provide urn in addition to hrn
376 - more code uses plxrn vs previous helper functions
377 - import replaces '+' in email addresses with '_'
378
379 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
380 - fix GetVersion code_tag and add code_url
381
382 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
383 - extend GetVersion towards minimum federation introspection, and expose local tag
384
385 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
386 - fixed some legacy issues (list vs List)
387 - deprecated sfa.util.namespace for xrn and plxrn
388 - unit tests ship as the sfa-tests rpm
389
390 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
391 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
392 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
393 - hrn-urn translations tweaked
394 - fixed 'service sfa status'
395 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
396 - started to repair sfadump - although not usable yet
397 - trust objects now have dump_string method that dump() actually prints
398 - unit tests under review
399 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
400 - binaries now support -v or -vv to increase loglevel
401 - trashed obsolete sfa.util.client
402
403 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
404 - various bugfixes and cleanup, improved/harmonized logging
405
406 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
407 - SfaServer now uses a pool of threads to handle requests concurrently
408 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
409 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
410 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
411 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
412 - Component manager does not install gid files if slice already has them  
413 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
414 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
415 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
416      
417 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
418 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
419 - - sfa-config-tty now has the same features like plc-config-tty
420 - - Contains code to support both urn and hrn
421 - - Cleaned up request_hash related stuff
422 - - SM, AM and Registry code is organized under respective managers
423 - - Site and Slice synchronization across federated aggregates
424 - - Script to generate sfa_component_config
425
426 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
427 - sfa-config-tty now has the same features like plc-config-tty
428 - Contains code to support both urn and hrn
429 - Cleaned up request_hash related stuff
430 - SM, AM and Registry code is organized under respective managers
431 - Slice synchronization across federated aggregates
432 - some bugs are fixed
433
434 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
435 - checkpoint with fewer mentions of geni
436
437 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
438 - checkpointing
439 - this is believed to pass the tests; among other things:
440 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
441
442 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
443 - This tag includes:
444 - - Sfatables
445 - - Preliminary version of hash based authentication
446 - - Initial code for Component Manager
447 - - Authority structure is moved to /var/lib/sfa/
448 - - some bug-fixes
449
450 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
451 - Create_slice and get_resources methods are connected to sfatables.
452 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
453
454 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
455 - Bug fix on update and remove_peer_object methods
456 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
457
458 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
459 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
460
461 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
462 - compatibility with RefreshPeer
463 - incremental mechanism for importing PLC records into SFA tables
464 - unified single database (still inside the underlying PLC db postgresql server)
465 - includes/improves call traceability and logging features
466 - several bug fixes
467
468 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
469 - added libxslt-python dependency
470
471 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
472 - unified single SFA database in the PLC-DB
473 - upcalls from  PLCAPI to SFA methods
474 - SFA call traceability and logging features
475 - many bug fixes
476 - includes first/rough version of sfatables for policy implementation
477
478 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
479 - snapshot after the GEC5 demo
480 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
481
482 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
483 - snapshot july 15 - has gone through superficial manual testing
484 - hopefully a good basis for gec5 demo
485 - multi-dir sfi client tested as well
486
487 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
488 - rename geniwrapper.spec into sfa.spec
489
490 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
491 - clean up in xmlrpc/soap, --protocol option to chose between both
492 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
493 - hopefully more helpful context in case of crashes when importing
494 - bugfixes for using only /etc/sfa for site-dep files
495 - bugfixes in wsdl generation
496
497 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
498 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
499 - config variables in sfa_config now start with SFA_ and not GENI_
500 - config.py can be loaded even with no config present
501
502 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
503 - first step for cleanup and reorganization
504 - mass-renaming from geni to sfa (some are still needed)
505 - sfa/trust implements the security architecture
506
507 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
508 - snapshot for reproducible builds
509
510 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
511 - snapshot for the convenience of alpha users
512
513 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
514 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
515
516 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
517 - ongoing work - snapshot for 4.3-rc9
518
519 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
520 - various fixes
521
522 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
523 - bugfixes - still a work in progress
524
525 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
526 - initial package
527
528
529 %define module_current_branch 0.2