Dummy Testbed Driver update and bug fix
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 17
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package nitos
92 Summary: the SFA layer around NITOS
93 Group: Applications/System
94 Requires: sfa
95
96 %package dummy
97 Summary: the SFA layer around a Dummy Testbed 
98 Group: Applications/System
99 Requires: sfa
100
101 %package sfatables
102 Summary: sfatables policy tool for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %package xmlbuilder
107 Summary: third-party xmlbuilder tool
108 Group: Applications/System
109 Provides: python-xmlbuilder
110
111 %package tests
112 Summary: unit tests suite for SFA
113 Group: Applications/System
114 Requires: sfa
115
116 %description
117 This package provides the python libraries for the PlanetLab implementation of SFA
118
119 %description flashpolicy
120 This package provides support for adobe flash client applications.  
121
122 %description client
123 This package provides the client side of the SFA API, in particular
124 sfi.py, together with other utilities.
125
126 %description plc
127 This package implements the SFA interface which serves as a layer
128 between the existing PlanetLab interfaces and the SFA API.
129
130 %description cm
131 This package implements the SFA interface which serves as a layer
132 between the existing PlanetLab NodeManager interfaces and the SFA API.
133
134 %description federica
135 The SFA driver for FEDERICA.
136
137 %description nitos
138 The SFA driver for NITOS.
139
140 %description sfatables
141 sfatables is a tool for defining access and admission control policies
142 in an SFA network, in much the same way as iptables is for ip
143 networks. This is the command line interface to manage sfatables
144
145 %description xmlbuilder
146 This package contains the xmlbuilder python library, packaged for
147 convenience as it is not supported by fedora
148
149 %description tests
150 Provides some binary unit tests in /usr/share/sfa/tests
151
152 %prep
153 %setup -q
154
155 %build
156 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %files
166 %{python_sitelib}/sfa/__init__.py*
167 %{python_sitelib}/sfa/trust
168 %{python_sitelib}/sfa/storage
169 %{python_sitelib}/sfa/util
170 %{python_sitelib}/sfa/server
171 %{python_sitelib}/sfa/methods
172 %{python_sitelib}/sfa/generic
173 %{python_sitelib}/sfa/managers
174 %{python_sitelib}/sfa/importer
175 %{python_sitelib}/sfa/rspecs
176 %{python_sitelib}/sfa/client
177 /etc/init.d/sfa
178 %{_bindir}/sfa-start.py*
179 %{_bindir}/sfaadmin.py*
180 %{_bindir}/sfaadmin
181 %{_bindir}/keyconvert.py*
182 %{_bindir}/sfa-config-tty
183 %{_bindir}/sfa-config
184 %config /etc/sfa/default_config.xml
185 %config (noreplace) /etc/sfa/aggregates.xml
186 %config (noreplace) /etc/sfa/registries.xml
187 /usr/share/sfa/migrations
188 /usr/share/sfa/examples
189 /var/www/html/wsdl/*.wsdl
190
191 %files flashpolicy
192 %{_bindir}/sfa_flashpolicy.py*
193 /etc/sfa/sfa_flashpolicy_config.xml
194
195 %files client
196 %config (noreplace) /etc/sfa/sfi_config
197 %{_bindir}/sfi*.py*
198 %{_bindir}/sfi
199 %{_bindir}/get*.py*
200 %{_bindir}/setRecord.py*
201 %{_bindir}/sfascan.py*
202 %{_bindir}/sfascan
203 %{_bindir}/sfadump.py*
204
205 %files plc
206 %defattr(-,root,root)
207 %{python_sitelib}/sfa/planetlab
208 %{python_sitelib}/sfa/openstack
209 /etc/sfa/pl.rng
210 /etc/sfa/credential.xsd
211 /etc/sfa/top.xsd
212 /etc/sfa/sig.xsd
213 /etc/sfa/xml.xsd
214 /etc/sfa/protogeni-rspec-common.xsd
215 /etc/sfa/topology
216 %{_bindir}/gen-sfa-cm-config.py*
217
218 %files cm
219 /etc/init.d/sfa-cm
220 %{_bindir}/sfa_component_setup.py*
221 # cron jobs here 
222
223 %files federica
224 %{python_sitelib}/sfa/federica
225
226 %files nitos
227 %{python_sitelib}/sfa/nitos
228
229 %files dummy
230 %{python_sitelib}/sfa/dummy
231
232 %files sfatables
233 /etc/sfatables/*
234 %{_bindir}/sfatables
235 %{python_sitelib}/sfatables
236
237 %files xmlbuilder
238 %{python_sitelib}/xmlbuilder
239
240 %files tests
241 %{_datadir}/sfa/tests
242
243 ### sfa installs the 'sfa' service
244 %post 
245 chkconfig --add sfa
246
247 %preun 
248 if [ "$1" = 0 ] ; then
249   /sbin/service sfa stop || :
250   /sbin/chkconfig --del sfa || :
251 fi
252
253 %postun
254 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
255
256 ### sfa-cm installs the 'sfa-cm' service
257 %post cm
258 chkconfig --add sfa-cm
259
260 %preun cm
261 if [ "$1" = 0 ] ; then
262    /sbin/service sfa-cm stop || :
263    /sbin/chkconfig --del sfa-cm || :
264 fi
265
266 %postun cm
267 [ "$1" -ge "1" ] && service sfa-cm restart || :
268
269 %changelog
270 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
271 - bugfix in forwarding Resolve requests
272 - various fixes in the nitos driver wrt keys and users
273
274 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
275 - various tweaks for the nitos driver
276
277 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
278 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
279 - deeper cleanup of the data-dependencies between SFA and the testbed
280 - in particular, sfi create issues Resolve(details=False)
281 - for that purpose, Resolve exposes reg-* keys for SFA builtins
282 - which in turn allows sfi list to show PIs, slice members and keys
283 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
284 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
285
286 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
287 - configurable data-dir (/var/lib/sfa)
288 - no more dependent on myplc-config
289 - some support for hrns with _ instead of \.
290 - fix for PL importing in presence of gpg keys
291 - DeleteSliver returns True instead of 1 in case of success
292 - Various improvements on the openstack/nova side
293 - new package sfa-nitos
294
295 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
296 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
297 - sfi to remove expired credentials
298
299 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
300 - Update Openstack driver to support Essex release/
301 - Fix authority xrn bug.
302   
303
304 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
305 - review packaging - site-packages/planetlab now come with sfa-plc
306 - new package sfa-federica
307 - clientbin moved one step upwards
308
309 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
310 - fix bug in sfi update()
311
312 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
313 - fix broken sfa.util.xrn class for lowercase
314
315 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
316 - new 'void' generic_flavour for running in registry-only mode
317 - first shot at refactoring importers - probably needs more work
318 - openstack: various enhancements
319 - sfi interface to registry not based on xml files anymore
320 - sfi show sorts result on record key
321 - bugfix in sfa update on users with a pl-backed registry
322
323 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
324 - renamed sfa/plc into sfa/planetlab
325 - plxrn moved in sfa/planetlab as well
326 - bugfix for sfaadmin reg update --pi <>
327
328 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
329 - native data model now has a authority x user (PI) relationship
330 - no call to 'augment_records_with_testbed_info' for GetCredential
331 - which means, registry can now be used without an underlying testbed
332 - reviewed code about relationships b/w objects and related in pl driver
333 - reviewed PL import wrt roles and pis
334 - removed mentions to is_enabled in driver
335 - small changes in update_relation* in driver interface
336 - sfaadmin: can create authorities and attach pi users to them
337 - sfaadmin: categories can be abbreviated
338 - sfi list and sfaadmin list have a new -r/--recursive option
339 - this means that List now supports an (optional) 'options' argument
340 - sfi config can display config vars
341 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
342
343 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
344 - make sync now supports vserver or lxc.
345 - Added slice expiration and login info to SliverStatus response. 
346 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
347   the 'component_name' attribute.
348 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
349   
350 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
351 - Introduced new administrative command line script, sfaadmin.py. Removed various single
352  purpose scripts and migrated their functionality into sfaadmin.py.
353 - Refactored Registry import scripts.
354 - Removed SQLAlchemy dependency from sfi.py.
355 - Fixed bugs in sfi.py
356 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
357
358 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
359 - slice x researcher rel. in database,
360 - plimporter to maintain that, as well as user.email, and more robust
361 - ongoing draft for sfaadmin tool
362 - support for a federica driver
363 - support for a nova/euca driver
364 - no more sfa-clean-peer-records script
365
366 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
367 - registry database has user's keys and mail (known as v0 for migrate)
368 - pl importer properly maintains user's keys and mail
369 - pl driver now to handle 'role' when adding person record (exp.)
370 - first draft of federica driver with config section
371 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
372 - plus, from master as of tag merged-in-sfa-2.1-2:
373 - disk_image revisited
374 - new nova_shell nova_driver & various tweaks for openstack
375
376 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
377 - uses sqlalchemy and related migrate
378 - thorough migration and upgrade scheme
379 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
380 - trashed dbinfo stuff in auth hierarchy
381 - data model still has little more than plain records
382 - checkpoint tag, not yet intended for release
383
384 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
385 - client: added -R --raw sfi cmdline option that displays raw server response.
386 - client: request GENI RSpec by default. 
387 - server: remove database dependencies from sfa.server.sfaapi.
388 - server: increased default credential lifetime to 31 days.
389 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
390 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
391 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
392  
393 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
394 - bugfix: 'geni_api' should be in the top level struct, not the code struct
395 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
396           output returned by the Aggregate Manager.
397 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
398 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
399 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
400           there is extra whitespace in the schemaLocation field.
401 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
402           advertisement rspecs.
403 - bugfix: <login> RSpec element should contain the 'username' attribute.
404 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
405  
406 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
407 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
408   exit when it encountered a user with an invalid public key.
409 - server: imporved logging in sfa-import-plc.py
410  
411 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
412 - bugfix: Fixed appending public keys in CreateSliver
413 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
414 - client: -c --current option allows users to request the current/uncached rspec.
415 - server: Added 'geni_api_versions' field to GetVersion() output.
416 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
417    
418 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
419 - bugfix: sfi was not sending call_id with ListResources to v2 servers
420 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
421 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
422
423 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
424 - client: sfi -a / -p deprecated (use -s instead)
425 - client: sfi cleaned up
426 - client: sfi has backward support for APIv1 aggregates again
427 - server: only APIv2 is supported and should be rather strict
428 - server: settings for turning on/off caching in sm or am
429 - server: plc-dependant code has moved from aggregate to pldriver
430 - server: driver interface extended accordingly
431
432 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
433 - screwed up previous tag
434
435 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
436 - client side revisited with a bootstrap library
437 - client side has a new source layout
438 - various (nasty) bug fixes wrt options and call_id
439
440 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
441 - various fixes in rspecs for sfav1&slice tags
442 - uses 'geni_rspec_version' and not just 'rspec_version'
443 - example flavour for the max testbed
444 - embryo for an sfa client library
445 - topology.py moved into plc
446 - sql: table is named records; record_types are enforced
447 - sql: table creation cleaned up
448
449 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
450 - cleaned up all references to SFA_*_TYPE in config
451 - enable cache at the aggregate by default
452 - registry now uses the driver in a sensible way (see managers/driver.py)
453 - slice manager supports sfav1/pgv2 neighbours
454 - get_key renamed into get_key_from_incoming_ip
455 - new sfa.storage module for record/table and all db-related stuff
456 - db schema in sfa.storage.sfa.sql
457 - init.d and cron.d move one step up
458 - cleaned up rspec/ directory
459 - add deps to pyopenssl and myplc-config
460 - start support for new API (return value)
461 - plc.remoteshell removed, use plshell instead
462 - plshell uses a 'capability' auth method whenever possible
463 - various tweaks in rspec elements
464 - made dependency on sfatables softer
465
466 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
467 - sfa should now be started *before* the initial import
468 - sfa to use its own database (default sfa) - can run without myplc
469 - server calls support optional 'options'
470 - client sends options in argument when needed
471 - fix infinite getattr recursion in elements/element.py
472 - error codes in line with geni
473
474 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
475 - fixed links and attributes in rspecs
476 - minor cleanup in the API methods, and more consistent names in manager methods
477
478 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
479 - ongoing refoactoring towards more genericity
480 - passes tests again although known issues remain with attributes/tags
481
482 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
483 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
484 - improvements in the pgv2 rspecs
485 - driver separated from api
486 - code starts moving around where it belongs
487 - sfascan caches getversion across invokations
488 - vini topology extracted as a config file
489
490 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
491 - first support for protogeni rspecs is working
492 - vini no longer needs a specific manager
493 - refactoring underway towards more flexible/generic architecture
494
495 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
496 - Unicode-friendliness for user names with accents/special chars.
497 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
498 - CreaetSliver no longer fails for users that have a capital letter in their URN.
499 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
500 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
501 - Fix bugs and missing imports     
502  
503
504 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
505 - new method record.get_field for sface
506
507 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
508 - new option -c to sfa-nuke-plc.py
509 - CreateSliver fixed for admin-only slice tags
510
511 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
512 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
513 - Fixed holes in certificate verification logic.
514 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
515 - Added 'boot_state' as an attribute of the node element in SFA rspec.
516 - Non authority certificates are marked as CA:FALSE.
517
518 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
519 - fix typo in sfa-1.0-31 tag.
520 - added CreateGid() Registry interface method.
521
522 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
523 - fix typo in sfa-1.0-30 tag
524
525 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
526 - Declare namespace and schema location in the credential.
527 - Fix bug that prevetend connections from timing out.
528 - Fix slice delegation.
529 - Add statistics to slicemaanger listresources/createsliver rspec.
530 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
531   of days a user can extend their slice expiration.
532 - CA certs are only issued to objects of type authority
533    
534 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
535 - tag 1.0-28 was broken due to typo in the changelog
536 - new class sfa/util/httpsProtocol.py that supports timeouts
537
538 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
539 - Resolved issue that caused sfa hold onto idle db connections.
540 - Fix bug that caused the registry to use the wrong type of credential.
541 - Support authority+sm type.
542 - Fix rspec merging bugs.
543 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
544 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
545  planetlab hosted initscripts using the <planetlab:initscript> tag  
546 - Can now handle extraneous whitespace in the rspec without failing.   
547  
548 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
549 - ProtoGENI v2 RSpec updates.
550 - Convert expiration timestamps with timezone info in credentials to utc.
551 - Fixed redundant logging issue. 
552 - Improved SliceManager and SFI client logging.
553 - Support aggregates that don't support the optional 'call_id' argument. 
554 - Only call get_trusted_certs() at aggreage interfaces that support the call.
555 - CreateSliver() now handles MyPLC slice attributes/tags.
556 - Cache now supports persistence.
557 - Hide whitelisted nodes.
558
559 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
560 - fixed issues with sup authority signing
561 - fixed bugs in remove_slivers and SliverStatus
562
563 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
564 - fix typo that prevented aggregates from operating properly
565
566 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
567 - load trusted certs into ssl context prior to handshake
568 - client's logfile lives in ~/.sfi/sfi.log
569
570 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
571 - includes a change on passphrases that was intended in 1.0-22
572
573 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
574 - Added support for ProtoGENI RSpec v2
575  
576 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
577 - stable sfascan
578 - fix in initscript, *ENABLED tags in config now taken into account
579
580 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
581 - some commits had not been pushed in tag 19
582
583 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
584 - GetVersion should now report full URLs with path
585 - scansfa has nicer output and new syntax (entry URLs as args and not options)
586 - dos2unix'ed flash policy pill
587
588 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
589 - fix packaging again for f8
590
591 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
592 - fix packaging (apparently broken in 1.0-16)
593 - first working version of sfascan
594 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
595 - deprecated the sfa_geni_aggregate config category
596
597 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
598 - Fix build problem
599 - First version of SFA scanner
600
601 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
602 - Add support for Flash clients using flashpolicy
603 - Fix problems with tag handling in RSpec
604
605 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
606 - Modifications to the Eucalyptus Aggregate Manager
607 - Fixes for VINI RSpec
608 - Fix tag handling for PL RSpec
609 - Fix XML Schema ordering for <urn> element
610
611 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
612 - just set x509 version to 2
613
614 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
615 - added urn to the node area in rspecs
616 - conversion to urn now exports fqdn
617 - sfa-import-plc.py now creates a unique registry record for each SFA interface
618
619 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
620 - undo broken attempt for python-2.7
621
622 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
623 - SMs avoid duplicates for when call graph has dags;
624 - just based on network's name, when a duplicate occurs, one is just dropped
625 - does not try to merge/aggregate 2 networks
626 - also reviewed logging with the hope to fix the sfa startup msg:
627 - TypeError: not all arguments converted during string formatting
628
629 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
630 - verify credentials against xsd schema
631 - Fix SM to SM communication
632 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
633 - new setting session_key_path
634
635 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
636 - fix registry credential regeneration and handle expiration
637 - support for setting slice tags (min_role=user)
638 - client can display its own version: sfi.py version --local
639 - GetVersion to provide urn in addition to hrn
640 - more code uses plxrn vs previous helper functions
641 - import replaces '+' in email addresses with '_'
642
643 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
644 - fix GetVersion code_tag and add code_url
645
646 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
647 - extend GetVersion towards minimum federation introspection, and expose local tag
648
649 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
650 - fixed some legacy issues (list vs List)
651 - deprecated sfa.util.namespace for xrn and plxrn
652 - unit tests ship as the sfa-tests rpm
653
654 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
655 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
656 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
657 - hrn-urn translations tweaked
658 - fixed 'service sfa status'
659 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
660 - started to repair sfadump - although not usable yet
661 - trust objects now have dump_string method that dump() actually prints
662 - unit tests under review
663 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
664 - binaries now support -v or -vv to increase loglevel
665 - trashed obsolete sfa.util.client
666
667 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
668 - various bugfixes and cleanup, improved/harmonized logging
669
670 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
671 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
672   to avoid returning a PLCAPI exception that might confuse users.
673 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
674 - fix build errors.  
675
676 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
677 - (Architecture) Credential format changed to match ProtoGENI xml format
678 - (Architecture) All interfaces export a new set of methods that are compatible
679    with the ProtoGeni Aggregate spec. These new methods are considered a 
680    replacement  for the pervious methods exported by the interfaces. All 
681    previous methods are still exported and work as normal, but they are 
682    considered deprecated and will not be supported in future releases.  
683 - (Architecture) SFI has been updated to use the new interface methods.
684 - (Architecture) Changed keyconvet implementation from c to python.
685 - (Architecture) Slice Manager now attempts looks for a delegated credential
686   provided by the client before using its own server credential.
687 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
688   This cache now exists only in memory and is cleared when service is restarted
689   or cache lifetime is exceeded.  
690 - (Performance) SliceManager sends request to Aggregates in parallel instead 
691   of sequentially.
692 - (Bug fix) SFA tickets now support the new rspec format.
693 - (Bug fix) SFI only uses cahced credential if they aren't expired.
694 - (Bug fix) Cerdential delegation modified to work with new credential format.
695 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
696   Aggregate instead of relaying through the Slice Manager.
697 - (Enhancement) Simplified caching. Accociated a global cache instance with
698   the api handler on every new server request, making it easier to access the 
699   cache and use in more general ways.     
700
701 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
702 - SfaServer now uses a pool of threads to handle requests concurrently
703 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
704 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
705 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
706 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
707 - Component manager does not install gid files if slice already has them  
708 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
709 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
710 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
711      
712 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
713 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
714 - - sfa-config-tty now has the same features like plc-config-tty
715 - - Contains code to support both urn and hrn
716 - - Cleaned up request_hash related stuff
717 - - SM, AM and Registry code is organized under respective managers
718 - - Site and Slice synchronization across federated aggregates
719 - - Script to generate sfa_component_config
720
721 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
722 - sfa-config-tty now has the same features like plc-config-tty
723 - Contains code to support both urn and hrn
724 - Cleaned up request_hash related stuff
725 - SM, AM and Registry code is organized under respective managers
726 - Slice synchronization across federated aggregates
727 - some bugs are fixed
728
729 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
730 - checkpoint with fewer mentions of geni
731
732 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
733 - checkpointing
734 - this is believed to pass the tests; among other things:
735 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
736
737 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
738 - This tag includes:
739 - - Sfatables
740 - - Preliminary version of hash based authentication
741 - - Initial code for Component Manager
742 - - Authority structure is moved to /var/lib/sfa/
743 - - some bug-fixes
744
745 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
746 - Create_slice and get_resources methods are connected to sfatables.
747 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
748
749 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
750 - Bug fix on update and remove_peer_object methods
751 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
752
753 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
754 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
755
756 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
757 - compatibility with RefreshPeer
758 - incremental mechanism for importing PLC records into SFA tables
759 - unified single database (still inside the underlying PLC db postgresql server)
760 - includes/improves call traceability and logging features
761 - several bug fixes
762
763 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
764 - added libxslt-python dependency
765
766 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
767 - unified single SFA database in the PLC-DB
768 - upcalls from  PLCAPI to SFA methods
769 - SFA call traceability and logging features
770 - many bug fixes
771 - includes first/rough version of sfatables for policy implementation
772
773 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
774 - snapshot after the GEC5 demo
775 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
776
777 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
778 - snapshot july 15 - has gone through superficial manual testing
779 - hopefully a good basis for gec5 demo
780 - multi-dir sfi client tested as well
781
782 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
783 - rename geniwrapper.spec into sfa.spec
784
785 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
786 - clean up in xmlrpc/soap, --protocol option to chose between both
787 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
788 - hopefully more helpful context in case of crashes when importing
789 - bugfixes for using only /etc/sfa for site-dep files
790 - bugfixes in wsdl generation
791
792 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
793 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
794 - config variables in sfa_config now start with SFA_ and not GENI_
795 - config.py can be loaded even with no config present
796
797 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
798 - first step for cleanup and reorganization
799 - mass-renaming from geni to sfa (some are still needed)
800 - sfa/trust implements the security architecture
801
802 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
803 - snapshot for reproducible builds
804
805 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
806 - snapshot for the convenience of alpha users
807
808 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
809 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
810
811 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
812 - ongoing work - snapshot for 4.3-rc9
813
814 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
815 - various fixes
816
817 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
818 - bugfixes - still a work in progress
819
820 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
821 - initial package
822
823
824 %define module_current_branch 0.2