Merge branch 'master' into senslab2
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 13
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package flashpolicy
66 Summary: SFA support for flash clients
67 Group: Applications/System
68 Requires: sfa
69
70 %package client
71 Summary: the SFA experimenter-side CLI
72 Group: Applications/System
73 Requires: sfa
74 Requires: pyOpenSSL >= 0.7
75
76 %package plc
77 Summary: the SFA layer around MyPLC
78 Group: Applications/System
79 Requires: sfa
80
81 %package cm
82 Summary: the SFA layer around MyPLC NodeManager
83 Group: Applications/System
84 Requires: sfa
85 Requires: pyOpenSSL >= 0.6
86
87 %package federica
88 Summary: the SFA layer around Federica
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa
106
107 %description
108 This package provides the python libraries for the PlanetLab implementation of SFA
109
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112
113 %description client
114 This package provides the client side of the SFA API, in particular
115 sfi.py, together with other utilities.
116
117 %description plc
118 This package implements the SFA interface which serves as a layer
119 between the existing PlanetLab interfaces and the SFA API.
120
121 %description cm
122 This package implements the SFA interface which serves as a layer
123 between the existing PlanetLab NodeManager interfaces and the SFA API.
124
125 %description federica
126 The SFA driver for FEDERICA.
127
128 %description sfatables
129 sfatables is a tool for defining access and admission control policies
130 in an SFA network, in much the same way as iptables is for ip
131 networks. This is the command line interface to manage sfatables
132
133 %description xmlbuilder
134 This package contains the xmlbuilder python library, packaged for
135 convenience as it is not supported by fedora
136
137 %description tests
138 Provides some binary unit tests in /usr/share/sfa/tests
139
140 %prep
141 %setup -q
142
143 %build
144 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %{python_sitelib}/sfa/__init__.py*
155 %{python_sitelib}/sfa/trust
156 %{python_sitelib}/sfa/storage
157 %{python_sitelib}/sfa/util
158 %{python_sitelib}/sfa/server
159 %{python_sitelib}/sfa/methods
160 %{python_sitelib}/sfa/generic
161 %{python_sitelib}/sfa/managers
162 %{python_sitelib}/sfa/importer
163 %{python_sitelib}/sfa/rspecs
164 %{python_sitelib}/sfa/client
165 /etc/init.d/sfa
166 %{_bindir}/sfa-start.py*
167 %{_bindir}/sfaadmin.py*
168 %{_bindir}/sfaadmin
169 %{_bindir}/keyconvert.py*
170 %{_bindir}/sfa-config-tty
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 /usr/share/sfa/migrations
175 /usr/share/sfa/examples
176 /var/www/html/wsdl/*.wsdl
177
178 %files flashpolicy
179 %{_bindir}/sfa_flashpolicy.py*
180 /etc/sfa/sfa_flashpolicy_config.xml
181
182 %files client
183 %config (noreplace) /etc/sfa/sfi_config
184 %{_bindir}/sfi*.py*
185 %{_bindir}/sfi
186 %{_bindir}/get*.py*
187 %{_bindir}/setRecord.py*
188 %{_bindir}/sfascan.py*
189 %{_bindir}/sfascan
190 %{_bindir}/sfadump.py*
191
192 %files plc
193 %defattr(-,root,root)
194 %{python_sitelib}/sfa/planetlab
195 %{python_sitelib}/sfa/openstack
196 /etc/sfa/pl.rng
197 /etc/sfa/credential.xsd
198 /etc/sfa/top.xsd
199 /etc/sfa/sig.xsd
200 /etc/sfa/xml.xsd
201 /etc/sfa/protogeni-rspec-common.xsd
202 /etc/sfa/topology
203 %{_bindir}/gen-sfa-cm-config.py*
204
205 %files cm
206 /etc/init.d/sfa-cm
207 %{_bindir}/sfa_component_setup.py*
208 # cron jobs here 
209
210 %files federica
211 %{python_sitelib}/sfa/federica
212
213 %files sfatables
214 /etc/sfatables/*
215 %{_bindir}/sfatables
216 %{python_sitelib}/sfatables
217
218 %files xmlbuilder
219 %{python_sitelib}/xmlbuilder
220
221 %files tests
222 %{_datadir}/sfa/tests
223
224 ### sfa installs the 'sfa' service
225 %post 
226 chkconfig --add sfa
227
228 %preun 
229 if [ "$1" = 0 ] ; then
230   /sbin/service sfa stop || :
231   /sbin/chkconfig --del sfa || :
232 fi
233
234 %postun
235 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
236
237 ### sfa-cm installs the 'sfa-cm' service
238 %post cm
239 chkconfig --add sfa-cm
240
241 %preun cm
242 if [ "$1" = 0 ] ; then
243    /sbin/service sfa-cm stop || :
244    /sbin/chkconfig --del sfa-cm || :
245 fi
246
247 %postun cm
248 [ "$1" -ge "1" ] && service sfa-cm restart || :
249
250 %changelog
251 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
252 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
253 - sfi to remove expired credentials
254
255 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
256 - Update Openstack driver to support Essex release/
257 - Fix authority xrn bug.
258   
259
260 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
261 - review packaging - site-packages/planetlab now come with sfa-plc
262 - new package sfa-federica
263 - clientbin moved one step upwards
264
265 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
266 - fix bug in sfi update()
267
268 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
269 - fix broken sfa.util.xrn class for lowercase
270
271 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
272 - new 'void' generic_flavour for running in registry-only mode
273 - first shot at refactoring importers - probably needs more work
274 - openstack: various enhancements
275 - sfi interface to registry not based on xml files anymore
276 - sfi show sorts result on record key
277 - bugfix in sfa update on users with a pl-backed registry
278
279 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
280 - renamed sfa/plc into sfa/planetlab
281 - plxrn moved in sfa/planetlab as well
282 - bugfix for sfaadmin reg update --pi <>
283
284 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
285 - native data model now has a authority x user (PI) relationship
286 - no call to 'augment_records_with_testbed_info' for GetCredential
287 - which means, registry can now be used without an underlying testbed
288 - reviewed code about relationships b/w objects and related in pl driver
289 - reviewed PL import wrt roles and pis
290 - removed mentions to is_enabled in driver
291 - small changes in update_relation* in driver interface
292 - sfaadmin: can create authorities and attach pi users to them
293 - sfaadmin: categories can be abbreviated
294 - sfi list and sfaadmin list have a new -r/--recursive option
295 - this means that List now supports an (optional) 'options' argument
296 - sfi config can display config vars
297 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
298
299 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
300 - make sync now supports vserver or lxc.
301 - Added slice expiration and login info to SliverStatus response. 
302 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
303   the 'component_name' attribute.
304 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
305   
306 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
307 - Introduced new administrative command line script, sfaadmin.py. Removed various single
308  purpose scripts and migrated their functionality into sfaadmin.py.
309 - Refactored Registry import scripts.
310 - Removed SQLAlchemy dependency from sfi.py.
311 - Fixed bugs in sfi.py
312 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
313
314 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
315 - slice x researcher rel. in database,
316 - plimporter to maintain that, as well as user.email, and more robust
317 - ongoing draft for sfaadmin tool
318 - support for a federica driver
319 - support for a nova/euca driver
320 - no more sfa-clean-peer-records script
321
322 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
323 - registry database has user's keys and mail (known as v0 for migrate)
324 - pl importer properly maintains user's keys and mail
325 - pl driver now to handle 'role' when adding person record (exp.)
326 - first draft of federica driver with config section
327 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
328 - plus, from master as of tag merged-in-sfa-2.1-2:
329 - disk_image revisited
330 - new nova_shell nova_driver & various tweaks for openstack
331
332 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
333 - uses sqlalchemy and related migrate
334 - thorough migration and upgrade scheme
335 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
336 - trashed dbinfo stuff in auth hierarchy
337 - data model still has little more than plain records
338 - checkpoint tag, not yet intended for release
339
340 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
341 - client: added -R --raw sfi cmdline option that displays raw server response.
342 - client: request GENI RSpec by default. 
343 - server: remove database dependencies from sfa.server.sfaapi.
344 - server: increased default credential lifetime to 31 days.
345 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
346 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
347 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
348  
349 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
350 - bugfix: 'geni_api' should be in the top level struct, not the code struct
351 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
352           output returned by the Aggregate Manager.
353 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
354 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
355 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
356           there is extra whitespace in the schemaLocation field.
357 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
358           advertisement rspecs.
359 - bugfix: <login> RSpec element should contain the 'username' attribute.
360 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
361  
362 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
363 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
364   exit when it encountered a user with an invalid public key.
365 - server: imporved logging in sfa-import-plc.py
366  
367 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
368 - bugfix: Fixed appending public keys in CreateSliver
369 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
370 - client: -c --current option allows users to request the current/uncached rspec.
371 - server: Added 'geni_api_versions' field to GetVersion() output.
372 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
373    
374 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
375 - bugfix: sfi was not sending call_id with ListResources to v2 servers
376 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
377 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
378
379 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
380 - client: sfi -a / -p deprecated (use -s instead)
381 - client: sfi cleaned up
382 - client: sfi has backward support for APIv1 aggregates again
383 - server: only APIv2 is supported and should be rather strict
384 - server: settings for turning on/off caching in sm or am
385 - server: plc-dependant code has moved from aggregate to pldriver
386 - server: driver interface extended accordingly
387
388 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
389 - screwed up previous tag
390
391 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
392 - client side revisited with a bootstrap library
393 - client side has a new source layout
394 - various (nasty) bug fixes wrt options and call_id
395
396 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
397 - various fixes in rspecs for sfav1&slice tags
398 - uses 'geni_rspec_version' and not just 'rspec_version'
399 - example flavour for the max testbed
400 - embryo for an sfa client library
401 - topology.py moved into plc
402 - sql: table is named records; record_types are enforced
403 - sql: table creation cleaned up
404
405 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
406 - cleaned up all references to SFA_*_TYPE in config
407 - enable cache at the aggregate by default
408 - registry now uses the driver in a sensible way (see managers/driver.py)
409 - slice manager supports sfav1/pgv2 neighbours
410 - get_key renamed into get_key_from_incoming_ip
411 - new sfa.storage module for record/table and all db-related stuff
412 - db schema in sfa.storage.sfa.sql
413 - init.d and cron.d move one step up
414 - cleaned up rspec/ directory
415 - add deps to pyopenssl and myplc-config
416 - start support for new API (return value)
417 - plc.remoteshell removed, use plshell instead
418 - plshell uses a 'capability' auth method whenever possible
419 - various tweaks in rspec elements
420 - made dependency on sfatables softer
421
422 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
423 - sfa should now be started *before* the initial import
424 - sfa to use its own database (default sfa) - can run without myplc
425 - server calls support optional 'options'
426 - client sends options in argument when needed
427 - fix infinite getattr recursion in elements/element.py
428 - error codes in line with geni
429
430 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
431 - fixed links and attributes in rspecs
432 - minor cleanup in the API methods, and more consistent names in manager methods
433
434 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
435 - ongoing refoactoring towards more genericity
436 - passes tests again although known issues remain with attributes/tags
437
438 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
439 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
440 - improvements in the pgv2 rspecs
441 - driver separated from api
442 - code starts moving around where it belongs
443 - sfascan caches getversion across invokations
444 - vini topology extracted as a config file
445
446 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
447 - first support for protogeni rspecs is working
448 - vini no longer needs a specific manager
449 - refactoring underway towards more flexible/generic architecture
450
451 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
452 - Unicode-friendliness for user names with accents/special chars.
453 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
454 - CreaetSliver no longer fails for users that have a capital letter in their URN.
455 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
456 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
457 - Fix bugs and missing imports     
458  
459
460 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
461 - new method record.get_field for sface
462
463 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
464 - new option -c to sfa-nuke-plc.py
465 - CreateSliver fixed for admin-only slice tags
466
467 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
468 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
469 - Fixed holes in certificate verification logic.
470 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
471 - Added 'boot_state' as an attribute of the node element in SFA rspec.
472 - Non authority certificates are marked as CA:FALSE.
473
474 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
475 - fix typo in sfa-1.0-31 tag.
476 - added CreateGid() Registry interface method.
477
478 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
479 - fix typo in sfa-1.0-30 tag
480
481 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
482 - Declare namespace and schema location in the credential.
483 - Fix bug that prevetend connections from timing out.
484 - Fix slice delegation.
485 - Add statistics to slicemaanger listresources/createsliver rspec.
486 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
487   of days a user can extend their slice expiration.
488 - CA certs are only issued to objects of type authority
489    
490 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
491 - tag 1.0-28 was broken due to typo in the changelog
492 - new class sfa/util/httpsProtocol.py that supports timeouts
493
494 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
495 - Resolved issue that caused sfa hold onto idle db connections.
496 - Fix bug that caused the registry to use the wrong type of credential.
497 - Support authority+sm type.
498 - Fix rspec merging bugs.
499 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
500 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
501  planetlab hosted initscripts using the <planetlab:initscript> tag  
502 - Can now handle extraneous whitespace in the rspec without failing.   
503  
504 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
505 - ProtoGENI v2 RSpec updates.
506 - Convert expiration timestamps with timezone info in credentials to utc.
507 - Fixed redundant logging issue. 
508 - Improved SliceManager and SFI client logging.
509 - Support aggregates that don't support the optional 'call_id' argument. 
510 - Only call get_trusted_certs() at aggreage interfaces that support the call.
511 - CreateSliver() now handles MyPLC slice attributes/tags.
512 - Cache now supports persistence.
513 - Hide whitelisted nodes.
514
515 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
516 - fixed issues with sup authority signing
517 - fixed bugs in remove_slivers and SliverStatus
518
519 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
520 - fix typo that prevented aggregates from operating properly
521
522 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
523 - load trusted certs into ssl context prior to handshake
524 - client's logfile lives in ~/.sfi/sfi.log
525
526 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
527 - includes a change on passphrases that was intended in 1.0-22
528
529 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
530 - Added support for ProtoGENI RSpec v2
531  
532 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
533 - stable sfascan
534 - fix in initscript, *ENABLED tags in config now taken into account
535
536 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
537 - some commits had not been pushed in tag 19
538
539 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
540 - GetVersion should now report full URLs with path
541 - scansfa has nicer output and new syntax (entry URLs as args and not options)
542 - dos2unix'ed flash policy pill
543
544 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
545 - fix packaging again for f8
546
547 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
548 - fix packaging (apparently broken in 1.0-16)
549 - first working version of sfascan
550 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
551 - deprecated the sfa_geni_aggregate config category
552
553 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
554 - Fix build problem
555 - First version of SFA scanner
556
557 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
558 - Add support for Flash clients using flashpolicy
559 - Fix problems with tag handling in RSpec
560
561 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
562 - Modifications to the Eucalyptus Aggregate Manager
563 - Fixes for VINI RSpec
564 - Fix tag handling for PL RSpec
565 - Fix XML Schema ordering for <urn> element
566
567 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
568 - just set x509 version to 2
569
570 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
571 - added urn to the node area in rspecs
572 - conversion to urn now exports fqdn
573 - sfa-import-plc.py now creates a unique registry record for each SFA interface
574
575 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
576 - undo broken attempt for python-2.7
577
578 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
579 - SMs avoid duplicates for when call graph has dags;
580 - just based on network's name, when a duplicate occurs, one is just dropped
581 - does not try to merge/aggregate 2 networks
582 - also reviewed logging with the hope to fix the sfa startup msg:
583 - TypeError: not all arguments converted during string formatting
584
585 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
586 - verify credentials against xsd schema
587 - Fix SM to SM communication
588 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
589 - new setting session_key_path
590
591 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
592 - fix registry credential regeneration and handle expiration
593 - support for setting slice tags (min_role=user)
594 - client can display its own version: sfi.py version --local
595 - GetVersion to provide urn in addition to hrn
596 - more code uses plxrn vs previous helper functions
597 - import replaces '+' in email addresses with '_'
598
599 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
600 - fix GetVersion code_tag and add code_url
601
602 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
603 - extend GetVersion towards minimum federation introspection, and expose local tag
604
605 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
606 - fixed some legacy issues (list vs List)
607 - deprecated sfa.util.namespace for xrn and plxrn
608 - unit tests ship as the sfa-tests rpm
609
610 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
611 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
612 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
613 - hrn-urn translations tweaked
614 - fixed 'service sfa status'
615 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
616 - started to repair sfadump - although not usable yet
617 - trust objects now have dump_string method that dump() actually prints
618 - unit tests under review
619 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
620 - binaries now support -v or -vv to increase loglevel
621 - trashed obsolete sfa.util.client
622
623 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
624 - various bugfixes and cleanup, improved/harmonized logging
625
626 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
627 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
628   to avoid returning a PLCAPI exception that might confuse users.
629 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
630 - fix build errors.  
631
632 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
633 - (Architecture) Credential format changed to match ProtoGENI xml format
634 - (Architecture) All interfaces export a new set of methods that are compatible
635    with the ProtoGeni Aggregate spec. These new methods are considered a 
636    replacement  for the pervious methods exported by the interfaces. All 
637    previous methods are still exported and work as normal, but they are 
638    considered deprecated and will not be supported in future releases.  
639 - (Architecture) SFI has been updated to use the new interface methods.
640 - (Architecture) Changed keyconvet implementation from c to python.
641 - (Architecture) Slice Manager now attempts looks for a delegated credential
642   provided by the client before using its own server credential.
643 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
644   This cache now exists only in memory and is cleared when service is restarted
645   or cache lifetime is exceeded.  
646 - (Performance) SliceManager sends request to Aggregates in parallel instead 
647   of sequentially.
648 - (Bug fix) SFA tickets now support the new rspec format.
649 - (Bug fix) SFI only uses cahced credential if they aren't expired.
650 - (Bug fix) Cerdential delegation modified to work with new credential format.
651 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
652   Aggregate instead of relaying through the Slice Manager.
653 - (Enhancement) Simplified caching. Accociated a global cache instance with
654   the api handler on every new server request, making it easier to access the 
655   cache and use in more general ways.     
656
657 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
658 - SfaServer now uses a pool of threads to handle requests concurrently
659 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
660 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
661 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
662 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
663 - Component manager does not install gid files if slice already has them  
664 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
665 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
666 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
667      
668 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
669 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
670 - - sfa-config-tty now has the same features like plc-config-tty
671 - - Contains code to support both urn and hrn
672 - - Cleaned up request_hash related stuff
673 - - SM, AM and Registry code is organized under respective managers
674 - - Site and Slice synchronization across federated aggregates
675 - - Script to generate sfa_component_config
676
677 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
678 - sfa-config-tty now has the same features like plc-config-tty
679 - Contains code to support both urn and hrn
680 - Cleaned up request_hash related stuff
681 - SM, AM and Registry code is organized under respective managers
682 - Slice synchronization across federated aggregates
683 - some bugs are fixed
684
685 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
686 - checkpoint with fewer mentions of geni
687
688 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
689 - checkpointing
690 - this is believed to pass the tests; among other things:
691 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
692
693 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
694 - This tag includes:
695 - - Sfatables
696 - - Preliminary version of hash based authentication
697 - - Initial code for Component Manager
698 - - Authority structure is moved to /var/lib/sfa/
699 - - some bug-fixes
700
701 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
702 - Create_slice and get_resources methods are connected to sfatables.
703 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
704
705 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
706 - Bug fix on update and remove_peer_object methods
707 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
708
709 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
710 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
711
712 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
713 - compatibility with RefreshPeer
714 - incremental mechanism for importing PLC records into SFA tables
715 - unified single database (still inside the underlying PLC db postgresql server)
716 - includes/improves call traceability and logging features
717 - several bug fixes
718
719 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
720 - added libxslt-python dependency
721
722 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
723 - unified single SFA database in the PLC-DB
724 - upcalls from  PLCAPI to SFA methods
725 - SFA call traceability and logging features
726 - many bug fixes
727 - includes first/rough version of sfatables for policy implementation
728
729 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
730 - snapshot after the GEC5 demo
731 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
732
733 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
734 - snapshot july 15 - has gone through superficial manual testing
735 - hopefully a good basis for gec5 demo
736 - multi-dir sfi client tested as well
737
738 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
739 - rename geniwrapper.spec into sfa.spec
740
741 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
742 - clean up in xmlrpc/soap, --protocol option to chose between both
743 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
744 - hopefully more helpful context in case of crashes when importing
745 - bugfixes for using only /etc/sfa for site-dep files
746 - bugfixes in wsdl generation
747
748 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
749 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
750 - config variables in sfa_config now start with SFA_ and not GENI_
751 - config.py can be loaded even with no config present
752
753 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
754 - first step for cleanup and reorganization
755 - mass-renaming from geni to sfa (some are still needed)
756 - sfa/trust implements the security architecture
757
758 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
759 - snapshot for reproducible builds
760
761 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
762 - snapshot for the convenience of alpha users
763
764 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
765 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
766
767 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
768 - ongoing work - snapshot for 4.3-rc9
769
770 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
771 - various fixes
772
773 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
774 - bugfixes - still a work in progress
775
776 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
777 - initial package
778
779
780 %define module_current_branch 0.2