add support for migrations with sqlalchemy-migrate
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 9
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/keyconvert.py*
152 %{_bindir}/sfa-config-tty
153 %config /etc/sfa/default_config.xml
154 %config (noreplace) /etc/sfa/aggregates.xml
155 %config (noreplace) /etc/sfa/registries.xml
156 /usr/share/sfa/examples
157 /var/www/html/wsdl/*.wsdl
158
159 %files plc
160 %defattr(-,root,root)
161 /etc/sfa/pl.rng
162 /etc/sfa/credential.xsd
163 /etc/sfa/top.xsd
164 /etc/sfa/sig.xsd
165 /etc/sfa/xml.xsd
166 /etc/sfa/protogeni-rspec-common.xsd
167 /etc/sfa/topology
168 %{_bindir}/sfa-import-plc.py*
169 %{_bindir}/sfa-nuke-plc.py*
170 %{_bindir}/sfa-clean-peer-records.py*
171 %{_bindir}/gen-sfa-cm-config.py*
172 %{_bindir}/sfa-ca.py*
173
174 %files client
175 %config (noreplace) /etc/sfa/sfi_config
176 %{_bindir}/sfi*.py*
177 %{_bindir}/sfi
178 %{_bindir}/get*.py*
179 %{_bindir}/setRecord.py*
180 %{_bindir}/sfascan.py*
181 %{_bindir}/sfascan
182 %{_bindir}/sfadump.py*
183
184 %files sfatables
185 /etc/sfatables/*
186 %{_bindir}/sfatables
187 %{python_sitelib}/sfatables
188
189 %files cm
190 /etc/init.d/sfa-cm
191 %{_bindir}/sfa_component_setup.py*
192 # cron jobs here 
193
194 %files flashpolicy
195 %{_bindir}/sfa_flashpolicy.py*
196 /etc/sfa/sfa_flashpolicy_config.xml
197
198 %files xmlbuilder
199 %{python_sitelib}/xmlbuilder
200
201 %files tests
202 %{_datadir}/sfa/tests
203
204 ### sfa-plc installs the 'sfa' service
205 %post plc
206 chkconfig --add sfa
207
208 %preun plc
209 if [ "$1" = 0 ] ; then
210   /sbin/service sfa stop || :
211   /sbin/chkconfig --del sfa || :
212 fi
213
214 %postun plc
215 [ "$1" -ge "1" ] && service sfa restart
216
217 ### sfa-cm installs the 'sfa-cm' service
218 %post cm
219 chkconfig --add sfa-cm
220
221 %preun cm
222 if [ "$1" = 0 ] ; then
223    /sbin/service sfa-cm stop || :
224    /sbin/chkconfig --del sfa-cm || :
225 fi
226
227 %postun cm
228 [ "$1" -ge "1" ] && service sfa-cm restart || :
229
230 %changelog
231 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
232 - bugfix: 'geni_api' should be in the top level struct, not the code struct
233 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
234           output returned by the Aggregate Manager.
235 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
236 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
237 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
238           there is extra whitespace in the schemaLocation field.
239 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
240           advertisement rspecs.
241 - bugfix: <login> RSpec element should contain the 'username' attribute.
242 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
243  
244 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
245 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
246   exit when it encountered a user with an invalid public key.
247 - server: imporved logging in sfa-import-plc.py
248  
249 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
250 - bugfix: Fixed appending public keys in CreateSliver
251 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
252 - client: -c --current option allows users to request the current/uncached rspec.
253 - server: Added 'geni_api_versions' field to GetVersion() output.
254 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
255    
256 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
257 - bugfix: sfi was not sending call_id with ListResources to v2 servers
258 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
259 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
260
261 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
262 - client: sfi -a / -p deprecated (use -s instead)
263 - client: sfi cleaned up
264 - client: sfi has backward support for APIv1 aggregates again
265 - server: only APIv2 is supported and should be rather strict
266 - server: settings for turning on/off caching in sm or am
267 - server: plc-dependant code has moved from aggregate to pldriver
268 - server: driver interface extended accordingly
269
270 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
271 - screwed up previous tag
272
273 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
274 - client side revisited with a bootstrap library
275 - client side has a new source layout
276 - various (nasty) bug fixes wrt options and call_id
277
278 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
279 - various fixes in rspecs for sfav1&slice tags
280 - uses 'geni_rspec_version' and not just 'rspec_version'
281 - example flavour for the max testbed
282 - embryo for an sfa client library
283 - topology.py moved into plc
284 - sql: table is named records; record_types are enforced
285 - sql: table creation cleaned up
286
287 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
288 - cleaned up all references to SFA_*_TYPE in config
289 - enable cache at the aggregate by default
290 - registry now uses the driver in a sensible way (see managers/driver.py)
291 - slice manager supports sfav1/pgv2 neighbours
292 - get_key renamed into get_key_from_incoming_ip
293 - new sfa.storage module for record/table and all db-related stuff
294 - db schema in sfa.storage.sfa.sql
295 - init.d and cron.d move one step up
296 - cleaned up rspec/ directory
297 - add deps to pyopenssl and myplc-config
298 - start support for new API (return value)
299 - plc.remoteshell removed, use plshell instead
300 - plshell uses a 'capability' auth method whenever possible
301 - various tweaks in rspec elements
302 - made dependency on sfatables softer
303
304 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
305 - sfa should now be started *before* the initial import
306 - sfa to use its own database (default sfa) - can run without myplc
307 - server calls support optional 'options'
308 - client sends options in argument when needed
309 - fix infinite getattr recursion in elements/element.py
310 - error codes in line with geni
311
312 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
313 - fixed links and attributes in rspecs
314 - minor cleanup in the API methods, and more consistent names in manager methods
315
316 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
317 - ongoing refoactoring towards more genericity
318 - passes tests again although known issues remain with attributes/tags
319
320 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
321 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
322 - improvements in the pgv2 rspecs
323 - driver separated from api
324 - code starts moving around where it belongs
325 - sfascan caches getversion across invokations
326 - vini topology extracted as a config file
327
328 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
329 - first support for protogeni rspecs is working
330 - vini no longer needs a specific manager
331 - refactoring underway towards more flexible/generic architecture
332
333 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
334 - Unicode-friendliness for user names with accents/special chars.
335 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
336 - CreaetSliver no longer fails for users that have a capital letter in their URN.
337 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
338 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
339 - Fix bugs and missing imports     
340  
341
342 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
343 - new method record.get_field for sface
344
345 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
346 - new option -c to sfa-nuke-plc.py
347 - CreateSliver fixed for admin-only slice tags
348
349 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
350 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
351 - Fixed holes in certificate verification logic.
352 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
353 - Added 'boot_state' as an attribute of the node element in SFA rspec.
354 - Non authority certificates are marked as CA:FALSE.
355
356 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
357 - fix typo in sfa-1.0-31 tag.
358 - added CreateGid() Registry interface method.
359
360 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
361 - fix typo in sfa-1.0-30 tag
362
363 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
364 - Declare namespace and schema location in the credential.
365 - Fix bug that prevetend connections from timing out.
366 - Fix slice delegation.
367 - Add statistics to slicemaanger listresources/createsliver rspec.
368 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
369   of days a user can extend their slice expiration.
370 - CA certs are only issued to objects of type authority
371    
372 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
373 - tag 1.0-28 was broken due to typo in the changelog
374 - new class sfa/util/httpsProtocol.py that supports timeouts
375
376 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
377 - Resolved issue that caused sfa hold onto idle db connections.
378 - Fix bug that caused the registry to use the wrong type of credential.
379 - Support authority+sm type.
380 - Fix rspec merging bugs.
381 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
382 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
383  planetlab hosted initscripts using the <planetlab:initscript> tag  
384 - Can now handle extraneous whitespace in the rspec without failing.   
385  
386 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
387 - ProtoGENI v2 RSpec updates.
388 - Convert expiration timestamps with timezone info in credentials to utc.
389 - Fixed redundant logging issue. 
390 - Improved SliceManager and SFI client logging.
391 - Support aggregates that don't support the optional 'call_id' argument. 
392 - Only call get_trusted_certs() at aggreage interfaces that support the call.
393 - CreateSliver() now handles MyPLC slice attributes/tags.
394 - Cache now supports persistence.
395 - Hide whitelisted nodes.
396
397 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
398 - fixed issues with sup authority signing
399 - fixed bugs in remove_slivers and SliverStatus
400
401 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
402 - fix typo that prevented aggregates from operating properly
403
404 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
405 - load trusted certs into ssl context prior to handshake
406 - client's logfile lives in ~/.sfi/sfi.log
407
408 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
409 - includes a change on passphrases that was intended in 1.0-22
410
411 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
412 - Added support for ProtoGENI RSpec v2
413  
414 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
415 - stable sfascan
416 - fix in initscript, *ENABLED tags in config now taken into account
417
418 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
419 - some commits had not been pushed in tag 19
420
421 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
422 - GetVersion should now report full URLs with path
423 - scansfa has nicer output and new syntax (entry URLs as args and not options)
424 - dos2unix'ed flash policy pill
425
426 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
427 - fix packaging again for f8
428
429 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
430 - fix packaging (apparently broken in 1.0-16)
431 - first working version of sfascan
432 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
433 - deprecated the sfa_geni_aggregate config category
434
435 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
436 - Fix build problem
437 - First version of SFA scanner
438
439 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
440 - Add support for Flash clients using flashpolicy
441 - Fix problems with tag handling in RSpec
442
443 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
444 - Modifications to the Eucalyptus Aggregate Manager
445 - Fixes for VINI RSpec
446 - Fix tag handling for PL RSpec
447 - Fix XML Schema ordering for <urn> element
448
449 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
450 - just set x509 version to 2
451
452 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
453 - added urn to the node area in rspecs
454 - conversion to urn now exports fqdn
455 - sfa-import-plc.py now creates a unique registry record for each SFA interface
456
457 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
458 - undo broken attempt for python-2.7
459
460 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
461 - SMs avoid duplicates for when call graph has dags;
462 - just based on network's name, when a duplicate occurs, one is just dropped
463 - does not try to merge/aggregate 2 networks
464 - also reviewed logging with the hope to fix the sfa startup msg:
465 - TypeError: not all arguments converted during string formatting
466
467 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
468 - verify credentials against xsd schema
469 - Fix SM to SM communication
470 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
471 - new setting session_key_path
472
473 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
474 - fix registry credential regeneration and handle expiration
475 - support for setting slice tags (min_role=user)
476 - client can display its own version: sfi.py version --local
477 - GetVersion to provide urn in addition to hrn
478 - more code uses plxrn vs previous helper functions
479 - import replaces '+' in email addresses with '_'
480
481 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
482 - fix GetVersion code_tag and add code_url
483
484 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
485 - extend GetVersion towards minimum federation introspection, and expose local tag
486
487 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
488 - fixed some legacy issues (list vs List)
489 - deprecated sfa.util.namespace for xrn and plxrn
490 - unit tests ship as the sfa-tests rpm
491
492 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
493 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
494 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
495 - hrn-urn translations tweaked
496 - fixed 'service sfa status'
497 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
498 - started to repair sfadump - although not usable yet
499 - trust objects now have dump_string method that dump() actually prints
500 - unit tests under review
501 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
502 - binaries now support -v or -vv to increase loglevel
503 - trashed obsolete sfa.util.client
504
505 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
506 - various bugfixes and cleanup, improved/harmonized logging
507
508 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
509 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
510   to avoid returning a PLCAPI exception that might confuse users.
511 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
512 - fix build errors.  
513
514 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
515 - (Architecture) Credential format changed to match ProtoGENI xml format
516 - (Architecture) All interfaces export a new set of methods that are compatible
517    with the ProtoGeni Aggregate spec. These new methods are considered a 
518    replacement  for the pervious methods exported by the interfaces. All 
519    previous methods are still exported and work as normal, but they are 
520    considered deprecated and will not be supported in future releases.  
521 - (Architecture) SFI has been updated to use the new interface methods.
522 - (Architecture) Changed keyconvet implementation from c to python.
523 - (Architecture) Slice Manager now attempts looks for a delegated credential
524   provided by the client before using its own server credential.
525 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
526   This cache now exists only in memory and is cleared when service is restarted
527   or cache lifetime is exceeded.  
528 - (Performance) SliceManager sends request to Aggregates in parallel instead 
529   of sequentially.
530 - (Bug fix) SFA tickets now support the new rspec format.
531 - (Bug fix) SFI only uses cahced credential if they aren't expired.
532 - (Bug fix) Cerdential delegation modified to work with new credential format.
533 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
534   Aggregate instead of relaying through the Slice Manager.
535 - (Enhancement) Simplified caching. Accociated a global cache instance with
536   the api handler on every new server request, making it easier to access the 
537   cache and use in more general ways.     
538
539 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
540 - SfaServer now uses a pool of threads to handle requests concurrently
541 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
542 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
543 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
544 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
545 - Component manager does not install gid files if slice already has them  
546 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
547 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
548 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
549      
550 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
551 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
552 - - sfa-config-tty now has the same features like plc-config-tty
553 - - Contains code to support both urn and hrn
554 - - Cleaned up request_hash related stuff
555 - - SM, AM and Registry code is organized under respective managers
556 - - Site and Slice synchronization across federated aggregates
557 - - Script to generate sfa_component_config
558
559 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
560 - sfa-config-tty now has the same features like plc-config-tty
561 - Contains code to support both urn and hrn
562 - Cleaned up request_hash related stuff
563 - SM, AM and Registry code is organized under respective managers
564 - Slice synchronization across federated aggregates
565 - some bugs are fixed
566
567 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
568 - checkpoint with fewer mentions of geni
569
570 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
571 - checkpointing
572 - this is believed to pass the tests; among other things:
573 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
574
575 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
576 - This tag includes:
577 - - Sfatables
578 - - Preliminary version of hash based authentication
579 - - Initial code for Component Manager
580 - - Authority structure is moved to /var/lib/sfa/
581 - - some bug-fixes
582
583 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
584 - Create_slice and get_resources methods are connected to sfatables.
585 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
586
587 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
588 - Bug fix on update and remove_peer_object methods
589 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
590
591 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
592 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
593
594 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
595 - compatibility with RefreshPeer
596 - incremental mechanism for importing PLC records into SFA tables
597 - unified single database (still inside the underlying PLC db postgresql server)
598 - includes/improves call traceability and logging features
599 - several bug fixes
600
601 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
602 - added libxslt-python dependency
603
604 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
605 - unified single SFA database in the PLC-DB
606 - upcalls from  PLCAPI to SFA methods
607 - SFA call traceability and logging features
608 - many bug fixes
609 - includes first/rough version of sfatables for policy implementation
610
611 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
612 - snapshot after the GEC5 demo
613 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
614
615 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
616 - snapshot july 15 - has gone through superficial manual testing
617 - hopefully a good basis for gec5 demo
618 - multi-dir sfi client tested as well
619
620 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
621 - rename geniwrapper.spec into sfa.spec
622
623 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
624 - clean up in xmlrpc/soap, --protocol option to chose between both
625 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
626 - hopefully more helpful context in case of crashes when importing
627 - bugfixes for using only /etc/sfa for site-dep files
628 - bugfixes in wsdl generation
629
630 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
631 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
632 - config variables in sfa_config now start with SFA_ and not GENI_
633 - config.py can be loaded even with no config present
634
635 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
636 - first step for cleanup and reorganization
637 - mass-renaming from geni to sfa (some are still needed)
638 - sfa/trust implements the security architecture
639
640 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
641 - snapshot for reproducible builds
642
643 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
644 - snapshot for the convenience of alpha users
645
646 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
647 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
648
649 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
650 - ongoing work - snapshot for 4.3-rc9
651
652 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
653 - various fixes
654
655 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
656 - bugfixes - still a work in progress
657
658 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
659 - initial package
660
661
662 %define module_current_branch 0.2