Merge branch 'master' into eucalyptus-devel
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 26
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart || :
197
198 %changelog
199 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
200 - fixed issues with sup authority signing
201 - fixed bugs in remove_slivers and SliverStatus
202
203 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
204 - fix typo that prevented aggregates from operating properly
205
206 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
207 - load trusted certs into ssl context prior to handshake
208 - client's logfile lives in ~/.sfi/sfi.log
209
210 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
211 - includes a change on passphrases that was intended in 1.0-22
212
213 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
214 - Added support for ProtoGENI RSpec v2
215  
216 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
217 - stable sfascan
218 - fix in initscript, *ENABLED tags in config now taken into account
219
220 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
221 - some commits had not been pushed in tag 19
222
223 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
224 - GetVersion should now report full URLs with path
225 - scansfa has nicer output and new syntax (entry URLs as args and not options)
226 - dos2unix'ed flash policy pill
227
228 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
229 - fix packaging again for f8
230
231 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
232 - fix packaging (apparently broken in 1.0-16)
233 - first working version of sfascan
234 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
235 - deprecated the sfa_geni_aggregate config category
236
237 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
238 - Fix build problem
239 - First version of SFA scanner
240
241 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
242 - Add support for Flash clients using flashpolicy
243 - Fix problems with tag handling in RSpec
244
245 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
246 - Modifications to the Eucalyptus Aggregate Manager
247 - Fixes for VINI RSpec
248 - Fix tag handling for PL RSpec
249 - Fix XML Schema ordering for <urn> element
250
251 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
252 - just set x509 version to 2
253
254 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
255 - added urn to the node area in rspecs
256 - conversion to urn now exports fqdn
257 - sfa-import-plc.py now creates a unique registry record for each SFA interface
258
259 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
260 - undo broken attempt for python-2.7
261
262 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
263 - SMs avoid duplicates for when call graph has dags;
264 - just based on network's name, when a duplicate occurs, one is just dropped
265 - does not try to merge/aggregate 2 networks
266 - also reviewed logging with the hope to fix the sfa startup msg:
267 - TypeError: not all arguments converted during string formatting
268
269 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
270 - verify credentials against xsd schema
271 - Fix SM to SM communication
272 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
273 - new setting session_key_path
274
275 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
276 - fix registry credential regeneration and handle expiration
277 - support for setting slice tags (min_role=user)
278 - client can display its own version: sfi.py version --local
279 - GetVersion to provide urn in addition to hrn
280 - more code uses plxrn vs previous helper functions
281 - import replaces '+' in email addresses with '_'
282
283 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
284 - fix GetVersion code_tag and add code_url
285
286 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
287 - extend GetVersion towards minimum federation introspection, and expose local tag
288
289 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
290 - fixed some legacy issues (list vs List)
291 - deprecated sfa.util.namespace for xrn and plxrn
292 - unit tests ship as the sfa-tests rpm
293
294 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
295 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
296 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
297 - hrn-urn translations tweaked
298 - fixed 'service sfa status'
299 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
300 - started to repair sfadump - although not usable yet
301 - trust objects now have dump_string method that dump() actually prints
302 - unit tests under review
303 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
304 - binaries now support -v or -vv to increase loglevel
305 - trashed obsolete sfa.util.client
306
307 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
308 - various bugfixes and cleanup, improved/harmonized logging
309
310 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
311 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
312   to avoid returning a PLCAPI exception that might confuse users.
313 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
314 - fix build errors.  
315
316 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
317 - (Architecture) Credential format changed to match ProtoGENI xml format
318 - (Architecture) All interfaces export a new set of methods that are compatible
319    with the ProtoGeni Aggregate spec. These new methods are considered a 
320    replacement  for the pervious methods exported by the interfaces. All 
321    previous methods are still exported and work as normal, but they are 
322    considered deprecated and will not be supported in future releases.  
323 - (Architecture) SFI has been updated to use the new interface methods.
324 - (Architecture) Changed keyconvet implementation from c to python.
325 - (Architecture) Slice Manager now attempts looks for a delegated credential
326   provided by the client before using its own server credential.
327 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
328   This cache now exists only in memory and is cleared when service is restarted
329   or cache lifetime is exceeded.  
330 - (Performance) SliceManager sends request to Aggregates in parallel instead 
331   of sequentially.
332 - (Bug fix) SFA tickets now support the new rspec format.
333 - (Bug fix) SFI only uses cahced credential if they aren't expired.
334 - (Bug fix) Cerdential delegation modified to work with new credential format.
335 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
336   Aggregate instead of relaying through the Slice Manager.
337 - (Enhancement) Simplified caching. Accociated a global cache instance with
338   the api handler on every new server request, making it easier to access the 
339   cache and use in more general ways.     
340
341 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
342 - SfaServer now uses a pool of threads to handle requests concurrently
343 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
344 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
345 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
346 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
347 - Component manager does not install gid files if slice already has them  
348 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
349 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
350 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
351      
352 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
353 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
354 - - sfa-config-tty now has the same features like plc-config-tty
355 - - Contains code to support both urn and hrn
356 - - Cleaned up request_hash related stuff
357 - - SM, AM and Registry code is organized under respective managers
358 - - Site and Slice synchronization across federated aggregates
359 - - Script to generate sfa_component_config
360
361 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
362 - sfa-config-tty now has the same features like plc-config-tty
363 - Contains code to support both urn and hrn
364 - Cleaned up request_hash related stuff
365 - SM, AM and Registry code is organized under respective managers
366 - Slice synchronization across federated aggregates
367 - some bugs are fixed
368
369 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
370 - checkpoint with fewer mentions of geni
371
372 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
373 - checkpointing
374 - this is believed to pass the tests; among other things:
375 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
376
377 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
378 - This tag includes:
379 - - Sfatables
380 - - Preliminary version of hash based authentication
381 - - Initial code for Component Manager
382 - - Authority structure is moved to /var/lib/sfa/
383 - - some bug-fixes
384
385 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
386 - Create_slice and get_resources methods are connected to sfatables.
387 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
388
389 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
390 - Bug fix on update and remove_peer_object methods
391 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
392
393 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
394 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
395
396 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
397 - compatibility with RefreshPeer
398 - incremental mechanism for importing PLC records into SFA tables
399 - unified single database (still inside the underlying PLC db postgresql server)
400 - includes/improves call traceability and logging features
401 - several bug fixes
402
403 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
404 - added libxslt-python dependency
405
406 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
407 - unified single SFA database in the PLC-DB
408 - upcalls from  PLCAPI to SFA methods
409 - SFA call traceability and logging features
410 - many bug fixes
411 - includes first/rough version of sfatables for policy implementation
412
413 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
414 - snapshot after the GEC5 demo
415 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
416
417 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
418 - snapshot july 15 - has gone through superficial manual testing
419 - hopefully a good basis for gec5 demo
420 - multi-dir sfi client tested as well
421
422 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
423 - rename geniwrapper.spec into sfa.spec
424
425 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
426 - clean up in xmlrpc/soap, --protocol option to chose between both
427 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
428 - hopefully more helpful context in case of crashes when importing
429 - bugfixes for using only /etc/sfa for site-dep files
430 - bugfixes in wsdl generation
431
432 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
433 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
434 - config variables in sfa_config now start with SFA_ and not GENI_
435 - config.py can be loaded even with no config present
436
437 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
438 - first step for cleanup and reorganization
439 - mass-renaming from geni to sfa (some are still needed)
440 - sfa/trust implements the security architecture
441
442 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
443 - snapshot for reproducible builds
444
445 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
446 - snapshot for the convenience of alpha users
447
448 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
449 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
450
451 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
452 - ongoing work - snapshot for 4.3-rc9
453
454 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
455 - various fixes
456
457 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
458 - bugfixes - still a work in progress
459
460 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
461 - initial package
462
463
464 %define module_current_branch 0.2