Merge branch 'master' of ssh://git.planet-lab.org/git/sfa
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 14
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %Package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py
167 /etc/sfa/flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart
197
198
199 %changelog
200 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
201 - Modifications to the Eucalyptus Aggregate Manager
202 - Fixes for VINI RSpec
203 - Fix tag handling for PL RSpec
204 - Fix XML Schema ordering for <urn> element
205
206 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
207 - just set x509 version to 2
208
209 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
210 - added urn to the node area in rspecs
211 - conversion to urn now exports fqdn
212 - sfa-import-plc.py now creates a unique registry record for each SFA interface
213
214 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
215 - undo broken attempt for python-2.7
216
217 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
218 - SMs avoid duplicates for when call graph has dags;
219 - just based on network's name, when a duplicate occurs, one is just dropped
220 - does not try to merge/aggregate 2 networks
221 - also reviewed logging with the hope to fix the sfa startup msg:
222 - TypeError: not all arguments converted during string formatting
223
224 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
225 - verify credentials against xsd schema
226 - Fix SM to SM communication
227 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
228 - new setting session_key_path
229
230 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
231 - fix registry credential regeneration and handle expiration
232 - support for setting slice tags (min_role=user)
233 - client can display its own version: sfi.py version --local
234 - GetVersion to provide urn in addition to hrn
235 - more code uses plxrn vs previous helper functions
236 - import replaces '+' in email addresses with '_'
237
238 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
239 - fix GetVersion code_tag and add code_url
240
241 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
242 - extend GetVersion towards minimum federation introspection, and expose local tag
243
244 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
245 - fixed some legacy issues (list vs List)
246 - deprecated sfa.util.namespace for xrn and plxrn
247 - unit tests ship as the sfa-tests rpm
248
249 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
250 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
251 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
252 - hrn-urn translations tweaked
253 - fixed 'service sfa status'
254 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
255 - started to repair sfadump - although not usable yet
256 - trust objects now have dump_string method that dump() actually prints
257 - unit tests under review
258 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
259 - binaries now support -v or -vv to increase loglevel
260 - trashed obsolete sfa.util.client
261
262 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
263 - various bugfixes and cleanup, improved/harmonized logging
264
265 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
266 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
267   to avoid returning a PLCAPI exception that might confuse users.
268 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
269 - fix build errors.  
270
271 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
272 - (Architecture) Credential format changed to match ProtoGENI xml format
273 - (Architecture) All interfaces export a new set of methods that are compatible
274    with the ProtoGeni Aggregate spec. These new methods are considered a 
275    replacement  for the pervious methods exported by the interfaces. All 
276    previous methods are still exported and work as normal, but they are 
277    considered deprecated and will not be supported in future releases.  
278 - (Architecture) SFI has been updated to use the new interface methods.
279 - (Architecture) Changed keyconvet implementation from c to python.
280 - (Architecture) Slice Manager now attempts looks for a delegated credential
281   provided by the client before using its own server credential.
282 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
283   This cache now exists only in memory and is cleared when service is restarted
284   or cache lifetime is exceeded.  
285 - (Performance) SliceManager sends request to Aggregates in parallel instead 
286   of sequentially.
287 - (Bug fix) SFA tickets now support the new rspec format.
288 - (Bug fix) SFI only uses cahced credential if they aren't expired.
289 - (Bug fix) Cerdential delegation modified to work with new credential format.
290 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
291   Aggregate instead of relaying through the Slice Manager.
292 - (Enhancement) Simplified caching. Accociated a global cache instance with
293   the api handler on every new server request, making it easier to access the 
294   cache and use in more general ways.     
295
296 %changelog
297 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
298 - Modifications to the Eucalyptus Aggregate Manager
299 - Fixes for VINI RSpec
300 - Fix tag handling for PL RSpec
301 - Fix XML Schema ordering for <urn> element
302
303 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
304 - just set x509 version to 2
305
306 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
307 - added urn to the node area in rspecs
308 - conversion to urn now exports fqdn
309 - sfa-import-plc.py now creates a unique registry record for each SFA interface
310
311 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
312 - undo broken attempt for python-2.7
313
314 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
315 - SMs avoid duplicates for when call graph has dags;
316 - just based on network's name, when a duplicate occurs, one is just dropped
317 - does not try to merge/aggregate 2 networks
318 - also reviewed logging with the hope to fix the sfa startup msg:
319 - TypeError: not all arguments converted during string formatting
320
321 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
322 - verify credentials against xsd schema
323 - Fix SM to SM communication
324 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
325 - new setting session_key_path
326
327 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
328 - fix registry credential regeneration and handle expiration
329 - support for setting slice tags (min_role=user)
330 - client can display its own version: sfi.py version --local
331 - GetVersion to provide urn in addition to hrn
332 - more code uses plxrn vs previous helper functions
333 - import replaces '+' in email addresses with '_'
334
335 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
336 - fix GetVersion code_tag and add code_url
337
338 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
339 - extend GetVersion towards minimum federation introspection, and expose local tag
340
341 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
342 - fixed some legacy issues (list vs List)
343 - deprecated sfa.util.namespace for xrn and plxrn
344 - unit tests ship as the sfa-tests rpm
345
346 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
347 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
348 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
349 - hrn-urn translations tweaked
350 - fixed 'service sfa status'
351 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
352 - started to repair sfadump - although not usable yet
353 - trust objects now have dump_string method that dump() actually prints
354 - unit tests under review
355 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
356 - binaries now support -v or -vv to increase loglevel
357 - trashed obsolete sfa.util.client
358
359 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
360 - various bugfixes and cleanup, improved/harmonized logging
361
362 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
363 - SfaServer now uses a pool of threads to handle requests concurrently
364 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
365 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
366 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
367 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
368 - Component manager does not install gid files if slice already has them  
369 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
370 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
371 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
372      
373 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
374 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
375 - - sfa-config-tty now has the same features like plc-config-tty
376 - - Contains code to support both urn and hrn
377 - - Cleaned up request_hash related stuff
378 - - SM, AM and Registry code is organized under respective managers
379 - - Site and Slice synchronization across federated aggregates
380 - - Script to generate sfa_component_config
381
382 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
383 - sfa-config-tty now has the same features like plc-config-tty
384 - Contains code to support both urn and hrn
385 - Cleaned up request_hash related stuff
386 - SM, AM and Registry code is organized under respective managers
387 - Slice synchronization across federated aggregates
388 - some bugs are fixed
389
390 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
391 - checkpoint with fewer mentions of geni
392
393 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
394 - checkpointing
395 - this is believed to pass the tests; among other things:
396 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
397
398 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
399 - This tag includes:
400 - - Sfatables
401 - - Preliminary version of hash based authentication
402 - - Initial code for Component Manager
403 - - Authority structure is moved to /var/lib/sfa/
404 - - some bug-fixes
405
406 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
407 - Create_slice and get_resources methods are connected to sfatables.
408 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
409
410 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
411 - Bug fix on update and remove_peer_object methods
412 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
413
414 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
415 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
416
417 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
418 - compatibility with RefreshPeer
419 - incremental mechanism for importing PLC records into SFA tables
420 - unified single database (still inside the underlying PLC db postgresql server)
421 - includes/improves call traceability and logging features
422 - several bug fixes
423
424 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
425 - added libxslt-python dependency
426
427 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
428 - unified single SFA database in the PLC-DB
429 - upcalls from  PLCAPI to SFA methods
430 - SFA call traceability and logging features
431 - many bug fixes
432 - includes first/rough version of sfatables for policy implementation
433
434 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
435 - snapshot after the GEC5 demo
436 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
437
438 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
439 - snapshot july 15 - has gone through superficial manual testing
440 - hopefully a good basis for gec5 demo
441 - multi-dir sfi client tested as well
442
443 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
444 - rename geniwrapper.spec into sfa.spec
445
446 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
447 - clean up in xmlrpc/soap, --protocol option to chose between both
448 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
449 - hopefully more helpful context in case of crashes when importing
450 - bugfixes for using only /etc/sfa for site-dep files
451 - bugfixes in wsdl generation
452
453 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
454 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
455 - config variables in sfa_config now start with SFA_ and not GENI_
456 - config.py can be loaded even with no config present
457
458 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
459 - first step for cleanup and reorganization
460 - mass-renaming from geni to sfa (some are still needed)
461 - sfa/trust implements the security architecture
462
463 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
464 - snapshot for reproducible builds
465
466 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
467 - snapshot for the convenience of alpha users
468
469 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
470 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
471
472 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
473 - ongoing work - snapshot for 4.3-rc9
474
475 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
476 - various fixes
477
478 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
479 - bugfixes - still a work in progress
480
481 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
482 - initial package
483
484
485 %define module_current_branch 0.2