Requires python-dateutil
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 0.9
9 %define taglevel 14
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python >= 2.5
32 Requires: m2crypto
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39  
40 # python 2.5 has uuid module added, for python 2.4 we still need it.
41 # we can't really check for if we can load uuid as a python module,
42 # it'll be installed by "devel.pkgs". we have the epel repository so
43 # python-uuid will be provided. but we can test for the python
44 # version.
45 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
46 # %if %has_py24
47 #
48 # this also didn't work very well. I'll just check for distroname - baris
49 %if %{distroname} == "centos5"
50 Requires: python-uuid
51 %endif
52
53 %package cm
54 Summary: the SFA wrapper around MyPLC's NodeManager
55 Group: Applications/System
56 Requires: sfa
57 Requires: pyOpenSSL >= 0.6
58
59 %package plc
60 Summary: the SFA wrapper arounf MyPLC
61 Group: Applications/System
62 Requires: sfa
63 Requires: python-psycopg2
64 Requires: myplc-config
65 Requires: pyOpenSSL >= 0.7
66
67 %package client
68 Summary: the SFA experimenter-side CLI
69 Group: Applications/System
70 Requires: sfa
71 Requires: pyOpenSSL >= 0.7
72
73 %package sfatables
74 Summary: sfatables policy tool for SFA
75 Group: Applications/System
76 Requires: sfa
77
78 %description
79 This package provides the python libraries that the SFA implementation requires
80
81 %description cm
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
84  
85 %description plc
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
88
89 %description client
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
92
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
97
98 %prep
99 %setup -q
100
101 %build
102 make
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 make install DESTDIR="$RPM_BUILD_ROOT"
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 # sfa and sfatables depend each other.
113 %{_bindir}/sfa-server.py*
114 /etc/sfatables/*
115 %{python_sitelib}/*
116 /usr/bin/keyconvert
117 /var/www/html/wsdl/*.wsdl
118
119 %files cm
120 /etc/init.d/sfa-cm
121 %{_bindir}/sfa_component_setup.py*
122 # cron jobs here 
123
124 %files plc
125 %defattr(-,root,root)
126 %config /etc/sfa/default_config.xml
127 %config (noreplace) /etc/sfa/aggregates.xml
128 %config (noreplace) /etc/sfa/registries.xml
129 /etc/init.d/sfa
130 /etc/sfa/pl.rng
131 %{_bindir}/sfa-config-tty
132 %{_bindir}/sfa-import-plc.py*
133 %{_bindir}/sfa-clean-peer-records.py*
134 %{_bindir}/sfa-nuke-plc.py*
135 %{_bindir}/gen-sfa-cm-config.py*
136 %{_bindir}/sfa-ca.py*
137
138 %files client
139 %config (noreplace) /etc/sfa/sfi_config
140 %{_bindir}/sfi.py*
141 %{_bindir}/getNodes.py*
142 %{_bindir}/getRecord.py*
143 %{_bindir}/setRecord.py*
144 %{_bindir}/sfadump.py*
145
146 %files sfatables
147 %{_bindir}/sfatables
148
149 %pre plc
150 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
151
152 %pre cm
153 [ -f %{_sysconfdir}/init.d/sfa-cm ] && service sfa-cm stop ||:
154
155 %post plc
156 chkconfig --add sfa
157
158 %post cm
159 chkconfig --add sfa-cm
160 %changelog
161 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
162 - SfaServer now uses a pool of threads to handle requests concurrently
163 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
164 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
165 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
166 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
167 - Component manager does not install gid files if slice already has them  
168 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
169 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
170 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
171      
172 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
173 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
174 - - sfa-config-tty now has the same features like plc-config-tty
175 - - Contains code to support both urn and hrn
176 - - Cleaned up request_hash related stuff
177 - - SM, AM and Registry code is organized under respective managers
178 - - Site and Slice synchronization across federated aggregates
179 - - Script to generate sfa_component_config
180
181 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
182 - sfa-config-tty now has the same features like plc-config-tty
183 - Contains code to support both urn and hrn
184 - Cleaned up request_hash related stuff
185 - SM, AM and Registry code is organized under respective managers
186 - Slice synchronization across federated aggregates
187 - some bugs are fixed
188
189 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
190 - checkpoint with fewer mentions of geni
191
192 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
193 - checkpointing
194 - this is believed to pass the tests; among other things:
195 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
196
197 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
198 - This tag includes:
199 - - Sfatables
200 - - Preliminary version of hash based authentication
201 - - Initial code for Component Manager
202 - - Authority structure is moved to /var/lib/sfa/
203 - - some bug-fixes
204
205 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
206 - Create_slice and get_resources methods are connected to sfatables.
207 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
208
209 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
210 - Bug fix on update and remove_peer_object methods
211 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
212
213 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
214 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
215
216 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
217 - compatibility with RefreshPeer
218 - incremental mechanism for importing PLC records into SFA tables
219 - unified single database (still inside the underlying PLC db postgresql server)
220 - includes/improves call traceability and logging features
221 - several bug fixes
222
223 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
224 - added libxslt-python dependency
225
226 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
227 - unified single SFA database in the PLC-DB
228 - upcalls from  PLCAPI to SFA methods
229 - SFA call traceability and logging features
230 - many bug fixes
231 - includes first/rough version of sfatables for policy implementation
232
233 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
234 - snapshot after the GEC5 demo
235 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
236
237 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
238 - snapshot july 15 - has gone through superficial manual testing
239 - hopefully a good basis for gec5 demo
240 - multi-dir sfi client tested as well
241
242 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
243 - rename geniwrapper.spec into sfa.spec
244
245 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
246 - clean up in xmlrpc/soap, --protocol option to chose between both
247 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
248 - hopefully more helpful context in case of crashes when importing
249 - bugfixes for using only /etc/sfa for site-dep files
250 - bugfixes in wsdl generation
251
252 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
253 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
254 - config variables in sfa_config now start with SFA_ and not GENI_
255 - config.py can be loaded even with no config present
256
257 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
258 - first step for cleanup and reorganization
259 - mass-renaming from geni to sfa (some are still needed)
260 - sfa/trust implements the security architecture
261
262 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
263 - snapshot for reproducible builds
264
265 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
266 - snapshot for the convenience of alpha users
267
268 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
269 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
270
271 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
272 - ongoing work - snapshot for 4.3-rc9
273
274 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
275 - various fixes
276
277 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
278 - bugfixes - still a work in progress
279
280 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
281 - initial package
282
283
284 %define module_current_branch 0.2