missing 'requires' when installed on a non-myplc box
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA layer around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA layer around MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: postgresql-python
59 Requires: python-psycopg2
60 Requires: myplc-config
61 Requires: pyOpenSSL >= 0.7
62
63 %package client
64 Summary: the SFA experimenter-side CLI
65 Group: Applications/System
66 Requires: sfa
67 Requires: pyOpenSSL >= 0.7
68
69 %package sfatables
70 Summary: sfatables policy tool for SFA
71 Group: Applications/System
72 Requires: sfa
73
74 %package flashpolicy
75 Summary: SFA support for flash clients
76 Group: Applications/System
77 Requires: sfa
78
79 %package tests
80 Summary: unit tests suite for SFA
81 Group: Applications/System
82 Requires: sfa
83
84 %description
85 This package provides the python libraries for the PlanetLab implementation of SFA
86
87 %description cm
88 This package implements the SFA interface which serves as a layer
89 between the existing PlanetLab NodeManager interfaces and the SFA API.
90  
91 %description plc
92 This package implements the SFA interface which serves as a layer
93 between the existing PlanetLab interfaces and the SFA API.
94
95 %description client
96 This package provides the client side of the SFA API, in particular
97 sfi.py, together with other utilities.
98
99 %description sfatables
100 sfatables is a tool for defining access and admission control policies
101 in an SFA network, in much the same way as iptables is for ip
102 networks. This is the command line interface to manage sfatables
103
104 %description flashpolicy
105 This package provides support for adobe flash client applications.  
106  
107 %description tests
108 Provides some binary unit tests in /usr/share/sfa/tests
109
110 %prep
111 %setup -q
112
113 %build
114 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 # sfa and sfatables depend each other.
125 %{_bindir}/sfa-start.py*
126 /etc/sfatables/*
127 %{python_sitelib}/*
128 %{_bindir}/keyconvert.py*
129 /var/www/html/wsdl/*.wsdl
130
131 %files cm
132 /etc/init.d/sfa-cm
133 %{_bindir}/sfa_component_setup.py*
134 # cron jobs here 
135
136 %files plc
137 %defattr(-,root,root)
138 %config /etc/sfa/default_config.xml
139 %config (noreplace) /etc/sfa/aggregates.xml
140 %config (noreplace) /etc/sfa/registries.xml
141 /etc/init.d/sfa
142 /etc/sfa/pl.rng
143 /etc/sfa/credential.xsd
144 /etc/sfa/top.xsd
145 /etc/sfa/sig.xsd
146 /etc/sfa/xml.xsd
147 /etc/sfa/protogeni-rspec-common.xsd
148 /etc/sfa/topology
149 %{_bindir}/sfa-config-tty
150 %{_bindir}/sfa-import-plc.py*
151 %{_bindir}/sfa-clean-peer-records.py*
152 %{_bindir}/sfa-nuke-plc.py*
153 %{_bindir}/gen-sfa-cm-config.py*
154 %{_bindir}/sfa-ca.py*
155
156 %files client
157 %config (noreplace) /etc/sfa/sfi_config
158 %{_bindir}/sfi*
159 %{_bindir}/getNodes.py*
160 %{_bindir}/getRecord.py*
161 %{_bindir}/setRecord.py*
162 %{_bindir}/sfadump.py*
163
164 %files sfatables
165 %{_bindir}/sfatables
166
167 %files flashpolicy
168 %{_bindir}/sfa_flashpolicy.py*
169 /etc/sfa/sfa_flashpolicy_config.xml
170
171 %files tests
172 %{_datadir}/sfa/tests
173
174 ### sfa-plc installs the 'sfa' service
175 %post plc
176 chkconfig --add sfa
177
178 %preun plc
179 if [ "$1" = 0 ] ; then
180   /sbin/service sfa stop || :
181   /sbin/chkconfig --del sfa || :
182 fi
183
184 %postun plc
185 [ "$1" -ge "1" ] && service sfa restart
186
187 ### sfa-cm installs the 'sfa-cm' service
188 %post cm
189 chkconfig --add sfa-cm
190
191 %preun cm
192 if [ "$1" = 0 ] ; then
193    /sbin/service sfa-cm stop || :
194    /sbin/chkconfig --del sfa-cm || :
195 fi
196
197 %postun cm
198 [ "$1" -ge "1" ] && service sfa-cm restart || :
199
200 %changelog
201 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
202 - ongoing refoactoring towards more genericity
203 - passes tests again although known issues remain with attributes/tags
204
205 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
206 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
207 - improvements in the pgv2 rspecs
208 - driver separated from api
209 - code starts moving around where it belongs
210 - sfascan caches getversion across invokations
211 - vini topology extracted as a config file
212
213 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
214 - first support for protogeni rspecs is working
215 - vini no longer needs a specific manager
216 - refactoring underway towards more flexible/generic architecture
217
218 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
219 - Unicode-friendliness for user names with accents/special chars.
220 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
221 - CreaetSliver no longer fails for users that have a capital letter in their URN.
222 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
223 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
224 - Fix bugs and missing imports     
225  
226
227 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
228 - new method record.get_field for sface
229
230 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
231 - new option -c to sfa-nuke-plc.py
232 - CreateSliver fixed for admin-only slice tags
233
234 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
235 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
236 - Fixed holes in certificate verification logic.
237 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
238 - Added 'boot_state' as an attribute of the node element in SFA rspec.
239 - Non authority certificates are marked as CA:FALSE.
240
241 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
242 - fix typo in sfa-1.0-31 tag.
243 - added CreateGid() Registry interface method.
244
245 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
246 - fix typo in sfa-1.0-30 tag
247
248 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
249 - Declare namespace and schema location in the credential.
250 - Fix bug that prevetend connections from timing out.
251 - Fix slice delegation.
252 - Add statistics to slicemaanger listresources/createsliver rspec.
253 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
254   of days a user can extend their slice expiration.
255 - CA certs are only issued to objects of type authority
256    
257 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
258 - tag 1.0-28 was broken due to typo in the changelog
259 - new class sfa/util/httpsProtocol.py that supports timeouts
260
261 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
262 - Resolved issue that caused sfa hold onto idle db connections.
263 - Fix bug that caused the registry to use the wrong type of credential.
264 - Support authority+sm type.
265 - Fix rspec merging bugs.
266 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
267 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
268  planetlab hosted initscripts using the <planetlab:initscript> tag  
269 - Can now handle extraneous whitespace in the rspec without failing.   
270  
271 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
272 - ProtoGENI v2 RSpec updates.
273 - Convert expiration timestamps with timezone info in credentials to utc.
274 - Fixed redundant logging issue. 
275 - Improved SliceManager and SFI client logging.
276 - Support aggregates that don't support the optional 'call_id' argument. 
277 - Only call get_trusted_certs() at aggreage interfaces that support the call.
278 - CreateSliver() now handles MyPLC slice attributes/tags.
279 - Cache now supports persistence.
280 - Hide whitelisted nodes.
281
282 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
283 - fixed issues with sup authority signing
284 - fixed bugs in remove_slivers and SliverStatus
285
286 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
287 - fix typo that prevented aggregates from operating properly
288
289 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
290 - load trusted certs into ssl context prior to handshake
291 - client's logfile lives in ~/.sfi/sfi.log
292
293 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
294 - includes a change on passphrases that was intended in 1.0-22
295
296 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
297 - Added support for ProtoGENI RSpec v2
298  
299 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
300 - stable sfascan
301 - fix in initscript, *ENABLED tags in config now taken into account
302
303 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
304 - some commits had not been pushed in tag 19
305
306 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
307 - GetVersion should now report full URLs with path
308 - scansfa has nicer output and new syntax (entry URLs as args and not options)
309 - dos2unix'ed flash policy pill
310
311 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
312 - fix packaging again for f8
313
314 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
315 - fix packaging (apparently broken in 1.0-16)
316 - first working version of sfascan
317 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
318 - deprecated the sfa_geni_aggregate config category
319
320 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
321 - Fix build problem
322 - First version of SFA scanner
323
324 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
325 - Add support for Flash clients using flashpolicy
326 - Fix problems with tag handling in RSpec
327
328 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
329 - Modifications to the Eucalyptus Aggregate Manager
330 - Fixes for VINI RSpec
331 - Fix tag handling for PL RSpec
332 - Fix XML Schema ordering for <urn> element
333
334 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
335 - just set x509 version to 2
336
337 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
338 - added urn to the node area in rspecs
339 - conversion to urn now exports fqdn
340 - sfa-import-plc.py now creates a unique registry record for each SFA interface
341
342 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
343 - undo broken attempt for python-2.7
344
345 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
346 - SMs avoid duplicates for when call graph has dags;
347 - just based on network's name, when a duplicate occurs, one is just dropped
348 - does not try to merge/aggregate 2 networks
349 - also reviewed logging with the hope to fix the sfa startup msg:
350 - TypeError: not all arguments converted during string formatting
351
352 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
353 - verify credentials against xsd schema
354 - Fix SM to SM communication
355 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
356 - new setting session_key_path
357
358 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
359 - fix registry credential regeneration and handle expiration
360 - support for setting slice tags (min_role=user)
361 - client can display its own version: sfi.py version --local
362 - GetVersion to provide urn in addition to hrn
363 - more code uses plxrn vs previous helper functions
364 - import replaces '+' in email addresses with '_'
365
366 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
367 - fix GetVersion code_tag and add code_url
368
369 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
370 - extend GetVersion towards minimum federation introspection, and expose local tag
371
372 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
373 - fixed some legacy issues (list vs List)
374 - deprecated sfa.util.namespace for xrn and plxrn
375 - unit tests ship as the sfa-tests rpm
376
377 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
378 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
379 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
380 - hrn-urn translations tweaked
381 - fixed 'service sfa status'
382 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
383 - started to repair sfadump - although not usable yet
384 - trust objects now have dump_string method that dump() actually prints
385 - unit tests under review
386 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
387 - binaries now support -v or -vv to increase loglevel
388 - trashed obsolete sfa.util.client
389
390 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
391 - various bugfixes and cleanup, improved/harmonized logging
392
393 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
394 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
395   to avoid returning a PLCAPI exception that might confuse users.
396 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
397 - fix build errors.  
398
399 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
400 - (Architecture) Credential format changed to match ProtoGENI xml format
401 - (Architecture) All interfaces export a new set of methods that are compatible
402    with the ProtoGeni Aggregate spec. These new methods are considered a 
403    replacement  for the pervious methods exported by the interfaces. All 
404    previous methods are still exported and work as normal, but they are 
405    considered deprecated and will not be supported in future releases.  
406 - (Architecture) SFI has been updated to use the new interface methods.
407 - (Architecture) Changed keyconvet implementation from c to python.
408 - (Architecture) Slice Manager now attempts looks for a delegated credential
409   provided by the client before using its own server credential.
410 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
411   This cache now exists only in memory and is cleared when service is restarted
412   or cache lifetime is exceeded.  
413 - (Performance) SliceManager sends request to Aggregates in parallel instead 
414   of sequentially.
415 - (Bug fix) SFA tickets now support the new rspec format.
416 - (Bug fix) SFI only uses cahced credential if they aren't expired.
417 - (Bug fix) Cerdential delegation modified to work with new credential format.
418 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
419   Aggregate instead of relaying through the Slice Manager.
420 - (Enhancement) Simplified caching. Accociated a global cache instance with
421   the api handler on every new server request, making it easier to access the 
422   cache and use in more general ways.     
423
424 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
425 - SfaServer now uses a pool of threads to handle requests concurrently
426 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
427 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
428 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
429 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
430 - Component manager does not install gid files if slice already has them  
431 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
432 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
433 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
434      
435 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
436 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
437 - - sfa-config-tty now has the same features like plc-config-tty
438 - - Contains code to support both urn and hrn
439 - - Cleaned up request_hash related stuff
440 - - SM, AM and Registry code is organized under respective managers
441 - - Site and Slice synchronization across federated aggregates
442 - - Script to generate sfa_component_config
443
444 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
445 - sfa-config-tty now has the same features like plc-config-tty
446 - Contains code to support both urn and hrn
447 - Cleaned up request_hash related stuff
448 - SM, AM and Registry code is organized under respective managers
449 - Slice synchronization across federated aggregates
450 - some bugs are fixed
451
452 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
453 - checkpoint with fewer mentions of geni
454
455 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
456 - checkpointing
457 - this is believed to pass the tests; among other things:
458 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
459
460 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
461 - This tag includes:
462 - - Sfatables
463 - - Preliminary version of hash based authentication
464 - - Initial code for Component Manager
465 - - Authority structure is moved to /var/lib/sfa/
466 - - some bug-fixes
467
468 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
469 - Create_slice and get_resources methods are connected to sfatables.
470 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
471
472 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
473 - Bug fix on update and remove_peer_object methods
474 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
475
476 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
477 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
478
479 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
480 - compatibility with RefreshPeer
481 - incremental mechanism for importing PLC records into SFA tables
482 - unified single database (still inside the underlying PLC db postgresql server)
483 - includes/improves call traceability and logging features
484 - several bug fixes
485
486 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
487 - added libxslt-python dependency
488
489 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
490 - unified single SFA database in the PLC-DB
491 - upcalls from  PLCAPI to SFA methods
492 - SFA call traceability and logging features
493 - many bug fixes
494 - includes first/rough version of sfatables for policy implementation
495
496 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
497 - snapshot after the GEC5 demo
498 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
499
500 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
501 - snapshot july 15 - has gone through superficial manual testing
502 - hopefully a good basis for gec5 demo
503 - multi-dir sfi client tested as well
504
505 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
506 - rename geniwrapper.spec into sfa.spec
507
508 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
509 - clean up in xmlrpc/soap, --protocol option to chose between both
510 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
511 - hopefully more helpful context in case of crashes when importing
512 - bugfixes for using only /etc/sfa for site-dep files
513 - bugfixes in wsdl generation
514
515 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
516 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
517 - config variables in sfa_config now start with SFA_ and not GENI_
518 - config.py can be loaded even with no config present
519
520 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
521 - first step for cleanup and reorganization
522 - mass-renaming from geni to sfa (some are still needed)
523 - sfa/trust implements the security architecture
524
525 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
526 - snapshot for reproducible builds
527
528 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
529 - snapshot for the convenience of alpha users
530
531 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
532 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
533
534 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
535 - ongoing work - snapshot for 4.3-rc9
536
537 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
538 - various fixes
539
540 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
541 - bugfixes - still a work in progress
542
543 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
544 - initial package
545
546
547 %define module_current_branch 0.2