Setting tag sfa-2.1-20
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 20
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package nitos
92 Summary: the SFA layer around NITOS
93 Group: Applications/System
94 Requires: sfa
95
96 %package dummy
97 Summary: the SFA layer around a Dummy Testbed 
98 Group: Applications/System
99 Requires: sfa
100
101 %package sfatables
102 Summary: sfatables policy tool for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %package xmlbuilder
107 Summary: third-party xmlbuilder tool
108 Group: Applications/System
109 Provides: python-xmlbuilder
110
111 %package tests
112 Summary: unit tests suite for SFA
113 Group: Applications/System
114 Requires: sfa
115
116 %description
117 This package provides the python libraries for the PlanetLab implementation of SFA
118
119 %description flashpolicy
120 This package provides support for adobe flash client applications.  
121
122 %description client
123 This package provides the client side of the SFA API, in particular
124 sfi.py, together with other utilities.
125
126 %description plc
127 This package implements the SFA interface which serves as a layer
128 between the existing PlanetLab interfaces and the SFA API.
129
130 %description cm
131 This package implements the SFA interface which serves as a layer
132 between the existing PlanetLab NodeManager interfaces and the SFA API.
133
134 %description federica
135 The SFA driver for FEDERICA.
136
137 %description nitos
138 The SFA driver for NITOS.
139
140 %description dummy
141 The SFA driver for a Dummy Testbed.
142
143 %description sfatables
144 sfatables is a tool for defining access and admission control policies
145 in an SFA network, in much the same way as iptables is for ip
146 networks. This is the command line interface to manage sfatables
147
148 %description xmlbuilder
149 This package contains the xmlbuilder python library, packaged for
150 convenience as it is not supported by fedora
151
152 %description tests
153 Provides some binary unit tests in /usr/share/sfa/tests
154
155 %prep
156 %setup -q
157
158 %build
159 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %{python_sitelib}/sfa/__init__.py*
170 %{python_sitelib}/sfa/trust
171 %{python_sitelib}/sfa/storage
172 %{python_sitelib}/sfa/util
173 %{python_sitelib}/sfa/server
174 %{python_sitelib}/sfa/methods
175 %{python_sitelib}/sfa/generic
176 %{python_sitelib}/sfa/managers
177 %{python_sitelib}/sfa/importer
178 %{python_sitelib}/sfa/rspecs
179 %{python_sitelib}/sfa/client
180 /etc/init.d/sfa
181 %{_bindir}/sfa-start.py*
182 %{_bindir}/sfaadmin.py*
183 %{_bindir}/sfaadmin
184 %{_bindir}/keyconvert.py*
185 %{_bindir}/sfa-config-tty
186 %{_bindir}/sfa-config
187 %config /etc/sfa/default_config.xml
188 %config (noreplace) /etc/sfa/aggregates.xml
189 %config (noreplace) /etc/sfa/registries.xml
190 /usr/share/sfa/migrations
191 /usr/share/sfa/examples
192 /var/www/html/wsdl/*.wsdl
193
194 %files flashpolicy
195 %{_bindir}/sfa_flashpolicy.py*
196 /etc/sfa/sfa_flashpolicy_config.xml
197
198 %files client
199 %config (noreplace) /etc/sfa/sfi_config
200 %{_bindir}/sfi*.py*
201 %{_bindir}/sfi
202 %{_bindir}/get*.py*
203 %{_bindir}/setRecord.py*
204 %{_bindir}/sfascan.py*
205 %{_bindir}/sfascan
206 %{_bindir}/sfadump.py*
207
208 %files plc
209 %defattr(-,root,root)
210 %{python_sitelib}/sfa/planetlab
211 %{python_sitelib}/sfa/openstack
212 /etc/sfa/pl.rng
213 /etc/sfa/credential.xsd
214 /etc/sfa/top.xsd
215 /etc/sfa/sig.xsd
216 /etc/sfa/xml.xsd
217 /etc/sfa/protogeni-rspec-common.xsd
218 /etc/sfa/topology
219 %{_bindir}/gen-sfa-cm-config.py*
220
221 %files cm
222 /etc/init.d/sfa-cm
223 %{_bindir}/sfa_component_setup.py*
224 # cron jobs here 
225
226 %files federica
227 %{python_sitelib}/sfa/federica
228
229 %files nitos
230 %{python_sitelib}/sfa/nitos
231
232 %files dummy
233 %{python_sitelib}/sfa/dummy
234
235 %files sfatables
236 /etc/sfatables/*
237 %{_bindir}/sfatables
238 %{python_sitelib}/sfatables
239
240 %files xmlbuilder
241 %{python_sitelib}/xmlbuilder
242
243 %files tests
244 %{_datadir}/sfa/tests
245
246 ### sfa installs the 'sfa' service
247 %post 
248 chkconfig --add sfa
249
250 %preun 
251 if [ "$1" = 0 ] ; then
252   /sbin/service sfa stop || :
253   /sbin/chkconfig --del sfa || :
254 fi
255
256 %postun
257 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
258
259 ### sfa-cm installs the 'sfa-cm' service
260 %post cm
261 chkconfig --add sfa-cm
262
263 %preun cm
264 if [ "$1" = 0 ] ; then
265    /sbin/service sfa-cm stop || :
266    /sbin/chkconfig --del sfa-cm || :
267 fi
268
269 %postun cm
270 [ "$1" -ge "1" ] && service sfa-cm restart || :
271
272 %changelog
273 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
274 - fix 2 major bugs in PL importer
275 - esp. wrt GID management against PLC key
276
277 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
278 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
279
280 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
281 - support fordelegation in sfaclientlib
282 - sfi delegate fixed
283 - other delegation-related sfi option trashed
284 - new config (based on ini format)
285 - new dummy driver and related package
286 - pl importer has more explicit error messages
287 - credential dump shows expiration
288
289 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
290 - bugfix in forwarding Resolve requests
291 - various fixes in the nitos driver wrt keys and users
292
293 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
294 - various tweaks for the nitos driver
295
296 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
297 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
298 - deeper cleanup of the data-dependencies between SFA and the testbed
299 - in particular, sfi create issues Resolve(details=False)
300 - for that purpose, Resolve exposes reg-* keys for SFA builtins
301 - which in turn allows sfi list to show PIs, slice members and keys
302 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
303 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
304
305 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
306 - configurable data-dir (/var/lib/sfa)
307 - no more dependent on myplc-config
308 - some support for hrns with _ instead of \.
309 - fix for PL importing in presence of gpg keys
310 - DeleteSliver returns True instead of 1 in case of success
311 - Various improvements on the openstack/nova side
312 - new package sfa-nitos
313
314 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
315 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
316 - sfi to remove expired credentials
317
318 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
319 - Update Openstack driver to support Essex release/
320 - Fix authority xrn bug.
321   
322
323 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
324 - review packaging - site-packages/planetlab now come with sfa-plc
325 - new package sfa-federica
326 - clientbin moved one step upwards
327
328 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
329 - fix bug in sfi update()
330
331 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
332 - fix broken sfa.util.xrn class for lowercase
333
334 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
335 - new 'void' generic_flavour for running in registry-only mode
336 - first shot at refactoring importers - probably needs more work
337 - openstack: various enhancements
338 - sfi interface to registry not based on xml files anymore
339 - sfi show sorts result on record key
340 - bugfix in sfa update on users with a pl-backed registry
341
342 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
343 - renamed sfa/plc into sfa/planetlab
344 - plxrn moved in sfa/planetlab as well
345 - bugfix for sfaadmin reg update --pi <>
346
347 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
348 - native data model now has a authority x user (PI) relationship
349 - no call to 'augment_records_with_testbed_info' for GetCredential
350 - which means, registry can now be used without an underlying testbed
351 - reviewed code about relationships b/w objects and related in pl driver
352 - reviewed PL import wrt roles and pis
353 - removed mentions to is_enabled in driver
354 - small changes in update_relation* in driver interface
355 - sfaadmin: can create authorities and attach pi users to them
356 - sfaadmin: categories can be abbreviated
357 - sfi list and sfaadmin list have a new -r/--recursive option
358 - this means that List now supports an (optional) 'options' argument
359 - sfi config can display config vars
360 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
361
362 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
363 - make sync now supports vserver or lxc.
364 - Added slice expiration and login info to SliverStatus response. 
365 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
366   the 'component_name' attribute.
367 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
368   
369 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
370 - Introduced new administrative command line script, sfaadmin.py. Removed various single
371  purpose scripts and migrated their functionality into sfaadmin.py.
372 - Refactored Registry import scripts.
373 - Removed SQLAlchemy dependency from sfi.py.
374 - Fixed bugs in sfi.py
375 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
376
377 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
378 - slice x researcher rel. in database,
379 - plimporter to maintain that, as well as user.email, and more robust
380 - ongoing draft for sfaadmin tool
381 - support for a federica driver
382 - support for a nova/euca driver
383 - no more sfa-clean-peer-records script
384
385 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
386 - registry database has user's keys and mail (known as v0 for migrate)
387 - pl importer properly maintains user's keys and mail
388 - pl driver now to handle 'role' when adding person record (exp.)
389 - first draft of federica driver with config section
390 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
391 - plus, from master as of tag merged-in-sfa-2.1-2:
392 - disk_image revisited
393 - new nova_shell nova_driver & various tweaks for openstack
394
395 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
396 - uses sqlalchemy and related migrate
397 - thorough migration and upgrade scheme
398 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
399 - trashed dbinfo stuff in auth hierarchy
400 - data model still has little more than plain records
401 - checkpoint tag, not yet intended for release
402
403 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
404 - client: added -R --raw sfi cmdline option that displays raw server response.
405 - client: request GENI RSpec by default. 
406 - server: remove database dependencies from sfa.server.sfaapi.
407 - server: increased default credential lifetime to 31 days.
408 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
409 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
410 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
411  
412 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
413 - bugfix: 'geni_api' should be in the top level struct, not the code struct
414 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
415           output returned by the Aggregate Manager.
416 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
417 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
418 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
419           there is extra whitespace in the schemaLocation field.
420 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
421           advertisement rspecs.
422 - bugfix: <login> RSpec element should contain the 'username' attribute.
423 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
424  
425 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
426 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
427   exit when it encountered a user with an invalid public key.
428 - server: imporved logging in sfa-import-plc.py
429  
430 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
431 - bugfix: Fixed appending public keys in CreateSliver
432 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
433 - client: -c --current option allows users to request the current/uncached rspec.
434 - server: Added 'geni_api_versions' field to GetVersion() output.
435 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
436    
437 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
438 - bugfix: sfi was not sending call_id with ListResources to v2 servers
439 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
440 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
441
442 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
443 - client: sfi -a / -p deprecated (use -s instead)
444 - client: sfi cleaned up
445 - client: sfi has backward support for APIv1 aggregates again
446 - server: only APIv2 is supported and should be rather strict
447 - server: settings for turning on/off caching in sm or am
448 - server: plc-dependant code has moved from aggregate to pldriver
449 - server: driver interface extended accordingly
450
451 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
452 - screwed up previous tag
453
454 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
455 - client side revisited with a bootstrap library
456 - client side has a new source layout
457 - various (nasty) bug fixes wrt options and call_id
458
459 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
460 - various fixes in rspecs for sfav1&slice tags
461 - uses 'geni_rspec_version' and not just 'rspec_version'
462 - example flavour for the max testbed
463 - embryo for an sfa client library
464 - topology.py moved into plc
465 - sql: table is named records; record_types are enforced
466 - sql: table creation cleaned up
467
468 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
469 - cleaned up all references to SFA_*_TYPE in config
470 - enable cache at the aggregate by default
471 - registry now uses the driver in a sensible way (see managers/driver.py)
472 - slice manager supports sfav1/pgv2 neighbours
473 - get_key renamed into get_key_from_incoming_ip
474 - new sfa.storage module for record/table and all db-related stuff
475 - db schema in sfa.storage.sfa.sql
476 - init.d and cron.d move one step up
477 - cleaned up rspec/ directory
478 - add deps to pyopenssl and myplc-config
479 - start support for new API (return value)
480 - plc.remoteshell removed, use plshell instead
481 - plshell uses a 'capability' auth method whenever possible
482 - various tweaks in rspec elements
483 - made dependency on sfatables softer
484
485 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
486 - sfa should now be started *before* the initial import
487 - sfa to use its own database (default sfa) - can run without myplc
488 - server calls support optional 'options'
489 - client sends options in argument when needed
490 - fix infinite getattr recursion in elements/element.py
491 - error codes in line with geni
492
493 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
494 - fixed links and attributes in rspecs
495 - minor cleanup in the API methods, and more consistent names in manager methods
496
497 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
498 - ongoing refoactoring towards more genericity
499 - passes tests again although known issues remain with attributes/tags
500
501 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
502 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
503 - improvements in the pgv2 rspecs
504 - driver separated from api
505 - code starts moving around where it belongs
506 - sfascan caches getversion across invokations
507 - vini topology extracted as a config file
508
509 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
510 - first support for protogeni rspecs is working
511 - vini no longer needs a specific manager
512 - refactoring underway towards more flexible/generic architecture
513
514 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
515 - Unicode-friendliness for user names with accents/special chars.
516 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
517 - CreaetSliver no longer fails for users that have a capital letter in their URN.
518 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
519 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
520 - Fix bugs and missing imports     
521  
522
523 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
524 - new method record.get_field for sface
525
526 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
527 - new option -c to sfa-nuke-plc.py
528 - CreateSliver fixed for admin-only slice tags
529
530 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
531 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
532 - Fixed holes in certificate verification logic.
533 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
534 - Added 'boot_state' as an attribute of the node element in SFA rspec.
535 - Non authority certificates are marked as CA:FALSE.
536
537 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
538 - fix typo in sfa-1.0-31 tag.
539 - added CreateGid() Registry interface method.
540
541 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
542 - fix typo in sfa-1.0-30 tag
543
544 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
545 - Declare namespace and schema location in the credential.
546 - Fix bug that prevetend connections from timing out.
547 - Fix slice delegation.
548 - Add statistics to slicemaanger listresources/createsliver rspec.
549 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
550   of days a user can extend their slice expiration.
551 - CA certs are only issued to objects of type authority
552    
553 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
554 - tag 1.0-28 was broken due to typo in the changelog
555 - new class sfa/util/httpsProtocol.py that supports timeouts
556
557 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
558 - Resolved issue that caused sfa hold onto idle db connections.
559 - Fix bug that caused the registry to use the wrong type of credential.
560 - Support authority+sm type.
561 - Fix rspec merging bugs.
562 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
563 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
564  planetlab hosted initscripts using the <planetlab:initscript> tag  
565 - Can now handle extraneous whitespace in the rspec without failing.   
566  
567 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
568 - ProtoGENI v2 RSpec updates.
569 - Convert expiration timestamps with timezone info in credentials to utc.
570 - Fixed redundant logging issue. 
571 - Improved SliceManager and SFI client logging.
572 - Support aggregates that don't support the optional 'call_id' argument. 
573 - Only call get_trusted_certs() at aggreage interfaces that support the call.
574 - CreateSliver() now handles MyPLC slice attributes/tags.
575 - Cache now supports persistence.
576 - Hide whitelisted nodes.
577
578 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
579 - fixed issues with sup authority signing
580 - fixed bugs in remove_slivers and SliverStatus
581
582 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
583 - fix typo that prevented aggregates from operating properly
584
585 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
586 - load trusted certs into ssl context prior to handshake
587 - client's logfile lives in ~/.sfi/sfi.log
588
589 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
590 - includes a change on passphrases that was intended in 1.0-22
591
592 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
593 - Added support for ProtoGENI RSpec v2
594  
595 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
596 - stable sfascan
597 - fix in initscript, *ENABLED tags in config now taken into account
598
599 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
600 - some commits had not been pushed in tag 19
601
602 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
603 - GetVersion should now report full URLs with path
604 - scansfa has nicer output and new syntax (entry URLs as args and not options)
605 - dos2unix'ed flash policy pill
606
607 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
608 - fix packaging again for f8
609
610 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
611 - fix packaging (apparently broken in 1.0-16)
612 - first working version of sfascan
613 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
614 - deprecated the sfa_geni_aggregate config category
615
616 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
617 - Fix build problem
618 - First version of SFA scanner
619
620 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
621 - Add support for Flash clients using flashpolicy
622 - Fix problems with tag handling in RSpec
623
624 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
625 - Modifications to the Eucalyptus Aggregate Manager
626 - Fixes for VINI RSpec
627 - Fix tag handling for PL RSpec
628 - Fix XML Schema ordering for <urn> element
629
630 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
631 - just set x509 version to 2
632
633 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
634 - added urn to the node area in rspecs
635 - conversion to urn now exports fqdn
636 - sfa-import-plc.py now creates a unique registry record for each SFA interface
637
638 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
639 - undo broken attempt for python-2.7
640
641 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
642 - SMs avoid duplicates for when call graph has dags;
643 - just based on network's name, when a duplicate occurs, one is just dropped
644 - does not try to merge/aggregate 2 networks
645 - also reviewed logging with the hope to fix the sfa startup msg:
646 - TypeError: not all arguments converted during string formatting
647
648 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
649 - verify credentials against xsd schema
650 - Fix SM to SM communication
651 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
652 - new setting session_key_path
653
654 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
655 - fix registry credential regeneration and handle expiration
656 - support for setting slice tags (min_role=user)
657 - client can display its own version: sfi.py version --local
658 - GetVersion to provide urn in addition to hrn
659 - more code uses plxrn vs previous helper functions
660 - import replaces '+' in email addresses with '_'
661
662 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
663 - fix GetVersion code_tag and add code_url
664
665 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
666 - extend GetVersion towards minimum federation introspection, and expose local tag
667
668 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
669 - fixed some legacy issues (list vs List)
670 - deprecated sfa.util.namespace for xrn and plxrn
671 - unit tests ship as the sfa-tests rpm
672
673 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
674 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
675 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
676 - hrn-urn translations tweaked
677 - fixed 'service sfa status'
678 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
679 - started to repair sfadump - although not usable yet
680 - trust objects now have dump_string method that dump() actually prints
681 - unit tests under review
682 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
683 - binaries now support -v or -vv to increase loglevel
684 - trashed obsolete sfa.util.client
685
686 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
687 - various bugfixes and cleanup, improved/harmonized logging
688
689 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
690 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
691   to avoid returning a PLCAPI exception that might confuse users.
692 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
693 - fix build errors.  
694
695 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
696 - (Architecture) Credential format changed to match ProtoGENI xml format
697 - (Architecture) All interfaces export a new set of methods that are compatible
698    with the ProtoGeni Aggregate spec. These new methods are considered a 
699    replacement  for the pervious methods exported by the interfaces. All 
700    previous methods are still exported and work as normal, but they are 
701    considered deprecated and will not be supported in future releases.  
702 - (Architecture) SFI has been updated to use the new interface methods.
703 - (Architecture) Changed keyconvet implementation from c to python.
704 - (Architecture) Slice Manager now attempts looks for a delegated credential
705   provided by the client before using its own server credential.
706 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
707   This cache now exists only in memory and is cleared when service is restarted
708   or cache lifetime is exceeded.  
709 - (Performance) SliceManager sends request to Aggregates in parallel instead 
710   of sequentially.
711 - (Bug fix) SFA tickets now support the new rspec format.
712 - (Bug fix) SFI only uses cahced credential if they aren't expired.
713 - (Bug fix) Cerdential delegation modified to work with new credential format.
714 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
715   Aggregate instead of relaying through the Slice Manager.
716 - (Enhancement) Simplified caching. Accociated a global cache instance with
717   the api handler on every new server request, making it easier to access the 
718   cache and use in more general ways.     
719
720 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
721 - SfaServer now uses a pool of threads to handle requests concurrently
722 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
723 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
724 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
725 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
726 - Component manager does not install gid files if slice already has them  
727 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
728 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
729 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
730      
731 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
732 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
733 - - sfa-config-tty now has the same features like plc-config-tty
734 - - Contains code to support both urn and hrn
735 - - Cleaned up request_hash related stuff
736 - - SM, AM and Registry code is organized under respective managers
737 - - Site and Slice synchronization across federated aggregates
738 - - Script to generate sfa_component_config
739
740 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
741 - sfa-config-tty now has the same features like plc-config-tty
742 - Contains code to support both urn and hrn
743 - Cleaned up request_hash related stuff
744 - SM, AM and Registry code is organized under respective managers
745 - Slice synchronization across federated aggregates
746 - some bugs are fixed
747
748 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
749 - checkpoint with fewer mentions of geni
750
751 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
752 - checkpointing
753 - this is believed to pass the tests; among other things:
754 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
755
756 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
757 - This tag includes:
758 - - Sfatables
759 - - Preliminary version of hash based authentication
760 - - Initial code for Component Manager
761 - - Authority structure is moved to /var/lib/sfa/
762 - - some bug-fixes
763
764 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
765 - Create_slice and get_resources methods are connected to sfatables.
766 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
767
768 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
769 - Bug fix on update and remove_peer_object methods
770 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
771
772 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
773 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
774
775 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
776 - compatibility with RefreshPeer
777 - incremental mechanism for importing PLC records into SFA tables
778 - unified single database (still inside the underlying PLC db postgresql server)
779 - includes/improves call traceability and logging features
780 - several bug fixes
781
782 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
783 - added libxslt-python dependency
784
785 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
786 - unified single SFA database in the PLC-DB
787 - upcalls from  PLCAPI to SFA methods
788 - SFA call traceability and logging features
789 - many bug fixes
790 - includes first/rough version of sfatables for policy implementation
791
792 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
793 - snapshot after the GEC5 demo
794 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
795
796 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
797 - snapshot july 15 - has gone through superficial manual testing
798 - hopefully a good basis for gec5 demo
799 - multi-dir sfi client tested as well
800
801 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
802 - rename geniwrapper.spec into sfa.spec
803
804 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
805 - clean up in xmlrpc/soap, --protocol option to chose between both
806 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
807 - hopefully more helpful context in case of crashes when importing
808 - bugfixes for using only /etc/sfa for site-dep files
809 - bugfixes in wsdl generation
810
811 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
812 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
813 - config variables in sfa_config now start with SFA_ and not GENI_
814 - config.py can be loaded even with no config present
815
816 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
817 - first step for cleanup and reorganization
818 - mass-renaming from geni to sfa (some are still needed)
819 - sfa/trust implements the security architecture
820
821 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
822 - snapshot for reproducible builds
823
824 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
825 - snapshot for the convenience of alpha users
826
827 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
828 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
829
830 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
831 - ongoing work - snapshot for 4.3-rc9
832
833 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
834 - various fixes
835
836 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
837 - bugfixes - still a work in progress
838
839 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
840 - initial package
841
842
843 %define module_current_branch 0.2