Setting tag sfa-2.1-7
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 7
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/sfaadmin.py*
152 %{_bindir}/sfaadmin
153 %{_bindir}/keyconvert.py*
154 %{_bindir}/sfa-config-tty
155 %config /etc/sfa/default_config.xml
156 %config (noreplace) /etc/sfa/aggregates.xml
157 %config (noreplace) /etc/sfa/registries.xml
158 /usr/share/sfa/migrations
159 /usr/share/sfa/examples
160 /var/www/html/wsdl/*.wsdl
161
162 %files plc
163 %defattr(-,root,root)
164 /etc/sfa/pl.rng
165 /etc/sfa/credential.xsd
166 /etc/sfa/top.xsd
167 /etc/sfa/sig.xsd
168 /etc/sfa/xml.xsd
169 /etc/sfa/protogeni-rspec-common.xsd
170 /etc/sfa/topology
171 %{_bindir}/gen-sfa-cm-config.py*
172
173 %files client
174 %config (noreplace) /etc/sfa/sfi_config
175 %{_bindir}/sfi*.py*
176 %{_bindir}/sfi
177 %{_bindir}/get*.py*
178 %{_bindir}/setRecord.py*
179 %{_bindir}/sfascan.py*
180 %{_bindir}/sfascan
181 %{_bindir}/sfadump.py*
182
183 %files sfatables
184 /etc/sfatables/*
185 %{_bindir}/sfatables
186 %{python_sitelib}/sfatables
187
188 %files cm
189 /etc/init.d/sfa-cm
190 %{_bindir}/sfa_component_setup.py*
191 # cron jobs here 
192
193 %files flashpolicy
194 %{_bindir}/sfa_flashpolicy.py*
195 /etc/sfa/sfa_flashpolicy_config.xml
196
197 %files xmlbuilder
198 %{python_sitelib}/xmlbuilder
199
200 %files tests
201 %{_datadir}/sfa/tests
202
203 ### sfa installs the 'sfa' service
204 %post 
205 chkconfig --add sfa
206
207 %preun 
208 if [ "$1" = 0 ] ; then
209   /sbin/service sfa stop || :
210   /sbin/chkconfig --del sfa || :
211 fi
212
213 %postun
214 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
215
216 ### sfa-cm installs the 'sfa-cm' service
217 %post cm
218 chkconfig --add sfa-cm
219
220 %preun cm
221 if [ "$1" = 0 ] ; then
222    /sbin/service sfa-cm stop || :
223    /sbin/chkconfig --del sfa-cm || :
224 fi
225
226 %postun cm
227 [ "$1" -ge "1" ] && service sfa-cm restart || :
228
229 %changelog
230 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
231 - renamed sfa/plc into sfa/planetlab
232 - plxrn moved in sfa/planetlab as well
233 - bugfix for sfaadmin reg update --pi <>
234
235 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
236 - native data model now has a authority x user (PI) relationship
237 - no call to 'augment_records_with_testbed_info' for GetCredential
238 - which means, registry can now be used without an underlying testbed
239 - reviewed code about relationships b/w objects and related in pl driver
240 - reviewed PL import wrt roles and pis
241 - removed mentions to is_enabled in driver
242 - small changes in update_relation* in driver interface
243 - sfaadmin: can create authorities and attach pi users to them
244 - sfaadmin: categories can be abbreviated
245 - sfi list and sfaadmin list have a new -r/--recursive option
246 - this means that List now supports an (optional) 'options' argument
247 - sfi config can display config vars
248 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
249
250 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
251 - make sync now supports vserver or lxc.
252 - Added slice expiration and login info to SliverStatus response. 
253 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
254   the 'component_name' attribute.
255 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
256   
257 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
258 - Introduced new administrative command line script, sfaadmin.py. Removed various single
259  purpose scripts and migrated their functionality into sfaadmin.py.
260 - Refactored Registry import scripts.
261 - Removed SQLAlchemy dependency from sfi.py.
262 - Fixed bugs in sfi.py
263 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
264
265 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
266 - slice x researcher rel. in database,
267 - plimporter to maintain that, as well as user.email, and more robust
268 - ongoing draft for sfaadmin tool
269 - support for a federica driver
270 - support for a nova/euca driver
271 - no more sfa-clean-peer-records script
272
273 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
274 - registry database has user's keys and mail (known as v0 for migrate)
275 - pl importer properly maintains user's keys and mail
276 - pl driver now to handle 'role' when adding person record (exp.)
277 - first draft of federica driver with config section
278 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
279 - plus, from master as of tag merged-in-sfa-2.1-2:
280 - disk_image revisited
281 - new nova_shell nova_driver & various tweaks for openstack
282
283 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
284 - uses sqlalchemy and related migrate
285 - thorough migration and upgrade scheme
286 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
287 - trashed dbinfo stuff in auth hierarchy
288 - data model still has little more than plain records
289 - checkpoint tag, not yet intended for release
290
291 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
292 - client: added -R --raw sfi cmdline option that displays raw server response.
293 - client: request GENI RSpec by default. 
294 - server: remove database dependencies from sfa.server.sfaapi.
295 - server: increased default credential lifetime to 31 days.
296 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
297 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
298 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
299  
300 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
301 - bugfix: 'geni_api' should be in the top level struct, not the code struct
302 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
303           output returned by the Aggregate Manager.
304 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
305 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
306 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
307           there is extra whitespace in the schemaLocation field.
308 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
309           advertisement rspecs.
310 - bugfix: <login> RSpec element should contain the 'username' attribute.
311 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
312  
313 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
314 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
315   exit when it encountered a user with an invalid public key.
316 - server: imporved logging in sfa-import-plc.py
317  
318 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
319 - bugfix: Fixed appending public keys in CreateSliver
320 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
321 - client: -c --current option allows users to request the current/uncached rspec.
322 - server: Added 'geni_api_versions' field to GetVersion() output.
323 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
324    
325 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
326 - bugfix: sfi was not sending call_id with ListResources to v2 servers
327 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
328 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
329
330 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
331 - client: sfi -a / -p deprecated (use -s instead)
332 - client: sfi cleaned up
333 - client: sfi has backward support for APIv1 aggregates again
334 - server: only APIv2 is supported and should be rather strict
335 - server: settings for turning on/off caching in sm or am
336 - server: plc-dependant code has moved from aggregate to pldriver
337 - server: driver interface extended accordingly
338
339 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
340 - screwed up previous tag
341
342 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
343 - client side revisited with a bootstrap library
344 - client side has a new source layout
345 - various (nasty) bug fixes wrt options and call_id
346
347 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
348 - various fixes in rspecs for sfav1&slice tags
349 - uses 'geni_rspec_version' and not just 'rspec_version'
350 - example flavour for the max testbed
351 - embryo for an sfa client library
352 - topology.py moved into plc
353 - sql: table is named records; record_types are enforced
354 - sql: table creation cleaned up
355
356 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
357 - cleaned up all references to SFA_*_TYPE in config
358 - enable cache at the aggregate by default
359 - registry now uses the driver in a sensible way (see managers/driver.py)
360 - slice manager supports sfav1/pgv2 neighbours
361 - get_key renamed into get_key_from_incoming_ip
362 - new sfa.storage module for record/table and all db-related stuff
363 - db schema in sfa.storage.sfa.sql
364 - init.d and cron.d move one step up
365 - cleaned up rspec/ directory
366 - add deps to pyopenssl and myplc-config
367 - start support for new API (return value)
368 - plc.remoteshell removed, use plshell instead
369 - plshell uses a 'capability' auth method whenever possible
370 - various tweaks in rspec elements
371 - made dependency on sfatables softer
372
373 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
374 - sfa should now be started *before* the initial import
375 - sfa to use its own database (default sfa) - can run without myplc
376 - server calls support optional 'options'
377 - client sends options in argument when needed
378 - fix infinite getattr recursion in elements/element.py
379 - error codes in line with geni
380
381 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
382 - fixed links and attributes in rspecs
383 - minor cleanup in the API methods, and more consistent names in manager methods
384
385 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
386 - ongoing refoactoring towards more genericity
387 - passes tests again although known issues remain with attributes/tags
388
389 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
390 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
391 - improvements in the pgv2 rspecs
392 - driver separated from api
393 - code starts moving around where it belongs
394 - sfascan caches getversion across invokations
395 - vini topology extracted as a config file
396
397 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
398 - first support for protogeni rspecs is working
399 - vini no longer needs a specific manager
400 - refactoring underway towards more flexible/generic architecture
401
402 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
403 - Unicode-friendliness for user names with accents/special chars.
404 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
405 - CreaetSliver no longer fails for users that have a capital letter in their URN.
406 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
407 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
408 - Fix bugs and missing imports     
409  
410
411 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
412 - new method record.get_field for sface
413
414 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
415 - new option -c to sfa-nuke-plc.py
416 - CreateSliver fixed for admin-only slice tags
417
418 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
419 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
420 - Fixed holes in certificate verification logic.
421 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
422 - Added 'boot_state' as an attribute of the node element in SFA rspec.
423 - Non authority certificates are marked as CA:FALSE.
424
425 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
426 - fix typo in sfa-1.0-31 tag.
427 - added CreateGid() Registry interface method.
428
429 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
430 - fix typo in sfa-1.0-30 tag
431
432 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
433 - Declare namespace and schema location in the credential.
434 - Fix bug that prevetend connections from timing out.
435 - Fix slice delegation.
436 - Add statistics to slicemaanger listresources/createsliver rspec.
437 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
438   of days a user can extend their slice expiration.
439 - CA certs are only issued to objects of type authority
440    
441 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
442 - tag 1.0-28 was broken due to typo in the changelog
443 - new class sfa/util/httpsProtocol.py that supports timeouts
444
445 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
446 - Resolved issue that caused sfa hold onto idle db connections.
447 - Fix bug that caused the registry to use the wrong type of credential.
448 - Support authority+sm type.
449 - Fix rspec merging bugs.
450 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
451 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
452  planetlab hosted initscripts using the <planetlab:initscript> tag  
453 - Can now handle extraneous whitespace in the rspec without failing.   
454  
455 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
456 - ProtoGENI v2 RSpec updates.
457 - Convert expiration timestamps with timezone info in credentials to utc.
458 - Fixed redundant logging issue. 
459 - Improved SliceManager and SFI client logging.
460 - Support aggregates that don't support the optional 'call_id' argument. 
461 - Only call get_trusted_certs() at aggreage interfaces that support the call.
462 - CreateSliver() now handles MyPLC slice attributes/tags.
463 - Cache now supports persistence.
464 - Hide whitelisted nodes.
465
466 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
467 - fixed issues with sup authority signing
468 - fixed bugs in remove_slivers and SliverStatus
469
470 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
471 - fix typo that prevented aggregates from operating properly
472
473 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
474 - load trusted certs into ssl context prior to handshake
475 - client's logfile lives in ~/.sfi/sfi.log
476
477 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
478 - includes a change on passphrases that was intended in 1.0-22
479
480 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
481 - Added support for ProtoGENI RSpec v2
482  
483 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
484 - stable sfascan
485 - fix in initscript, *ENABLED tags in config now taken into account
486
487 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
488 - some commits had not been pushed in tag 19
489
490 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
491 - GetVersion should now report full URLs with path
492 - scansfa has nicer output and new syntax (entry URLs as args and not options)
493 - dos2unix'ed flash policy pill
494
495 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
496 - fix packaging again for f8
497
498 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
499 - fix packaging (apparently broken in 1.0-16)
500 - first working version of sfascan
501 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
502 - deprecated the sfa_geni_aggregate config category
503
504 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
505 - Fix build problem
506 - First version of SFA scanner
507
508 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
509 - Add support for Flash clients using flashpolicy
510 - Fix problems with tag handling in RSpec
511
512 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
513 - Modifications to the Eucalyptus Aggregate Manager
514 - Fixes for VINI RSpec
515 - Fix tag handling for PL RSpec
516 - Fix XML Schema ordering for <urn> element
517
518 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
519 - just set x509 version to 2
520
521 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
522 - added urn to the node area in rspecs
523 - conversion to urn now exports fqdn
524 - sfa-import-plc.py now creates a unique registry record for each SFA interface
525
526 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
527 - undo broken attempt for python-2.7
528
529 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
530 - SMs avoid duplicates for when call graph has dags;
531 - just based on network's name, when a duplicate occurs, one is just dropped
532 - does not try to merge/aggregate 2 networks
533 - also reviewed logging with the hope to fix the sfa startup msg:
534 - TypeError: not all arguments converted during string formatting
535
536 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
537 - verify credentials against xsd schema
538 - Fix SM to SM communication
539 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
540 - new setting session_key_path
541
542 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
543 - fix registry credential regeneration and handle expiration
544 - support for setting slice tags (min_role=user)
545 - client can display its own version: sfi.py version --local
546 - GetVersion to provide urn in addition to hrn
547 - more code uses plxrn vs previous helper functions
548 - import replaces '+' in email addresses with '_'
549
550 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
551 - fix GetVersion code_tag and add code_url
552
553 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
554 - extend GetVersion towards minimum federation introspection, and expose local tag
555
556 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
557 - fixed some legacy issues (list vs List)
558 - deprecated sfa.util.namespace for xrn and plxrn
559 - unit tests ship as the sfa-tests rpm
560
561 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
562 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
563 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
564 - hrn-urn translations tweaked
565 - fixed 'service sfa status'
566 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
567 - started to repair sfadump - although not usable yet
568 - trust objects now have dump_string method that dump() actually prints
569 - unit tests under review
570 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
571 - binaries now support -v or -vv to increase loglevel
572 - trashed obsolete sfa.util.client
573
574 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
575 - various bugfixes and cleanup, improved/harmonized logging
576
577 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
578 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
579   to avoid returning a PLCAPI exception that might confuse users.
580 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
581 - fix build errors.  
582
583 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
584 - (Architecture) Credential format changed to match ProtoGENI xml format
585 - (Architecture) All interfaces export a new set of methods that are compatible
586    with the ProtoGeni Aggregate spec. These new methods are considered a 
587    replacement  for the pervious methods exported by the interfaces. All 
588    previous methods are still exported and work as normal, but they are 
589    considered deprecated and will not be supported in future releases.  
590 - (Architecture) SFI has been updated to use the new interface methods.
591 - (Architecture) Changed keyconvet implementation from c to python.
592 - (Architecture) Slice Manager now attempts looks for a delegated credential
593   provided by the client before using its own server credential.
594 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
595   This cache now exists only in memory and is cleared when service is restarted
596   or cache lifetime is exceeded.  
597 - (Performance) SliceManager sends request to Aggregates in parallel instead 
598   of sequentially.
599 - (Bug fix) SFA tickets now support the new rspec format.
600 - (Bug fix) SFI only uses cahced credential if they aren't expired.
601 - (Bug fix) Cerdential delegation modified to work with new credential format.
602 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
603   Aggregate instead of relaying through the Slice Manager.
604 - (Enhancement) Simplified caching. Accociated a global cache instance with
605   the api handler on every new server request, making it easier to access the 
606   cache and use in more general ways.     
607
608 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
609 - SfaServer now uses a pool of threads to handle requests concurrently
610 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
611 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
612 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
613 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
614 - Component manager does not install gid files if slice already has them  
615 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
616 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
617 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
618      
619 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
620 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
621 - - sfa-config-tty now has the same features like plc-config-tty
622 - - Contains code to support both urn and hrn
623 - - Cleaned up request_hash related stuff
624 - - SM, AM and Registry code is organized under respective managers
625 - - Site and Slice synchronization across federated aggregates
626 - - Script to generate sfa_component_config
627
628 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
629 - sfa-config-tty now has the same features like plc-config-tty
630 - Contains code to support both urn and hrn
631 - Cleaned up request_hash related stuff
632 - SM, AM and Registry code is organized under respective managers
633 - Slice synchronization across federated aggregates
634 - some bugs are fixed
635
636 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
637 - checkpoint with fewer mentions of geni
638
639 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
640 - checkpointing
641 - this is believed to pass the tests; among other things:
642 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
643
644 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
645 - This tag includes:
646 - - Sfatables
647 - - Preliminary version of hash based authentication
648 - - Initial code for Component Manager
649 - - Authority structure is moved to /var/lib/sfa/
650 - - some bug-fixes
651
652 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
653 - Create_slice and get_resources methods are connected to sfatables.
654 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
655
656 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
657 - Bug fix on update and remove_peer_object methods
658 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
659
660 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
661 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
662
663 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
664 - compatibility with RefreshPeer
665 - incremental mechanism for importing PLC records into SFA tables
666 - unified single database (still inside the underlying PLC db postgresql server)
667 - includes/improves call traceability and logging features
668 - several bug fixes
669
670 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
671 - added libxslt-python dependency
672
673 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
674 - unified single SFA database in the PLC-DB
675 - upcalls from  PLCAPI to SFA methods
676 - SFA call traceability and logging features
677 - many bug fixes
678 - includes first/rough version of sfatables for policy implementation
679
680 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
681 - snapshot after the GEC5 demo
682 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
683
684 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
685 - snapshot july 15 - has gone through superficial manual testing
686 - hopefully a good basis for gec5 demo
687 - multi-dir sfi client tested as well
688
689 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
690 - rename geniwrapper.spec into sfa.spec
691
692 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
693 - clean up in xmlrpc/soap, --protocol option to chose between both
694 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
695 - hopefully more helpful context in case of crashes when importing
696 - bugfixes for using only /etc/sfa for site-dep files
697 - bugfixes in wsdl generation
698
699 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
700 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
701 - config variables in sfa_config now start with SFA_ and not GENI_
702 - config.py can be loaded even with no config present
703
704 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
705 - first step for cleanup and reorganization
706 - mass-renaming from geni to sfa (some are still needed)
707 - sfa/trust implements the security architecture
708
709 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
710 - snapshot for reproducible builds
711
712 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
713 - snapshot for the convenience of alpha users
714
715 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
716 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
717
718 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
719 - ongoing work - snapshot for 4.3-rc9
720
721 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
722 - various fixes
723
724 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
725 - bugfixes - still a work in progress
726
727 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
728 - initial package
729
730
731 %define module_current_branch 0.2