oops
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45  
46 # python 2.5 has uuid module added, for python 2.4 we still need it.
47 # we can't really check for if we can load uuid as a python module,
48 # it'll be installed by "devel.pkgs". we have the epel repository so
49 # python-uuid will be provided. but we can test for the python
50 # version.
51 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
52 # %if %has_py24
53 #
54 # this also didn't work very well. I'll just check for distroname - baris
55 #%if %{distroname} == "centos5"
56 #Requires: python-uuid
57 #%endif
58
59 %package plc
60 Summary: the SFA layer around MyPLC
61 Group: Applications/System
62 Requires: sfa
63 Requires: python-psycopg2
64
65 %package client
66 Summary: the SFA experimenter-side CLI
67 Group: Applications/System
68 Requires: sfa
69 Requires: pyOpenSSL >= 0.7
70
71 %package sfatables
72 Summary: sfatables policy tool for SFA
73 Group: Applications/System
74 Requires: sfa
75
76 %package cm
77 Summary: the SFA layer around MyPLC NodeManager
78 Group: Applications/System
79 Requires: sfa
80 Requires: pyOpenSSL >= 0.6
81
82 %package flashpolicy
83 Summary: SFA support for flash clients
84 Group: Applications/System
85 Requires: sfa
86
87 %package tests
88 Summary: unit tests suite for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %description
93 This package provides the python libraries for the PlanetLab implementation of SFA
94
95 %description plc
96 This package implements the SFA interface which serves as a layer
97 between the existing PlanetLab interfaces and the SFA API.
98
99 %description client
100 This package provides the client side of the SFA API, in particular
101 sfi.py, together with other utilities.
102
103 %description sfatables
104 sfatables is a tool for defining access and admission control policies
105 in an SFA network, in much the same way as iptables is for ip
106 networks. This is the command line interface to manage sfatables
107
108 %description cm
109 This package implements the SFA interface which serves as a layer
110 between the existing PlanetLab NodeManager interfaces and the SFA API.
111  
112 %description flashpolicy
113 This package provides support for adobe flash client applications.  
114  
115 %description tests
116 Provides some binary unit tests in /usr/share/sfa/tests
117
118 %prep
119 %setup -q
120
121 %build
122 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
127 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/*egg-info
128 # this gets duplicated
129 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/sfa/storage/sfa.sql
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 # sfa and sfatables depend on each other.
136 %{python_sitelib}/sfa
137 %{python_sitelib}/xmlbuilder
138 /etc/init.d/sfa
139 %{_bindir}/sfa-start.py*
140 %{_bindir}/keyconvert.py*
141 %{_bindir}/sfa-config-tty
142 %config /etc/sfa/default_config.xml
143 %config (noreplace) /etc/sfa/aggregates.xml
144 %config (noreplace) /etc/sfa/registries.xml
145 /usr/share/sfa/sfa.sql
146 /var/www/html/wsdl/*.wsdl
147
148 %files plc
149 %defattr(-,root,root)
150 /etc/sfa/pl.rng
151 /etc/sfa/credential.xsd
152 /etc/sfa/top.xsd
153 /etc/sfa/sig.xsd
154 /etc/sfa/xml.xsd
155 /etc/sfa/protogeni-rspec-common.xsd
156 /etc/sfa/topology
157 %{_bindir}/sfa-import-plc.py*
158 %{_bindir}/sfa-nuke-plc.py*
159 %{_bindir}/sfa-clean-peer-records.py*
160 %{_bindir}/gen-sfa-cm-config.py*
161 %{_bindir}/sfa-ca.py*
162
163 %files client
164 %config (noreplace) /etc/sfa/sfi_config
165 %{_bindir}/sfi*
166 %{_bindir}/getNodes.py*
167 %{_bindir}/getRecord.py*
168 %{_bindir}/setRecord.py*
169 %{_bindir}/sfadump.py*
170
171 %files sfatables
172 /etc/sfatables/*
173 %{_bindir}/sfatables
174 %{python_sitelib}/sfatables
175
176 %files cm
177 /etc/init.d/sfa-cm
178 %{_bindir}/sfa_component_setup.py*
179 # cron jobs here 
180
181 %files flashpolicy
182 %{_bindir}/sfa_flashpolicy.py*
183 /etc/sfa/sfa_flashpolicy_config.xml
184
185 %files tests
186 %{_datadir}/sfa/tests
187
188 ### sfa-plc installs the 'sfa' service
189 %post plc
190 chkconfig --add sfa
191
192 %preun plc
193 if [ "$1" = 0 ] ; then
194   /sbin/service sfa stop || :
195   /sbin/chkconfig --del sfa || :
196 fi
197
198 %postun plc
199 [ "$1" -ge "1" ] && service sfa restart
200
201 ### sfa-cm installs the 'sfa-cm' service
202 %post cm
203 chkconfig --add sfa-cm
204
205 %preun cm
206 if [ "$1" = 0 ] ; then
207    /sbin/service sfa-cm stop || :
208    /sbin/chkconfig --del sfa-cm || :
209 fi
210
211 %postun cm
212 [ "$1" -ge "1" ] && service sfa-cm restart || :
213
214 %changelog
215 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
216 - sfa should now be started *before* the initial import
217 - sfa to use its own database (default sfa) - can run without myplc
218 - server calls support optional 'options'
219 - client sends options in argument when needed
220 - fix infinite getattr recursion in elements/element.py
221 - error codes in line with geni
222
223 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
224 - fixed links and attributes in rspecs
225 - minor cleanup in the API methods, and more consistent names in manager methods
226
227 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
228 - ongoing refoactoring towards more genericity
229 - passes tests again although known issues remain with attributes/tags
230
231 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
232 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
233 - improvements in the pgv2 rspecs
234 - driver separated from api
235 - code starts moving around where it belongs
236 - sfascan caches getversion across invokations
237 - vini topology extracted as a config file
238
239 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
240 - first support for protogeni rspecs is working
241 - vini no longer needs a specific manager
242 - refactoring underway towards more flexible/generic architecture
243
244 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
245 - Unicode-friendliness for user names with accents/special chars.
246 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
247 - CreaetSliver no longer fails for users that have a capital letter in their URN.
248 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
249 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
250 - Fix bugs and missing imports     
251  
252
253 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
254 - new method record.get_field for sface
255
256 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
257 - new option -c to sfa-nuke-plc.py
258 - CreateSliver fixed for admin-only slice tags
259
260 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
261 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
262 - Fixed holes in certificate verification logic.
263 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
264 - Added 'boot_state' as an attribute of the node element in SFA rspec.
265 - Non authority certificates are marked as CA:FALSE.
266
267 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
268 - fix typo in sfa-1.0-31 tag.
269 - added CreateGid() Registry interface method.
270
271 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
272 - fix typo in sfa-1.0-30 tag
273
274 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
275 - Declare namespace and schema location in the credential.
276 - Fix bug that prevetend connections from timing out.
277 - Fix slice delegation.
278 - Add statistics to slicemaanger listresources/createsliver rspec.
279 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
280   of days a user can extend their slice expiration.
281 - CA certs are only issued to objects of type authority
282    
283 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
284 - tag 1.0-28 was broken due to typo in the changelog
285 - new class sfa/util/httpsProtocol.py that supports timeouts
286
287 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
288 - Resolved issue that caused sfa hold onto idle db connections.
289 - Fix bug that caused the registry to use the wrong type of credential.
290 - Support authority+sm type.
291 - Fix rspec merging bugs.
292 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
293 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
294  planetlab hosted initscripts using the <planetlab:initscript> tag  
295 - Can now handle extraneous whitespace in the rspec without failing.   
296  
297 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
298 - ProtoGENI v2 RSpec updates.
299 - Convert expiration timestamps with timezone info in credentials to utc.
300 - Fixed redundant logging issue. 
301 - Improved SliceManager and SFI client logging.
302 - Support aggregates that don't support the optional 'call_id' argument. 
303 - Only call get_trusted_certs() at aggreage interfaces that support the call.
304 - CreateSliver() now handles MyPLC slice attributes/tags.
305 - Cache now supports persistence.
306 - Hide whitelisted nodes.
307
308 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
309 - fixed issues with sup authority signing
310 - fixed bugs in remove_slivers and SliverStatus
311
312 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
313 - fix typo that prevented aggregates from operating properly
314
315 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
316 - load trusted certs into ssl context prior to handshake
317 - client's logfile lives in ~/.sfi/sfi.log
318
319 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
320 - includes a change on passphrases that was intended in 1.0-22
321
322 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
323 - Added support for ProtoGENI RSpec v2
324  
325 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
326 - stable sfascan
327 - fix in initscript, *ENABLED tags in config now taken into account
328
329 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
330 - some commits had not been pushed in tag 19
331
332 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
333 - GetVersion should now report full URLs with path
334 - scansfa has nicer output and new syntax (entry URLs as args and not options)
335 - dos2unix'ed flash policy pill
336
337 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
338 - fix packaging again for f8
339
340 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
341 - fix packaging (apparently broken in 1.0-16)
342 - first working version of sfascan
343 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
344 - deprecated the sfa_geni_aggregate config category
345
346 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
347 - Fix build problem
348 - First version of SFA scanner
349
350 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
351 - Add support for Flash clients using flashpolicy
352 - Fix problems with tag handling in RSpec
353
354 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
355 - Modifications to the Eucalyptus Aggregate Manager
356 - Fixes for VINI RSpec
357 - Fix tag handling for PL RSpec
358 - Fix XML Schema ordering for <urn> element
359
360 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
361 - just set x509 version to 2
362
363 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
364 - added urn to the node area in rspecs
365 - conversion to urn now exports fqdn
366 - sfa-import-plc.py now creates a unique registry record for each SFA interface
367
368 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
369 - undo broken attempt for python-2.7
370
371 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
372 - SMs avoid duplicates for when call graph has dags;
373 - just based on network's name, when a duplicate occurs, one is just dropped
374 - does not try to merge/aggregate 2 networks
375 - also reviewed logging with the hope to fix the sfa startup msg:
376 - TypeError: not all arguments converted during string formatting
377
378 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
379 - verify credentials against xsd schema
380 - Fix SM to SM communication
381 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
382 - new setting session_key_path
383
384 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
385 - fix registry credential regeneration and handle expiration
386 - support for setting slice tags (min_role=user)
387 - client can display its own version: sfi.py version --local
388 - GetVersion to provide urn in addition to hrn
389 - more code uses plxrn vs previous helper functions
390 - import replaces '+' in email addresses with '_'
391
392 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
393 - fix GetVersion code_tag and add code_url
394
395 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
396 - extend GetVersion towards minimum federation introspection, and expose local tag
397
398 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
399 - fixed some legacy issues (list vs List)
400 - deprecated sfa.util.namespace for xrn and plxrn
401 - unit tests ship as the sfa-tests rpm
402
403 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
404 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
405 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
406 - hrn-urn translations tweaked
407 - fixed 'service sfa status'
408 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
409 - started to repair sfadump - although not usable yet
410 - trust objects now have dump_string method that dump() actually prints
411 - unit tests under review
412 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
413 - binaries now support -v or -vv to increase loglevel
414 - trashed obsolete sfa.util.client
415
416 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
417 - various bugfixes and cleanup, improved/harmonized logging
418
419 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
420 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
421   to avoid returning a PLCAPI exception that might confuse users.
422 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
423 - fix build errors.  
424
425 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
426 - (Architecture) Credential format changed to match ProtoGENI xml format
427 - (Architecture) All interfaces export a new set of methods that are compatible
428    with the ProtoGeni Aggregate spec. These new methods are considered a 
429    replacement  for the pervious methods exported by the interfaces. All 
430    previous methods are still exported and work as normal, but they are 
431    considered deprecated and will not be supported in future releases.  
432 - (Architecture) SFI has been updated to use the new interface methods.
433 - (Architecture) Changed keyconvet implementation from c to python.
434 - (Architecture) Slice Manager now attempts looks for a delegated credential
435   provided by the client before using its own server credential.
436 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
437   This cache now exists only in memory and is cleared when service is restarted
438   or cache lifetime is exceeded.  
439 - (Performance) SliceManager sends request to Aggregates in parallel instead 
440   of sequentially.
441 - (Bug fix) SFA tickets now support the new rspec format.
442 - (Bug fix) SFI only uses cahced credential if they aren't expired.
443 - (Bug fix) Cerdential delegation modified to work with new credential format.
444 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
445   Aggregate instead of relaying through the Slice Manager.
446 - (Enhancement) Simplified caching. Accociated a global cache instance with
447   the api handler on every new server request, making it easier to access the 
448   cache and use in more general ways.     
449
450 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
451 - SfaServer now uses a pool of threads to handle requests concurrently
452 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
453 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
454 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
455 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
456 - Component manager does not install gid files if slice already has them  
457 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
458 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
459 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
460      
461 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
462 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
463 - - sfa-config-tty now has the same features like plc-config-tty
464 - - Contains code to support both urn and hrn
465 - - Cleaned up request_hash related stuff
466 - - SM, AM and Registry code is organized under respective managers
467 - - Site and Slice synchronization across federated aggregates
468 - - Script to generate sfa_component_config
469
470 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
471 - sfa-config-tty now has the same features like plc-config-tty
472 - Contains code to support both urn and hrn
473 - Cleaned up request_hash related stuff
474 - SM, AM and Registry code is organized under respective managers
475 - Slice synchronization across federated aggregates
476 - some bugs are fixed
477
478 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
479 - checkpoint with fewer mentions of geni
480
481 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
482 - checkpointing
483 - this is believed to pass the tests; among other things:
484 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
485
486 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
487 - This tag includes:
488 - - Sfatables
489 - - Preliminary version of hash based authentication
490 - - Initial code for Component Manager
491 - - Authority structure is moved to /var/lib/sfa/
492 - - some bug-fixes
493
494 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
495 - Create_slice and get_resources methods are connected to sfatables.
496 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
497
498 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
499 - Bug fix on update and remove_peer_object methods
500 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
501
502 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
503 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
504
505 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
506 - compatibility with RefreshPeer
507 - incremental mechanism for importing PLC records into SFA tables
508 - unified single database (still inside the underlying PLC db postgresql server)
509 - includes/improves call traceability and logging features
510 - several bug fixes
511
512 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
513 - added libxslt-python dependency
514
515 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
516 - unified single SFA database in the PLC-DB
517 - upcalls from  PLCAPI to SFA methods
518 - SFA call traceability and logging features
519 - many bug fixes
520 - includes first/rough version of sfatables for policy implementation
521
522 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
523 - snapshot after the GEC5 demo
524 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
525
526 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
527 - snapshot july 15 - has gone through superficial manual testing
528 - hopefully a good basis for gec5 demo
529 - multi-dir sfi client tested as well
530
531 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
532 - rename geniwrapper.spec into sfa.spec
533
534 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
535 - clean up in xmlrpc/soap, --protocol option to chose between both
536 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
537 - hopefully more helpful context in case of crashes when importing
538 - bugfixes for using only /etc/sfa for site-dep files
539 - bugfixes in wsdl generation
540
541 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
542 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
543 - config variables in sfa_config now start with SFA_ and not GENI_
544 - config.py can be loaded even with no config present
545
546 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
547 - first step for cleanup and reorganization
548 - mass-renaming from geni to sfa (some are still needed)
549 - sfa/trust implements the security architecture
550
551 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
552 - snapshot for reproducible builds
553
554 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
555 - snapshot for the convenience of alpha users
556
557 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
558 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
559
560 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
561 - ongoing work - snapshot for 4.3-rc9
562
563 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
564 - various fixes
565
566 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
567 - bugfixes - still a work in progress
568
569 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
570 - initial package
571
572
573 %define module_current_branch 0.2