Merge branch 'sqlalchemy' of ssh://git.onelab.eu/git/sfa into sqlalchemy
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/keyconvert.py*
152 %{_bindir}/sfa-config-tty
153 %config /etc/sfa/default_config.xml
154 %config (noreplace) /etc/sfa/aggregates.xml
155 %config (noreplace) /etc/sfa/registries.xml
156 /usr/share/sfa/migrations
157 /usr/share/sfa/examples
158 /var/www/html/wsdl/*.wsdl
159
160 %files plc
161 %defattr(-,root,root)
162 /etc/sfa/pl.rng
163 /etc/sfa/credential.xsd
164 /etc/sfa/top.xsd
165 /etc/sfa/sig.xsd
166 /etc/sfa/xml.xsd
167 /etc/sfa/protogeni-rspec-common.xsd
168 /etc/sfa/topology
169 %{_bindir}/sfa-import.py*
170 %{_bindir}/sfa-nuke.py*
171 %{_bindir}/sfa-clean-peer-records.py*
172 %{_bindir}/gen-sfa-cm-config.py*
173 %{_bindir}/sfa-ca.py*
174
175 %files client
176 %config (noreplace) /etc/sfa/sfi_config
177 %{_bindir}/sfi*.py*
178 %{_bindir}/sfi
179 %{_bindir}/get*.py*
180 %{_bindir}/setRecord.py*
181 %{_bindir}/sfascan.py*
182 %{_bindir}/sfascan
183 %{_bindir}/sfadump.py*
184
185 %files sfatables
186 /etc/sfatables/*
187 %{_bindir}/sfatables
188 %{python_sitelib}/sfatables
189
190 %files cm
191 /etc/init.d/sfa-cm
192 %{_bindir}/sfa_component_setup.py*
193 # cron jobs here 
194
195 %files flashpolicy
196 %{_bindir}/sfa_flashpolicy.py*
197 /etc/sfa/sfa_flashpolicy_config.xml
198
199 %files xmlbuilder
200 %{python_sitelib}/xmlbuilder
201
202 %files tests
203 %{_datadir}/sfa/tests
204
205 ### sfa installs the 'sfa' service
206 %post 
207 chkconfig --add sfa
208
209 %preun 
210 if [ "$1" = 0 ] ; then
211   /sbin/service sfa stop || :
212   /sbin/chkconfig --del sfa || :
213 fi
214
215 %postun
216 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
217
218 ### sfa-cm installs the 'sfa-cm' service
219 %post cm
220 chkconfig --add sfa-cm
221
222 %preun cm
223 if [ "$1" = 0 ] ; then
224    /sbin/service sfa-cm stop || :
225    /sbin/chkconfig --del sfa-cm || :
226 fi
227
228 %postun cm
229 [ "$1" -ge "1" ] && service sfa-cm restart || :
230
231 %changelog
232 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
233 - registry database has user's keys and mail (known as v0 for migrate)
234 - pl importer properly maintains user's keys and mail
235 - pl driver now to handle 'role' when adding person record (exp.)
236 - first draft of federica driver with config section
237 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
238 - plus, from master as of tag merged-in-sfa-2.1-2:
239 - disk_image revisited
240 - new nova_shell nova_driver & various tweaks for openstack
241
242 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
243 - uses sqlalchemy and related migrate
244 - thorough migration and upgrade scheme
245 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
246 - trashed dbinfo stuff in auth hierarchy
247 - data model still has little more than plain records
248 - checkpoint tag, not yet intended for release
249
250 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
251 - client: added -R --raw sfi cmdline option that displays raw server response.
252 - client: request GENI RSpec by default. 
253 - server: remove database dependencies from sfa.server.sfaapi.
254 - server: increased default credential lifetime to 31 days.
255 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
256 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
257 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
258  
259 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
260 - bugfix: 'geni_api' should be in the top level struct, not the code struct
261 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
262           output returned by the Aggregate Manager.
263 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
264 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
265 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
266           there is extra whitespace in the schemaLocation field.
267 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
268           advertisement rspecs.
269 - bugfix: <login> RSpec element should contain the 'username' attribute.
270 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
271  
272 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
273 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
274   exit when it encountered a user with an invalid public key.
275 - server: imporved logging in sfa-import-plc.py
276  
277 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
278 - bugfix: Fixed appending public keys in CreateSliver
279 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
280 - client: -c --current option allows users to request the current/uncached rspec.
281 - server: Added 'geni_api_versions' field to GetVersion() output.
282 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
283    
284 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
285 - bugfix: sfi was not sending call_id with ListResources to v2 servers
286 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
287 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
288
289 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
290 - client: sfi -a / -p deprecated (use -s instead)
291 - client: sfi cleaned up
292 - client: sfi has backward support for APIv1 aggregates again
293 - server: only APIv2 is supported and should be rather strict
294 - server: settings for turning on/off caching in sm or am
295 - server: plc-dependant code has moved from aggregate to pldriver
296 - server: driver interface extended accordingly
297
298 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
299 - screwed up previous tag
300
301 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
302 - client side revisited with a bootstrap library
303 - client side has a new source layout
304 - various (nasty) bug fixes wrt options and call_id
305
306 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
307 - various fixes in rspecs for sfav1&slice tags
308 - uses 'geni_rspec_version' and not just 'rspec_version'
309 - example flavour for the max testbed
310 - embryo for an sfa client library
311 - topology.py moved into plc
312 - sql: table is named records; record_types are enforced
313 - sql: table creation cleaned up
314
315 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
316 - cleaned up all references to SFA_*_TYPE in config
317 - enable cache at the aggregate by default
318 - registry now uses the driver in a sensible way (see managers/driver.py)
319 - slice manager supports sfav1/pgv2 neighbours
320 - get_key renamed into get_key_from_incoming_ip
321 - new sfa.storage module for record/table and all db-related stuff
322 - db schema in sfa.storage.sfa.sql
323 - init.d and cron.d move one step up
324 - cleaned up rspec/ directory
325 - add deps to pyopenssl and myplc-config
326 - start support for new API (return value)
327 - plc.remoteshell removed, use plshell instead
328 - plshell uses a 'capability' auth method whenever possible
329 - various tweaks in rspec elements
330 - made dependency on sfatables softer
331
332 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
333 - sfa should now be started *before* the initial import
334 - sfa to use its own database (default sfa) - can run without myplc
335 - server calls support optional 'options'
336 - client sends options in argument when needed
337 - fix infinite getattr recursion in elements/element.py
338 - error codes in line with geni
339
340 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
341 - fixed links and attributes in rspecs
342 - minor cleanup in the API methods, and more consistent names in manager methods
343
344 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
345 - ongoing refoactoring towards more genericity
346 - passes tests again although known issues remain with attributes/tags
347
348 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
349 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
350 - improvements in the pgv2 rspecs
351 - driver separated from api
352 - code starts moving around where it belongs
353 - sfascan caches getversion across invokations
354 - vini topology extracted as a config file
355
356 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
357 - first support for protogeni rspecs is working
358 - vini no longer needs a specific manager
359 - refactoring underway towards more flexible/generic architecture
360
361 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
362 - Unicode-friendliness for user names with accents/special chars.
363 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
364 - CreaetSliver no longer fails for users that have a capital letter in their URN.
365 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
366 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
367 - Fix bugs and missing imports     
368  
369
370 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
371 - new method record.get_field for sface
372
373 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
374 - new option -c to sfa-nuke-plc.py
375 - CreateSliver fixed for admin-only slice tags
376
377 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
378 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
379 - Fixed holes in certificate verification logic.
380 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
381 - Added 'boot_state' as an attribute of the node element in SFA rspec.
382 - Non authority certificates are marked as CA:FALSE.
383
384 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
385 - fix typo in sfa-1.0-31 tag.
386 - added CreateGid() Registry interface method.
387
388 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
389 - fix typo in sfa-1.0-30 tag
390
391 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
392 - Declare namespace and schema location in the credential.
393 - Fix bug that prevetend connections from timing out.
394 - Fix slice delegation.
395 - Add statistics to slicemaanger listresources/createsliver rspec.
396 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
397   of days a user can extend their slice expiration.
398 - CA certs are only issued to objects of type authority
399    
400 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
401 - tag 1.0-28 was broken due to typo in the changelog
402 - new class sfa/util/httpsProtocol.py that supports timeouts
403
404 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
405 - Resolved issue that caused sfa hold onto idle db connections.
406 - Fix bug that caused the registry to use the wrong type of credential.
407 - Support authority+sm type.
408 - Fix rspec merging bugs.
409 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
410 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
411  planetlab hosted initscripts using the <planetlab:initscript> tag  
412 - Can now handle extraneous whitespace in the rspec without failing.   
413  
414 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
415 - ProtoGENI v2 RSpec updates.
416 - Convert expiration timestamps with timezone info in credentials to utc.
417 - Fixed redundant logging issue. 
418 - Improved SliceManager and SFI client logging.
419 - Support aggregates that don't support the optional 'call_id' argument. 
420 - Only call get_trusted_certs() at aggreage interfaces that support the call.
421 - CreateSliver() now handles MyPLC slice attributes/tags.
422 - Cache now supports persistence.
423 - Hide whitelisted nodes.
424
425 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
426 - fixed issues with sup authority signing
427 - fixed bugs in remove_slivers and SliverStatus
428
429 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
430 - fix typo that prevented aggregates from operating properly
431
432 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
433 - load trusted certs into ssl context prior to handshake
434 - client's logfile lives in ~/.sfi/sfi.log
435
436 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
437 - includes a change on passphrases that was intended in 1.0-22
438
439 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
440 - Added support for ProtoGENI RSpec v2
441  
442 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
443 - stable sfascan
444 - fix in initscript, *ENABLED tags in config now taken into account
445
446 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
447 - some commits had not been pushed in tag 19
448
449 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
450 - GetVersion should now report full URLs with path
451 - scansfa has nicer output and new syntax (entry URLs as args and not options)
452 - dos2unix'ed flash policy pill
453
454 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
455 - fix packaging again for f8
456
457 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
458 - fix packaging (apparently broken in 1.0-16)
459 - first working version of sfascan
460 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
461 - deprecated the sfa_geni_aggregate config category
462
463 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
464 - Fix build problem
465 - First version of SFA scanner
466
467 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
468 - Add support for Flash clients using flashpolicy
469 - Fix problems with tag handling in RSpec
470
471 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
472 - Modifications to the Eucalyptus Aggregate Manager
473 - Fixes for VINI RSpec
474 - Fix tag handling for PL RSpec
475 - Fix XML Schema ordering for <urn> element
476
477 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
478 - just set x509 version to 2
479
480 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
481 - added urn to the node area in rspecs
482 - conversion to urn now exports fqdn
483 - sfa-import-plc.py now creates a unique registry record for each SFA interface
484
485 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
486 - undo broken attempt for python-2.7
487
488 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
489 - SMs avoid duplicates for when call graph has dags;
490 - just based on network's name, when a duplicate occurs, one is just dropped
491 - does not try to merge/aggregate 2 networks
492 - also reviewed logging with the hope to fix the sfa startup msg:
493 - TypeError: not all arguments converted during string formatting
494
495 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
496 - verify credentials against xsd schema
497 - Fix SM to SM communication
498 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
499 - new setting session_key_path
500
501 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
502 - fix registry credential regeneration and handle expiration
503 - support for setting slice tags (min_role=user)
504 - client can display its own version: sfi.py version --local
505 - GetVersion to provide urn in addition to hrn
506 - more code uses plxrn vs previous helper functions
507 - import replaces '+' in email addresses with '_'
508
509 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
510 - fix GetVersion code_tag and add code_url
511
512 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
513 - extend GetVersion towards minimum federation introspection, and expose local tag
514
515 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
516 - fixed some legacy issues (list vs List)
517 - deprecated sfa.util.namespace for xrn and plxrn
518 - unit tests ship as the sfa-tests rpm
519
520 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
521 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
522 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
523 - hrn-urn translations tweaked
524 - fixed 'service sfa status'
525 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
526 - started to repair sfadump - although not usable yet
527 - trust objects now have dump_string method that dump() actually prints
528 - unit tests under review
529 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
530 - binaries now support -v or -vv to increase loglevel
531 - trashed obsolete sfa.util.client
532
533 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
534 - various bugfixes and cleanup, improved/harmonized logging
535
536 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
537 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
538   to avoid returning a PLCAPI exception that might confuse users.
539 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
540 - fix build errors.  
541
542 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
543 - (Architecture) Credential format changed to match ProtoGENI xml format
544 - (Architecture) All interfaces export a new set of methods that are compatible
545    with the ProtoGeni Aggregate spec. These new methods are considered a 
546    replacement  for the pervious methods exported by the interfaces. All 
547    previous methods are still exported and work as normal, but they are 
548    considered deprecated and will not be supported in future releases.  
549 - (Architecture) SFI has been updated to use the new interface methods.
550 - (Architecture) Changed keyconvet implementation from c to python.
551 - (Architecture) Slice Manager now attempts looks for a delegated credential
552   provided by the client before using its own server credential.
553 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
554   This cache now exists only in memory and is cleared when service is restarted
555   or cache lifetime is exceeded.  
556 - (Performance) SliceManager sends request to Aggregates in parallel instead 
557   of sequentially.
558 - (Bug fix) SFA tickets now support the new rspec format.
559 - (Bug fix) SFI only uses cahced credential if they aren't expired.
560 - (Bug fix) Cerdential delegation modified to work with new credential format.
561 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
562   Aggregate instead of relaying through the Slice Manager.
563 - (Enhancement) Simplified caching. Accociated a global cache instance with
564   the api handler on every new server request, making it easier to access the 
565   cache and use in more general ways.     
566
567 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
568 - SfaServer now uses a pool of threads to handle requests concurrently
569 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
570 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
571 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
572 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
573 - Component manager does not install gid files if slice already has them  
574 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
575 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
576 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
577      
578 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
579 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
580 - - sfa-config-tty now has the same features like plc-config-tty
581 - - Contains code to support both urn and hrn
582 - - Cleaned up request_hash related stuff
583 - - SM, AM and Registry code is organized under respective managers
584 - - Site and Slice synchronization across federated aggregates
585 - - Script to generate sfa_component_config
586
587 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
588 - sfa-config-tty now has the same features like plc-config-tty
589 - Contains code to support both urn and hrn
590 - Cleaned up request_hash related stuff
591 - SM, AM and Registry code is organized under respective managers
592 - Slice synchronization across federated aggregates
593 - some bugs are fixed
594
595 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
596 - checkpoint with fewer mentions of geni
597
598 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
599 - checkpointing
600 - this is believed to pass the tests; among other things:
601 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
602
603 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
604 - This tag includes:
605 - - Sfatables
606 - - Preliminary version of hash based authentication
607 - - Initial code for Component Manager
608 - - Authority structure is moved to /var/lib/sfa/
609 - - some bug-fixes
610
611 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
612 - Create_slice and get_resources methods are connected to sfatables.
613 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
614
615 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
616 - Bug fix on update and remove_peer_object methods
617 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
618
619 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
620 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
621
622 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
623 - compatibility with RefreshPeer
624 - incremental mechanism for importing PLC records into SFA tables
625 - unified single database (still inside the underlying PLC db postgresql server)
626 - includes/improves call traceability and logging features
627 - several bug fixes
628
629 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
630 - added libxslt-python dependency
631
632 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
633 - unified single SFA database in the PLC-DB
634 - upcalls from  PLCAPI to SFA methods
635 - SFA call traceability and logging features
636 - many bug fixes
637 - includes first/rough version of sfatables for policy implementation
638
639 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
640 - snapshot after the GEC5 demo
641 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
642
643 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
644 - snapshot july 15 - has gone through superficial manual testing
645 - hopefully a good basis for gec5 demo
646 - multi-dir sfi client tested as well
647
648 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
649 - rename geniwrapper.spec into sfa.spec
650
651 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
652 - clean up in xmlrpc/soap, --protocol option to chose between both
653 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
654 - hopefully more helpful context in case of crashes when importing
655 - bugfixes for using only /etc/sfa for site-dep files
656 - bugfixes in wsdl generation
657
658 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
659 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
660 - config variables in sfa_config now start with SFA_ and not GENI_
661 - config.py can be loaded even with no config present
662
663 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
664 - first step for cleanup and reorganization
665 - mass-renaming from geni to sfa (some are still needed)
666 - sfa/trust implements the security architecture
667
668 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
669 - snapshot for reproducible builds
670
671 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
672 - snapshot for the convenience of alpha users
673
674 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
675 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
676
677 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
678 - ongoing work - snapshot for 4.3-rc9
679
680 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
681 - various fixes
682
683 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
684 - bugfixes - still a work in progress
685
686 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
687 - initial package
688
689
690 %define module_current_branch 0.2