Setting tag sfa-1.0-10
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 10
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %Package tests
74 Summary: unit tests suite for SFA
75 Group: Applications/System
76 Requires: sfa
77
78 %description
79 This package provides the python libraries for the PlanetLab implementation of SFA
80
81 %description cm
82 This package implements the SFA interface which serves as a layer
83 between the existing PlanetLab NodeManager interfaces and the SFA API.
84  
85 %description plc
86 This package implements the SFA interface which serves as a layer
87 between the existing PlanetLab interfaces and the SFA API.
88
89 %description client
90 This package provides the client side of the SFA API, in particular
91 sfi.py, together with other utilities.
92
93 %description sfatables
94 sfatables is a tool for defining access and admission control policies
95 in an SFA network, in much the same way as iptables is for ip
96 networks. This is the command line interface to manage sfatables
97
98 %description tests
99 Provides some binary unit tests in /usr/share/sfa/tests
100
101 %prep
102 %setup -q
103
104 %build
105 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 # sfa and sfatables depend each other.
116 %{_bindir}/sfa-server.py*
117 /etc/sfatables/*
118 %{python_sitelib}/*
119 %{_bindir}/keyconvert.py*
120 /var/www/html/wsdl/*.wsdl
121
122 %files cm
123 /etc/init.d/sfa-cm
124 %{_bindir}/sfa_component_setup.py*
125 # cron jobs here 
126
127 %files plc
128 %defattr(-,root,root)
129 %config /etc/sfa/default_config.xml
130 %config (noreplace) /etc/sfa/aggregates.xml
131 %config (noreplace) /etc/sfa/registries.xml
132 /etc/init.d/sfa
133 /etc/sfa/pl.rng
134 /etc/sfa/credential.xsd
135 /etc/sfa/top.xsd
136 /etc/sfa/sig.xsd
137 /etc/sfa/xml.xsd
138 /etc/sfa/protogeni-rspec-common.xsd
139 %{_bindir}/sfa-config-tty
140 %{_bindir}/sfa-import-plc.py*
141 %{_bindir}/sfa-clean-peer-records.py*
142 %{_bindir}/sfa-nuke-plc.py*
143 %{_bindir}/gen-sfa-cm-config.py*
144 %{_bindir}/sfa-ca.py*
145
146 %files client
147 %config (noreplace) /etc/sfa/sfi_config
148 %{_bindir}/sfi*
149 %{_bindir}/getNodes.py*
150 %{_bindir}/getRecord.py*
151 %{_bindir}/setRecord.py*
152 %{_bindir}/sfadump.py*
153
154 %files sfatables
155 %{_bindir}/sfatables
156
157 %files tests
158 %{_datadir}/sfa/tests
159
160 ### sfa-plc installs the 'sfa' service
161 %post plc
162 chkconfig --add sfa
163
164 %preun plc
165 if [ "$1" = 0 ] ; then
166   /sbin/service sfa stop || :
167   /sbin/chkconfig --del sfa || :
168 fi
169
170 %postun plc
171 [ "$1" -ge "1" ] && service sfa restart
172
173 ### sfa-cm installs the 'sfa-cm' service
174 %post cm
175 chkconfig --add sfa-cm
176
177 %preun cm
178 if [ "$1" = 0 ] ; then
179    /sbin/service sfa-cm stop || :
180    /sbin/chkconfig --del sfa-cm || :
181 fi
182
183 %postun cm
184 [ "$1" -ge "1" ] && service sfa-cm restart
185
186
187 %changelog
188 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
189 - SMs avoid duplicates for when call graph has dags;
190 - just based on network's name, when a duplicate occurs, one is just dropped
191 - does not try to merge/aggregate 2 networks
192 - also reviewed logging with the hope to fix the sfa startup msg:
193 - TypeError: not all arguments converted during string formatting
194
195 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
196 - verify credentials against xsd schema
197 - Fix SM to SM communication
198 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
199 - new setting session_key_path
200
201 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
202 - fix registry credential regeneration and handle expiration
203 - support for setting slice tags (min_role=user)
204 - client can display its own version: sfi.py version --local
205 - GetVersion to provide urn in addition to hrn
206 - more code uses plxrn vs previous helper functions
207 - import replaces '+' in email addresses with '_'
208
209 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
210 - fix GetVersion code_tag and add code_url
211
212 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
213 - extend GetVersion towards minimum federation introspection, and expose local tag
214
215 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
216 - fixed some legacy issues (list vs List)
217 - deprecated sfa.util.namespace for xrn and plxrn
218 - unit tests ship as the sfa-tests rpm
219
220 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
221 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
222 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
223 - hrn-urn translations tweaked
224 - fixed 'service sfa status'
225 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
226 - started to repair sfadump - although not usable yet
227 - trust objects now have dump_string method that dump() actually prints
228 - unit tests under review
229 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
230 - binaries now support -v or -vv to increase loglevel
231 - trashed obsolete sfa.util.client
232
233 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
234 - various bugfixes and cleanup, improved/harmonized logging
235
236 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
237 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
238   to avoid returning a PLCAPI exception that might confuse users.
239 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
240 - fix build errors.  
241
242 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
243 - (Architecture) Credential format changed to match ProtoGENI xml format
244 - (Architecture) All interfaces export a new set of methods that are compatible
245    with the ProtoGeni Aggregate spec. These new methods are considered a 
246    replacement  for the pervious methods exported by the interfaces. All 
247    previous methods are still exported and work as normal, but they are 
248    considered deprecated and will not be supported in future releases.  
249 - (Architecture) SFI has been updated to use the new interface methods.
250 - (Architecture) Changed keyconvet implementation from c to python.
251 - (Architecture) Slice Manager now attempts looks for a delegated credential
252   provided by the client before using its own server credential.
253 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
254   This cache now exists only in memory and is cleared when service is restarted
255   or cache lifetime is exceeded.  
256 - (Performance) SliceManager sends request to Aggregates in parallel instead 
257   of sequentially.
258 - (Bug fix) SFA tickets now support the new rspec format.
259 - (Bug fix) SFI only uses cahced credential if they aren't expired.
260 - (Bug fix) Cerdential delegation modified to work with new credential format.
261 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
262   Aggregate instead of relaying through the Slice Manager.
263 - (Enhancement) Simplified caching. Accociated a global cache instance with
264   the api handler on every new server request, making it easier to access the 
265   cache and use in more general ways.     
266
267 %changelog
268 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
269 - SMs avoid duplicates for when call graph has dags;
270 - just based on network's name, when a duplicate occurs, one is just dropped
271 - does not try to merge/aggregate 2 networks
272 - also reviewed logging with the hope to fix the sfa startup msg:
273 - TypeError: not all arguments converted during string formatting
274
275 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
276 - verify credentials against xsd schema
277 - Fix SM to SM communication
278 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
279 - new setting session_key_path
280
281 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
282 - fix registry credential regeneration and handle expiration
283 - support for setting slice tags (min_role=user)
284 - client can display its own version: sfi.py version --local
285 - GetVersion to provide urn in addition to hrn
286 - more code uses plxrn vs previous helper functions
287 - import replaces '+' in email addresses with '_'
288
289 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
290 - fix GetVersion code_tag and add code_url
291
292 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
293 - extend GetVersion towards minimum federation introspection, and expose local tag
294
295 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
296 - fixed some legacy issues (list vs List)
297 - deprecated sfa.util.namespace for xrn and plxrn
298 - unit tests ship as the sfa-tests rpm
299
300 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
301 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
302 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
303 - hrn-urn translations tweaked
304 - fixed 'service sfa status'
305 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
306 - started to repair sfadump - although not usable yet
307 - trust objects now have dump_string method that dump() actually prints
308 - unit tests under review
309 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
310 - binaries now support -v or -vv to increase loglevel
311 - trashed obsolete sfa.util.client
312
313 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
314 - various bugfixes and cleanup, improved/harmonized logging
315
316 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
317 - SfaServer now uses a pool of threads to handle requests concurrently
318 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
319 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
320 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
321 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
322 - Component manager does not install gid files if slice already has them  
323 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
324 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
325 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
326      
327 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
328 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
329 - - sfa-config-tty now has the same features like plc-config-tty
330 - - Contains code to support both urn and hrn
331 - - Cleaned up request_hash related stuff
332 - - SM, AM and Registry code is organized under respective managers
333 - - Site and Slice synchronization across federated aggregates
334 - - Script to generate sfa_component_config
335
336 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
337 - sfa-config-tty now has the same features like plc-config-tty
338 - Contains code to support both urn and hrn
339 - Cleaned up request_hash related stuff
340 - SM, AM and Registry code is organized under respective managers
341 - Slice synchronization across federated aggregates
342 - some bugs are fixed
343
344 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
345 - checkpoint with fewer mentions of geni
346
347 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
348 - checkpointing
349 - this is believed to pass the tests; among other things:
350 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
351
352 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
353 - This tag includes:
354 - - Sfatables
355 - - Preliminary version of hash based authentication
356 - - Initial code for Component Manager
357 - - Authority structure is moved to /var/lib/sfa/
358 - - some bug-fixes
359
360 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
361 - Create_slice and get_resources methods are connected to sfatables.
362 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
363
364 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
365 - Bug fix on update and remove_peer_object methods
366 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
367
368 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
369 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
370
371 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
372 - compatibility with RefreshPeer
373 - incremental mechanism for importing PLC records into SFA tables
374 - unified single database (still inside the underlying PLC db postgresql server)
375 - includes/improves call traceability and logging features
376 - several bug fixes
377
378 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
379 - added libxslt-python dependency
380
381 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
382 - unified single SFA database in the PLC-DB
383 - upcalls from  PLCAPI to SFA methods
384 - SFA call traceability and logging features
385 - many bug fixes
386 - includes first/rough version of sfatables for policy implementation
387
388 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
389 - snapshot after the GEC5 demo
390 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
391
392 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
393 - snapshot july 15 - has gone through superficial manual testing
394 - hopefully a good basis for gec5 demo
395 - multi-dir sfi client tested as well
396
397 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
398 - rename geniwrapper.spec into sfa.spec
399
400 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
401 - clean up in xmlrpc/soap, --protocol option to chose between both
402 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
403 - hopefully more helpful context in case of crashes when importing
404 - bugfixes for using only /etc/sfa for site-dep files
405 - bugfixes in wsdl generation
406
407 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
408 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
409 - config variables in sfa_config now start with SFA_ and not GENI_
410 - config.py can be loaded even with no config present
411
412 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
413 - first step for cleanup and reorganization
414 - mass-renaming from geni to sfa (some are still needed)
415 - sfa/trust implements the security architecture
416
417 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
418 - snapshot for reproducible builds
419
420 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
421 - snapshot for the convenience of alpha users
422
423 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
424 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
425
426 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
427 - ongoing work - snapshot for 4.3-rc9
428
429 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
430 - various fixes
431
432 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
433 - bugfixes - still a work in progress
434
435 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
436 - initial package
437
438
439 %define module_current_branch 0.2