Setting tag sfa-1.0-15
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.0
3 %define taglevel 15
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA wrapper around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA wrapper arounf MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %Package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-server.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py
167 /etc/sfa/flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart
197
198
199 %changelog
200 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
201 - Add support for Flash clients using flashpolicy
202 - Fix problems with tag handling in RSpec
203
204 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
205 - Modifications to the Eucalyptus Aggregate Manager
206 - Fixes for VINI RSpec
207 - Fix tag handling for PL RSpec
208 - Fix XML Schema ordering for <urn> element
209
210 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
211 - just set x509 version to 2
212
213 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
214 - added urn to the node area in rspecs
215 - conversion to urn now exports fqdn
216 - sfa-import-plc.py now creates a unique registry record for each SFA interface
217
218 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
219 - undo broken attempt for python-2.7
220
221 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
222 - SMs avoid duplicates for when call graph has dags;
223 - just based on network's name, when a duplicate occurs, one is just dropped
224 - does not try to merge/aggregate 2 networks
225 - also reviewed logging with the hope to fix the sfa startup msg:
226 - TypeError: not all arguments converted during string formatting
227
228 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
229 - verify credentials against xsd schema
230 - Fix SM to SM communication
231 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
232 - new setting session_key_path
233
234 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
235 - fix registry credential regeneration and handle expiration
236 - support for setting slice tags (min_role=user)
237 - client can display its own version: sfi.py version --local
238 - GetVersion to provide urn in addition to hrn
239 - more code uses plxrn vs previous helper functions
240 - import replaces '+' in email addresses with '_'
241
242 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
243 - fix GetVersion code_tag and add code_url
244
245 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
246 - extend GetVersion towards minimum federation introspection, and expose local tag
247
248 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
249 - fixed some legacy issues (list vs List)
250 - deprecated sfa.util.namespace for xrn and plxrn
251 - unit tests ship as the sfa-tests rpm
252
253 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
254 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
255 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
256 - hrn-urn translations tweaked
257 - fixed 'service sfa status'
258 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
259 - started to repair sfadump - although not usable yet
260 - trust objects now have dump_string method that dump() actually prints
261 - unit tests under review
262 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
263 - binaries now support -v or -vv to increase loglevel
264 - trashed obsolete sfa.util.client
265
266 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
267 - various bugfixes and cleanup, improved/harmonized logging
268
269 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
270 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
271   to avoid returning a PLCAPI exception that might confuse users.
272 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
273 - fix build errors.  
274
275 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
276 - (Architecture) Credential format changed to match ProtoGENI xml format
277 - (Architecture) All interfaces export a new set of methods that are compatible
278    with the ProtoGeni Aggregate spec. These new methods are considered a 
279    replacement  for the pervious methods exported by the interfaces. All 
280    previous methods are still exported and work as normal, but they are 
281    considered deprecated and will not be supported in future releases.  
282 - (Architecture) SFI has been updated to use the new interface methods.
283 - (Architecture) Changed keyconvet implementation from c to python.
284 - (Architecture) Slice Manager now attempts looks for a delegated credential
285   provided by the client before using its own server credential.
286 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
287   This cache now exists only in memory and is cleared when service is restarted
288   or cache lifetime is exceeded.  
289 - (Performance) SliceManager sends request to Aggregates in parallel instead 
290   of sequentially.
291 - (Bug fix) SFA tickets now support the new rspec format.
292 - (Bug fix) SFI only uses cahced credential if they aren't expired.
293 - (Bug fix) Cerdential delegation modified to work with new credential format.
294 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
295   Aggregate instead of relaying through the Slice Manager.
296 - (Enhancement) Simplified caching. Accociated a global cache instance with
297   the api handler on every new server request, making it easier to access the 
298   cache and use in more general ways.     
299
300 %changelog
301 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
302 - Add support for Flash clients using flashpolicy
303 - Fix problems with tag handling in RSpec
304
305 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
306 - Modifications to the Eucalyptus Aggregate Manager
307 - Fixes for VINI RSpec
308 - Fix tag handling for PL RSpec
309 - Fix XML Schema ordering for <urn> element
310
311 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
312 - just set x509 version to 2
313
314 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
315 - added urn to the node area in rspecs
316 - conversion to urn now exports fqdn
317 - sfa-import-plc.py now creates a unique registry record for each SFA interface
318
319 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
320 - undo broken attempt for python-2.7
321
322 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
323 - SMs avoid duplicates for when call graph has dags;
324 - just based on network's name, when a duplicate occurs, one is just dropped
325 - does not try to merge/aggregate 2 networks
326 - also reviewed logging with the hope to fix the sfa startup msg:
327 - TypeError: not all arguments converted during string formatting
328
329 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
330 - verify credentials against xsd schema
331 - Fix SM to SM communication
332 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
333 - new setting session_key_path
334
335 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
336 - fix registry credential regeneration and handle expiration
337 - support for setting slice tags (min_role=user)
338 - client can display its own version: sfi.py version --local
339 - GetVersion to provide urn in addition to hrn
340 - more code uses plxrn vs previous helper functions
341 - import replaces '+' in email addresses with '_'
342
343 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
344 - fix GetVersion code_tag and add code_url
345
346 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
347 - extend GetVersion towards minimum federation introspection, and expose local tag
348
349 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
350 - fixed some legacy issues (list vs List)
351 - deprecated sfa.util.namespace for xrn and plxrn
352 - unit tests ship as the sfa-tests rpm
353
354 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
355 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
356 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
357 - hrn-urn translations tweaked
358 - fixed 'service sfa status'
359 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
360 - started to repair sfadump - although not usable yet
361 - trust objects now have dump_string method that dump() actually prints
362 - unit tests under review
363 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
364 - binaries now support -v or -vv to increase loglevel
365 - trashed obsolete sfa.util.client
366
367 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
368 - various bugfixes and cleanup, improved/harmonized logging
369
370 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
371 - SfaServer now uses a pool of threads to handle requests concurrently
372 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
373 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
374 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
375 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
376 - Component manager does not install gid files if slice already has them  
377 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
378 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
379 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
380      
381 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
382 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
383 - - sfa-config-tty now has the same features like plc-config-tty
384 - - Contains code to support both urn and hrn
385 - - Cleaned up request_hash related stuff
386 - - SM, AM and Registry code is organized under respective managers
387 - - Site and Slice synchronization across federated aggregates
388 - - Script to generate sfa_component_config
389
390 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
391 - sfa-config-tty now has the same features like plc-config-tty
392 - Contains code to support both urn and hrn
393 - Cleaned up request_hash related stuff
394 - SM, AM and Registry code is organized under respective managers
395 - Slice synchronization across federated aggregates
396 - some bugs are fixed
397
398 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
399 - checkpoint with fewer mentions of geni
400
401 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
402 - checkpointing
403 - this is believed to pass the tests; among other things:
404 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
405
406 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
407 - This tag includes:
408 - - Sfatables
409 - - Preliminary version of hash based authentication
410 - - Initial code for Component Manager
411 - - Authority structure is moved to /var/lib/sfa/
412 - - some bug-fixes
413
414 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
415 - Create_slice and get_resources methods are connected to sfatables.
416 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
417
418 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
419 - Bug fix on update and remove_peer_object methods
420 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
421
422 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
423 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
424
425 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
426 - compatibility with RefreshPeer
427 - incremental mechanism for importing PLC records into SFA tables
428 - unified single database (still inside the underlying PLC db postgresql server)
429 - includes/improves call traceability and logging features
430 - several bug fixes
431
432 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
433 - added libxslt-python dependency
434
435 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
436 - unified single SFA database in the PLC-DB
437 - upcalls from  PLCAPI to SFA methods
438 - SFA call traceability and logging features
439 - many bug fixes
440 - includes first/rough version of sfatables for policy implementation
441
442 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
443 - snapshot after the GEC5 demo
444 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
445
446 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
447 - snapshot july 15 - has gone through superficial manual testing
448 - hopefully a good basis for gec5 demo
449 - multi-dir sfi client tested as well
450
451 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
452 - rename geniwrapper.spec into sfa.spec
453
454 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
455 - clean up in xmlrpc/soap, --protocol option to chose between both
456 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
457 - hopefully more helpful context in case of crashes when importing
458 - bugfixes for using only /etc/sfa for site-dep files
459 - bugfixes in wsdl generation
460
461 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
462 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
463 - config variables in sfa_config now start with SFA_ and not GENI_
464 - config.py can be loaded even with no config present
465
466 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
467 - first step for cleanup and reorganization
468 - mass-renaming from geni to sfa (some are still needed)
469 - sfa/trust implements the security architecture
470
471 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
472 - snapshot for reproducible builds
473
474 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
475 - snapshot for the convenience of alpha users
476
477 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
478 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
479
480 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
481 - ongoing work - snapshot for 4.3-rc9
482
483 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
484 - various fixes
485
486 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
487 - bugfixes - still a work in progress
488
489 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
490 - initial package
491
492
493 %define module_current_branch 0.2