solve merge conflict
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34  
35 # python 2.5 has uuid module added, for python 2.4 we still need it.
36 # we can't really check for if we can load uuid as a python module,
37 # it'll be installed by "devel.pkgs". we have the epel repository so
38 # python-uuid will be provided. but we can test for the python
39 # version.
40 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
41 # %if %has_py24
42 #
43 # this also didn't work very well. I'll just check for distroname - baris
44 #%if %{distroname} == "centos5"
45 #Requires: python-uuid
46 #%endif
47
48 %package cm
49 Summary: the SFA layer around MyPLC NodeManager
50 Group: Applications/System
51 Requires: sfa
52 Requires: pyOpenSSL >= 0.6
53
54 %package plc
55 Summary: the SFA layer around MyPLC
56 Group: Applications/System
57 Requires: sfa
58 Requires: python-psycopg2
59 Requires: myplc-config
60 Requires: pyOpenSSL >= 0.7
61
62 %package client
63 Summary: the SFA experimenter-side CLI
64 Group: Applications/System
65 Requires: sfa
66 Requires: pyOpenSSL >= 0.7
67
68 %package sfatables
69 Summary: sfatables policy tool for SFA
70 Group: Applications/System
71 Requires: sfa
72
73 %package flashpolicy
74 Summary: SFA support for flash clients
75 Group: Applications/System
76 Requires: sfa
77
78 %package tests
79 Summary: unit tests suite for SFA
80 Group: Applications/System
81 Requires: sfa
82
83 %description
84 This package provides the python libraries for the PlanetLab implementation of SFA
85
86 %description cm
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab NodeManager interfaces and the SFA API.
89  
90 %description plc
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab interfaces and the SFA API.
93
94 %description client
95 This package provides the client side of the SFA API, in particular
96 sfi.py, together with other utilities.
97
98 %description sfatables
99 sfatables is a tool for defining access and admission control policies
100 in an SFA network, in much the same way as iptables is for ip
101 networks. This is the command line interface to manage sfatables
102
103 %description flashpolicy
104 This package provides support for adobe flash client applications.  
105  
106 %description tests
107 Provides some binary unit tests in /usr/share/sfa/tests
108
109 %prep
110 %setup -q
111
112 %build
113 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 # sfa and sfatables depend each other.
124 %{_bindir}/sfa-start.py*
125 /etc/sfatables/*
126 %{python_sitelib}/*
127 %{_bindir}/keyconvert.py*
128 /var/www/html/wsdl/*.wsdl
129
130 %files cm
131 /etc/init.d/sfa-cm
132 %{_bindir}/sfa_component_setup.py*
133 # cron jobs here 
134
135 %files plc
136 %defattr(-,root,root)
137 %config /etc/sfa/default_config.xml
138 %config (noreplace) /etc/sfa/aggregates.xml
139 %config (noreplace) /etc/sfa/registries.xml
140 /etc/init.d/sfa
141 /etc/sfa/pl.rng
142 /etc/sfa/credential.xsd
143 /etc/sfa/top.xsd
144 /etc/sfa/sig.xsd
145 /etc/sfa/xml.xsd
146 /etc/sfa/protogeni-rspec-common.xsd
147 %{_bindir}/sfa-config-tty
148 %{_bindir}/sfa-import-plc.py*
149 %{_bindir}/sfa-clean-peer-records.py*
150 %{_bindir}/sfa-nuke-plc.py*
151 %{_bindir}/gen-sfa-cm-config.py*
152 %{_bindir}/sfa-ca.py*
153
154 %files client
155 %config (noreplace) /etc/sfa/sfi_config
156 %{_bindir}/sfi*
157 %{_bindir}/getNodes.py*
158 %{_bindir}/getRecord.py*
159 %{_bindir}/setRecord.py*
160 %{_bindir}/sfadump.py*
161
162 %files sfatables
163 %{_bindir}/sfatables
164
165 %files flashpolicy
166 %{_bindir}/sfa_flashpolicy.py*
167 /etc/sfa/sfa_flashpolicy_config.xml
168
169 %files tests
170 %{_datadir}/sfa/tests
171
172 ### sfa-plc installs the 'sfa' service
173 %post plc
174 chkconfig --add sfa
175
176 %preun plc
177 if [ "$1" = 0 ] ; then
178   /sbin/service sfa stop || :
179   /sbin/chkconfig --del sfa || :
180 fi
181
182 %postun plc
183 [ "$1" -ge "1" ] && service sfa restart
184
185 ### sfa-cm installs the 'sfa-cm' service
186 %post cm
187 chkconfig --add sfa-cm
188
189 %preun cm
190 if [ "$1" = 0 ] ; then
191    /sbin/service sfa-cm stop || :
192    /sbin/chkconfig --del sfa-cm || :
193 fi
194
195 %postun cm
196 [ "$1" -ge "1" ] && service sfa-cm restart || :
197
198 %changelog
199 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
200 - first support for protogeni rspecs is working
201 - vini no longer needs a specific manager
202 - refactoring underway towards more flexible/generic architecture
203
204 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
205 - Unicode-friendliness for user names with accents/special chars.
206 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
207 - CreaetSliver no longer fails for users that have a capital letter in their URN.
208 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
209 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
210 - Fix bugs and missing imports     
211  
212
213 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
214 - new method record.get_field for sface
215
216 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
217 - new option -c to sfa-nuke-plc.py
218 - CreateSliver fixed for admin-only slice tags
219
220 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
221 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
222 - Fixed holes in certificate verification logic.
223 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
224 - Added 'boot_state' as an attribute of the node element in SFA rspec.
225 - Non authority certificates are marked as CA:FALSE.
226
227 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
228 - fix typo in sfa-1.0-31 tag.
229 - added CreateGid() Registry interface method.
230
231 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
232 - fix typo in sfa-1.0-30 tag
233
234 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
235 - Declare namespace and schema location in the credential.
236 - Fix bug that prevetend connections from timing out.
237 - Fix slice delegation.
238 - Add statistics to slicemaanger listresources/createsliver rspec.
239 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
240   of days a user can extend their slice expiration.
241 - CA certs are only issued to objects of type authority
242    
243 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
244 - tag 1.0-28 was broken due to typo in the changelog
245 - new class sfa/util/httpsProtocol.py that supports timeouts
246
247 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
248 - Resolved issue that caused sfa hold onto idle db connections.
249 - Fix bug that caused the registry to use the wrong type of credential.
250 - Support authority+sm type.
251 - Fix rspec merging bugs.
252 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
253 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
254  planetlab hosted initscripts using the <planetlab:initscript> tag  
255 - Can now handle extraneous whitespace in the rspec without failing.   
256  
257 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
258 - ProtoGENI v2 RSpec updates.
259 - Convert expiration timestamps with timezone info in credentials to utc.
260 - Fixed redundant logging issue. 
261 - Improved SliceManager and SFI client logging.
262 - Support aggregates that don't support the optional 'call_id' argument. 
263 - Only call get_trusted_certs() at aggreage interfaces that support the call.
264 - CreateSliver() now handles MyPLC slice attributes/tags.
265 - Cache now supports persistence.
266 - Hide whitelisted nodes.
267
268 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
269 - fixed issues with sup authority signing
270 - fixed bugs in remove_slivers and SliverStatus
271
272 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
273 - fix typo that prevented aggregates from operating properly
274
275 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
276 - load trusted certs into ssl context prior to handshake
277 - client's logfile lives in ~/.sfi/sfi.log
278
279 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
280 - includes a change on passphrases that was intended in 1.0-22
281
282 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
283 - Added support for ProtoGENI RSpec v2
284  
285 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
286 - stable sfascan
287 - fix in initscript, *ENABLED tags in config now taken into account
288
289 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
290 - some commits had not been pushed in tag 19
291
292 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
293 - GetVersion should now report full URLs with path
294 - scansfa has nicer output and new syntax (entry URLs as args and not options)
295 - dos2unix'ed flash policy pill
296
297 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
298 - fix packaging again for f8
299
300 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
301 - fix packaging (apparently broken in 1.0-16)
302 - first working version of sfascan
303 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
304 - deprecated the sfa_geni_aggregate config category
305
306 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
307 - Fix build problem
308 - First version of SFA scanner
309
310 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
311 - Add support for Flash clients using flashpolicy
312 - Fix problems with tag handling in RSpec
313
314 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
315 - Modifications to the Eucalyptus Aggregate Manager
316 - Fixes for VINI RSpec
317 - Fix tag handling for PL RSpec
318 - Fix XML Schema ordering for <urn> element
319
320 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
321 - just set x509 version to 2
322
323 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
324 - added urn to the node area in rspecs
325 - conversion to urn now exports fqdn
326 - sfa-import-plc.py now creates a unique registry record for each SFA interface
327
328 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
329 - undo broken attempt for python-2.7
330
331 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
332 - SMs avoid duplicates for when call graph has dags;
333 - just based on network's name, when a duplicate occurs, one is just dropped
334 - does not try to merge/aggregate 2 networks
335 - also reviewed logging with the hope to fix the sfa startup msg:
336 - TypeError: not all arguments converted during string formatting
337
338 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
339 - verify credentials against xsd schema
340 - Fix SM to SM communication
341 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
342 - new setting session_key_path
343
344 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
345 - fix registry credential regeneration and handle expiration
346 - support for setting slice tags (min_role=user)
347 - client can display its own version: sfi.py version --local
348 - GetVersion to provide urn in addition to hrn
349 - more code uses plxrn vs previous helper functions
350 - import replaces '+' in email addresses with '_'
351
352 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
353 - fix GetVersion code_tag and add code_url
354
355 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
356 - extend GetVersion towards minimum federation introspection, and expose local tag
357
358 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
359 - fixed some legacy issues (list vs List)
360 - deprecated sfa.util.namespace for xrn and plxrn
361 - unit tests ship as the sfa-tests rpm
362
363 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
364 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
365 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
366 - hrn-urn translations tweaked
367 - fixed 'service sfa status'
368 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
369 - started to repair sfadump - although not usable yet
370 - trust objects now have dump_string method that dump() actually prints
371 - unit tests under review
372 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
373 - binaries now support -v or -vv to increase loglevel
374 - trashed obsolete sfa.util.client
375
376 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
377 - various bugfixes and cleanup, improved/harmonized logging
378
379 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
380 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
381   to avoid returning a PLCAPI exception that might confuse users.
382 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
383 - fix build errors.  
384
385 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
386 - (Architecture) Credential format changed to match ProtoGENI xml format
387 - (Architecture) All interfaces export a new set of methods that are compatible
388    with the ProtoGeni Aggregate spec. These new methods are considered a 
389    replacement  for the pervious methods exported by the interfaces. All 
390    previous methods are still exported and work as normal, but they are 
391    considered deprecated and will not be supported in future releases.  
392 - (Architecture) SFI has been updated to use the new interface methods.
393 - (Architecture) Changed keyconvet implementation from c to python.
394 - (Architecture) Slice Manager now attempts looks for a delegated credential
395   provided by the client before using its own server credential.
396 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
397   This cache now exists only in memory and is cleared when service is restarted
398   or cache lifetime is exceeded.  
399 - (Performance) SliceManager sends request to Aggregates in parallel instead 
400   of sequentially.
401 - (Bug fix) SFA tickets now support the new rspec format.
402 - (Bug fix) SFI only uses cahced credential if they aren't expired.
403 - (Bug fix) Cerdential delegation modified to work with new credential format.
404 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
405   Aggregate instead of relaying through the Slice Manager.
406 - (Enhancement) Simplified caching. Accociated a global cache instance with
407   the api handler on every new server request, making it easier to access the 
408   cache and use in more general ways.     
409
410 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
411 - SfaServer now uses a pool of threads to handle requests concurrently
412 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
413 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
414 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
415 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
416 - Component manager does not install gid files if slice already has them  
417 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
418 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
419 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
420      
421 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
422 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
423 - - sfa-config-tty now has the same features like plc-config-tty
424 - - Contains code to support both urn and hrn
425 - - Cleaned up request_hash related stuff
426 - - SM, AM and Registry code is organized under respective managers
427 - - Site and Slice synchronization across federated aggregates
428 - - Script to generate sfa_component_config
429
430 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
431 - sfa-config-tty now has the same features like plc-config-tty
432 - Contains code to support both urn and hrn
433 - Cleaned up request_hash related stuff
434 - SM, AM and Registry code is organized under respective managers
435 - Slice synchronization across federated aggregates
436 - some bugs are fixed
437
438 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
439 - checkpoint with fewer mentions of geni
440
441 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
442 - checkpointing
443 - this is believed to pass the tests; among other things:
444 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
445
446 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
447 - This tag includes:
448 - - Sfatables
449 - - Preliminary version of hash based authentication
450 - - Initial code for Component Manager
451 - - Authority structure is moved to /var/lib/sfa/
452 - - some bug-fixes
453
454 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
455 - Create_slice and get_resources methods are connected to sfatables.
456 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
457
458 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
459 - Bug fix on update and remove_peer_object methods
460 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
461
462 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
463 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
464
465 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
466 - compatibility with RefreshPeer
467 - incremental mechanism for importing PLC records into SFA tables
468 - unified single database (still inside the underlying PLC db postgresql server)
469 - includes/improves call traceability and logging features
470 - several bug fixes
471
472 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
473 - added libxslt-python dependency
474
475 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
476 - unified single SFA database in the PLC-DB
477 - upcalls from  PLCAPI to SFA methods
478 - SFA call traceability and logging features
479 - many bug fixes
480 - includes first/rough version of sfatables for policy implementation
481
482 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
483 - snapshot after the GEC5 demo
484 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
485
486 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
487 - snapshot july 15 - has gone through superficial manual testing
488 - hopefully a good basis for gec5 demo
489 - multi-dir sfi client tested as well
490
491 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
492 - rename geniwrapper.spec into sfa.spec
493
494 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
495 - clean up in xmlrpc/soap, --protocol option to chose between both
496 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
497 - hopefully more helpful context in case of crashes when importing
498 - bugfixes for using only /etc/sfa for site-dep files
499 - bugfixes in wsdl generation
500
501 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
502 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
503 - config variables in sfa_config now start with SFA_ and not GENI_
504 - config.py can be loaded even with no config present
505
506 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
507 - first step for cleanup and reorganization
508 - mass-renaming from geni to sfa (some are still needed)
509 - sfa/trust implements the security architecture
510
511 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
512 - snapshot for reproducible builds
513
514 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
515 - snapshot for the convenience of alpha users
516
517 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
518 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
519
520 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
521 - ongoing work - snapshot for 4.3-rc9
522
523 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
524 - various fixes
525
526 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
527 - bugfixes - still a work in progress
528
529 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
530 - initial package
531
532
533 %define module_current_branch 0.2