cosmetic
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 9
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # the eucalyptus aggregate uses this module
47 Requires: python-xmlbuilder
48  
49 # python 2.5 has uuid module added, for python 2.4 we still need it.
50 # we can't really check for if we can load uuid as a python module,
51 # it'll be installed by "devel.pkgs". we have the epel repository so
52 # python-uuid will be provided. but we can test for the python
53 # version.
54 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
55 # %if %has_py24
56 #
57 # this also didn't work very well. I'll just check for distroname - baris
58 #%if %{distroname} == "centos5"
59 #Requires: python-uuid
60 #%endif
61
62 %package plc
63 Summary: the SFA layer around MyPLC
64 Group: Applications/System
65 Requires: sfa
66 Requires: python-psycopg2
67
68 %package client
69 Summary: the SFA experimenter-side CLI
70 Group: Applications/System
71 Requires: sfa
72 Requires: pyOpenSSL >= 0.7
73
74 %package sfatables
75 Summary: sfatables policy tool for SFA
76 Group: Applications/System
77 Requires: sfa
78
79 %package cm
80 Summary: the SFA layer around MyPLC NodeManager
81 Group: Applications/System
82 Requires: sfa
83 Requires: pyOpenSSL >= 0.6
84
85 %package flashpolicy
86 Summary: SFA support for flash clients
87 Group: Applications/System
88 Requires: sfa
89
90 %package xmlbuilder
91 Summary: third-party xmlbuilder tool
92 Group: Applications/System
93 Provides: python-xmlbuilder
94
95 %package tests
96 Summary: unit tests suite for SFA
97 Group: Applications/System
98 Requires: sfa
99
100 %description
101 This package provides the python libraries for the PlanetLab implementation of SFA
102
103 %description plc
104 This package implements the SFA interface which serves as a layer
105 between the existing PlanetLab interfaces and the SFA API.
106
107 %description client
108 This package provides the client side of the SFA API, in particular
109 sfi.py, together with other utilities.
110
111 %description sfatables
112 sfatables is a tool for defining access and admission control policies
113 in an SFA network, in much the same way as iptables is for ip
114 networks. This is the command line interface to manage sfatables
115
116 %description cm
117 This package implements the SFA interface which serves as a layer
118 between the existing PlanetLab NodeManager interfaces and the SFA API.
119
120 %description flashpolicy
121 This package provides support for adobe flash client applications.  
122
123 %description xmlbuilder
124 This package contains the xmlbuilder python library, packaged for
125 convenience as it is not supported by fedora
126
127 %description tests
128 Provides some binary unit tests in /usr/share/sfa/tests
129
130 %prep
131 %setup -q
132
133 %build
134 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 # sfa and sfatables depend on each other.
145 %{python_sitelib}/sfa
146 /etc/init.d/sfa
147 %{_bindir}/sfa-start.py*
148 %{_bindir}/keyconvert.py*
149 %{_bindir}/sfa-config-tty
150 %config /etc/sfa/default_config.xml
151 %config (noreplace) /etc/sfa/aggregates.xml
152 %config (noreplace) /etc/sfa/registries.xml
153 /usr/share/sfa/sfa.sql
154 /usr/share/sfa/examples
155 /var/www/html/wsdl/*.wsdl
156
157 %files plc
158 %defattr(-,root,root)
159 /etc/sfa/pl.rng
160 /etc/sfa/credential.xsd
161 /etc/sfa/top.xsd
162 /etc/sfa/sig.xsd
163 /etc/sfa/xml.xsd
164 /etc/sfa/protogeni-rspec-common.xsd
165 /etc/sfa/topology
166 %{_bindir}/sfa-import-plc.py*
167 %{_bindir}/sfa-nuke-plc.py*
168 %{_bindir}/sfa-clean-peer-records.py*
169 %{_bindir}/gen-sfa-cm-config.py*
170 %{_bindir}/sfa-ca.py*
171
172 %files client
173 %config (noreplace) /etc/sfa/sfi_config
174 %{_bindir}/sfi*.py*
175 %{_bindir}/sfi
176 %{_bindir}/get*.py*
177 %{_bindir}/setRecord.py*
178 %{_bindir}/sfascan.py*
179 %{_bindir}/sfascan
180 %{_bindir}/sfadump.py*
181
182 %files sfatables
183 /etc/sfatables/*
184 %{_bindir}/sfatables
185 %{python_sitelib}/sfatables
186
187 %files cm
188 /etc/init.d/sfa-cm
189 %{_bindir}/sfa_component_setup.py*
190 # cron jobs here 
191
192 %files flashpolicy
193 %{_bindir}/sfa_flashpolicy.py*
194 /etc/sfa/sfa_flashpolicy_config.xml
195
196 %files xmlbuilder
197 %{python_sitelib}/xmlbuilder
198
199 %files tests
200 %{_datadir}/sfa/tests
201
202 ### sfa-plc installs the 'sfa' service
203 %post plc
204 chkconfig --add sfa
205
206 %preun plc
207 if [ "$1" = 0 ] ; then
208   /sbin/service sfa stop || :
209   /sbin/chkconfig --del sfa || :
210 fi
211
212 %postun plc
213 [ "$1" -ge "1" ] && service sfa restart
214
215 ### sfa-cm installs the 'sfa-cm' service
216 %post cm
217 chkconfig --add sfa-cm
218
219 %preun cm
220 if [ "$1" = 0 ] ; then
221    /sbin/service sfa-cm stop || :
222    /sbin/chkconfig --del sfa-cm || :
223 fi
224
225 %postun cm
226 [ "$1" -ge "1" ] && service sfa-cm restart || :
227
228 %changelog
229 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
230 - bugfix: 'geni_api' should be in the top level struct, not the code struct
231 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
232           output returned by the Aggregate Manager.
233 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
234 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
235 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
236           there is extra whitespace in the schemaLocation field.
237 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
238           advertisement rspecs.
239 - bugfix: <login> RSpec element should contain the 'username' attribute.
240 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
241  
242 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
243 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
244   exit when it encountered a user with an invalid public key.
245 - server: imporved logging in sfa-import-plc.py
246  
247 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
248 - bugfix: Fixed appending public keys in CreateSliver
249 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
250 - client: -c --current option allows users to request the current/uncached rspec.
251 - server: Added 'geni_api_versions' field to GetVersion() output.
252 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
253    
254 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
255 - bugfix: sfi was not sending call_id with ListResources to v2 servers
256 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
257 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
258
259 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
260 - client: sfi -a / -p deprecated (use -s instead)
261 - client: sfi cleaned up
262 - client: sfi has backward support for APIv1 aggregates again
263 - server: only APIv2 is supported and should be rather strict
264 - server: settings for turning on/off caching in sm or am
265 - server: plc-dependant code has moved from aggregate to pldriver
266 - server: driver interface extended accordingly
267
268 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
269 - screwed up previous tag
270
271 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
272 - client side revisited with a bootstrap library
273 - client side has a new source layout
274 - various (nasty) bug fixes wrt options and call_id
275
276 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
277 - various fixes in rspecs for sfav1&slice tags
278 - uses 'geni_rspec_version' and not just 'rspec_version'
279 - example flavour for the max testbed
280 - embryo for an sfa client library
281 - topology.py moved into plc
282 - sql: table is named records; record_types are enforced
283 - sql: table creation cleaned up
284
285 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
286 - cleaned up all references to SFA_*_TYPE in config
287 - enable cache at the aggregate by default
288 - registry now uses the driver in a sensible way (see managers/driver.py)
289 - slice manager supports sfav1/pgv2 neighbours
290 - get_key renamed into get_key_from_incoming_ip
291 - new sfa.storage module for record/table and all db-related stuff
292 - db schema in sfa.storage.sfa.sql
293 - init.d and cron.d move one step up
294 - cleaned up rspec/ directory
295 - add deps to pyopenssl and myplc-config
296 - start support for new API (return value)
297 - plc.remoteshell removed, use plshell instead
298 - plshell uses a 'capability' auth method whenever possible
299 - various tweaks in rspec elements
300 - made dependency on sfatables softer
301
302 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
303 - sfa should now be started *before* the initial import
304 - sfa to use its own database (default sfa) - can run without myplc
305 - server calls support optional 'options'
306 - client sends options in argument when needed
307 - fix infinite getattr recursion in elements/element.py
308 - error codes in line with geni
309
310 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
311 - fixed links and attributes in rspecs
312 - minor cleanup in the API methods, and more consistent names in manager methods
313
314 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
315 - ongoing refoactoring towards more genericity
316 - passes tests again although known issues remain with attributes/tags
317
318 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
319 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
320 - improvements in the pgv2 rspecs
321 - driver separated from api
322 - code starts moving around where it belongs
323 - sfascan caches getversion across invokations
324 - vini topology extracted as a config file
325
326 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
327 - first support for protogeni rspecs is working
328 - vini no longer needs a specific manager
329 - refactoring underway towards more flexible/generic architecture
330
331 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
332 - Unicode-friendliness for user names with accents/special chars.
333 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
334 - CreaetSliver no longer fails for users that have a capital letter in their URN.
335 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
336 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
337 - Fix bugs and missing imports     
338  
339
340 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
341 - new method record.get_field for sface
342
343 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
344 - new option -c to sfa-nuke-plc.py
345 - CreateSliver fixed for admin-only slice tags
346
347 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
348 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
349 - Fixed holes in certificate verification logic.
350 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
351 - Added 'boot_state' as an attribute of the node element in SFA rspec.
352 - Non authority certificates are marked as CA:FALSE.
353
354 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
355 - fix typo in sfa-1.0-31 tag.
356 - added CreateGid() Registry interface method.
357
358 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
359 - fix typo in sfa-1.0-30 tag
360
361 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
362 - Declare namespace and schema location in the credential.
363 - Fix bug that prevetend connections from timing out.
364 - Fix slice delegation.
365 - Add statistics to slicemaanger listresources/createsliver rspec.
366 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
367   of days a user can extend their slice expiration.
368 - CA certs are only issued to objects of type authority
369    
370 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
371 - tag 1.0-28 was broken due to typo in the changelog
372 - new class sfa/util/httpsProtocol.py that supports timeouts
373
374 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
375 - Resolved issue that caused sfa hold onto idle db connections.
376 - Fix bug that caused the registry to use the wrong type of credential.
377 - Support authority+sm type.
378 - Fix rspec merging bugs.
379 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
380 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
381  planetlab hosted initscripts using the <planetlab:initscript> tag  
382 - Can now handle extraneous whitespace in the rspec without failing.   
383  
384 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
385 - ProtoGENI v2 RSpec updates.
386 - Convert expiration timestamps with timezone info in credentials to utc.
387 - Fixed redundant logging issue. 
388 - Improved SliceManager and SFI client logging.
389 - Support aggregates that don't support the optional 'call_id' argument. 
390 - Only call get_trusted_certs() at aggreage interfaces that support the call.
391 - CreateSliver() now handles MyPLC slice attributes/tags.
392 - Cache now supports persistence.
393 - Hide whitelisted nodes.
394
395 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
396 - fixed issues with sup authority signing
397 - fixed bugs in remove_slivers and SliverStatus
398
399 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
400 - fix typo that prevented aggregates from operating properly
401
402 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
403 - load trusted certs into ssl context prior to handshake
404 - client's logfile lives in ~/.sfi/sfi.log
405
406 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
407 - includes a change on passphrases that was intended in 1.0-22
408
409 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
410 - Added support for ProtoGENI RSpec v2
411  
412 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
413 - stable sfascan
414 - fix in initscript, *ENABLED tags in config now taken into account
415
416 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
417 - some commits had not been pushed in tag 19
418
419 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
420 - GetVersion should now report full URLs with path
421 - scansfa has nicer output and new syntax (entry URLs as args and not options)
422 - dos2unix'ed flash policy pill
423
424 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
425 - fix packaging again for f8
426
427 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
428 - fix packaging (apparently broken in 1.0-16)
429 - first working version of sfascan
430 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
431 - deprecated the sfa_geni_aggregate config category
432
433 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
434 - Fix build problem
435 - First version of SFA scanner
436
437 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
438 - Add support for Flash clients using flashpolicy
439 - Fix problems with tag handling in RSpec
440
441 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
442 - Modifications to the Eucalyptus Aggregate Manager
443 - Fixes for VINI RSpec
444 - Fix tag handling for PL RSpec
445 - Fix XML Schema ordering for <urn> element
446
447 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
448 - just set x509 version to 2
449
450 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
451 - added urn to the node area in rspecs
452 - conversion to urn now exports fqdn
453 - sfa-import-plc.py now creates a unique registry record for each SFA interface
454
455 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
456 - undo broken attempt for python-2.7
457
458 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
459 - SMs avoid duplicates for when call graph has dags;
460 - just based on network's name, when a duplicate occurs, one is just dropped
461 - does not try to merge/aggregate 2 networks
462 - also reviewed logging with the hope to fix the sfa startup msg:
463 - TypeError: not all arguments converted during string formatting
464
465 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
466 - verify credentials against xsd schema
467 - Fix SM to SM communication
468 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
469 - new setting session_key_path
470
471 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
472 - fix registry credential regeneration and handle expiration
473 - support for setting slice tags (min_role=user)
474 - client can display its own version: sfi.py version --local
475 - GetVersion to provide urn in addition to hrn
476 - more code uses plxrn vs previous helper functions
477 - import replaces '+' in email addresses with '_'
478
479 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
480 - fix GetVersion code_tag and add code_url
481
482 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
483 - extend GetVersion towards minimum federation introspection, and expose local tag
484
485 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
486 - fixed some legacy issues (list vs List)
487 - deprecated sfa.util.namespace for xrn and plxrn
488 - unit tests ship as the sfa-tests rpm
489
490 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
491 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
492 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
493 - hrn-urn translations tweaked
494 - fixed 'service sfa status'
495 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
496 - started to repair sfadump - although not usable yet
497 - trust objects now have dump_string method that dump() actually prints
498 - unit tests under review
499 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
500 - binaries now support -v or -vv to increase loglevel
501 - trashed obsolete sfa.util.client
502
503 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
504 - various bugfixes and cleanup, improved/harmonized logging
505
506 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
507 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
508   to avoid returning a PLCAPI exception that might confuse users.
509 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
510 - fix build errors.  
511
512 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
513 - (Architecture) Credential format changed to match ProtoGENI xml format
514 - (Architecture) All interfaces export a new set of methods that are compatible
515    with the ProtoGeni Aggregate spec. These new methods are considered a 
516    replacement  for the pervious methods exported by the interfaces. All 
517    previous methods are still exported and work as normal, but they are 
518    considered deprecated and will not be supported in future releases.  
519 - (Architecture) SFI has been updated to use the new interface methods.
520 - (Architecture) Changed keyconvet implementation from c to python.
521 - (Architecture) Slice Manager now attempts looks for a delegated credential
522   provided by the client before using its own server credential.
523 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
524   This cache now exists only in memory and is cleared when service is restarted
525   or cache lifetime is exceeded.  
526 - (Performance) SliceManager sends request to Aggregates in parallel instead 
527   of sequentially.
528 - (Bug fix) SFA tickets now support the new rspec format.
529 - (Bug fix) SFI only uses cahced credential if they aren't expired.
530 - (Bug fix) Cerdential delegation modified to work with new credential format.
531 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
532   Aggregate instead of relaying through the Slice Manager.
533 - (Enhancement) Simplified caching. Accociated a global cache instance with
534   the api handler on every new server request, making it easier to access the 
535   cache and use in more general ways.     
536
537 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
538 - SfaServer now uses a pool of threads to handle requests concurrently
539 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
540 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
541 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
542 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
543 - Component manager does not install gid files if slice already has them  
544 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
545 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
546 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
547      
548 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
549 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
550 - - sfa-config-tty now has the same features like plc-config-tty
551 - - Contains code to support both urn and hrn
552 - - Cleaned up request_hash related stuff
553 - - SM, AM and Registry code is organized under respective managers
554 - - Site and Slice synchronization across federated aggregates
555 - - Script to generate sfa_component_config
556
557 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
558 - sfa-config-tty now has the same features like plc-config-tty
559 - Contains code to support both urn and hrn
560 - Cleaned up request_hash related stuff
561 - SM, AM and Registry code is organized under respective managers
562 - Slice synchronization across federated aggregates
563 - some bugs are fixed
564
565 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
566 - checkpoint with fewer mentions of geni
567
568 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
569 - checkpointing
570 - this is believed to pass the tests; among other things:
571 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
572
573 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
574 - This tag includes:
575 - - Sfatables
576 - - Preliminary version of hash based authentication
577 - - Initial code for Component Manager
578 - - Authority structure is moved to /var/lib/sfa/
579 - - some bug-fixes
580
581 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
582 - Create_slice and get_resources methods are connected to sfatables.
583 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
584
585 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
586 - Bug fix on update and remove_peer_object methods
587 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
588
589 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
590 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
591
592 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
593 - compatibility with RefreshPeer
594 - incremental mechanism for importing PLC records into SFA tables
595 - unified single database (still inside the underlying PLC db postgresql server)
596 - includes/improves call traceability and logging features
597 - several bug fixes
598
599 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
600 - added libxslt-python dependency
601
602 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
603 - unified single SFA database in the PLC-DB
604 - upcalls from  PLCAPI to SFA methods
605 - SFA call traceability and logging features
606 - many bug fixes
607 - includes first/rough version of sfatables for policy implementation
608
609 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
610 - snapshot after the GEC5 demo
611 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
612
613 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
614 - snapshot july 15 - has gone through superficial manual testing
615 - hopefully a good basis for gec5 demo
616 - multi-dir sfi client tested as well
617
618 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
619 - rename geniwrapper.spec into sfa.spec
620
621 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
622 - clean up in xmlrpc/soap, --protocol option to chose between both
623 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
624 - hopefully more helpful context in case of crashes when importing
625 - bugfixes for using only /etc/sfa for site-dep files
626 - bugfixes in wsdl generation
627
628 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
629 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
630 - config variables in sfa_config now start with SFA_ and not GENI_
631 - config.py can be loaded even with no config present
632
633 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
634 - first step for cleanup and reorganization
635 - mass-renaming from geni to sfa (some are still needed)
636 - sfa/trust implements the security architecture
637
638 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
639 - snapshot for reproducible builds
640
641 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
642 - snapshot for the convenience of alpha users
643
644 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
645 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
646
647 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
648 - ongoing work - snapshot for 4.3-rc9
649
650 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
651 - various fixes
652
653 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
654 - bugfixes - still a work in progress
655
656 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
657 - initial package
658
659
660 %define module_current_branch 0.2