Setting tag sliver-openvswitch-2.1.90-1
[sliver-openvswitch.git] / sliver-openvswitch.spec
1 %define name sliver-openvswitch
2 # to check for any change:
3 # grep AC_INIT configure.ac 
4 %define version 2.1.90
5 %define taglevel 1
6
7 %define debug_package %{nil}
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Vendor: OneLab
12 Packager: OneLab <support@planet-lab.eu>
13 Distribution: PlanetLab %{plrelease}
14 URL: %{SCMURL}
15 # Dependencies
16 # mar 2013 - because of the move to f18 I have to turn off auto requires
17 # this is because rpm would otherwise find deps to /bin/python and /bin/perl
18 # In other modules I was able to solve this by referring to /usr/bin/python 
19 # instead of just python in the builds scripts, but here it looks too complex
20 AutoReq: no
21
22 Summary: Openvswitch modified for running from a PlanetLab sliver
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Applications
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 Source0: sliver-openvswitch-%{version}.tar.gz
30
31 %description
32 Openvswitch tuned for running within a PlanetLab sliver
33
34 %prep 
35 %setup -q
36
37 %build
38 ./boot.sh
39 # let's be as close as the regular linux/fedora layout
40 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-logdir=/var/log
41 make
42
43 %install
44 make install DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /usr/bin/*
51 /usr/sbin/*
52 /usr/share/openvswitch
53 /usr/share/man
54
55 %post
56
57 %postun
58
59 %changelog
60 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-2.1.90-1
61 - merged in mainstream 2.1.90
62 - more robust server startup on the slivers
63
64 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-2.0.90-1
65 - merge with upstream
66 - switch to version 2, multi-threaded - specifically 2.0.90
67 - simple connectivity test - run with 'make test'
68
69 * Sat Jul 06 2013 Giuseppe Lettieri <g.lettieri@iet.unipi.it> - sliver-openvswitch-1.11.90-1
70 - merge with mainstream
71
72 * Sat Jul 06 2013 Giuseppe Lettieri <g.lettieri@iet.unipi.it> - sliver-openvswitch-1.10.90-3
73 - merge with mainstream
74
75 * Wed May 01 2013 Giuseppe Lettieri <g.lettieri@iet.unipi.it> - sliver-openvswitch-1.10.90-2
76 - - fixed several bugs in the external-nodes support in exp-tool/Makefile
77 - - let sliver-ovs return an error if tap device configuration failed
78
79 * Mon Apr 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.10.90-1
80 - merged with upstream (develoment version 1.10.90)
81 - integrated ALLEGRA contributions for the termination of virtual cables in external nodes.
82
83 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.9.90-3
84 - pulled mainstream - amazingly this is still known as 1.9.90 despite the size of changes
85
86 * Fri Dec 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.9.90-2
87 - merged with upstream
88 - handling of promisc &up/down flags for tap devices
89 - small improvements to the Makefile
90
91 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-6
92 - fixes in the exp-tool makefile (bash redirections, scp with key..)
93
94 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-5
95 - numerous additional make targets for finer control (use make help)
96 - including gprobe for reporting traffic to an ndnmap instance
97 - related, more functions in sliver-ovs as well, like exposing
98 - detailed info (mac, dpids..) relevant to the OF controller
99 - retrieving rx_bytes/tx_bytes (fixed) accessible through ovs-appctl
100
101 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-4
102 - fix file descriptor leaks
103
104 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-3
105 - can specify OpenFlow controller ip/port for each ovs instance
106 - through $(CONTROLLER_<id>), or $(CONTROLLER) by default
107
108 * Thu Sep 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-2
109 - add/skip packet information on tap send/recv
110
111 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-1
112 - merged mainstream 1.8.90
113 - planetlab extensions to the openvswitch: single helper command tool 'sliver-ovs' in /usr/sbin
114 - planetlab exp-tool : single config file (conf.mk)
115 - planetlab exp-tool : can retrieve and save current topology