bump mainstream version number and reset taglevel to 1
[sliver-openvswitch.git] / sliver-openvswitch.spec
1 %define name sliver-openvswitch
2 # to check for any change:
3 # grep AC_INIT configure.ac 
4 %define version 1.9.90
5 %define taglevel 1
6
7 %define debug_package %{nil}
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Vendor: OneLab
12 Packager: OneLab <support@planet-lab.eu>
13 Distribution: PlanetLab %{plrelease}
14 URL: %{SCMURL}
15 #Requires: 
16
17 Summary: Openvswitch modified for running from a PlanetLab sliver
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Applications
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 Source0: sliver-openvswitch-%{version}.tar.gz
25
26 %description
27 Openvswitch tuned for running within a PlanetLab sliver
28
29 %prep 
30 %setup -q
31
32 %build
33 ./boot.sh
34 # let's be as close as the regular linux/fedora layout
35 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-logdir=/var/log
36 make
37
38 %install
39 make install DESTDIR=$RPM_BUILD_ROOT
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 /usr
46
47 %post
48
49 %postun
50
51 %changelog
52 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-5
53 - numerous additional make targets for finer control (use make help)
54 - including gprobe for reporting traffic to an ndnmap instance
55 - related, more functions in sliver-ovs as well, like exposing
56 - detailed info (mac, dpids..) relevant to the OF controller
57 - retrieving rx_bytes/tx_bytes (fixed) accessible through ovs-appctl
58
59 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-4
60 - fix file descriptor leaks
61
62 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-3
63 - can specify OpenFlow controller ip/port for each ovs instance
64 - through $(CONTROLLER_<id>), or $(CONTROLLER) by default
65
66 * Thu Sep 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-2
67 - add/skip packet information on tap send/recv
68
69 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliver-openvswitch-1.8.90-1
70 - merged mainstream 1.8.90
71 - planetlab extensions to the openvswitch: single helper command tool 'sliver-ovs' in /usr/sbin
72 - planetlab exp-tool : single config file (conf.mk)
73 - planetlab exp-tool : can retrieve and save current topology